Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Dell XPS 1530 netio.sys blue screen

03 Apr 2011   #1

Windows 7 32bit
Dell XPS 1530 netio.sys blue screen


Can anyone help my laptop keeps going to a blue screen!

Hopefully I will get this message done:-

Problem signature:
Problem Event Name: BlueScreen
OS Version: 6.1.7601.
Locale ID: 2057

Additional information about the problem:
BCCode: d1
BCP1: 0000000000000028
BCP2: 0000000000000002
BCP3: 0000000000000000
BCP4: FFFFF8800172FB2D
OS Version: 6_1_7601
Service Pack: 1_0
Product: 768_1

I have a dell 1530 64 bit windows 7 home originally installed on the laptop.

I attached as requested but get an error when I do the performance report

Any help would be great thanks

My System SpecsSystem Spec
03 Apr 2011   #2

win 7 ultimate32bit, Win8.1pro wmc 32bit

Hi frankj, welcome to the forums , have a look here Blue screen due to netio.sys in Windows 7 - Microsoft Answers update your ethernet card drivers , another forum member with more experience in BSODs will be along presently :)
My System SpecsSystem Spec
03 Apr 2011   #3

Windows 10 Pro x64, Arch Linux

Seems like the issue is with your Network card driver, update it
Drivers & Downloads
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck D1, {28, 2, 0, fffff88001718b2d}

Probably caused by : NETIO.SYS ( NETIO!RtlCopyBufferToMdl+1d )

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arg1: 0000000000000028, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, value 0 = read operation, 1 = write operation
Arg4: fffff88001718b2d, address which referenced memory

Debugging Details:

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff8000350b0e8


fffff880`01718b2d 448b5228        mov     r10d,dword ptr [rdx+28h]





TRAP_FRAME:  fffff8800337f620 -- (.trap 0xfffff8800337f620)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=fffff8800337f840 rbx=0000000000000000 rcx=0000000000000000
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff88001718b2d rsp=fffff8800337f7b0 rbp=fffff8800337f8e0
 r8=00000000ffffffbc  r9=0000000000000044 r10=0000000000000000
r11=fffffa800193d4c0 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl zr na po nc
fffff880`01718b2d 448b5228        mov     r10d,dword ptr [rdx+28h] ds:0011:00000000`00000028=????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff800032d9be9 to fffff800032da640

fffff880`0337f4d8 fffff800`032d9be9 : 00000000`0000000a 00000000`00000028 00000000`00000002 00000000`00000000 : nt!KeBugCheckEx
fffff880`0337f4e0 fffff800`032d8860 : fffffa80`01c40000 fffff880`0188cdd2 fffffa80`072ab4d0 00000000`00000044 : nt!KiBugCheckDispatch+0x69
fffff880`0337f620 fffff880`01718b2d : ffff0000`02aef6ef 00000000`00000001 fffffa80`072ab4d0 00000000`00000000 : nt!KiPageFault+0x260
fffff880`0337f7b0 fffff880`018d05ec : fffff880`0337f8c8 fffff880`0189f376 00000000`00000001 fffff880`0337f940 : NETIO!RtlCopyBufferToMdl+0x1d
fffff880`0337f810 fffff880`0189c963 : fffffa80`0193d4c0 00000000`00000001 fffffa80`01846830 00000000`00000000 : tcpip! ?? ::FNODOBFM::`string'+0x1d6ef
fffff880`0337f880 fffff880`0188ad54 : fffffa80`0176dce0 00000000`000085f3 fffff880`0337fd78 fffffa80`026c7000 : tcpip!TcpTcbCarefulDatagram+0x543
fffff880`0337fa30 fffff880`018895ea : fffffa80`025919c0 fffff880`01881a00 fffffa80`0256c358 00000000`00000000 : tcpip!TcpTcbReceive+0x724
fffff880`0337fc20 fffff880`0188b2ab : fffff880`04c360fa fffffa80`026c7000 00000000`00000000 fffff880`0337ff00 : tcpip!TcpMatchReceive+0x1fa
fffff880`0337fd70 fffff880`01882137 : fffffa80`025919c0 fffffa80`025985f3 fffffa80`0000a138 00000000`0000a138 : tcpip!TcpPreValidatedReceive+0x36b
fffff880`0337fe40 fffff880`01881caa : 00000000`00000000 fffff880`01991800 fffff880`03380000 fffffa80`07497010 : tcpip!IppDeliverListToProtocol+0x97
fffff880`0337ff00 fffff880`018812a9 : 00000000`00000000 fffffa80`073e4010 fffffa80`074a0790 fffff880`0337fff0 : tcpip!IppProcessDeliverList+0x5a
fffff880`0337ffa0 fffff880`0187efff : 00000000`00000000 00000000`04d0c300 fffff880`01991800 fffff880`01991800 : tcpip!IppReceiveHeaderBatch+0x23a
fffff880`03380080 fffff880`0187e5f2 : fffffa80`04d0b2e0 00000000`00000000 fffffa80`04d0c300 fffffa80`00000001 : tcpip!IpFlcReceivePackets+0x64f
fffff880`03380280 fffff880`018f275a : 00000000`00000000 fffffa80`07f95a40 fffffa80`04d0c310 00000000`00000001 : tcpip!FlpReceiveNonPreValidatedNetBufferListChain+0x2b2
fffff880`03380360 fffff800`032e7078 : 00000000`00000000 fffff880`0174d390 fffffa80`01695b60 00000000`00000001 : tcpip! ?? ::FNODOBFM::`string'+0x56e52
fffff880`033803b0 fffff880`0187e152 : fffff880`0187d9b0 fffffa80`07b87080 fffff880`01996900 fffff880`01883301 : nt!KeExpandKernelStackAndCalloutEx+0xd8
fffff880`03380490 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : tcpip!FlReceiveNetBufferListChain+0xb2


fffff880`01718b2d 448b5228        mov     r10d,dword ptr [rdx+28h]


SYMBOL_NAME:  NETIO!RtlCopyBufferToMdl+1d

FOLLOWUP_NAME:  MachineOwner




FAILURE_BUCKET_ID:  X64_0xD1_NETIO!RtlCopyBufferToMdl+1d

BUCKET_ID:  X64_0xD1_NETIO!RtlCopyBufferToMdl+1d

Followup: MachineOwner
My System SpecsSystem Spec

03 Apr 2011   #4

Windows 7 32bit

thanks will try that
My System SpecsSystem Spec
03 Apr 2011   #5

Windows 7 32bit

If anyone has any other suggestions it would be great, updated the drivers and still the laptop goes to bluescreen.
My System SpecsSystem Spec

 Dell XPS 1530 netio.sys blue screen

Thread Tools

Similar help and support threads
Thread Forum
Blue Screen On Dell Desktop
Hi Lads, if you could help with this I would appreciate it, it's a Dell Inispiron desktop.
BSOD Help and Support
Driver Power State Failure Error Message on Dell XPS 1530
When I tried to put my computer in sleep mode, I got a blue error screen with the bug "Driver Power State Failure." Upon using BlueScreenView, I got this information: Dump File 101512-14476-01.dmp Crash Time 10/15/2012 9:02:26 Bug Check String PMDRIVER_POWER_STATE_FAILURE ...
BSOD Help and Support
Windows 7 x64 Dell XPS M1530 blue screen
Hello everyone, this is going to be my first thread on this forums and I would like to say nice to meet you all. I recently upgraded my Dell XPS M1530 from Vista to Windows 7 x64. I did a clean installation from scratch so my computer wouldn't be slow. Unfortunately Dell XPS M1530 is not...
BSOD Help and Support
not recognizing my nVIDIA 8600 on Dell XPS 1530
hey all, i recently did a clean install of win 7 home premium 64bit from win vista 32bit - after everything was installed, i noticed Windows 7 is not recognizing my video card (won't show up in my device manager) - so installing new drivers (from nvidia or dell) isn't getting me anywhere. any...
Graphic Cards
Blue Screen Windows 7 NETIO.SYS and ntoskrnl.exe
I got a blue screen when I turn off my computer. I attach the minidump files. I ran "sfc /scannow" and all is fine. Any idea about that error?, thanks. ================================================== Dump File : 042910-14289-01.dmp Crash Time : 04/29/2010 03:46:01 p.m....
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:10.
Twitter Facebook Google+