Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Memtest Fail Questions & BSOD's

25 May 2011   #1

Win 7 Prem Home64-bit
Memtest Fail Questions & BSOD's

Here's my Sys specs:

GIGABYTE GA-890FXA-UD5 AM3 AMD 890FX SATA 6Gb/s USB 3.0 ATX AMD Motherboard
SAPPHIRE 100290SR Radeon HD 5870 (Cypress XT) 2GB 256-bit GDDR5 PCI Express 2.1 x16 HDCP Ready CrossFireX Support Eyefinity 6 Edition Video Card
Rosewill Libertas Series LIB-650 650W Continuous @40C,80 PLUS Certified, Full Modular, ATX12V v2.3/EPS12V v2.92,SLI Ready, CrossFire Ready, Active PFC, Compatible with Core i7, i5 Power Supply
AMD Phenom II X6 1090T Black Edition Thuban 3.2GHz Socket AM3 125W Six-Core Desktop Processor HDT90ZFBGRBOX
GeIL Black Dragon 8GB (4 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Desktop Memory Model GB38GB1600C9QC
HITACHI Deskstar H3IK10003272SP (0S02860) 1TB 7200 RPM SATA 3.0Gb/s 3.5" Internal Hard Drive
ASUS DRW-24B1ST/BLK/B/AS Black SATA 24X DVD Burner - Bulk - OEM
Rosewill RK-7310 Black USB Wired Super Slim Multimedia Keyboard
Microsoft Windows 7 Home Premium Full
Rosewill RNX-N180PCe PCI Express Revision 1.1 Wireless Adapter

Hello all:

My system is unstable and I've decided to finally do something about it. I get BSOD's fairly regularly. I'd attach the dumps but I'm writing this from the office computer so it's going have to wait. Checking the 50+ dumps, the bulk of the crashes come from ntoskrnl.exe/ntkrnlpa.exe/atikmdag.sys. The "nt" are apart of the kernel so I really doubt that's the root of the problem, it's something else I'm sure. The ATI, is from the GPU but not real sure what's causing it. Catalyst and the associated drivers are up to date it would appear.

Last night I ran:
  • Dskchk.ext --> No problems on C:. I ran again on my other drive pulled from my previous comp. A few errors but it appears they were fixed. Nothing major on this HD. Just WoW and some misc files.
  • CCleaner ---> Found some lost registry files, cleaned it up and no issues to report.
  • Prime95 ---> I only ran for about 30 mins before bed, no issues. I know it needs to run for a lot longer but my hunch is that the CPU is not the issue here.
  • Memtest86+ ---> Here's where I got some issues.
Test#1 -----> Ran for about <5mins, screen went blank no response did a soft reset...
Test#2------> Ran again errors started popping up somewhere in between the 5-10min mark. The errors just kept piling up in a few mins I was at like 350k.
Test#3-6---> Ran each stick individually in the first slot failed all failing at around the 1:45 mark or while beginning memtest's test #7. The error just kept piling up like the above test.

So what do you think at this point? Is it the ram stick or the MOBO? It's sort of strange that all of the sticks would fail individually at the exact same time. One thing to note, I checked Gigabyte's website and my particular ramstick is not listed on their compatability chart. They also said that they can't check every stick of RAM on the market so it could be fine just not checked.

The majority of the BSOD's happen while gaming. WoW, Rift, The Witcher, Sims 4, NWN2. Pretty much all of my games I play except EVE for some reason. That game's never crashed on me.

Any help with this be great. If you have any questions please let me know.


My System SpecsSystem Spec
25 May 2011   #2

Windows 7 Ultimate x86

Did you try the sticks one by one in the other slots?
(That's how you determin if it's the RAM itself or the slot that is bad. It's rather uncommon that all RAMs give up the same time (unless a surge ran through the comp caused by a thunderstorm or by false handling (static charges)

My System SpecsSystem Spec
25 May 2011   #3

Win 7 Prem Home64-bit

I'll give that a whirl after work here and report back.

I really hope it's just faulty RAM.
My System SpecsSystem Spec

26 May 2011   #4

Win 7 Prem Home64-bit


I went ahead and attached the dumps and perfmon here. There's 51 BSODS I believe since I built the computer.

A few updates:
  • I learned that the RAM clock speed was not at the RAM's intended speed. Changed to 1600mhz from 1333mhz.
  • The timing was also off. Changed to RAM specs. I thought this might have been the problem but Memtest still reported errors at about the same time during the test.
  • I got about half way through individually testing each RAM stick in each DIMM slot. Each failed. I'm pretty sure the other two sticks will yield the same result.
  • The ATi GPU is updated
  • The Realtek driver has been updated as of this morning.
Please let me know if you have any questions.

My System SpecsSystem Spec
26 May 2011   #5

Microsoft Community Contributor Award Recipient

Windows 7 Ult x64 - SP1/ Windows 8 Pro x64

There is a known issue with AMD CPUs integrated memory controllers having problems running RAM at 1600 MHz and above.

For starters change the RAM back to 1333MHz.

It is unusual to have four individual RAM cards fail when tested one at a time.
Test all the RAM cards in more than one motherboard slot, preferably in all four slots.
Unless, as mentioned, there has been a voltage spike, ground fault, or static discharge.

Lets take a look at your setup.

Information on the memtest86+ RAM testing.
When you run memtest86+ you are looking for bad RAM cards, bad motherboard slots, so you need to follow the testing procedure in the tutorial.
Sometimes errors from these tests can be corrected by adjusting the settings.
RAM - Test with Memtest86+

D/L CPUZ and post a snip of the CPU, Mainboard, Memory, and SPD tabs.
For posting the information , enter 'Snipping tool' in the Start button > Search box, hit enter. Select the area you want to post and save to a convenient place.
How to Post a Screenshot in Seven Forums

Have you been checking your temperatures?
UseCore Temp , to check the CPU temps when at idle, under load and/or testing.
Let us know the minimum and maximum temps you get.

Go to your BIOS and tell us what the CPU, RAM and the CPU integrated memory controller voltages are.

Anytime you have more than 4GB RAM, 2GB RAM cards, more than 2 RAM cards, you will likely need to adjust some settings to get it to run stable.

With the above info we can see if anything needs adjusted.

Running the debugger........
Will add info as I get it.

As suspected
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
Use !analyze -v to get detailed debugging information.
BugCheck 109, {a3a039d89ca8a4e9, b3b7465eef2576df, fffff800033589f0, 1}
*** WARNING: Unable to verify timestamp for win32k.sys
*** ERROR: Module load completed but symbols could not be loaded for win32k.sys
Probably caused by : memory_corruption
Followup: memory_corruption
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
This bugcheck is generated when the kernel detects that critical kernel code or
data have been corrupted. There are generally three causes for a corruption:
1) A driver has inadvertently or deliberately modified critical kernel code
 or data. See
2) A developer attempted to set a normal kernel breakpoint using a kernel
 debugger that was not attached when the system was booted. Normal breakpoints,
 "bp", can only be set if the debugger is attached at boot time. Hardware
 breakpoints, "ba", can be set at any time.
3) A hardware corruption occurred, e.g. failing RAM holding kernel code or data.
Arg1: a3a039d89ca8a4e9, Reserved
Arg2: b3b7465eef2576df, Reserved
Arg3: fffff800033589f0, Failure type dependent information
Arg4: 0000000000000001, Type of corrupted region, can be
 0 : A generic data region
 1 : Modification of a function or .pdata
 2 : A processor IDT
 3 : A processor GDT
 4 : Type 1 process list corruption
 5 : Type 2 process list corruption
 6 : Debug routine modification
 7 : Critical MSR modification
Debugging Details:

LAST_CONTROL_TRANSFER:  from 0000000000000000 to fffff800030bd700
fffff880`031925d8 00000000`00000000 : 00000000`00000109 a3a039d8`9ca8a4e9 b3b7465e`ef2576df fffff800`033589f0 : nt!KeBugCheckEx

CHKIMG_EXTENSION: !chkimg -lo 50 -d !nt
    fffff80003358bbf - nt!CmpSetValueKeyExisting+1cf
 [ 30:70 ]
1 error : !nt (fffff80003358bbf)
MODULE_NAME: memory_corruption
IMAGE_NAME:  memory_corruption
FOLLOWUP_NAME:  memory_corruption
Followup: memory_corruption
My System SpecsSystem Spec
26 May 2011   #6

Win 7 Prem Home64-bit

Thanks for the reply.

I'll go back and change it back to 1333mhz. The memory corruption dump last weekend, that's the first time ever I've seen that BSOD on this rig. I've had it since 11/10. I was playing a new game, not sure it has anything to do with it or not.

After work here I'll test the remaining sticks in each slot and post results. My setup is the default unganged FYI.

I have CPUz installed, I post the details here.

I ran prime95, and under max load highest temp was 60c. I'll have to double check on the idle temp. I'll get the remaining answers to your questions after work.

Thanks for your help.
My System SpecsSystem Spec
26 May 2011   #7

Microsoft Community Contributor Award Recipient

Windows 7 Ult x64 - SP1/ Windows 8 Pro x64

You're welcome.

Good information.

Have you had 8GB RAM since 11/10?
All matched, same brand etc.?

Unganged is the preferred setting for your RAM.

The Prime95 temp is good.
My System SpecsSystem Spec
26 May 2011   #8

Win 7 Prem Home64-bit

Quote   Quote: Originally Posted by Dave76 View Post
You're welcome.

Good information.

Have you had 8GB RAM since 11/10?
All matched, same brand etc.?

Unganged is the preferred setting for your RAM.

The Prime95 temp is good.
Yes sir, all matched and same brand too.
My System SpecsSystem Spec
26 May 2011   #9

Microsoft Community Contributor Award Recipient

Windows 7 Ult x64 - SP1/ Windows 8 Pro x64

If you post the info requested above, we can check the RAM settings.

More than 4GB RAM, 2GB RAM cards and more than two RAM cards usually need a voltage bump for the integrated memory controller.

Can you enter your system specs in the 'My System Specs' drop box in the lower left corner of any of your posts?
This will keep everyone from having to go to the first post to see your specs.
My System SpecsSystem Spec
26 May 2011   #10

Win 7 Prem Home64-bit


I changed the RAMM back to 1333mhz. I tested all of the RAM sticks in each DIMM and they all failed at about the same time:

Here's the specs you've requested, I hope:
  • Sys Temp 30c Idle
  • CPU Temp 41c Idle
  • Vcore 1.472v
  • DDR3 1.5 running at 1.52vish
  • +3.3v running at 3.4vish
  • 12v running at 12.1v
  • System Voltage 2.5
  • DRAM Voltage at 1.51v which is running lower than the given RAM specs of 1.6v
  • DRAM VTT voltage .750v
  • HT link Voltage 1.2v
  • NB/PCIe/PLL Voltage 1.8v
Random question, Turbo CPB is disabled, should I turn that on?

Here are the screenshots of CPUz:
Attachment 156578
Attachment 156579
Attachment 156580

Please let me know if you have any questions.

My System SpecsSystem Spec

 Memtest Fail Questions & BSOD's

Thread Tools

Similar help and support threads
Thread Forum
Many BSOD's and very bad MemTest Results
Hi all, I'm after experiencing an onslaught of BSOD's today, each with a different error code. Also, After doing a MemTest, on the first Pass, It counted up a total of 200'000+ errors :( I restarted the Memtest after getting over 200'000 errors (it tending to go on and on and on . . .), and on...
BSOD Help and Support
Random BSOD, Tried everything even new Motherboard and Memtest+
Right where to start... I have built a custom PC, needless to say its not my first so I knew what I was doing. I installed Windows 7 64 Ultimate to it and had it up and running fine, it ran for hours then blue screened on me, I thought it might have been a one off so tried again and it kept...
BSOD Help and Support
Restore Fail. Boot at infinite loop. Memtest.exe missing/corrupt.
Hi I am running Windows 7 Home x64. I've tried to restore my ASUS laptop (i think the model name was k53e or something similar) to factory settings, but I couldn't do so (????) because while other people told me to press f9 at bootup, when I pressed f9, I only got the choice of either booting up...
Backup and Restore
BSOD despite no errors in prime95, memtest, etc
Windows 7 32 bit 2.4Ghz 1M 533 2x512mb ddr 333 PC2700 Nvidia P162 WD 80gb ide drive Constant BSOD opening program like cpu-z, SIW 2011, etc...despite 24+ hours no errors in Prime95 Small FTTs, 11+ hours no errors in Prime95 Blend, 24+ hours in both memtest86+ and windows memory diagnostic...
BSOD Help and Support
MemTest Over 18688 Errors! BSOD help please!!
Hi, after getting the BSOD many times, reinstalling windows and trying to debug i still have no idea how to fix my brand new system:cry: I just bought a dell xps 9100 with 12gbs of ram and im assuming that its faulty because memtest returned 18000+ errors in around 10 minutes of checking.. ...
BSOD Help and Support
Need help with a BSOD and Memtest-86 test
Hi all, need help. I have posted a BSOD issue and and in order to detect possible memory problem, i have execute Memtest-86 v4.0 (bootable) but after 8 minutes working, my PC has begin to ...BEEP! BEEP! BEEP! :( I have stooped process and redo it to take some pictures. While the process, in...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:06.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App