Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Several BSODs

02 Jun 2011   #1

Windows 7 x64
Several BSODs

I had 3 BSODs two days ago (I looked up some information about it and it seemed to be related to my touchpad). So I turned off my touchpad, but that's not really a good fix seeing as now I can't use my touchpad.

I'm posting here just to see if you guys can give some more information about the problem or how I may fix it. I don't want this to continue, and I'm still within the 30 days that I can return my laptop if there is something wrong with the hardware... but that would be a big hassle.

I attached the BSOD jcgriff thingy as well as the SystemHealth thingy.

My System SpecsSystem Spec
02 Jun 2011   #2

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

 Microsoft (R) Windows Debugger Version 6.11.0001.404 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Users\richc46\AppData\Local\Temp\Temp1_Windows_NT6_BSOD_jcgriff2 (1).zip\Windows_NT6_BSOD_jcgriff2\053111-18376-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available
Symbol search path is: SRV*c:\symbols*
Executable search path is: 
Windows 7 Kernel Version 7600 MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Built by: 7600.16792.amd64fre.win7_gdr.110408-1633
Machine Name:
Kernel base = 0xfffff800`02c59000 PsLoadedModuleList = 0xfffff800`02e96e50
Debug session time: Tue May 31 23:44:15.404 2011 (GMT-4)
System Uptime: 0 days 4:03:35.965
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
Use !analyze -v to get detailed debugging information.
BugCheck D1, {fffffa8607a1025a, 2, 0, fffff88008cc262d}
Unable to load image \SystemRoot\system32\DRIVERS\ETD.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for ETD.sys
*** ERROR: Module load completed but symbols could not be loaded for ETD.sys
Probably caused by : ETD.sys ( ETD+1162d )
Followup: MachineOwner
0: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arg1: fffffa8607a1025a, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, value 0 = read operation, 1 = write operation
Arg4: fffff88008cc262d, address which referenced memory
Debugging Details:

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff80002f010e0
fffff880`08cc262d 448aa44bec000000 mov     r12b,byte ptr [rbx+rcx*2+0ECh]
TRAP_FRAME:  fffff80000b9c970 -- (.trap 0xfffff80000b9c970)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=00000000fffffffe rbx=0000000000000000 rcx=00000002fffffff7
rdx=fffffa8007d586b8 rsi=0000000000000000 rdi=0000000000000000
rip=fffff88008cc262d rsp=fffff80000b9cb00 rbp=fffffa8007d586b8
 r8=00000000fffffffd  r9=fffff80000b9ccd8 r10=000000000000002c
r11=fffffa8007904308 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz na po nc
fffff880`08cc262d 448aa44bec000000 mov     r12b,byte ptr [rbx+rcx*2+0ECh] ds:3e80:00000006`000000da=??
Resetting default scope
LAST_CONTROL_TRANSFER:  from fffff80002cc8c69 to fffff80002cc9700
fffff800`00b9c828 fffff800`02cc8c69 : 00000000`0000000a fffffa86`07a1025a 00000000`00000002 00000000`00000000 : nt!KeBugCheckEx
fffff800`00b9c830 fffff800`02cc78e0 : fffff800`00b96080 fffffa80`07a10180 00000000`00000000 00000000`00000000 : nt!KiBugCheckDispatch+0x69
fffff800`00b9c970 fffff880`08cc262d : 00000000`00000053 00000000`00000003 fffffa80`079ab110 fffff880`08c90468 : nt!KiPageFault+0x260
fffff800`00b9cb00 00000000`00000053 : 00000000`00000003 fffffa80`079ab110 fffff880`08c90468 00000000`00000054 : ETD+0x1162d
fffff800`00b9cb08 00000000`00000003 : fffffa80`079ab110 fffff880`08c90468 00000000`00000054 fffff880`08c853a4 : 0x53
fffff800`00b9cb10 fffffa80`079ab110 : fffff880`08c90468 00000000`00000054 fffff880`08c853a4 00000000`00000053 : 0x3
fffff800`00b9cb18 fffff880`08c90468 : 00000000`00000054 fffff880`08c853a4 00000000`00000053 fffff880`08c8516f : 0xfffffa80`079ab110
fffff800`00b9cb20 00000000`00000054 : fffff880`08c853a4 00000000`00000053 fffff880`08c8516f 00000000`00000008 : i8042prt!ntoskrnl_NULL_THUNK_DATA+0x908
fffff800`00b9cb28 fffff880`08c853a4 : 00000000`00000053 fffff880`08c8516f 00000000`00000008 fffff800`00b9cba0 : 0x54
fffff800`00b9cb30 fffff800`00b9cbd0 : fffffa80`07903190 00000000`00000008 fffff800`00b96080 00000000`00000001 : i8042prt!WPP_RECORDER_SF_+0x94
fffff800`00b9cb70 fffffa80`07903190 : 00000000`00000008 fffff800`00b96080 00000000`00000001 00000000`00000000 : 0xfffff800`00b9cbd0
fffff800`00b9cb78 00000000`00000008 : fffff800`00b96080 00000000`00000001 00000000`00000000 fffffa80`07d586d0 : 0xfffffa80`07903190
fffff800`00b9cb80 fffff800`00b96080 : 00000000`00000001 00000000`00000000 fffffa80`07d586d0 fffffa80`07a10180 : 0x8
fffff800`00b9cb88 00000000`00000001 : 00000000`00000000 fffffa80`07d586d0 fffffa80`07a10180 fffffa80`07a10030 : 0xfffff800`00b96080
fffff800`00b9cb90 00000000`00000000 : fffffa80`07d586d0 fffffa80`07a10180 fffffa80`07a10030 fffff800`00b9ccd8 : 0x1
Every one of your 3 reports came up the same.
The cause is this driver
Etd.sys file description
Productname:Elantech Smart-Pad
Description:ETD Ware TSR Enhancements
Company:ELANTECH Devices Corp.

Update the driver or remove the software completely.
My System SpecsSystem Spec
02 Jun 2011   #3

Windows 7 x64

The driver seems to be up to date as far as I can tell. Since it has something to do with my touchpad driver, would removing it make my touchpad stop working? Am I be asking this in the wrong section?
My System SpecsSystem Spec

02 Jun 2011   #4

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

Yes you start to delete drivers the software will not work properly or at all. You may try to disable it and see if you still get BSODs?
Did you go to the website to look for the most up to date or did you use Windows Update and Device manager?
My System SpecsSystem Spec
02 Jun 2011   #5

Windows 7 x64

Acer had no driver info for my laptop, but the one they showed on a similar model was the version I had. And I did disable the touch pad and the bsods stopped.

Think it is hardware problem?
My System SpecsSystem Spec
02 Jun 2011   #6

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

I think its a software problem. If you disabled the touch pad and the problem stopped, that is the problem.
Did you install any software about the time the problem started or make any other changes?
Go to device manager (type those words in search by the start button) and try to update from there. If it says you have most current, get the previous version and see how it works.
My System SpecsSystem Spec
03 Jun 2011   #7

Windows 7 x64

The problem has stopped:
It didn't happen again.
Thanks for all the help.
My System SpecsSystem Spec
03 Jun 2011   #8

Microsoft Community Contributor Award Recipient

Windows 10, Home Clean Install

You are very welcome
My System SpecsSystem Spec

 Several BSODs

Thread Tools

Similar help and support threads
Thread Forum
Please help me with my BSODs
I experience BSODs every time my laptop is plugged in. But no BSODs happen when I'm not plugged in. Please help me on what I need to do. Here are my laptop's specs: Asus K42jC-vx169 Core i5 M460 2.53GHz 2Gb Ram 320Gb HDD 1gb VRAM (Nvidia GeForce CUDA 310M) Windows 7 ultimate 64-bit
BSOD Help and Support
And Still More BSODs
Sorry in my last post I said I changed CPU when I actually meant Motherboard. After changing my motherboard and running memtest ver. 4.0 I would usually end up with 1 mil errors for every ram in every slot. Same problem happened to my last motherboard which was the same model. Whenever I run...
BSOD Help and Support
BSODs, lots of BSODS
Hi, The blue screen of death are coming with win32k.sys, at first then irql_not_less_or_equal. I have win7 64 bit, clean installed like 1 year or so back. The dell hardware I bought was almost 2 years back but was fully replaced, motherboard, cpu except hardrive 6 months back. It is...
BSOD Help and Support
BSODs every day... need help
Hi guys, i have a serious problem with my new config... i built it 2 weeks ago, and since then i get the BSODs almost every day. i run memtest on both RAMs, individually both were OK, but when tried to run the test on dual, the system crashed after few seconds. checkdisk showed no problems on...
BSOD Help and Support
BSODs in Win 7 pro
Hello, I'm running W7 Pro, and have been having problems with BSODs. I recently purchased a powered usb hub, and on three separate occasions, I received a BSOD error related to the USB. I can't remember exactly what the error was, as the computer's activity log notes the crash, but not the...
BSOD Help and Support
BSODs on win 7 x64
I recently upgraded to win 7 and iv been getting random BSODs. the reason I decided to upgrade was because I started to get some BSODs on vista x64. I have a feeling it could be related to my wireless adapter (ZYXEL G202) drivers. I have attached the latest BSOD minidump files. Could somebody...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:16.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App