Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD with Wiped Partition

04 Jun 2011   #1

Windows 7 Ultimate X86
BSOD with Wiped Partition

Okay, I need URGENT help. I figured Seven Forums would be a good place to ask. I honestly don't know who else to ask. Feel free to move this topic if it is in the wrong location, or even point me in the direction of someone who could help me better.

My specs, in case anyone wants them:
Windows 7 Ultiamte x86 (main OS)
Ubuntu 11.04 (what I'm currently using to type this)
AMD Phenom II x4 965 BE CPU
ASUS M4A89 series motherboard (honestly, I can't remember the full model number right now)
1TB Seagate Barricuda S-ATA HDD
80GB Western Digital IDE HDD

I custom-built it myself in April 2010. I have had the motherboard replaced recently as the previous one died in just under a year for no apparent reason.

Let me explain what happened:

I was trying to format a secondary IDE drive as FAT32 so that I could back up my Playstation 3 HDD to upgrade it. I've managed to do it before for my cousin's PS3, but Maxtor MaxBlast doesn't seem to have the options to do so any more, so I was looking for better programs.

I had made an image of the IDE drive (the 80GB one), as I had previously cloned my pretty-much-dead (basically, old and slow, and in need of a new battery) laptop's HDD onto that IDE that is in this desktop computer of mine. I used Maxtor MaxBlast to do that, and I mounted it to make sure it worked fine, which it did.

Then I erased the drive, formatted it, and was kind of messing around. I tried using some program first, something like FormatFAT32 or something. People said it'd do what I wanted, but it didn't really seem like it would format the entire drive, just the free space, so I clicked Initialize, which wiped the drive. I thought that was fine, but the program wouldn't recognise it anymore.

So, I opened up the format utility via Computer, and tried to format it. It said it was in use by another program, I said format anyway, but it decided to not work, so I tried cancelling it. Then it said that it failed to cancel. I could either click Retry to try cancelling again or click Cancel to cancel it immediately. Not much choice there. I DID click Retry first, but it didn't work (got the same message), so I clicked Cancel. It seemed to be fine, as if I had never tried to format it.

Then I opened Windows Disk Management under Computer Services or whatever it's called, and formatted it that way, but I only got the option of exFAT or NTFS. I chose NTFS, then decided to delete it again and try exFAT, for no real reason, to be honest... Anyway, it worked, but it was going very slow for both deleting and formatting partitions. Once I got it to exFAT, it didn't have the drive letter I chose assigned to it (E, so I right-clicked and set that up. It didn't seem to work, so I decided to delete the volume and try formatting it again to make sure the drive letter was set from the start this time (even though it was the time before... it was also not marked active until I did so).

This is where things got messy. Right now, it's 3am, and this was about half an hour ago, so I was obviously tired, and I'm sick right now, so that doesn't help. What happened is that the drive letter (E appeared, but I had already chose to delete the volume. Since it didn't seem to be doing anything, I decided to ignore the fact that I had clicked Delete. Probably a big mistake. I know what I did, so I don't see why ignoring it would change that, and I know that the formatting on the computer had been going slow, as well as when I had previously tried to install some other Western Digital formatting program but it was doing as much as the formatting via Computer, so I closed that (which took ages to close, and still lingered in Services as Windows Installer).

Anyway, I had found this German command-line program that was meant to work. Someone on the Playstation forums suggested it (to someone, not to me though. I just found it via Google). It was called h2format.exe. So I decided that since nothing was happening and my E drive still seemed to be fine and partitioned, that I would try to format it as FAT32 using this program. It worked. It started working, at least. I was just happily listening to some music, planning on formatting the drive, getting some sleep, waking up in the morning, taking it out of my computer, and backing up my PS3 with it.

Here's the problem: Blue Screen of Death. I can't even remember the error. I have a feeling it mentioned NTFS. You know, how there's that line of text that tells you what the error specifically is. I have a feeling it started with "~NTFS", but I could be wrong. I had a pretty bad feeling. But I had only been messing with my IDE drive, so no biggy. The computer restarted itself, I got to GRUB, I selected Windows 7 (actually, it's the default, but I hit Enter to speed up the boot anyway, rather than waiting for the timer to finish counting down).

Then I got three lines of text on a black screen. Or maybe it was two. Honestly, I can't remember. But I know the first one was that it could not fine the drive, with the model number or serial number or something, that is associated with my Seagate S-ATA drive (I've seen it in Windows plenty of times. I think it's the model number. I could be wrong).

So back to GRUB it took me. I booted into Ubuntu. Opened GParted, and..... my IDE drive is now /dev/sda instead of /dev/sdb. So I changed to /dev/sdb. There were my partitions. Ubuntu, Linux Swap, that pointless free space, and...... 910GB of unallocated space at the beginning of the drive. My whole Windows partition has been completely erased from existence.

I'm seriously panicking so much. I feel a hundred times more sick than I do right now, and this common cold has been pretty nasty over this past week. If I'm right about how hard drives work, I believe it should be recoverable. However, to what extent, I am unsure, and as for how practical and easy this is, I also have no idea. What I just lost..... countless hours of work, information, data - all vital to my every-day life. Maybe saying that makes me sound like a pathetic no-life nerd, but for someone who lives for computers, that's a lot of stuff to lose.

I know, stupid of me not to have a backup, but the only reason I don't is because I don't have the money for a new HDD. I was planning to buy a bigger one later in the year so that I could install 64-bit Windows on it and backup all my data (I had filled about 90% of the 1TB drive), but right now, I just have no money.

So please, I may not have any files to show anyone (because I kinda don't have access to them AT ALL), but I need URGENT help. When the rest of the family turns the computer on in the morning..... well, they will have lost everything too. If ANYONE can help in ANY way, I would greatly appreciate it to no end. I would do almost anything to get this data back.

Ironically, Ubuntu seems to have perfectly formatted my IDE drive, which it identified as pretty much corrupted (as the BSOD was during the format), but I'd rather lose that stupid old thing than all my Windows data.

I've included as much information as I possibly can think of. I'm desperate. Please help me.

My System SpecsSystem Spec
04 Jun 2011   #2
Microsoft MVP


1. Use Ubuntu to recover your Windows data IMMEDIATELY. The most important data is in the C:\Users folder - so back that up to another location (I'd make a 2nd copy on your Ubuntu partition - just so it doesn't get lost).

2. Provide us with the memory dumps from the Windows installation. They are usually in the C:\Windows\Minidump folder. Zip them up and upload them here. If there isn't anything in that folder, check to see if there's a file named MEMORY.dmp in the C:\Windows directory. If so, zip it up and upload it to a free filehosting service (it'll be too big to upload here) and post a link to it here.

3. From what you describe I suspect that you've hosed your Windows installation. To fix it you'll need your Windows installation disk. Follow the steps in this post for Startup Repair: Startup Repair Try Startup Repair 3 times.

4. Then try to get into Windows. If not possible, try getting into Safe Mode (tapping F8 just before the Windows splash screen shows up). Then try to run a repair installation of Windows 7 using this procedure: Repair Install

If you're still not able to get into Windows, then make sure your data is backed up - and then reinstall Windows (this'll wipe out all your data, so a backup is crucial at this point).

Good luck - this is a whole lot to do before anyone gets up!
FWIW - the NTFS error has to do with the file system on the hard drive. You may be able to "cheat" and remove (unplug both the data and power cable) the IDE drive and see if you can boot to Windows on the other drive.
My System SpecsSystem Spec
04 Jun 2011   #3

Windows 7 Ultimate X86

Thank you so much for your reply. However, my first problem is how to actually recover the data. Since the partition has been wiped, I no longer have access to my Windows files through Ubuntu, so I have no idea how to recover them.

Obviously, I don't want to do anything to it without certainty, so that I don't make the problem worse. Also, I only have a 20GB-size partition for Ubuntu so backing up several hundred gigabytes of data is unfortunately not feasible. That being said, if I can back up important documents, I guess that's a start.

I did a quick search on Google about recovering the data through Ubuntu, and I came across something called TestDisk. I don't know if that would be a viable solution, or if I should avoid it.

Anyway, for now, the family is staying away from the computer, but it won't be long until they realise that everything is gone. To make matters worse, my PS3 won't read my 80GB IDE drive, and another one I have, a 100GB IDE drive, also hasn't been working right (kept failing to install in Windows no matter what I did). I guess that's the least of my worries now, but the fact that it what I originally set out to do just ended in a huge mess is not helpful whatsoever. It's just made things worse, and I've made no progress.

EDIT: I wrote down the error message I get upon trying to boot into Windows. Also, I have removed the IDE drive as of this morning and it hasn't changed anything (apart from my main drive, my 1TB HDD, changing back to /dev/sda, which I guess is the slightest bit of progress). Here's the error message:

error: no such device 36BE5724BE56DC45
error: no such disk.

Press any key to continue...
It automatically goes back to GRUB after about 10 seconds, whether or not I press any key.

Edit 2: I'm back in Windows. I took the risk (seems that I didn't learn my lesson) and tried TestDisk via Ubuntu. It found my full partition table and re-wrote it. The only problem was that then GRUB didn't work. I guess that is probably to be expected.

I had a look at the partition table in GParted through my Ubuntu Live CD, but it said Unallocated for the whole disk (even though that was still only the size of /dev/sda2 - my Windows 7 partition), and right-clicking and selecting information said something about the partition table not being allowed to be outside of the disk or something.

Then I stuck in my Windows 7 disk. Startup Repair failed each time I tried it (I believe I tried it twice), so I opened command prompt and entered:

bootrec /fixmbr
bootrec /fixboot
After rebooting, I was back into Windows 7. I'm guessing everything should be in-tact now, so I should just need to reinstall GRUB. I'm not sure what to do about these two IDE drives I have now. I have a USB adapter that I ripped out of an external enclosure. It was working fine before but doesn't seem to now. My 100GB IDE HDD is detected but fails to install the driver in Windows, and the 80GB one that caused the problem in the first place won't pick up via USB, but last I checked, it was working fine via the IDE cable inside my PC. I haven't tried the 100GB one inside the computer yet, so I'll try that too. I guess I need to get saving for a drive to make a back up, just to be safe.

I'm going to go ahead and upload any of the logs I can find, just in case. PeerGuardian, which I have starting on startup, was giving me errors when I finally got back into windows. Something about a .log file. I thought it was specific to that program, but I just want to make sure.

I've attached the .dmp file that was under C:\Windows\Minidump, but the MEMORY.dmp file under C:\Windows is almost 500MB, and New Zealand internet is EXTREMELY slow, even on broadband (I was excited when I got 1.83Mbps download speed the other day, which is sad), so I won't bother uploading that unless it's crucial. I have attached the System Health Report, although it all seems to be fine - nothing out of the ordinary, as far as I can tell. I also attached the BSOD files using the BSOD Dump & System File Collection app.
My System SpecsSystem Spec

05 Jun 2011   #4
Microsoft MVP


I think that you've solved your own problem by rewriting the partition table and running the bootrec commands.
Rather than mucking things up with more diagnostics, I'd suggest you wait to see if you get another BSOD. If you do, zip it up and post it.

As for the USB drives - I have never had a Western Digital hard drive fail on me - but nearly every external USB drive that I've had from them has failed. And, I've ripped them apart only to find that the hard drive was fine - it's was the USB connector that was bad (both the desktop and the pocket models).

Good luck!
My System SpecsSystem Spec
05 Jun 2011   #5

Windows 7 Ultimate X86

Thanks very much. However, my IDE drive that is 100GB (a Maxtor) will stop my PC from booting (it gets to the Starting Windows splash screen and won't continue past there), although I have yet to try the Western Digital one (I honestly can't be bothered, because now the USB connector won't pick it up at all, and it was at least DETECTING it with the Maxtor one before).

My biggest problem with the aftermath of my original problem, is that the partition table still seems kind of stuffed up. Windows seems to be fine and display it fine under Disk Management, but I cannot find a way to get back into Ubuntu. I guess I'll just have to delete the partitions via Windows, then reinstall it, but using the Live CD, GParted tells me that the disc is unallocated, and because of that, there's nothing to mount to try reinstalling GRUB with or anything like that. I'm not sure what's gone wrong here, but I guess I'm probably better asking on the Ubuntu forums for this problem.

Anyway, thanks for your help. Everything seems to work well now (or at least, as well as it did before yesterday).
My System SpecsSystem Spec

 BSOD with Wiped Partition

Thread Tools

Similar help and support threads
Thread Forum
Wiped Primary partition holding XP, now can't boot 7
From within windows 7 I used CCleaner to wipe my partition containing XP. When I rebooted, the system wouldn't start at all. I had forgotten that XP was setup on the first ~100gb of the drive as a partition (partition 1), and 7 was on the remaining (partition 2). So I'm guessing that I...
General Discussion
Please help. Partition table wiped out just before install
HELP NEED to restore partition table damaged by Kaspersky
Hardware & Devices
Wiped my OP drive
As the heading says I wiped my Operating Drive on my desktop. And created a fresh Windows 7 and other software. I am having problems with one program. I had it on the previous OP before I wiped it. Although I had a little problem connecting last time. The software worked great, the software is...
Hardware & Devices
Window wiped out
Hi I tried to install window Sever r2 on my laptop which originally has a window 7 I mistakenly chose the same drive of window 7 . Finally, Window R2 overwrote the original window.This is the situation .Now I want to ask the following question: 1, How can I retrieve back the original window ?...
General Discussion
Creating Primary Partition On Wiped HDD ?
Hi, I have used a DOS utility called copywipe 1.14 to wipe a hard drive for a clean installation of windows 7. However, the utility has not only removed all data from the hard drive, it has also deleted the primary partition and master boot record as far as I am aware. Can anyone please...
Installation & Setup
C Drive Wiped due to bad partition?
Greetings, I need help trying to recover some files on my pc. I had an XP installation working fine on a single hd setup with about 25 gb free space. I tried partitioning the drive (c:) to free up that empty space so that I could install Windows 7 on it, (i guess its called dual boot?) I...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:52.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App