Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD error Netio.sys

08 Jun 2011   #1

Windows 7 Home Basic (64-Bit)
BSOD error Netio.sys

Windows 7 Home 64-Bit
Sony Viao 8 months old
Just reinstalled OS a month back as old hard disk had crashed due to boot sector error

Have attached the crash dump... Plz help!!!

My System SpecsSystem Spec
08 Jun 2011   #2

Win 8 Release candidate 8400

Quote   Quote: Originally Posted by ashishnaik View Post
Windows 7 Home 64-Bit
Sony Viao 8 months old
Just reinstalled OS a month back as old hard disk had crashed due to boot sector error

Have attached the crash dump... Plz help!!!
All of these virtually identical and blamed on NETIO.sys. This is often caused by Zone Alarm. If you have it installed remove it.

If not run a system file check

Run a system file check to verify and repair your system files.
To do this type cmd in search, then right click to run as administrator, then

Read here for more information SFC /SCANNOW Command - System File Checker

Let us know the results from the report at the end.

Microsoft (R) Windows Debugger Version 6.11.0001.404 X86
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Users\K\Desktop\Windows_NT6_BSOD_jcgriff2\060811-16629-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*C:\Symbols*;srv*e:\symbols
Executable search path is: 
Windows 7 Kernel Version 7601 (Service Pack 1) MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Built by: 7601.17592.amd64fre.win7sp1_gdr.110408-1631
Machine Name:
Kernel base = 0xfffff800`0380f000 PsLoadedModuleList = 0xfffff800`03a54650
Debug session time: Wed Jun  8 13:54:28.073 2011 (GMT-4)
System Uptime: 0 days 23:08:48.244
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck D1, {28, 2, 0, fffff880017adb2d}

Probably caused by : NETIO.SYS ( NETIO!RtlCopyBufferToMdl+1d )

Followup: MachineOwner

2: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arg1: 0000000000000028, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, value 0 = read operation, 1 = write operation
Arg4: fffff880017adb2d, address which referenced memory

Debugging Details:

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff80003abe100


fffff880`017adb2d 448b5228        mov     r10d,dword ptr [rdx+28h]





TRAP_FRAME:  fffff88003394620 -- (.trap 0xfffff88003394620)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=fffff88003394840 rbx=0000000000000000 rcx=0000000000000000
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff880017adb2d rsp=fffff880033947b0 rbp=fffff880033948e0
 r8=00000000ffffffbc  r9=0000000000000044 r10=0000000000000000
r11=fffffa800282b280 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl zr na po nc
fffff880`017adb2d 448b5228        mov     r10d,dword ptr [rdx+28h] ds:00000000`00000028=????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff8000388e2a9 to fffff8000388ed00

fffff880`033944d8 fffff800`0388e2a9 : 00000000`0000000a 00000000`00000028 00000000`00000002 00000000`00000000 : nt!KeBugCheckEx
fffff880`033944e0 fffff800`0388cf20 : fffffa80`027c9610 fffffa80`0291d110 00000000`00000004 00000000`00000044 : nt!KiBugCheckDispatch+0x69
fffff880`03394620 fffff880`017adb2d : fffff880`03163180 fffff880`0105c95c fffffa80`050b9e20 00000000`00000532 : nt!KiPageFault+0x260
fffff880`033947b0 fffff880`018af5ec : 00000000`00000000 fffff880`0187e376 00000000`00000001 fffffa80`00000002 : NETIO!RtlCopyBufferToMdl+0x1d
fffff880`03394810 fffff880`0187b963 : fffffa80`0282b280 00000000`00000001 fffffa80`02ed9140 00000000`00000000 : tcpip! ?? ::FNODOBFM::`string'+0x1d6ef
fffff880`03394880 fffff880`01869d54 : fffffa80`02851390 00000000`0000eeed fffff880`03394d78 fffffa80`0519e000 : tcpip!TcpTcbCarefulDatagram+0x543
fffff880`03394a30 fffff880`018685ea : fffffa80`05084b00 fffff880`01860a00 fffffa80`05042448 00000000`00000000 : tcpip!TcpTcbReceive+0x724
fffff880`03394c20 fffff880`0186a2ab : fffffa80`02bca112 fffffa80`0519e000 00000000`00000000 fffff880`03394f00 : tcpip!TcpMatchReceive+0x1fa
fffff880`03394d70 fffff880`01861137 : fffffa80`05084b00 fffffa80`0505eeed fffffa80`00002164 00000000`00002164 : tcpip!TcpPreValidatedReceive+0x36b
fffff880`03394e40 fffff880`01860caa : 00000000`00000000 fffff880`01970800 fffff880`03395000 fffff880`0160490c : tcpip!IppDeliverListToProtocol+0x97
fffff880`03394f00 fffff880`018602a9 : 00000000`00000001 00000000`00000000 fffffa80`0287ba00 fffff880`03394ff0 : tcpip!IppProcessDeliverList+0x5a
fffff880`03394fa0 fffff880`0185dfff : fffff880`01970800 fffffa80`02bca102 fffff880`01970800 fffff880`01970800 : tcpip!IppReceiveHeaderBatch+0x23a
fffff880`03395080 fffff880`0185d5f2 : fffffa80`05746f70 00000000`00000000 fffffa80`055c6b00 00000000`00000001 : tcpip!IpFlcReceivePackets+0x64f
fffff880`03395280 fffff880`018d175a : 00000000`00000000 00000000`00000000 fffffa80`055c6ba0 fffffa80`02b1ae80 : tcpip!FlpReceiveNonPreValidatedNetBufferListChain+0x2b2
fffff880`03395360 fffff800`0389b668 : fffffa80`0304b010 00000000`00000000 fffffa80`023fcb60 00000000`00000001 : tcpip! ?? ::FNODOBFM::`string'+0x56e52
fffff880`033953b0 fffff880`0185d152 : fffff880`0185c9b0 fffffa80`02e044c0 fffff880`01975900 fffff880`01862301 : nt!KeExpandKernelStackAndCalloutEx+0xd8
fffff880`03395490 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : tcpip!FlReceiveNetBufferListChain+0xb2


fffff880`017adb2d 448b5228        mov     r10d,dword ptr [rdx+28h]


SYMBOL_NAME:  NETIO!RtlCopyBufferToMdl+1d

FOLLOWUP_NAME:  MachineOwner




FAILURE_BUCKET_ID:  X64_0xD1_NETIO!RtlCopyBufferToMdl+1d

BUCKET_ID:  X64_0xD1_NETIO!RtlCopyBufferToMdl+1d

Followup: MachineOwner

2: kd> lmvm NETIO
start             end                 module name
fffff880`0179c000 fffff880`017fc000   NETIO      (pdb symbols)          c:\symbols\netio.pdb\DD06DDC1DE2F426D85400E127C2DF49A2\netio.pdb
    Loaded symbol image file: NETIO.SYS
    Mapped memory image file: C:\Symbols\NETIO.SYS\4CE7938160000\NETIO.SYS
    Image path: \SystemRoot\system32\drivers\NETIO.SYS
    Image name: NETIO.SYS
    Timestamp:        Sat Nov 20 04:23:13 2010 (4CE79381)
    CheckSum:         00066D17
    ImageSize:        00060000
    File version:     6.1.7601.17514
    Product version:  6.1.7601.17514
    File flags:       0 (Mask 3F)
    File OS:          40004 NT Win32
    File type:        3.6 Driver
    File date:        00000000.00000000
    Translations:     0409.04b0
    CompanyName:      Microsoft Corporation
    ProductName:      Microsoft® Windows® Operating System
    InternalName:     netio.sys
    OriginalFilename: netio.sys
    ProductVersion:   6.1.7601.17514
    FileVersion:      6.1.7601.17514 (win7sp1_rtm.101119-1850)
    FileDescription:  Network I/O Subsystem
    LegalCopyright:   © Microsoft Corporation. All rights reserved.
My System SpecsSystem Spec
09 Jun 2011   #3

Windows 7 Home Basic (64-Bit)

Don't have Zonealarm installed at all... also tried SFC /SCANNOW... It didn't show up any errors in the system...

The message was "Windows Resource Protection did not find any integrity violations."

Also just remembered that I had installed Adobe flash player after which the crash started happening. Plz help...
My System SpecsSystem Spec

15 Jun 2011   #4

Windows 7 Home Basic (64-Bit)


Can anybody help with the above query? I tried running sfc /scannow but no error message came up...
My System SpecsSystem Spec
15 Jun 2011   #5

Win 8 Release candidate 8400

Quote   Quote: Originally Posted by ashishnaik View Post

Can anybody help with the above query? I tried running sfc /scannow but no error message came up...
Since the file system appears to be ok we need to starat looking elsewhere.

Have you had more BSOD's? If so upload the dmps.

Lets start by checking the RAM by running memtest.

Download a copy of Memtest86 and burn the ISO to a CD using Iso Recorder or another ISO burning program.

Boot from the CD, and leave it running for at least 5 or 6 passes.

Just remember, any time Memtest reports errors, it can be either bad RAM or a bad motherboard slot.

Test the sticks individually, and if you find a good one, test it in all slots.
My System SpecsSystem Spec

 BSOD error Netio.sys

Thread Tools

Similar help and support threads
Thread Forum
BSOD while browsing, netio.sys error
I have one BSOD per day. I tried a lot of things that I found here. I scan the computer with Malwarebytes and MSE, updated with windows update, updated the network driver, unistalled a lot of software that could be related, ran check disk, used system restore. I just couldn't use system file...
BSOD Help and Support
BSOD random W7 Pro x64, error NETIO.SYS \ ntoskrnl.exe
Hi there, my colleague is getting random BSOD on his relatively new Dell E6330 with W7 Pro x64. I have grabbed some dump files and tried to understand them in BlueScreenView, but they don't make a lot of sense to me, but these two items are frequently mentioned: NETIO.SYS \ ntoskrnl.exe. ...
BSOD Help and Support
BSOD while doing just about anything, error 0x000000d1 with netio.sys
I am in the process of doing a memory test, will get back to you the results. I did the network driver updates, but I'm still having the BSOD. It appears to have a correlation to utorrent (but I am unsure) I will post the 5 latest crash dumps , thank you all for helping ahead of time
BSOD Help and Support
BSOD While using uTorrent, NETIO.sys error
Hey all, I've been lurking for a bit, trying to figure this out myself, but I haven't been able to. For a little under a week I have been getting a BSOD if I try to torrent something and do something else. If I leave it running on it's own, it can usually complete, unless I am downloading...
BSOD Help and Support
BSOD netio.sys error
I am getting a BSOD from time to time and I have only had the computer for a couple of weeks. It seems like it happens most often when I am downloading. This is my system: Acer AX1930-ES10P Desktop 2.7GHz Intel Pentium G630 processor: L3 Cache 4GB system memory Microsoft...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 17:55.
Twitter Facebook Google+