Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Application is unable to locate MFC90U.dll and others

29 Jun 2011   #1

Windows 7 32 bit
Application is unable to locate MFC90U.dll and others

Good Day Friends,

I have an application installed on a Windows 7 machine at office. The application installs VS 2008 Redistributable files during its installations. The installation works fine.

On the launch, the application crashes. On reviewing the Event Viewer, I can see "MFC90U.dll" listed under one of the "Data" tags.

I tried copying all the MS 2008 related files and manifests to the local directory. This also didn't work.

There are other products on the machine which are supposedly using earlier versions on VS Redistributable files. These applications work fine.

Is there any chance that the co-existence of the multiple versions of the VS Redistributable files is causing any issues?

Is there any way of specifying manifests in the local directory for the missing DLLs so that application can locate them?

Please advice. I am stuck on it for 3 days now.

Thanks & Regards!
Pankaj Dwivedi.

My System SpecsSystem Spec
30 Jun 2011   #2

Microsoft Community Contributor Award Recipient

Windows 7 x64

Before doing anything else I would reinstall or repair install (if the app supports it)
The application that is the source of the error.
You may want to run the setup or installer file as an admin and temporarily disabling UAC for the duration of the repair/reinstall.

It sounds like the file simply didn't write.

You can also try installing the latest visual C++ library and see if that resolves your problem.
Download Details - Microsoft Download Center - Microsoft Visual C++ 2010 Redistributable Package (x86)
My System SpecsSystem Spec
30 Jun 2011   #3

Windows 7 32 bit

Dear Mag,

The VS 2008 Redistributable has installed successfully. I can see it listed under the Control Panel -> Programs.

Also, the problem is not seen when the application is installed on a clean machine. Only after other products, that are using older versions of VS Redistributables, were installed that the problem surfaced.

Now, I have uninstalled all the other products and reinstalled the application. Still, no luck.

I manually reinstalled the VS 2008 Redistributable.
My System SpecsSystem Spec

30 Jun 2011   #4

Microsoft Community Contributor Award Recipient

Windows 7 x64

Well I don't understand why you are resistant to the ideal of updating the library but that was my one thought that didn't get complicated.
My System SpecsSystem Spec
30 Jun 2011   #5

Windows 7 32 bit


I understand that using 2010 Redistributables may solve the problem. But it is not an option as the application officially supports 2008 only.

I am working towards getting a clean image again and then try to reproduce the problem by installing the application first followed by other products.

But, in the worst case, there may not be any new clue as to why only this application is crashing.
My System SpecsSystem Spec
30 Jun 2011   #6

Microsoft Community Contributor Award Recipient

Windows 7 x64

well either the actual aforementioned file has a problem. Or the program's association to it is somehow broken, that would usually be a registry entry.
Reinstalling would generally be the way to fix this.
It's why I suggested trying a second install process with the windows security toned down a step to see if it's interfering with your install.
Though if that is the case it should occur on any similar machine you attempted to install it on.
My System SpecsSystem Spec

 Application is unable to locate MFC90U.dll and others

Thread Tools

Similar help and support threads
Thread Forum
cmd.exe application error - application was unable to start correctly
cmd.exe application error - application was unable to start correctly (0x0000142). Click ok to close the application Anyone know why it happened? I got this error when I tried to restart to install an update. However, in windows update, it showed I had nothing to update. There was the little...
General Discussion
Unable to locate any drivers for my USB devices
I seem to be unable to connect devices via USB and have my Win7 Pro (x64) locate the correct driver for it. A couple of weeks ago I connected a wireless mouse. I placed the USB receiver into my laptop, I saw the little animated icon in the system tray looking like it was installing something,...
Buzzing Sound Unable To Locate Source
I've researched it.. I've listened.. I've removed components. I cannot find the source. Only thing I haven't been able to test is the power supply. Here is a link to a video (ignore the images) to show you what the noise sounds like. Hopefully that can help determine the source. Yfrog Video :...
Hardware & Devices
Unable to locate screensaver files
Hello,I just did a search for my screensavers,as I have done in the past,from start>search>.scr but no screensaver flies show up.I went to C:\Windows\system 32 but no scr or screensaver folders show.When I type in .scr in search I get a few different results,text docs,and when I click on show more...
Failed to locate Application Resources
Hey everybody, sorry if this isn't the right place to post, but I wasn't sure... Very recently, upon login every time the welcome screen shows up much longer than usual and when my desktop finally loads, I get an error message saying "Failed to locate application resources." The header in the...
General Discussion
Unable to create/locate partition
I have two identical sata drives. They were previously configured at raid 0 so reset and removed the raid config in my bios. I have a Asus p5wd2 Premium mobo. When I try to install I get this error message "Setup was unable to create a new system partition or locate existing system ...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:58.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App