Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Class not registered (Exception from HRESULT: 0x800154).....

30 Jun 2011   #1

Windows 7 64-bit
Class not registered (Exception from HRESULT: 0x800154).....

So EVERYTHING was working perfectly fine today on my Sony Vaio VGN-FW510D Laptop until I uninstalled Team Fortress 2 today. (It's a game) I used Revo Uninstaller to uninstall it and then scanned and deleted the leftovers (it scans and deletes leftover files and folders and registry strings/keys) ... everything was fine... then, I went to eat dinner.... I come back and log on... First problem I notice, no sound. For some reason there were no more sounds working anymore... I tried YouTube videos, going into Playback devices, sound check... nothing worked... The next problem was these two windows error boxes that now pop up when I log on.. The box both say:

SmartWi Connection Utility

Class not registered (Exception from HRESULT: 0x80040154(REGDB_E_CLASSNOTRED))

And now my wireless internet does not work! (That's the SmartWi..)
Yes... right now I'm typing using a temporary wired connection
So... being able to solve many computer related problems myself, I tried all of these methods and obviously did not succeed.. :

- Free Windows Registry Repair
- Little Registry Cleaner
- Windows Disk Check
- Windows Memory Check
- Safe Mode
- System Restore
- Uninstalling STEAM
- Re-Installing SmartWi Connection

Please.... anyone who's knowledgeable with registry keys and such, I think I accidentally deleted an important registry key with Revo Uninstaller and I need to do the Run: regsvr32 ______.dll thing... but I'm not experienced with it and I don't know which .dll's to put....
Any help will be greatly appreciated

So the problems are:
- No Sound
- No Wireless Internet

I have a Sony Vaio Laptop and I'm using Windows 7 64-bit... this same message will be posted on other forums so please don't say something obvious like check Sony's forums..

My System SpecsSystem Spec
30 Jun 2011   #2
Orbital Shark


Hi, welcome to the forums

Have you tried uninstalling the SmartWi software then downloading the latest version from the Sony site and re-installing?

A re-install of the software should replace any missing registry entries that would have been previously removed, regardless of how.
My System SpecsSystem Spec

 Class not registered (Exception from HRESULT: 0x800154).....

Thread Tools

Similar help and support threads
Thread Forum
class not registered
Hi guys, When ever I download something in google chrome and I click show containing folder, an error comes up saying "class not registered". The same thing happens in uTorrent when I click show containing folder on one of my torrents. After that the program becomes unresponsive I was hoping...
General Discussion
Class Not Registered
running win 7 Pro, "Class Not Registered" comes up any time I'm trying to access Admin areas. It's last research before format drive and install clean copy Os.. any thoughts Tnx
General Discussion
Class Not Registered Error In Outlook 2010
I recently downloaded IE9 for my Win7 SP1 system and set it as the default browser. When I open an email in Outlook 2010 and try to access a link to a web site from it. I get a "Class not registered" error. See attached snip. I have tried the 'Fix' found on the web { How to reset Internet...
Browsers & Mail
Class Not Registered
Hi guys Desktop R click and select personalise and I get the above error. I have read through the previous forum threads covering this error and tried the various fixes via cmd.exe (as admin). I am either missing a .dll somewhere any easy fix?. Clean install yesterday and no naughty...
Class not registered error
Anyone know how to fix the attached error? This error comes up when I try to go into Computer Management, Services, Component Services but not MSConfig. I have tried System Restore points, but no go.
Performance & Maintenance
mmc.exe class not registered error
Haven't had this error since Win 2000, but after installing a clean copy of Windows 7 on my workstation, and a number of programs, when I try to run mmc from the run prompt I get a Class Not Registered Error, which is causing havoc on all my software installations. Any ideas on how to fix or...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:48.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App