Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: BSOD when playing Shogun 2 Total War

18 Jul 2011   #1
Uncle Seamus

Windows Seven Home Premium 64-bit
 
 
BSOD when playing Shogun 2 Total War

Hi everyone,

the title pretty much covers it all: the computer randomly crashes when playing Shogun 2. I've added a minidump file in the hopes that someone can tell me what exactly goes wrong.

Thanks in advance!


My System SpecsSystem Spec
.
18 Jul 2011   #2
FredeGail

Microsoft Windows 7 Ultimate: x64 (SP1)
 
 

I will analyze your .dmp when I'm home infront of my machine.
Hold on !

Best Regards,
FredeGail
My System SpecsSystem Spec
18 Jul 2011   #3
FredeGail

Microsoft Windows 7 Ultimate: x64 (SP1)
 
 

Hello again, it's quite hard to analyse this one, as it's could be anything.

BSOD Summary
Code:
Microsoft (R) Windows Debugger Version 6.12.0002.633 X86
Copyright (c) Microsoft Corporation. All rights reserved.


Loading Dump File [C:\Users\Frederik\AppData\Local\Temp\Rar$DI00.623\071811-17097-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*C:\SymCache*http://msdl.microsoft.com/download/symbols
Executable search path is: 
Windows 7 Kernel Version 7600 MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Built by: 7600.16617.amd64fre.win7_gdr.100618-1621
Machine Name:
Kernel base = 0xfffff800`02a00000 PsLoadedModuleList = 0xfffff800`02c3de50
Debug session time: Mon Jul 18 18:08:28.755 2011 (UTC + 2:00)
System Uptime: 0 days 1:22:23.706
Loading Kernel Symbols
...............................................................
................................................................
..........................
Loading User Symbols
Loading unloaded module list
.....
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 3B, {c0000005, fffff80002a829b3, fffff880087e1070, 0}

Probably caused by : ntkrnlmp.exe ( nt!ObDereferenceObjectExWithTag+23 )

Followup: MachineOwner
---------

1: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************

SYSTEM_SERVICE_EXCEPTION (3b)
An exception happened while executing a system service routine.
Arguments:
Arg1: 00000000c0000005, Exception code that caused the bugcheck
Arg2: fffff80002a829b3, Address of the instruction which caused the bugcheck
Arg3: fffff880087e1070, Address of the context record for the exception that caused the bugcheck
Arg4: 0000000000000000, zero.

Debugging Details:
------------------


EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - Instruktionen ved 0x%08lx refererede hukommelse ved 0x%08lx. Hukommelsen kunne ikke %s.

FAULTING_IP: 
nt!ObDereferenceObjectExWithTag+23
fffff800`02a829b3 f0480fc13b      lock xadd qword ptr [rbx],rdi

CONTEXT:  fffff880087e1070 -- (.cxr 0xfffff880087e1070)
rax=0000000000000000 rbx=0000000000000001 rcx=fffffa8004b84060
rdx=0000000000000001 rsi=fffffa8004b84060 rdi=ffffffffffffffff
rip=fffff80002a829b3 rsp=fffff880087e1a40 rbp=fffff880087e1c60
 r8=00000000746c6644  r9=00000000000000e8 r10=fffff80002a00000
r11=fffffa8004b84030 r12=0000000000000000 r13=0000000000000002
r14=0000000000000028 r15=0000000000000000
iopl=0         nv up ei ng nz ac po cy
cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00010297
nt!ObDereferenceObjectExWithTag+0x23:
fffff800`02a829b3 f0480fc13b      lock xadd qword ptr [rbx],rdi ds:002b:00000000`00000001=????????????????
Resetting default scope

CUSTOMER_CRASH_COUNT:  1

DEFAULT_BUCKET_ID:  VISTA_DRIVER_FAULT

BUGCHECK_STR:  0x3B

PROCESS_NAME:  audiodg.exe

CURRENT_IRQL:  0

LAST_CONTROL_TRANSFER:  from fffff80002a82872 to fffff80002a829b3

STACK_TEXT:  
fffff880`087e1a40 fffff800`02a82872 : 00000000`00000001 ffffffff`fff9ccb4 fffff880`087e1c60 00000000`00000001 : nt!ObDereferenceObjectExWithTag+0x23
fffff880`087e1a70 fffff800`02a275ce : 00000000`00000000 00000000`00000001 fffff880`087e1b98 00000000`00000000 : nt!ExpSetTimer+0x1f2
fffff880`087e1b40 fffff800`02a6f993 : fffffa80`04b39b60 00000000`00000028 00000000`00000000 00000000`00000000 : nt!NtSetTimerEx+0x11d
fffff880`087e1be0 00000000`7747148a : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
00000000`0236f5c8 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x7747148a


FOLLOWUP_IP: 
nt!ObDereferenceObjectExWithTag+23
fffff800`02a829b3 f0480fc13b      lock xadd qword ptr [rbx],rdi

SYMBOL_STACK_INDEX:  0

SYMBOL_NAME:  nt!ObDereferenceObjectExWithTag+23

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: nt

IMAGE_NAME:  ntkrnlmp.exe

DEBUG_FLR_IMAGE_TIMESTAMP:  4c1c44a9

STACK_COMMAND:  .cxr 0xfffff880087e1070 ; kb

FAILURE_BUCKET_ID:  X64_0x3B_nt!ObDereferenceObjectExWithTag+23

BUCKET_ID:  X64_0x3B_nt!ObDereferenceObjectExWithTag+23

Followup: MachineOwner
---------
Try making a full scan with Malwarebytes
Furmark
RAM - Test with Memtest86+
And very recommend: Driver Verifier - Enable and Disable, if any BSOD, upload the .dmp file and it will hopefully tell us which one were the faulty one.

Best Regards,
FredeGail
My System SpecsSystem Spec
.

18 Jul 2011   #4
Uncle Seamus

Windows Seven Home Premium 64-bit
 
 

thanks for helping out, gonna check my drivers right now
My System SpecsSystem Spec
18 Jul 2011   #5
Uncle Seamus

Windows Seven Home Premium 64-bit
 
 

the drivers are certainly to blame:
when I started up driver verifier, my computer was unable to perform the necessary
reboot, so I had to boot in safe mode and disable the program.
After I had done that and started the pc in normal mode, my avast antivirus was
disabled and I had no internet access.

Both issues are fixed now but as I said, there's something seriously wrong with those
drivers of mine
My System SpecsSystem Spec
18 Jul 2011   #6
FredeGail

Microsoft Windows 7 Ultimate: x64 (SP1)
 
 

Quote   Quote: Originally Posted by Uncle Seamus View Post
the drivers are certainly to blame:
when I started up driver verifier, my computer was unable to perform the necessary
reboot, so I had to boot in safe mode and disable the program.
After I had done that and started the pc in normal mode, my avast antivirus was
disabled and I had no internet access.

Both issues are fixed now but as I said, there's something seriously wrong with those
drivers of mine
Strange.
Are there any new .dmp to be uploaded?

Best Regards,
FredeGail
My System SpecsSystem Spec
18 Jul 2011   #7
Uncle Seamus

Windows Seven Home Premium 64-bit
 
 

strange indeed, no new dump files for the moment
I'll run shogun 2 tomorrow again and post a new minidump then
My System SpecsSystem Spec
18 Jul 2011   #8
FredeGail

Microsoft Windows 7 Ultimate: x64 (SP1)
 
 

Hopefully we'll get a better .dmp file this time.

Best Regards,
FredeGail
My System SpecsSystem Spec
20 Jul 2011   #9
Uncle Seamus

Windows Seven Home Premium 64-bit
 
 

well, no recent BSOD's:

like before, Shogun 2 shuts down after a couple of minutes and I get an error screen saying "Shogun 2 TW has stopped working", but unlike a couple of days ago, the computer doesn't show a BSOD afterwards.

Guess this thread doesn't belong in the "crashes and debugging" department anymore...

Thanks for your time!
My System SpecsSystem Spec
Reply

 BSOD when playing Shogun 2 Total War




Thread Tools




Similar help and support threads
Thread Forum
Shogun 2 Total War - Game explorer verification problem
Hi all, this is my first post after bit of lurking :) Hope the forum section is right as well! I have a problem with Shogun 2, a game I used to play some months ago witouth problems. Now I have downloaded it again (from STEAM), re-installed it and no matter what I've tried I always get this...
Gaming
BSOD playing Total War: Shogun 2
Hello People of Seven Forums, Hopefully someone could help me with this: While I was playing Shogun 2 a wild blue screen appeared after a minute of buzzing noise like in a freeze. I don't have much information about the blue screen since I looked at it for a couple of seconds and then tried...
BSOD Help and Support
BSOD while playing Total War Shogun 2 Fall of The Samurai
I was playing Fall of The Samurai when black pixels started to appear on my screen then the whole PC shut down. When I rebooted, it told me that it's a bluescreen. Here's what it showed me on reboot - --------------------------------------------------------------------------------- Problem...
BSOD Help and Support
Can't install my COD:Black Ops, COD:Modern Warfare 2 & Total Shogun 2
Recently, I was installed my game COD: Black Ops and Modern Warfare 2 into my Toshiba Qosmio F750 "non-free glasses 3D" with this windows 7 and despite of that I can't directly install COD:Modern Warfare 2 and Total Shogun 2. The problem is that "DX............is not sufficient with your setting"...
Gaming
BSOD playing Shogun 2 Total War
Windows 7 Ultimate x64 Custom computer purchased without OS Full Retail OS installed Age of system (hardware): 1day Age of OS installation: 1day
BSOD Help and Support
Shogun 2 Total War: issues with battery charging while playing.
So, the problem is very simple - when I start the game, my battery won't charge. It only does on loading screens (when I enter or end battle). My laptop is Acer Aspire 8942G, Win 7. It looks like the game blocks or conflicts with my charger when I play it. Once I switch tabs, the battery...
Gaming


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 11:09.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App