Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD - Software or Hardware???

19 Jul 2011   #1

Windows 7 Home Premium 64bit
BSOD - Software or Hardware???

Hi, could someone help me figure out why my computer seems to randomly crash with a BSOD. It is happening seemingly random, that means some days it will crash 3 times, other times it will go days without a crash. I can't attribute any particular activity with the crashing.

My computer is unaltered/unopened since buying it new, so still under warranty. However if it's a software problem, I should be able to fix it myself without send it away.
here are the specs:
Acer Aspire AX1301, Windows 7 Home Premium, CPU AMD Athlon II X4 620 quad-core, VGA: HD 4350 512Mb ATI Radeon

I have my suspicions about my wireless usb dongle. Its a D-link DWA-125 and it has been nothing but a pain to use!

Just a bit of further info: i also have dual OS with Linux installed on a separate partition, and the computer also crashes under Linux. However i still cant distinguish between software and hardware becasue it could still be the wireless USB.

My dump files are attached.
Any help would be very much appreciated! Thanks alot!

My System SpecsSystem Spec
19 Jul 2011   #2

Microsoft Windows 7 Ultimate: x64 (SP1)

Hello whity & Welcome to SevenForums!

BSOD Summary
Microsoft (R) Windows Debugger Version 6.12.0002.633 X86
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Users\Frederik\AppData\Local\Temp\Rar$DI11.835\031911-21044-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*C:\SymCache*
Executable search path is: 
Windows 7 Kernel Version 7600 MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Built by: 7600.16695.amd64fre.win7_gdr.101026-1503
Machine Name:
Kernel base = 0xfffff800`02c17000 PsLoadedModuleList = 0xfffff800`02e54e50
Debug session time: Sat Mar 19 16:36:34.391 2011 (UTC + 2:00)
System Uptime: 0 days 1:37:12.357
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 1E, {0, 0, 0, 0}

Probably caused by : USBSTOR.SYS ( USBSTOR!USBSTOR_BulkQueueResetPipe+51 )

Followup: MachineOwner

3: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

This is a very common bugcheck.  Usually the exception address pinpoints
the driver/function that caused the problem.  Always note this address
as well as the link date of the driver/image that contains this address.
Arg1: 0000000000000000, The exception code that was not handled
Arg2: 0000000000000000, The address that the exception occurred at
Arg3: 0000000000000000, Parameter 0 of the exception
Arg4: 0000000000000000, Parameter 1 of the exception

Debugging Details:

EXCEPTION_CODE: (Win32) 0 (0) - Handlingen er gennemf rt.

00000000`00000000 ??              ???

EXCEPTION_PARAMETER1:  0000000000000000

EXCEPTION_PARAMETER2:  0000000000000000







EXCEPTION_RECORD:  fffff880009b0928 -- (.exr 0xfffff880009b0928)
ExceptionAddress: fffff80002c8f09e (nt!ExQueueWorkItem+0x000000000000010e)
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 0000000000000000
   Parameter[1]: ffffffffffffffff
Attempt to read from address ffffffffffffffff

TRAP_FRAME:  fffff880009b09d0 -- (.trap 0xfffff880009b09d0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=ff00f80002e2c5a0 rbx=0000000000000000 rcx=0000000000000001
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff80002c8f09e rsp=fffff880009b0b60 rbp=fffffa8006120c00
 r8=0000000000000000  r9=fffff80002f81920 r10=fffff88002dd3b80
r11=fffff880009b0ba0 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz na po nc
fffff800`02c8f09e f083402801      lock add dword ptr [rax+28h],1 ds:8010:ff00f800`02e2c5c8=????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80002c7f46e to fffff80002c87710

fffff880`009afa18 fffff800`02c7f46e : 00000000`00000075 fffff880`02a5d59a fffff880`009b0190 fffff800`02cb4668 : nt!KeBugCheck
fffff880`009afa20 fffff800`02cad40d : fffff800`02e95b7c fffff800`02dcfea4 fffff800`02c17000 fffff880`009b0928 : nt!KiKernelCalloutExceptionHandler+0xe
fffff880`009afa50 fffff800`02cb4a90 : fffff800`02dd6a60 fffff880`009afac8 fffff880`009b0928 fffff800`02c17000 : nt!RtlpExecuteHandlerForException+0xd
fffff880`009afa80 fffff800`02cc19ef : fffff880`009b0928 fffff880`009b0190 fffff880`00000000 fffffa80`075feb60 : nt!RtlDispatchException+0x410
fffff880`009b0160 fffff800`02c86d82 : fffff880`009b0928 fffff800`02e2c5a0 fffff880`009b09d0 fffffa80`0612e840 : nt!KiDispatchException+0x16f
fffff880`009b07f0 fffff800`02c8568a : fffffa80`03d48301 00000000`00000000 fffffa80`03d48010 fffffa80`053a76a0 : nt!KiExceptionDispatch+0xc2
fffff880`009b09d0 fffff800`02c8f09e : ffffffff`c0000004 fffffa80`053a6a10 fffffa80`053a61a0 fffff880`03e54783 : nt!KiGeneralProtectionFault+0x10a
fffff880`009b0b60 fffff880`0221370d : fffffa80`06122b60 fffffa80`06122b60 00000000`00000002 fffffa80`06122a10 : nt!ExQueueWorkItem+0x10e
fffff880`009b0bd0 fffff880`022130bb : fffffa80`06122b60 fffffa80`06120cc0 fffffa80`06126f80 fffffa80`06122a10 : USBSTOR!USBSTOR_BulkQueueResetPipe+0x51
fffff880`009b0c10 fffff800`02c89d26 : fffff800`0321fc60 fffffa80`06824f73 00000000`00000000 00000000`00000c00 : USBSTOR!USBSTOR_DataCompletion+0x173
fffff880`009b0c70 fffff880`03e655d9 : fffffa80`053a6050 fffffa80`06122c00 ffffffff`c0000004 00000000`00000000 : nt!IopfCompleteRequest+0x3a6
fffff880`009b0d50 fffff880`03e65ab7 : fffffa80`03d48002 fffffa80`06824c60 00000000`ffffffff fffffa80`053a6ea8 : USBPORT!USBPORT_Core_iCompleteDoneTransfer+0xa15
fffff880`009b0e30 fffff880`03e6364f : fffffa80`053a6ea8 fffffa80`053a61a0 fffffa80`053a7040 00000000`00000000 : USBPORT!USBPORT_Core_iIrpCsqCompleteDoneTransfer+0x3a7
fffff880`009b0e90 fffff880`03e54f89 : fffffa80`053a6050 00000000`00000000 fffffa80`053a6e02 fffffa80`053a6ea8 : USBPORT!USBPORT_Core_UsbIocDpc_Worker+0xf3
fffff880`009b0ed0 fffff800`02c92bfc : fffff880`02dd3180 fffffa80`053a6ea8 fffffa80`053a6ec0 00000000`0000ffff : USBPORT!USBPORT_Xdpc_Worker+0x1d9
fffff880`009b0f00 fffff800`02c8d865 : 00000000`00000000 fffffa80`04281760 00000000`00000000 fffff880`03e54db0 : nt!KiRetireDpcList+0x1bc
fffff880`009b0fb0 fffff800`02c8d67c : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KxRetireDpcList+0x5
fffff880`08309770 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiDispatchInterruptContinue


fffff880`0221370d 4883c430        add     rsp,30h



FOLLOWUP_NAME:  MachineOwner





BUCKET_ID:  X64_0x1E_0_USBSTOR!USBSTOR_BulkQueueResetPipe+51

Followup: MachineOwner
USBSTOR.SYS is a USB Mass Storage Class Driver which controls when you plug and unplug your USBs. This is caused by one of your crashes. Is their any chance you can update this?
It's quite new though:
USBSTOR  USBSTOR.SYS  Tue Jul 14 02:06:34 2009
There's a couple of more types of errors, but let's start of like this.

Best Regards,
My System SpecsSystem Spec
19 Jul 2011   #3

Windows 7 Home Premium 64bit

Thanks for the fast reply FredeGail!

I tried to update the driver through device manager, it suggests that it already has the most up-to-date driver.
I also noticed that this driver from the 'Universal serial Bus Controllers' in the tree menu will disappear if i disconnect the wireless USB. Further more, since the driver could not be updated, i tried disabling it. Despite getting a warning that my USB will not work, the internet USB is still functioning while disabled. should i keep it disabled and wait to see if i get another crash??
My System SpecsSystem Spec

19 Jul 2011   #4

Microsoft Windows 7 Ultimate: x64 (SP1)

Quote   Quote: Originally Posted by whity View Post
Thanks for the fast reply FredeGail!

I tried to update the driver through device manager, it suggests that it already has the most up-to-date driver.
I also noticed that this driver from the 'Universal serial Bus Controllers' in the tree menu will disappear if i disconnect the wireless USB. Further more, since the driver could not be updated, i tried disabling it. Despite getting a warning that my USB will not work, the internet USB is still functioning while disabled. should i keep it disabled and wait to see if i get another crash??
Sure, wait to see if it crashes again, and if it does, it's probably it's causing something else. Wait for the next crash incoming as I'm pretty sure there will be one due to many different causes of crashes I saw.
I'm going to Thailand early morning tomorrow, so if you're super-duper-monkey-fast I can analyse your next .dmp!

Best Regards,
My System SpecsSystem Spec
25 Jul 2011   #5

Windows 7 Home Premium 64bit

Computer has ran well the last week, I figured problem must be solved....
I thought wrong! another BSOD!
I've attached the dumpfile... any help would be much appreciated!
My System SpecsSystem Spec

 BSOD - Software or Hardware???

Thread Tools

Similar help and support threads
Thread Forum
Random BSOD - hardware or software problem?
Hallo everybody, I hope you can help me. I have continuos BSOD or pc freezing since two months. Dont know if it is an hardware, software or virus problem. I tried different programs and tests, but the pc still has this problem. This is a work station that run only original programs. I send the...
BSOD Help and Support
BSOD - No New Hardware Installed - No Software Updated
I have received the following BSOD - twice today and looking for any input please! BCCode: 109 BCP1: A3A039D89E93B99D BCP2: B3B7465EF11188DB BCP3: FFFFF80004031000 BCP4: 0000000000000001 OS Version: 6_1_7601 Service Pack: 1_0 Product: 256_1
BSOD Help and Support
Dell Inspirion 1525 BSOD No hardware change or software change
BSOD happened today and was wondering was there a solution for this problem. I don't know why the issue has come up as now.
BSOD Help and Support
Is this BSOD hardware or software related?
I've recently build a new computer, but have been receiving several intermittent BSODs. I don't know a lot about them, so if anyone could help determine what might be the cause, or at least if it's hardware or software related? I'm aware the performance report says i have no security...
BSOD Help and Support
Misterious BSOD & Freezes, clues point to both Hardware and Software
I have a serious and mysterious problem with my system. Things that happened in the last few days according to Soluto: Screenshot Event viewer says this about and before one of the BSODs (AKA Stop Error and Bug Check): Screenshot ; Screenshot ; Screenshot and this one: Screenshot My specs...
BSOD Help and Support
BSOD, software or hardware problem?
I think HDAudio.sys is the problem but I'm not sure. can somebody check my dump file ?
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 16:49.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App