Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: driver IRQL not equal or less

30 Jul 2011   #1

Windows 7 Home Premium 64bit
driver IRQL not equal or less


I've been having this blue screen continuously for the past couple of weeks. I thought about updating drivers, although if there's any insight you guys can give me I would really appreciate it. My basic system info:

Model: Dell XPS L501X
SO: Windows 7 64bit
Processor: Intel Core i5 CPU M 560 @ 2.67 GHz 2.67 GHz
RAM: 6.00 GB

The system and OS are around 3 months old. I attach the ZIP file for more info.


My System SpecsSystem Spec
30 Jul 2011   #2

Windows 10 Pro x64, Arch Linux

The most probable cause it your McAfee Software, you should remove it and use MSE instead

Please remove any CD virtualization programs such as Daemon Tools and Alcohol 120%. They use a driver, found in your dmp, sptd.sys, that is notorious for causing BSODs. Use this SPTD uninstaller when you're done: DuplexSecure - Downloads
You can use MagicDisc as an alternative.
sptd.sys        fffff880`01038000    fffff880`0119a000    0x00162000    0x4ceba9d9    23/11/2010 15:47:37
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arg1: 0000000000000028, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, value 0 = read operation, 1 = write operation
Arg4: fffff88001917b2d, address which referenced memory

Debugging Details:

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff800034fc100


fffff880`01917b2d 448b5228        mov     r10d,dword ptr [rdx+28h]





TRAP_FRAME:  fffff880035bc660 -- (.trap 0xfffff880035bc660)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=fffff880035bc880 rbx=0000000000000000 rcx=0000000000000000
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff88001917b2d rsp=fffff880035bc7f0 rbp=fffff880035bc920
 r8=00000000ffffffbc  r9=0000000000000044 r10=0000000000000000
r11=fffffa800daf7c70 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl zr na po nc
fffff880`01917b2d 448b5228        mov     r10d,dword ptr [rdx+28h] ds:00000000`00000028=????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff800032cc2a9 to fffff800032ccd00

fffff880`035bc518 fffff800`032cc2a9 : 00000000`0000000a 00000000`00000028 00000000`00000002 00000000`00000000 : nt!KeBugCheckEx
fffff880`035bc520 fffff800`032caf20 : 00000000`00000000 fffff880`01a867a2 fffff880`035bc6b8 00000000`00000044 : nt!KiBugCheckDispatch+0x69
fffff880`035bc660 fffff880`01917b2d : fffffa80`08cad160 00000000`00000397 00000000`00000000 00830000`0e000000 : nt!KiPageFault+0x260
fffff880`035bc7f0 fffff880`01ac566c : 00000000`00000315 fffff880`01a942d6 00000000`00000001 fffffa80`0caa0b00 : NETIO!RtlCopyBufferToMdl+0x1d
fffff880`035bc850 fffff880`01a918c3 : fffffa80`0daf7c70 00000000`00000001 fffffa80`08cad160 00000000`00000000 : tcpip! ?? ::FNODOBFM::`string'+0x1d74f
fffff880`035bc8c0 fffff880`01a84724 : fffff880`035bcd78 00000000`00000029 fffffa80`08cad160 00000000`00000000 : tcpip!TcpTcbCarefulDatagram+0x543
fffff880`035bca70 fffff880`01a8304a : fffffa80`06977d80 fffff880`01a7b504 fffffa80`068c7010 00000000`00000000 : tcpip!TcpTcbReceive+0x694
fffff880`035bcc20 fffff880`01a84c7b : fffff880`04fe40fa fffffa80`06a91000 00000000`00000000 fffff880`035bcf00 : tcpip!TcpMatchReceive+0x1fa
fffff880`035bcd70 fffff880`01a7bb97 : fffffa80`06977d80 fffffa80`0697c4e8 fffffa80`0000f46b 00000000`0000f46b : tcpip!TcpPreValidatedReceive+0x36b
fffff880`035bce40 fffff880`01a7b70a : 00000000`00000000 fffff880`01b97800 fffff880`035bd000 fffffa80`05f055c0 : tcpip!IppDeliverListToProtocol+0x97
fffff880`035bcf00 fffff880`01a7ad09 : 00000000`00000001 00000000`00000011 00000000`00000003 fffff880`035bcff0 : tcpip!IppProcessDeliverList+0x5a
fffff880`035bcfa0 fffff880`01a78a7f : 00000000`00000000 00000000`099b2800 fffff880`01b97800 fffff880`01b97800 : tcpip!IppReceiveHeaderBatch+0x23a
fffff880`035bd080 fffff880`01a78072 : fffffa80`099b37d0 00000000`00000000 fffffa80`099b2800 fffffa80`00000001 : tcpip!IpFlcReceivePackets+0x64f
fffff880`035bd280 fffff880`01af83da : fffff880`035bd5d0 00000000`00000000 fffffa80`099b2820 00000000`00000000 : tcpip!FlpReceiveNonPreValidatedNetBufferListChain+0x2b2
fffff880`035bd360 fffff800`032d9668 : fffffa80`0d3efdc0 fffffa80`0ec875b0 fffffa80`05a68b60 00000000`00000001 : tcpip! ?? ::FNODOBFM::`string'+0x568e2
fffff880`035bd3b0 fffff880`01a77bd2 : fffff880`01a77430 00000000`00000002 00000000`00000000 00000000`00000001 : nt!KeExpandKernelStackAndCalloutEx+0xd8
fffff880`035bd490 fffff880`018d20eb : fffffa80`099b4740 00000000`00000000 fffffa80`091181a0 00000000`00000000 : tcpip!FlReceiveNetBufferListChain+0xb2
fffff880`035bd500 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : ndis!ndisMIndicateNetBufferListsToOpen+0xdb


fffff880`01917b2d 448b5228        mov     r10d,dword ptr [rdx+28h]


SYMBOL_NAME:  NETIO!RtlCopyBufferToMdl+1d

FOLLOWUP_NAME:  MachineOwner




FAILURE_BUCKET_ID:  X64_0xD1_NETIO!RtlCopyBufferToMdl+1d

BUCKET_ID:  X64_0xD1_NETIO!RtlCopyBufferToMdl+1d

Followup: MachineOwner
My System SpecsSystem Spec
31 Jul 2011   #3

Windows 7 Home Premium 64bit
Thank you!

Thank you very much for your advice! I changed my Antivirus and erased DT, and I had no problems so far. I'll just put it as solved, thank you for answering so fast and accurately.
My System SpecsSystem Spec


 driver IRQL not equal or less

Thread Tools

Similar help and support threads
Thread Forum
BSOD - driver power state failure/driver IRQL not less or equal
Hello, I would appreciate any help with the following problem: the pc sometimes seemingly randomly shows BSOD with errors named in the title, I also attach corresponding screenshots. The problem wont happen if the PC power is supplied from the adapter AND there is some content running on the...
BSOD Help and Support
Driver IRQL Not Less Or Equal
Hi I have very recently begun to get a lot of these BSODs on my desktop the system was running fine till a few days ago but now i get regular crashes. I had installed a new WD 1TB hdd into the system a month back but it had worked fine uptill now.
BSOD Help and Support
Driver IRQL Not or Less Equal
Having lots of issues, i'm sure someone out there knows what this is. stop: 0x000000D1 (ox000000000000001C, 0x0000000000000002, 0x00000000000001, 0xFFFFF88001A7B3BA) tcpip.sys - address FFFFF88001A7B3BA at FFFFF88001A02000, DateStamp 4c15a458. It's a Lenovo Thinkpad Edge 14, Windows 7...
BSOD Help and Support
BOD:Driver Irql less or not equal
Hi, I'm using windows 7 ultimate x86. recently i got the blue screen with Driver Irql less or not equal. i reinstalled windows to x64 and again i got the BOD. when i get error pc resets and windows load and after windows loaded, again i got BOD, but i don't got it for 10 hours, and after that...
BSOD Help and Support
Driver IRQL not less or equal
I get these BSODs anytime at irregular basis, it can happen while playing games or when just browsing on the web. I have several programs loading automatically so I can't see which program, if any, that cause the problem. I've tried to update all drivers but maybe I missed some. Please help...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:49.
Twitter Facebook