Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD while updating new graphics card

10 Aug 2011   #1

Windows 7 Home Premium 64-bit (6.1, Build 7601)
BSOD while updating new graphics card

To cut a long story short, I'd sent my computer off to Currys/PCWorld (where my dad works) for them to do a full diagnostic of my PC (because my graphics card was faulty a few months ago).

Through/by no choice of my own, I was given a new graphics card - an ASUS ATi Radeon EAH5770 CU core, 1GB GDDR5 (powered by a HD Radeon 5770 = not bad I suppose; at least it's much better than my old GeForce 8800GTS)

I found out it needed updating, and (I can't remember why or how I managed it but) I did that through Steam; but then I got a BSOD message

(perfmon.html is included in the zip file)

-Windows 7 X64
-Not the original OS (was Vista)
-Full retail (legally bought) version
-I bought my computer/hardware on 13th March 2007
-installed Windows 7 [32-bit] on 24th October 2009, then the 64-bit on 4th January 2011

My System SpecsSystem Spec
10 Aug 2011   #2

Microsoft Windows 7 Ultimate: x64 (SP1)

Hello Gaz1701 & Welcome to SevenForums!

The crash you experienced was caused by the driver for the ATI card. Uninstall it, and install it again from the link below.

Global Provider of Innovative Graphics, Processors and Media Solutions | AMD

BSOD Summary
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 116, {fffffa80046034e0, fffff8800757d9c8, 0, 2}

Unable to load image \SystemRoot\system32\DRIVERS\atikmpag.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for atikmpag.sys
*** ERROR: Module load completed but symbols could not be loaded for atikmpag.sys
Probably caused by : atikmpag.sys ( atikmpag+79c8 )

Followup: MachineOwner

0: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Attempt to reset the display driver and recover from timeout failed.
Arg1: fffffa80046034e0, Optional pointer to internal TDR recovery context (TDR_RECOVERY_CONTEXT).
Arg2: fffff8800757d9c8, The pointer into responsible device driver module (e.g. owner tag).
Arg3: 0000000000000000, Optional error code (NTSTATUS) of the last failed operation.
Arg4: 0000000000000002, Optional internal context dependent data.

Debugging Details:

fffff880`0757d9c8 4883ec28        sub     rsp,28h






fffff880`09086898 fffff880`04b1e000 : 00000000`00000116 fffffa80`046034e0 fffff880`0757d9c8 00000000`00000000 : nt!KeBugCheckEx
fffff880`090868a0 fffff880`04b1dd0a : fffff880`0757d9c8 fffffa80`046034e0 fffffa80`07e31010 fffffa80`061a5410 : dxgkrnl!TdrBugcheckOnTimeout+0xec
fffff880`090868e0 fffff880`05323f07 : fffffa80`046034e0 00000000`00000000 fffffa80`07e31010 fffffa80`061a5410 : dxgkrnl!TdrIsRecoveryRequired+0x1a2
fffff880`09086910 fffff880`05351d5a : 00000000`ffffffff 00000000`00039307 fffff880`09086a70 00000000`00000102 : dxgmms1!VidSchiReportHwHang+0x40b
fffff880`090869f0 fffff880`0534d6af : fffffa80`061a5410 ffffffff`feced300 00000000`00000000 fffff8a0`03a18000 : dxgmms1!VidSchWaitForCompletionEvent+0x196
fffff880`09086a30 fffff880`0534c023 : fffffa80`061a5410 00000000`00000002 fffff880`09086b90 fffff880`09086b80 : dxgmms1!VidSchiWaitForEmptyHwQueue+0x8f
fffff880`09086b20 fffff880`0534c2fe : 00000000`00000000 00000000`00000002 00000003`00000380 fffffa80`06371af0 : dxgmms1!VidSchiHandleControlEvent+0x3b
fffff880`09086b50 fffff880`0531f2c6 : ffffffff`ff676980 fffffa80`061a5410 00000000`00000080 00000000`00000000 : dxgmms1!VidSchiWaitForSchedulerEvents+0x23e
fffff880`09086bf0 fffff880`0534be7a : fffffa80`07e31010 fffffa80`07e31010 00000000`00000080 fffffa80`061a5410 : dxgmms1!VidSchiScheduleCommandToRun+0x1da
fffff880`09086d00 fffff800`02d6832e : fffff880`00000000 fffffa80`07a575c0 fffffa80`039cd040 fffff800`02ac3817 : dxgmms1!VidSchiWorkerThread+0xba
fffff880`09086d40 fffff800`02abd666 : fffff800`02c3ee80 fffffa80`07a575c0 fffffa80`06dbbb60 fffff880`01250cb0 : nt!PspSystemThreadStartup+0x5a
fffff880`09086d80 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiStartSystemThread+0x16

STACK_COMMAND:  .bugcheck ; kb

fffff880`0757d9c8 4883ec28        sub     rsp,28h

SYMBOL_NAME:  atikmpag+79c8

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: atikmpag

IMAGE_NAME:  atikmpag.sys


FAILURE_BUCKET_ID:  X64_0x116_IMAGE_atikmpag.sys

BUCKET_ID:  X64_0x116_IMAGE_atikmpag.sys

Followup: MachineOwner
Best Regards,
My System SpecsSystem Spec

 BSOD while updating new graphics card

Thread Tools

Similar help and support threads
Thread Forum
BSOD when updating Graphics Card
Hi, so I tried to update my Graphic Card here Desktop but it gave me a bsod, I have a minidump but can;t attach it because its saying I need admin priv which I already have..but still not letting me.
BSOD Help and Support
Having trouble updating my Graphics Card
So a few minutes ago I opened this Webm Drive club 1411776050682.gif (GIF Image, 266 × 199 pixels) and a few seconds into it I got a BSOD. It made a memory dump, but I can't open it because its saying I need admin privilege, which I already am. So everytime I play the GIF the video breaks, it gives...
Graphic Cards
Need help updating drivers for graphics card.
Hello everyone. I am having a lot of trouble trying to update the driver on my graphics card. I currently have an Alienware MX17 R3 with an Radeon HD 6870m. I try to download the driver directly from the AMD site but I get this message. (Attatched) I go to the Alienware driver page and...
Graphic Cards
Resolution change after updating graphics card
I just updated my 5800 series Radeon, and now my display won't go past 1152 x 864. I know my laptop can go to 1440x900. What's going on?
Graphic Cards
Updating My Graphics Card with my new Windows 7
ok so my hard drive took a dump. so i went out and bought a brand new one and installed it myself. then i went and got windows 7 and also installed that myself. (DYI!) But im trying to burn a movie with Windows DVD Maker, but it told my that my video card does not meet the minimum requirments. So i...
Graphic Cards
Updating NVIDIA graphics card
AH NEVER MIND, I UPDATED THE GRAPHICS CARD, however I updated my graphics card, went well. I got this when trying to troubleshoot the problem why I cannot have Aero on my Windows 7: I scanned for hardware changes and got this aswell:
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 14:11.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App