Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Applications only launch from start menu when ran as administrator

19 Sep 2011   #1

Seven / Arch
Applications only launch from start menu when ran as administrator

EDIT: Is this in the wrong section? Mostly BSOD errors here...

Hello there, the thread title is only one symptom of the issue with my PC but i couldn't think of a more appropriate one (Feel free to suggest alternatives).

System setup:

Win7 (Working fine since Xmas, just playing up now) Dual booted with Ubuntu 10.10
Installed a custom theme (May be related to the issue Gizdom Reloaded:Gizdom Reloaded for Windows 7 by =kAtz93 on deviantART)
Overclocked system (Worth mentioning but i have removed the OC to try and fix it)
Custom built PC (OC'd Benchmark:
MBAM believes it is clean of malware (Done 4 scans this week)

The symptoms:

Applications won't run from the start menu or the quick launch bar, to get round this i have been clicking on the steam icon in the tray going to store and then clicking a link to facebook to access firefox! However this issue isn't consistent, sometimes it will work fine for a while before this occurs. (Side note this workaround has stopped working see later...)

If the latter is occurring and I then open up say My Documents and right click on a file (Any file type) explorer crashes, well it just stalls at first then if i try to close the window i get the "Would you like to close or wait for etc..." popup... if i say close then explorer all crashes taskbar vanishes etc... after a couple of seconds it reappears then when i next attempt to use explorer i get this error: "The remote procedure call failed and did not execute". (This is no longer happening)

So i left it for a while and it started to work fine again completely out of the blue! But about 5 days later i got these errors again... so thinking it is to do with the theme and replaced all the settings to default, but now i can't really do anything... for example after clicking "Personalize" on the desktop nothing happens then when i reboot i get "Explorer.exe: Server failed to execute"... I managed to do a scan with MBAM and it seems clean to me...

So more things established... I ran an anti rootkit software (Sophos) and that didn't turn anything of notice up, and i have done another MBAM scan and still nothing. Now I have worked out if i run programs as admin from the start menu they now work! So thats strange, and the server execution fail error is made by right clicking on the desktop and clicking personalize, after 2 or 3 minutes i get that error. I'm sure it can be reproduced in other ways but thats the way i am seeing it...

Any ideas on what may be causing this are very much welcome and solutions are even better! Please don't suggest a re-installation as i really really don't want to do that!

More info: I created a new user with standard permissions and they suffered the same issues. I also ran kaspersky's anti root kit... with no result

Even more info: Found this thread - UAC - (palm face)

And used Process Hacker tool to look at how my processes are running and it is rather interesting:

The applications highlighted in orange are working, they all have High permissions because I "Right click > Run as Administrator", the ones in pink with Medium permissions I have ran as you would normally so they have standard permissions, however they are not showing up at all. So you can see under the orange firefox (The one that i ran as admin and works) Is a firefox that i ran normally, the process starts uses some RAM but doesn't get past that. There is no visual error or outcome just the program doesn't start. And thats the same for all of my other applications as well...

Thanks a lot for your help : )

My System SpecsSystem Spec
10 Oct 2011   #2

Seven / Arch

I am about to re-install Windows against my will! I have left this for ages and not figured out a solution so i think that a re-install is my only hope : (

My System SpecsSystem Spec
10 Oct 2011   #3

Windows 7 Professional SP1 32-bit

I just saw this thread - hopefully it's not too late to stop you from reinstalling! What you can do for now is open a DOS command prompt and typing sfc /scannow. This should check your Windows system for corrupted files and replace them as needed. You might have to do this 3 times with a restart between each time.

Also, I notice you're running Sandboxie. Just on a hunch I would suggest uninstalling this and seeing if that helps the problems go away. Sandboxie is an interesting security tool but it's not useful for most people and not meant as a complement for antivirus or antispyware software. Unless you have a very good specific reason for running Sandboxie, I would recommend disabling and uninstalling it.
My System SpecsSystem Spec

10 Oct 2011   #4

Seven / Arch

Thanks a lot for your reply!

I have done sfc /scannow multiple times and it has said that errors were found but not repaired. Then a log file is made but i can never make sense of it, perhaps this may be of use?

And i will try to uninstall SandBoxie, although i cannot see why this would cause a problem?

Thanks again : )
My System SpecsSystem Spec

 Applications only launch from start menu when ran as administrator

Thread Tools

Similar help and support threads
Thread Forum
Applications no longer show in the Start Menu
edit: well, that was a quick fix. After I looked in the Start Menu properties to see if there were any settings there I could change, applications now show up fine. Yesterday I was upgrading a friend's laptop from Vista to 7. Before installing 7, I wanted to take a backup of their user folder....
Performance & Maintenance
Windows 7 Start Menu can't find Applications....?
Windows 7 Pro system, Start Menu's Search Bar has always been able to find my executables as you type them. For example, type "pho" and as you're typing it, "Photoshop" would appear for you to click. Type "fi" and "Firefox" would appear ready to click and run. Sometime recently, partial names...
General Discussion
Some Programs Slow to Launch from Start Menu
Hi I have a weird situation. Some programs are slow to launch from the start menu (win7 home premium), while they start quickly when launched from an explorer windows. Any suggestions as to what could cause this ? Rgds, J.
Performance & Maintenance
New applications not highlighted in start menu
New applications installed not highlighted in start menu Hi everybody i installed a few new applications. After installation i don t see them in my startup menu, not like in xp were new applications were marked via new programs installed - I already tapped the options show newly installed...
Performance & Maintenance
another way to launch the start menu?
anybody know an app or command that can launch the start menu? something i can pin to the taskbar. instead of hacking explorer.exe, i just want to hide the orb with Start Killer and get to the start menu with the left-most pinned item... even something that would send the WIN key would...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:33.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App