Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 doesn't boot and bluescreens after resizing hybrid GPT/MBR

24 Oct 2011   #1
John H Meyer

Windows 7 EE x64
Windows 7 doesn't boot and bluescreens after resizing hybrid GPT/MBR

Note: I am unable to provide any of the bluescreen information files, as I currently only have access to the recovery console. I'll be happy to run any applications that can be run from there or send any log files already present on my computer.

I run Windows 7 Enterprise Edition 64 bit (company licence, clean install done by me 1 year ago) on a MacBook Pro (13'', mid 2010) with Boot Camp. As MacBooks use EFI, the volume is formatted using GPT. Boot Camp creates a GPT/MBR hybrid partitioning to run Windows. I took the following steps to resize my Windows partition. These are well established and should have resulted in a larger Windows partition that boots fine. However, the end result is that Windows does not boot anymore and displays a blue screen.

I used GParted from a bootable Linux CD to resize my partition. Here is a screenshot of the final result (screenshots are reduce to reduce file size, sorry about the quality):

ImageShack® - Online Photo and Video Hosting

I then used rEFIt from a bootable Mac CD to correct the MBR:

ImageShack® - Online Photo and Video Hosting

After I noted that Windows does not boot and displays a bluescreen, I used bootrec.exe from the recovery console to fix the MBR:

ImageShack® - Online Photo and Video Hosting

I used bcdedit.exe from the recovery console to rebuild the BCD:

ImageShack® - Online Photo and Video Hosting

Examining the partition using diskpart.exe from the recovery console looks like everything is all right. The system boots from a 200 MB EFI partition (type EE) and then switches to the Windows partition (type 07):

ImageShack® - Online Photo and Video Hosting

Now to the error I get. Windows starts booting fine and displays the Windows logo. Then I get a "autochk program not found - skipping AUTOCHECK " message:

ImageShack® - Online Photo and Video Hosting

And finally a bluescreen with
STOP: c000021a {Fatal System Error}
The Session Manager Initialization system process terminated unexpectedly with a status of 0xc000003a (0x00000000 0x00000000). The system has been shut down.

ImageShack® - Online Photo and Video Hosting

Any suggestions?

My System SpecsSystem Spec
25 Oct 2011   #2
John H Meyer

Windows 7 EE x64

I deleted an OS X partition before resizing. Apparently this was the problem. The problem could be solved by creating a small dummy partition in the same position as the old one (and then use rEFIt and recovery console to repair MBR and BCD). Everything works fine now.
My System SpecsSystem Spec

 Windows 7 doesn't boot and bluescreens after resizing hybrid GPT/MBR

Thread Tools

Similar help and support threads
Thread Forum
Boot Windows 7/8 from GPT on BIOS system : No hybrid MBRs or DUET!
Hi guys, Till now, Windows 7/8 x64 could boot from a GPT disk only on a UEFI system. Methods to enable this are hybrid MBRs and DUET. Both of which are hacks. We now have a simple way to boot windows (BOTH 32bit AND 64 bit) from a GPT disk on a BIOS system WITHOUT hybrid MBRs or DUET, using...
Installation & Setup
Oxc0000225 boot fail after resizing storage drive want to duel boot
Hi i want to duel boot windows 7 and windows 8.1...i have a 240gb ssd with windows 7 already installed on it....i also have a 2tb storage hardrive and i use this for storage..btw this hardrive did have my windows 7 on it untill i bought the ssd then i ported windows 7 on to the ssd using Paragon...
Installation & Setup
Something went wrong while resizing partition, now windows cant boot.
I really need your help with this problem. I have an Acer Aspire 5733-6607 with Windows 7 Home Premium 64bit installed. Two Months ago, I made another partition to install Elementary OS on it. After getting tired of it, i decided to delete the partition and resize my windows partition using...
Backup and Restore
Hybrid Boot in Windows 7 - is it possible?
Hi, and I'm back after several years of hibernation (I know, bad pun. ehehehe) Well, we all know how nifty Hybrid Boot is, logging off and hibernating the system files and all for a quick boot. Now here is the question, is it possible to add Hybrid Boot to Windows 7? Of course I did some...
Windows 7 - Error 0xc0000225 after resizing partition, can't boot
Hi everybody, I tried to resize my Win7 parition with Esaeus partition manager. So I had to restart win7 and before starting the SO the program began resizing the partitions. Unfortunately my brother plugged off the pc and when I restarted the pc on Win7 I saw this error: 0xc0000225 "boot...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 13:14.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App