Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD when replacing a new RAM

04 Jan 2012   #41

Microsoft Community Contributor Award Recipient

Windows 7 Ult x64 - SP1/ Windows 8 Pro x64

That is called a cold boot crash, they are difficult to diagnose and can be caused by a number of things.

Disable Driver Verifier, it's not giving us any good info.
Driver Verifier - Enable and Disable

Uninstall Daemon Tools. It's driver, SPTD, is known to cause problems in Windows 7. Once it's removed, run the SPTD removal tool. DuplexSecure
Confirm when you have done this.

What were the results when you ran prime95?
Did it stop on it's own or did you shut it down?

Both of the latest crashes are blamed on Windows services, these are not the cause but the result of the problem.
These type of crashes are usually hardware related.

Your last crash was STOP 0x0000003B: SYSTEM_SERVICE_EXCEPTION
Usual causes: System service, Device driver, graphics driver, ?memory
The DMP file is indicating a possible memory problem.

*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An exception happened while executing a system service routine.
Arg1: 00000000c0000005, Exception code that caused the bugcheck
Arg2: fffff960001a58aa, Address of the instruction which caused the bugcheck
Arg3: fffff88009bf19c0, Address of the context record for the exception that caused the bugcheck
Arg4: 0000000000000000, zero.

Debugging Details:

EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

fffff960`001a58aa f3410f7f4158    movdqu  xmmword ptr [r9+58h],xmm0

CONTEXT:  fffff88009bf19c0 -- (.cxr 0xfffff88009bf19c0)
rax=00000000000000a0 rbx=fffff900c00b8010 rcx=fffff88009bf2400
rdx=fffff88009bf23d0 rsi=fffff900c0904630 rdi=0000000100000001
rip=fffff960001a58aa rsp=fffff88009bf23a8 rbp=0000000000000001
 r8=fffff88009bf23d0  r9=fff7f900c0a72e30 r10=0000000000000001
r11=fffffa8005e84b60 r12=fffff900c0904630 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz ac po cy
cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00010297
fffff960`001a58aa f3410f7f4158    movdqu  xmmword ptr [r9+58h],xmm0 ds:002b:fff7f900`c0a72e88=????????????????????????????????
Resetting default scope




PROCESS_NAME:  explorer.exe


LAST_CONTROL_TRANSFER:  from 0000000000000000 to fffff960001a58aa

fffff880`09bf23a8 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : win32k!RGNOBJ::vSet+0x26

fffff960`001a58aa f3410f7f4158    movdqu  xmmword ptr [r9+58h],xmm0


SYMBOL_NAME:  win32k!RGNOBJ::vSet+26

FOLLOWUP_NAME:  MachineOwner


IMAGE_NAME:  win32k.sys


STACK_COMMAND:  .cxr 0xfffff88009bf19c0 ; kb

FAILURE_BUCKET_ID:  X64_0x3B_VRF_win32k!RGNOBJ::vSet+26

BUCKET_ID:  X64_0x3B_VRF_win32k!RGNOBJ::vSet+26

Followup: MachineOwner

The second to last crash was STOP 0x0000001E: KMODE_EXCEPTION_NOT_HANDLED
Usual causes: Device driver, hardware, System service, compatibility, Remote control programs, memory, BIOS

*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

This is a very common bugcheck.  Usually the exception address pinpoints
the driver/function that caused the problem.  Always note this address
as well as the link date of the driver/image that contains this address.
Arg1: 0000000000000000, The exception code that was not handled
Arg2: 0000000000000000, The address that the exception occurred at
Arg3: 0000000000000000, Parameter 0 of the exception
Arg4: 0000000000000000, Parameter 1 of the exception

Debugging Details:

EXCEPTION_CODE: (Win32) 0 (0) - The operation completed successfully.

00000000`00000000 ??              ???

EXCEPTION_PARAMETER1:  0000000000000000

EXCEPTION_PARAMETER2:  0000000000000000







EXCEPTION_RECORD:  fffff880031fd368 -- (.exr 0xfffff880031fd368)
ExceptionAddress: fffff880011adc4c (ataport!IdeLogCrbActive+0x00000000000000b8)
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 0000000000000000
   Parameter[1]: ffffffffffffffff
Attempt to read from address ffffffffffffffff

TRAP_FRAME:  fffff880031fd410 -- (.trap 0xfffff880031fd410)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=fff7fa8004798b70 rbx=0000000000000000 rcx=fffffa8005506a50
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff880011adc4c rsp=fffff880031fd5a0 rbp=0000000000000001
 r8=0000000000000000  r9=0000000000000000 r10=fffffa80053cfd40
r11=fffff880031fd6d0 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz na pe nc
fffff880`011adc4c 488b4808        mov     rcx,qword ptr [rax+8] ds:ffc0:fff7fa80`04798b78=????????????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff8000328b5fe to fffff80003293c10

fffff880`031fc448 fffff800`0328b5fe : 000044c2`000044c2 fffff800`000044c2 fffff880`031fcbc0 fffff800`032bf830 : nt!KeBugCheck
fffff880`031fc450 fffff800`032bf4fd : fffff800`0349d71c fffff800`033dac30 fffff800`03217000 fffff880`031fd368 : nt!KiKernelCalloutExceptionHandler+0xe
fffff880`031fc480 fffff800`032be2d5 : fffff800`033de0fc fffff880`031fc4f8 fffff880`031fd368 fffff800`03217000 : nt!RtlpExecuteHandlerForException+0xd
fffff880`031fc4b0 fffff800`032cf361 : fffff880`031fd368 fffff880`031fcbc0 fffff880`00000000 fffffa80`04c205a0 : nt!RtlDispatchException+0x415
fffff880`031fcb90 fffff800`032932c2 : fffff880`031fd368 fffffa80`055069d8 fffff880`031fd410 fffffa80`055051b0 : nt!KiDispatchException+0x135
fffff880`031fd230 fffff800`03291bca : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiExceptionDispatch+0xc2
fffff880`031fd410 fffff880`011adc4c : fffffa80`053ba830 00000000`ffffff01 fffffa80`055051b0 00000000`00000001 : nt!KiGeneralProtectionFault+0x10a
fffff880`031fd5a0 fffff880`011b7c89 : fffffa80`04c20970 fffffa80`054f01a0 fffffa80`04c205a0 fffffa80`054f01a0 : ataport!IdeLogCrbActive+0xb8
fffff880`031fd5d0 fffff800`038049ce : fffffa80`04c20970 00000000`00000300 00000000`00000000 00000000`00000020 : ataport!IdeStartIoCallBack+0xc9
fffff880`031fd740 fffff800`0380513d : fffffa80`053a9d40 fffffa80`0537e850 00000000`00000000 00000000`00000000 : hal!HalpAllocateAdapterCallback+0x146
fffff880`031fd7e0 fffff800`0380471f : fffffa80`04c20640 00000000`00020000 fffffa80`0537e850 fffffa80`047988c0 : hal!HalAllocateAdapterChannel+0x101
fffff880`031fd820 fffff880`0117a0d3 : fffffa80`04c205a0 fffff880`0117a12c fffffa80`00000340 fffffa80`0537e850 : hal!HalBuildScatterGatherList+0x2f3
fffff880`031fd890 fffff880`011b7b53 : fffffa80`04c205a0 fffffa80`055051b0 fffffa80`054f01a0 fffffa80`04c205a0 : PCIIDEX!BmSetup+0x6b
fffff880`031fd8f0 fffff880`011b6803 : fffffa80`054f1500 fffffa80`055051b0 fffffa80`054f1500 fffffa80`054f01a0 : ataport!IdeDispatchChannelRequest+0xef
fffff880`031fd920 fffff880`011b6336 : 00000000`00000001 fffffa80`04c205a0 00000000`00000001 fffffa80`04c205a0 : ataport!IdeStartChannelRequest+0x113
fffff880`031fd9a0 fffff880`011b859a : fffffa80`047f0000 00000000`00000000 fffffa80`055051b0 fffffa80`04c20a30 : ataport!IdeStartNextDeviceRequest+0x18e
fffff880`031fda40 fffff880`011b8104 : fffffa80`054f01a0 00000000`00000000 fffffa80`054f01a0 fffffa80`04c20a30 : ataport!IdeProcessCompletedRequests+0x26a
fffff880`031fdb70 fffff880`00e964ce : fffffa80`047f0000 00000000`000130ef fffffa80`054f0050 fffffa80`047f0750 : ataport!IdePortCompletionDpc+0x1a8
fffff880`031fdc30 fffffa80`047f0000 : 00000000`000130ef fffffa80`054f0050 fffffa80`047f0750 fffff880`031d5180 : sptd+0x424ce
fffff880`031fdc38 00000000`000130ef : fffffa80`054f0050 fffffa80`047f0750 fffff880`031d5180 00000000`00000000 : 0xfffffa80`047f0000
fffff880`031fdc40 fffffa80`054f0050 : fffffa80`047f0750 fffff880`031d5180 00000000`00000000 fffff880`031d9f40 : 0x130ef
fffff880`031fdc48 fffffa80`047f0750 : fffff880`031d5180 00000000`00000000 fffff880`031d9f40 00000000`00000022 : 0xfffffa80`054f0050
fffff880`031fdc50 fffff880`031d5180 : 00000000`00000000 fffff880`031d9f40 00000000`00000022 00000000`00000000 : 0xfffffa80`047f0750
fffff880`031fdc58 00000000`00000000 : fffff880`031d9f40 00000000`00000022 00000000`00000000 00000000`00000000 : 0xfffff880`031d5180


fffff880`011adc4c 488b4808        mov     rcx,qword ptr [rax+8]


SYMBOL_NAME:  ataport!IdeLogCrbActive+b8

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: ataport

IMAGE_NAME:  ataport.SYS


FAILURE_BUCKET_ID:  X64_0x1E_0_VRF_ataport!IdeLogCrbActive+b8

BUCKET_ID:  X64_0x1E_0_VRF_ataport!IdeLogCrbActive+b8

Followup: MachineOwner

My System SpecsSystem Spec
05 Jan 2012   #42

win 7 home premium 64bit

I have removed Daemon together with its SPTD long ago. And I'm using powerISO now. I though its friendly with 7 64bit.

I ran the prime95 and stop it manually as per Jonathan King instruction.
Quote   Quote: Originally Posted by Jonathan_King View Post
The tests will run indefinitely - until you stop them. There are three different tests (Blend, Small FFTs, Large FFTs); run each of them for about an hour.
Here's the result:Attachment 191572 Attachment 191573
Is there anything else I could do to fix this?
Or I guess I'll back to the PC store and asking them for more further assistance, and asking for warranty of course. Cause it seems this problems is getting complicated.
My System SpecsSystem Spec
05 Jan 2012   #43

Microsoft Community Contributor Award Recipient

Windows 7 Ult x64 - SP1/ Windows 8 Pro x64

Your last DMP file is still showing the SPTD driver still installed.
Did you run run the SPTD removal tool: DuplexSecure < Link
My System SpecsSystem Spec

05 Jan 2012   #44

win 7 home premium 64bit

yeah I did already, no SPTD driver detected anymore.
Here's my SS: Attachment 191636
My System SpecsSystem Spec
05 Jan 2012   #45

Microsoft Community Contributor Award Recipient

Windows 7 Ult x64 - SP1/ Windows 8 Pro x64

Best to take it back to the PC store, explain to them that it's a cold boot issue.

Let them fix it under the warranty.
My System SpecsSystem Spec
06 Jan 2012   #46

win 7 home premium 64bit

Sure thing, thx a lot for your help dave, really appreciated. I'll inform you after I get all the things fix..:)
My System SpecsSystem Spec
06 Jan 2012   #47

Microsoft Community Contributor Award Recipient

Windows 7 Ult x64 - SP1/ Windows 8 Pro x64

Your welcome.

Let us know the results.
My System SpecsSystem Spec
06 Jan 2012   #48

Windows 7 - Vista

For info, sptd.sys was on the stack of that last dump -

STACK_TEXT:   (edited)
031fcbc0 fffff800`032bf830 : nt!KeBugCheck
03217000 fffff880`031fd368 : nt!KiKernelCalloutExceptionHandler+0xe
031fd368 fffff800`03217000 : nt!RtlpExecuteHandlerForException+0xd
00000000 fffffa80`04c205a0 : nt!RtlDispatchException+0x415
031fd410 fffffa80`055051b0 : nt!KiDispatchException+0x135
00000000 00000000`00000000 : nt!KiExceptionDispatch+0xc2
055051b0 00000000`00000001 : nt!KiGeneralProtectionFault+0x10a
04c205a0 fffffa80`054f01a0 : ataport!IdeLogCrbActive+0xb8
00000000 00000000`00000020 : ataport!IdeStartIoCallBack+0xc9
00000000 00000000`00000000 : hal!HalpAllocateAdapterCallback+0x146
0537e850 fffffa80`047988c0 : hal!HalAllocateAdapterChannel+0x101
00000340 fffffa80`0537e850 : hal!HalBuildScatterGatherList+0x2f3
054f01a0 fffffa80`04c205a0 : PCIIDEX!BmSetup+0x6b
054f1500 fffffa80`054f01a0 : ataport!IdeDispatchChannelRequest+0xef
00000001 fffffa80`04c205a0 : ataport!IdeStartChannelRequest+0x113
055051b0 fffffa80`04c20a30 : ataport!IdeStartNextDeviceRequest+0x18e
054f01a0 fffffa80`04c20a30 : ataport!IdeProcessCompletedRequests+0x26a
054f0050 fffffa80`047f0750 : ataport!IdePortCompletionDpc+0x1a8
047f0750 fffff880`031d5180 : sptd+0x424ce
031d5180 00000000`00000000 : 0xfffffa80`047f0000
00000000 fffff880`031d9f40 : 0x130ef
031d9f40 00000000`00000022 : 0xfffffa80`054f0050
00000022 00000000`00000000 : 0xfffffa80`047f0750
00000000 00000000`00000000 : 0xfffff880`031d5180
Glad to hear it's removed.

If you have any other virtual devices installed, I suggest removal for now.

Regards. . .

My System SpecsSystem Spec

 BSOD when replacing a new RAM

Thread Tools

Similar help and support threads
Thread Forum
BSOD after replacing heatsink
Hello, I was using a stock heatsink in my computer before, and was receiving strange readings of a CPU at 113 degrees Celsius, so I opened it up, installed a better heatsink, and still got the same results. I learned that Speccy is just defaulting to that temperature because it can't read it. ...
BSOD Help and Support
BSOD after replacing my corrupted HDD to a SSD
I've replaced my HDD, and installed windows seven on my empty ssd, but I can install any large programs like a game or my antivirus, or even my language pack for windows without having BSOD. This problem occured at the very beginning as downloading my antivirus was one of the first thing I've done...
BSOD Help and Support
BSOD's after replacing motherboard
My DFI motherboard recently failed, and with them ending their consumer product line, was unable to have it replaced. I bought instead a Gigabyte X58A-OC which I have been happy with, other than that I am getting random bluscreens. The same thing happens every time I start getting them; I get one...
BSOD Help and Support
Please Help! BSOD's Even After Replacing SSD!
I thought my problem was a bad SSD, and so did Crucial, but after having it replaced under warranty, I am still having the same BSOD's. I am computer literate, but completely clueless about debugging. I tried to follow instructions and have attached a zip file with the minidump files...
BSOD Help and Support
BSOD even after replacing RAM.
Alright, so a few weeks back I was having constant BSOD problems(Literally couldn't get it to start sometimes) and for the past week or so it's been perfectly fine on 2GB of RAM. No BSOD's or anything. Now just now I got a 3B error and I believe it cited a memory fault. I just got this brand new...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:28.
Twitter Facebook Google+