Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD occurring at random in ntoskrnl.exe, error code: 0x0000003b

25 Jan 2012   #21

Windows 7 Home Premium 64 Bit

Did the steps for the wireless driver help your system be more stable during sleep cycles, or did you have to change the settings through advanced power options? Let us know how the system is running and if you need further assistance. :)

My System SpecsSystem Spec
25 Jan 2012   #22

Windows 7 Home Premium 64 bit

The USB wireless adapter was becoming unreliable for other reasons (e.g., it would sometimes just turn off for no reason), and since all these crash reports apparently point to it, I bought a real wireless adapter card. I don't want to say everything is fine and invoke the wrath of the luck gods, but so far no BSODs. I wouldn't have been able to track this issue to its source without your advice in this thread, so thanks once again!
My System SpecsSystem Spec
25 Jan 2012   #23

Windows 7 Home Premium 64 Bit

No problem. Glad the new adapter has provided more stability. :)

If you would like to mark this thread as solved, the green button at the top or bottom of the thread next to the orange button marked Post Reply allows you to do so.
My System SpecsSystem Spec

14 Feb 2012   #24

Windows 7 Home Premium 64 bit

I should probably never have marked this as resolved, it only guaranteed that this would happen again. Another 0x0000003b SYSTEM_SERVICE_EXCEPTION originating in ntoskrnl.exe. I've attached the usual reporting info. I don't understand this. I got a new network adapter and nothing happens for over a month and then this. This is honestly really depressing, I built this computer myself and yet I don't understand what I'm doing wrong. In this case, unlike in the past, I did install new programs. A lot actually... I found the list of free software and kind of went nuts downloading and installing things. I made a system restore point beforehand, but having to reinstall everything or figure out which one is at fault is going to be a nightmare. Are any of the programs on that list known to cause issues? I can write out a list of what I installed if that would help.
My System SpecsSystem Spec
14 Feb 2012   #25

Windows 7 Home Premium 64 bit

Additionally, this is the network card I installed: - Rosewill RNX-N150PCx Wireless Adapter IEEE 802.11b/g/n PCI 2.2 Up to 150Mbps Wireless Data Rates 64/128 bits WEP, WPA (TKIP with IEEE802.1x), WPA2 (AES with IEEE802.1x)

Was working fine until today so I am inclined to blame this on new software, hopefully.
My System SpecsSystem Spec
14 Feb 2012   #26

Windows 7 Home Premium 64 Bit

Microsoft (R) Windows Debugger Version 6.11.0001.404 X86
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [F:\BSODDmpFiles\littleraskol\Windows_NT6_BSOD_jcgriff2\021412-23322-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*C:\SymCache*
Executable search path is: 
Windows 7 Kernel Version 7601 (Service Pack 1) MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Built by: 7601.17640.amd64fre.win7sp1_gdr.110622-1506
Machine Name:
Kernel base = 0xfffff800`03668000 PsLoadedModuleList = 0xfffff800`038ad670
Debug session time: Tue Feb 14 07:18:34.783 2012 (GMT-7)
System Uptime: 1 days 17:42:00.329
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 3B, {c0000005, fffff800036dcb65, fffff880079c0cd0, 0}

Probably caused by : hidusb.sys ( hidusb!HumGetStringDescriptor+10a )

Followup: MachineOwner

1: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An exception happened while executing a system service routine.
Arg1: 00000000c0000005, Exception code that caused the bugcheck
Arg2: fffff800036dcb65, Address of the exception record for the exception that caused the bugcheck
Arg3: fffff880079c0cd0, Address of the context record for the exception that caused the bugcheck
Arg4: 0000000000000000, zero.

Debugging Details:

EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

fffff800`036dcb65 498b08          mov     rcx,qword ptr [r8]

CONTEXT:  fffff880079c0cd0 -- (.cxr 0xfffff880079c0cd0)
rax=00000000ca040003 rbx=0000000000000001 rcx=fffff880009ea060
rdx=0042034c61004201 rsi=0000000000000012 rdi=0000000000000000
rip=fffff800036dcb65 rsp=fffff880079c16b0 rbp=fffff880009ea060
 r8=0042034c61004200  r9=fffff80003668000 r10=fffff880009ea060
r11=fffff880079c1800 r12=fffff8000386f340 r13=0000000000000000
r14=0000000000000002 r15=0000000055646948
iopl=0         nv up ei pl nz na po nc
cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00010206
fffff800`036dcb65 498b08          mov     rcx,qword ptr [r8] ds:002b:0042034c`61004200=????????????????
Resetting default scope




PROCESS_NAME:  mainserv.exe


LAST_CONTROL_TRANSFER:  from fffff800038131de to fffff800036dcb65

fffff880`079c16b0 fffff800`038131de : fffffa80`096a7948 fffff800`036e9f32 fffffa80`0be4a4f0 fffff800`036f689c : nt!ExpInterlockedPopEntrySListFault16
fffff880`079c16c0 fffff880`0695eb4e : 00000000`0000000a 00000000`00000001 fffffa80`08c23630 fffff880`06956d2d : nt!ExAllocatePoolWithTag+0xfe
fffff880`079c17b0 fffff880`06956f2f : fffffa80`00000106 fffffa80`0be4a848 fffffa80`0be4a800 fffffa80`08cf0910 : hidusb!HumGetStringDescriptor+0x10a
fffff880`079c1830 fffff880`0696702f : fffffa80`0a72e001 fffffa80`0be4a848 00000000`00000001 fffffa80`08cf0a80 : hidusb!HumInternalIoctl+0x10b
fffff880`079c18a0 fffff880`06966dd0 : fffffa80`0be4a848 fffff880`0696f4a0 fffffa80`08ce17e0 00000000`000b01be : HIDCLASS!HidpGetDeviceString+0x8b
fffff880`079c18e0 fffff880`069658d3 : fffff880`06970301 fffffa80`0be4a4f0 fffffa80`08ce17e0 fffff800`000b01be : HIDCLASS!HidpIrpMajorDeviceControl+0xb2c
fffff880`079c1970 fffff880`069b683f : 00000000`c00000bb 00000000`c00000bb fffff880`079c1ca0 fffffa80`0be4a4f0 : HIDCLASS!HidpMajorHandler+0x1c3
fffff880`079c19e0 fffff800`039ffa97 : fffffa80`0c7bcbb0 fffffa80`0c7bcbb0 fffffa80`0be4a890 fffffa80`0be4a4f0 : HidBatt!HidBattIoControl+0x87
fffff880`079c1a10 fffff800`03a002f6 : 00000000`016bf100 00000000`00000000 00000000`00000000 00000000`00000000 : nt!IopXxxControlFile+0x607
fffff880`079c1b40 fffff800`036e3ed3 : 00000000`72722450 00000000`016bf170 00000000`016bfd20 00000000`7efaa000 : nt!NtDeviceIoControlFile+0x56
fffff880`079c1bb0 00000000`72722e09 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
00000000`016bf0f8 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x72722e09

fffff880`0695eb4e 4889842488000000 mov     qword ptr [rsp+88h],rax


SYMBOL_NAME:  hidusb!HumGetStringDescriptor+10a

FOLLOWUP_NAME:  MachineOwner


IMAGE_NAME:  hidusb.sys


STACK_COMMAND:  .cxr 0xfffff880079c0cd0 ; kb

FAILURE_BUCKET_ID:  X64_0x3B_hidusb!HumGetStringDescriptor+10a

BUCKET_ID:  X64_0x3B_hidusb!HumGetStringDescriptor+10a

Followup: MachineOwner
When you removed the old device, did you uninstall the device through device manager beforehand? I still see the jswpslwfx.sys loaded, which I believe is the usb wireless driver.

USB Driver - General Fix for Problems may help to remove the old device and its driver.
My System SpecsSystem Spec
14 Feb 2012   #27

Windows 7 Home Premium 64 bit

Huh, that's a good point... I probably didn't. Man, I really hope it's that simple! Thanks again. Will update with any issues and close in a week or so if everything works out.
My System SpecsSystem Spec
14 Feb 2012   #28

Windows 7 Home Premium 64 Bit

You're welcome. Best of luck it is that simple. :)
My System SpecsSystem Spec
14 Feb 2012   #29

Windows 7 Home Premium 64 bit

Followed those instructions, although there weren't any unused/greyed out USB drivers. However, the USB network adapter driver software could be uninstalled like any application, so I did that.

Interestingly, the device manager listed a "Realtek PCIe GBE Family Controller" that apparently wasn't working. The reason:

This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)
Disabling it did nothing as far as I could tell, so I re-enabled it. Driver is up to date according to Windows. I don't really even know what this is. Could it be a problem?
My System SpecsSystem Spec
14 Feb 2012   #30

Windows 7 Home Premium 64 Bit

The Realtek PCIe GBE Family Controller belongs to your Ethernet card.

The crash was USB based, so I am thinking it was the remnants from the wireless USB device you had. See if removing it provides stability for the system.
My System SpecsSystem Spec

 BSOD occurring at random in ntoskrnl.exe, error code: 0x0000003b

Thread Tools

Similar help and support threads
Thread Forum
Random BSOD occurring almost daily, error 0x0000003b
I have been experiencing an random intermittent BSOD. I once was able to track it to the adobeflash player and disabling it seemed to improve things. However, the web without adobe flash is not as useful. I was hoping someone could give me a better analysis of what is going wrong. Problem...
BSOD Help and Support
BSOD error 0x0000003B occurring randomly & frequently
Lately I've been getting a BSOD with a stop: 0x0000003B error on my laptop. I've tried updating my graphics driver, running a sfc /scannow test, tried the applicable hotfix from the Microsoft website and nothing solves the issue. Here are the contents of my windows/minidump/ folder:...
BSOD Help and Support
BOSD Random Times/Applications, error 0x0000003B ntoskrnl.exe
My computer recently started blue screening with the error code 0x0000003B seeming to come from ntoskrnl.exe, I haven't installed any new software (to my knowledge) recently, and I've also been having Windows Explorer crash and freeze up right after I boot. I'm attaching my recent dump files and if...
BSOD Help and Support
Random BSOD error 0x0000003B ntoskrnl.exe
Hello :) I am having random BSOD issues, just recently i download blue screen view and at the top of the list it has ntoskrnl.exe that seemed to be causing the issue. I will upload the minidump file if that makes things easier, besides that i don't know much else to report on, help is...
BSOD Help and Support
BSOD Error Code 0x0000003B Random Timing
i have been getting random bluescreens all with error code 3B. ther has been no pattern. I have also uploaded here the SF diagnostic tool results. can someone help?
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:40.
Twitter Facebook Google+