Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD since playing SWTOR and more frequently since moving PC

11 Jan 2012   #1

Microsoft Windows 7 Home Premium 32-bit 7601 Multiprocessor Free Service Pack 1
BSOD since playing SWTOR and more frequently since moving PC

Hi, I've been playing STWOR and started getting BSOD over the past few weeks but I also moved the PC to a different room 3 weeks ago and cleaned it all out (thought overheating might be the cause - it wasn't) and am stuck now looking at the dmp files, actually I can't find anything that lets me look at them, wordpad makes no sense and notepad is denied even as Admin.

So, I followed the guide and created info on last 7 dumps.

I'm an Ex. software engineer but rarely touched windows so whilst I'm very much into self help and geeky enough to follow the info, I must admit to not understanding this!

PC details,
- x86
- Was OEM with Vista, upgraded to Windows 7 retail about 9 months ago
- PC about 3 years old


Edit - Since posting I found the tool BlueScreenView and found 3 BSOD's were caused by the wireless dongle WPN111, I do remember having a problem with this last year but am using the latest drivers for this and have tried both dongles I have. Looks like I'll have to run an ethernet cable to the PC.

The other drivers, halmacpi.dll, avgmfx86.sys (I'll remove AGV AV to check this one) and tcpip.sys are more interesting that I'l like any advice on please.

My System SpecsSystem Spec
11 Jan 2012   #2

Microsoft Community Contributor Award Recipient

Windows 7 x64

You need windows debugger to view dump files, and even then they are pretty useless unless you know what you are looking at.

At any rate. In this particular case the debugger was actually quite clear for once.
The offending component seems to be related to a Netgear device you have. (probably router)
I would swing by the netgear website and try to locate updated drivers/software for it.
Probably caused by : WPN111.sys ( WPN111+35bb3 )

Followup: MachineOwner

0: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arg1: ea03ffc4, memory referenced
Arg2: 00000002, IRQL
Arg3: 00000000, value 0 = read operation, 1 = write operation
Arg4: d35d5bb3, address which referenced memory

Debugging Details:

READ_ADDRESS: GetPointerFromAddress: unable to read from e2fa0848
Unable to read MiSystemVaType memory at e2f7fe20


d35d5bb3 8b0c82          mov     ecx,dword ptr [edx+eax*4]





TRAP_FRAME:  e2f5ead8 -- (.trap 0xffffffffe2f5ead8)
ErrCode = 00000000
eax=00000000 ebx=00000800 ecx=00000001 edx=ea03ffc4 esi=0000000f edi=c4bc6ce0
eip=d35d5bb3 esp=e2f5eb4c ebp=e2eae4c5 iopl=0         nv up ei pl nz na pe nc
cs=0008  ss=0010  ds=0023  es=0023  fs=0030  gs=0000             efl=00010206
d35d5bb3 8b0c82          mov     ecx,dword ptr [edx+eax*4] ds:0023:ea03ffc4=a2000000
Resetting default scope

LAST_CONTROL_TRANSFER:  from d35d5bb3 to e2e785fb

e2f5ead8 d35d5bb3 badb0d00 ea03ffc4 0000884e nt!KiTrap0E+0x2cf
WARNING: Stack unwind information not available. Following frames may be wrong.
e2f5eb50 d35d5e6c ea03ffc4 0000003c d35d5161 WPN111+0x35bb3
e2f5eb5c d35d5161 ea03ffc4 c4c9e000 d35d7ad7 WPN111+0x35e6c
e2f5eb8c e2eaf913 00000000 c3f5ce28 00000000 WPN111+0x35161
00000000 00000000 00000000 00000000 00000000 nt!IopfCompleteRequest+0x128


d35d5bb3 8b0c82          mov     ecx,dword ptr [edx+eax*4]


SYMBOL_NAME:  WPN111+35bb3

FOLLOWUP_NAME:  MachineOwner





BUCKET_ID:  0xD1_WPN111+35bb3

Followup: MachineOwner
My System SpecsSystem Spec
11 Jan 2012   #3

Microsoft Windows 7 Home Premium 32-bit 7601 Multiprocessor Free Service Pack 1

Thanks for clarifying that Maguscreed, I found some drivers for the wireless adpator that work have been updated with Win 7 - Really should look more often for these things, they are dated April 11!

running 'verifier' and selecting drivers caused all sorts of BSOD on boot errors and I couldn't get into safe mode either, had to use install disc and go back 3 days of restore points to get a boot!

Anyway, that is highlighting 'halmacpi.dll' as the problem, can I discard this one now?

Thanks for you assistance, Antony.
My System SpecsSystem Spec

11 Jan 2012   #4

Microsoft Community Contributor Award Recipient

Windows 7 x64

yes I leave driver verifier off for general use.
It can get picky and cause bsod's when there should be none.
My System SpecsSystem Spec
11 Jan 2012   #5

Microsoft Windows 7 Home Premium 32-bit 7601 Multiprocessor Free Service Pack 1

I'll leave it now then and see what happens,

Many thanks, Antony.
My System SpecsSystem Spec
11 Jan 2012   #6

Microsoft Windows 7 Home Premium 32-bit 7601 Multiprocessor Free Service Pack 1

Well for anyone else having problems with Win 7 and Netgear WPN111 dongle, I can say that the new driver installer V3.0 for Win 7 has faulty drivers in it. You get a Code 10 error on the device and it doesn't start.

My solution after a days frustration was to revert back to the v1.0.0.1 driver which has worked fine all evening (was BCOD every few hours on V2 drivers)

I'm waiting to see if Netgear will send standalone drivers as Im aware their installer software causes problems anyway.
My System SpecsSystem Spec
12 Jan 2012   #7

Windows 7 Home Premium 64 Bit

Thanks for posting back your solution for others having the same problem. We always appreciate post backs and people who do their own troubleshooting. I have given you rep for the steps.
My System SpecsSystem Spec

 BSOD since playing SWTOR and more frequently since moving PC

Thread Tools

Similar help and support threads
Thread Forum
BSOD playing SWTOR, Error 1e
BCCode: 1e BCP1: 0000000000000000 BCP2: 0000000000000000 BCP3: 0000000000000000 BCP4: 0000000000000000 OS Version: 6_1_7601 Service Pack: 1_0 Product: 768_1 Just playing SWTOR and it crashes almost every time within 30 minutes.
BSOD Help and Support
BSOD while playing WoW and SWTOR
I get the BSOD often when play WoW, and when I used to play SWTOR. I get it when there are no other programs running, and I don't have any virtual drive software installed. I tried looking up the most up-to-drivers according to EasyDriverPro, but didn't find them at the manufacturer's website. I...
BSOD Help and Support
System Specs: Win 7 64 bit 16gb ram 1600mhz ddr3 cors. Dominator 60gb ssd 570 gtx GPU i7 920 @ 3.8 Had SWTOR running, skype up, the league of legends launcher and a few firefox pages. Got a random BSOD. Just did a fresh install this past weekend, and just got new memory as well. I...
BSOD Help and Support
BSOD playing SWTOR: Error 0x5
Hey guys, I recently made my first computer build and it was working fine for a few days, but now I'm beginning to see some lovely Blue Screens. I've got a long log of the blue screens and I've tried the typical checks for problems, but I just can't figure anything out. The computers new and I...
BSOD Help and Support
BSOD playing SWTOR 0x000000000000031
Hi. I keep getting BSODs, especially when playing SWTOR, but it has happened when not playing a game at all, just listening to spotify. I got a tip from a friend that it could be a conflict between HDMI audio and sound card, that's why some devices are disabled in the performance report. ...
BSOD Help and Support
BSOD playing SWTOR after upgrading to SLI
Greetings, Last night I installed a second Gigabyte GV-N460OC-1GI (Nvidia GTX 460) in SLI. The following is a sequence of events leading up to the BSOD, which may shed some light on the issue. - Immediately after booting the PC, I received a "Chassis intruded, Fatal error, System halted"...
Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:54.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App