Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Need help with Windows 7 BSOD on Lenovo T500

17 Aug 2009   #1

Need help with Windows 7 BSOD on Lenovo T500

My system is crashing several times a day and I need your help in figuring out why.

I have the Windows 7 RTM build installed on a Lenovo T500. The only hardware I've customized is replacing the 160 GB drive with a 320 GB drive.

The system specs are

Lenovo T500
Core 2 Duo T9600 @ 2.8 Ghz
2 GB Turbomeory
ATI Mobile Radeon 3650
Intel Wifi 5300 agn
Integrated camera, bluetooth, and WWAN

I am running the latest BIOS: 3.01-1.03.

The laptop came with Vista 32-bit, but I immediately installed Vista Ultimate 64-bit on the 320 GB drive. I had occasonal BSOD's in Vista, mostly while running on battery, and not often enough to be completely annoying (once a week or so).

Since I've installed Windows 7 Ultimate 64-bit, the BSODs are pretty regular (several times a day).

With the exception of two drivers, the only ones I've installed are from Windows 7 or Windows Update. The two I installed were from the Lenovo Windows 7 beta drivers web site to resovle the "unknonw driver" indication in the Devices control panel for a device labeled "PCI Simple Communications Controller" and another similarly named (sorry I didn't write down the exact name).

Below is the WinDBG "analyze" output from the full memory dump. All the dumps look exactly the same: "BugCheck D1, {22, 2, 8, 22}" and the stack trace is the same.

At this point, I don't know what my next steps should be to determine what the issues are. Unfortunately, if I don't figure something out, I'm going to have to go back to Vista or XP, but I don't really want to. My co-workers are losing patience watching reboots in meetings :-(. I'm a software developer for my day job, but not at this low of a level in the software stck. If necessary, I figure I could likely setup a remote kernel debugger, but I thought the memory dump was supposed to have enough to diagnose.

Thoughts, suggestions?

Microsoft (R) Windows Debugger Version 6.11.0001.404 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [L:\200908161904-MEMORY.DMP]
Kernel Summary Dump File: Only kernel address space is available

Symbol search path is: L:\Symbols
Executable search path is: 
Windows 7 Kernel Version 7600 MP (2 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7600.16385.amd64fre.win7_rtm.090713-1255
Machine Name:
Kernel base = 0xfffff800`02a0a000 PsLoadedModuleList = 0xfffff800`02c47e50
Debug session time: Sun Aug 16 19:02:43.499 2009 (GMT-5)
System Uptime: 0 days 9:17:20.760
Loading Kernel Symbols
Loading User Symbols

Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck D1, {22, 2, 8, 22}

Probably caused by : ntkrnlmp.exe ( nt!KiPageFault+260 )

Followup: MachineOwner

1: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arg1: 0000000000000022, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000008, value 0 = read operation, 1 = write operation
Arg4: 0000000000000022, address which referenced memory

Debugging Details:

READ_ADDRESS:  0000000000000022 


00000000`00000022 ??              ???




TRAP_FRAME:  fffff88002f1bb10 -- (.trap 0xfffff88002f1bb10)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000050 rbx=0000000000000000 rcx=fffffa8000000001
rdx=fffffa8000000000 rsi=0000000000000000 rdi=0000000000000000
rip=0000000000000022 rsp=fffff88002f1bca0 rbp=0000000000000000
 r8=0000000000000000  r9=0000000000000000 r10=0000000000000000
r11=fffff88002f1b9e0 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up di pl zr na po nc
00000000`00000022 ??              ???
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80002a7b469 to fffff80002a7bf00

00000000`00000022 ??              ???

fffff880`02f1b9c8 fffff800`02a7b469 : 00000000`0000000a 00000000`00000022 00000000`00000002 00000000`00000008 : nt!KeBugCheckEx
fffff880`02f1b9d0 fffff800`02a7a0e0 : 00000015`b91da5c9 fffffa80`00000002 00000015`b91da5c9 00000abc`b91d9b22 : nt!KiBugCheckDispatch+0x69
fffff880`02f1bb10 00000000`00000022 : 00000000`00000000 00000000`00000000 fffffa80`07684ae0 00000000`00000000 : nt!KiPageFault+0x260
fffff880`02f1bca0 00000000`00000000 : 00000000`00000000 fffffa80`07684ae0 00000000`00000000 fffffa80`07684cf8 : 0x22


fffff800`02a7a0e0 440f20c0        mov     rax,cr8


SYMBOL_NAME:  nt!KiPageFault+260

FOLLOWUP_NAME:  MachineOwner


IMAGE_NAME:  ntkrnlmp.exe


FAILURE_BUCKET_ID:  X64_0xD1_CODE_AV_BAD_IP_nt!KiPageFault+260

BUCKET_ID:  X64_0xD1_CODE_AV_BAD_IP_nt!KiPageFault+260

Followup: MachineOwner

My System SpecsSystem Spec
17 Aug 2009   #2

Win 8 Release candidate 8400


Hi we have some ppl who are excellant at BSOD dump files and Im sure they could tell more if you zipped the dump and upload it to us. I know your running 6 bit and the faulting module is ntkrnlmp.exe, but wihout the dump I/we cant tell much. Also do you have your page file off or set small?

Im going to Pm someone with this thread in the mean time

My System SpecsSystem Spec
17 Aug 2009   #3


Make a memtest bootable CD and scan your memory for errors...
My System SpecsSystem Spec

17 Aug 2009   #4


I ran the tests from memtest86+ v2.11 and all passed.

When you boot memtest86 v3.5, you get three choices: 1) single CPU, 2) multi CPU, and 3) old version (3.4). Using the single CPU choice, it always fails at 41% of Test 1 (test 0 passes). The title for Test 1 is "Address test, own address". If I skip test 1, the rest of the tests pass. All tests pass running the multi CPU choice and all tests pass running the v3.4 choice.

By "fail", I mean that system reboots. The memtest application does not capture the failure and provide any feedback.

"Single CPU Test #1" does pass on my Dell desktop.

I also ran through all of the tests including the memory tests in the Lenovo-provided PC Doctor for DOS v2.0.1769 (the latest on the Lenovo web site) and there were no failures.

I did re-seat the memory, but I have not tried removing either of the sticks or replacing it with other memory.
My System SpecsSystem Spec
17 Aug 2009   #5
Microsoft MVP


Please zip up the contents of C:\Windows\Mindump and upload the .zip file with your next post.
My System SpecsSystem Spec
17 Aug 2009   #6


Quote   Quote: Originally Posted by usasma View Post
Please zip up the contents of C:\Windows\Mindump and upload the .zip file with your next post.
My System SpecsSystem Spec
18 Aug 2009   #7
Microsoft MVP


A quick look at the dump files suggests that netw5v64.sys is likely to be the culprit.
This belongs to your Intel WiFi Link 5300 AGN adapter.

Please download new drivers from the Intel website,
then uninstall the current drivers from Control Panel...Programs...Uninstall a program,
then install the freshly downloaded drivers,
then test to see if this has fixed it.

The dump file summary is remarkably free of any evidence, it does point to this driver as being from May 31, 2007: ibmpmdrv.sys
This belongs to the IBM ThinkPad Power Management driver.
I'd advise updating it also.

After updating these 2 drivers, please test the system to see if there are any more BSOD's. If so, upload the dump files and we'll see where we can go from there.
My System SpecsSystem Spec
18 Aug 2009   #8


Intel doesn't have Windows 7 specific versions of their drivers that I could find. I assume the Vista 64-bit drivers are OK?

I've upgraded from from Microsoft to from Intel.

Rather than change two things at once, I'll go with this change for a while and see what that does. If there is still failure, then I'll update the IBM PM driver.

My System SpecsSystem Spec
18 Aug 2009   #9
Microsoft MVP


Sounds like a plan to me. Please let us know what happens!
My System SpecsSystem Spec
26 Aug 2009   #10


I updated the wireless driver from Intel and had a crash 3-4 hours later. I then installed the Lenovo Power Management software. It did not replace ibmpmdrv.sys, but since I installed that package, no BSODs!

Thanks for your assistance!
My System SpecsSystem Spec

 Need help with Windows 7 BSOD on Lenovo T500

Thread Tools

Similar help and support threads
Thread Forum
No wireless adapter - Lenovo T500
Hi folks, A couple weeks ago, my computer (Lenovo T500) stopped recognizing wireless networks. I went to update the wireless adapter driver, and saw that there was no wireless adapter shown in the device manager. I downloaded the driver straight from Lenovo, but there's still no adapter showing...
Network & Sharing
BSOD - Lenovo T500
Hi Gents, I'm getting a stop 0x0000008E BSOD on startup. I'll get past the login screen, but after a few minutes the BSOD will pop up. Also, none of the icons for my taskbar shortcuts appear -- I just get that "white piece of paper" showing up. I have not installed any new hardware or software...
BSOD Help and Support
Lenovo t500 BSOD Kernel-power issues (windows7 x64)
My system is crashing daily to critical kernel-power issue. I have Windows 7 x64 professional installed on a Lenovo T500. The only hardware I've customized is replacing the 160 GB drive with a 500 GB drive and put 2GB more memory. Im using discrete graphic only mode (it uses only ati 3650)....
BSOD Help and Support
BSOD Win7 Lenovo T500
I did a fresh install of Windows 7 Professional 64-bit and it was great until I keep on getting BSOD every once in a while. Frankly, it is starting to get annoying now seeing how I got a couple in a row. Hopefully some of you can help. Thanks for your time.
BSOD Help and Support
Lenovo T500 and bluetooth
Hallo I have a question. My bluetooth was working ok at vista, now I reinstalled the system for win7 (64 bit). When I try to add a new device, it does not find any. I installed the BT drivers from lenovo for windows 7. BT is always on. What can be wrong? any help please??

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:21.
Twitter Facebook