Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD - Multiple with different STOP errors

04 Feb 2012   #1

Windows 7 Home Premium 64bit
BSOD - Multiple with different STOP errors

I have been trying to resolve some BSOD I got on my PC. To do this I also re-installed windows several times. I build and install everything by myself for years, but this is the first PC with a lot of BSODs. Also everyone of them looks different, so I could never find a pattern or a good clue.

I used the Debugging Tool for windows to check the minidumps by myself, but as far as my knowledge goes, I didn't find anything special in there. The only thing that was obvious was that in all BSODs the ntoskrnl.exe was involved. This was something BlueScreenView revealed also. In my opinion however it seems there is more to it, since the ntoskrnl.exe could probably also crash because of another driver or hardware problem.

On my previous fresh Windows 7 Install I did found out once that alot of BSOD I had at that time were caused by a bad Creative driver for my X-Fi. On the web I found a useful hint, because other X-Fi users pointed to the beta-drivers for the card. The official Creative drivers are almost two years older then these beta drivers, so obviously the beta drivers should be the first choice. These drivers are the ones I use now. I also had some problem with my OCZ Vertex 3 MI, like most owners of this hardware, and the problem was the unstable firmware. I am using the latest firmware now, which is 2.15, and that made the system alot more stable. The third problem is happening in POST: my logitech G110 keyboard features an USB hub and connection for media. These kind of USB keyboards had some problem with recognision and initialisation in the UEFI BIOS. For that I also updated to the latest BIOS for my motherboard.

All in all you can see I discovered and tried to fix a lot of different causes for BSODs. I also ran memtest once on the system for two hours, but this was in Dual Channel setup. Didn't gave any errors anyway.

The latest minidump is created by the use of Verifier. I turned verifier on to test the two drivers for my AMD HD6970(crossfired). After 5 minutes in windows the BSOD appeared. I am using AMD Catalyst 12.1 drivers. I tried this, because the BSODs all are different then the ones I had on previous Windows 7 installations (on the same pc), but the only thing I changed in the current installation, was the AMD 12.1 drivers.

I reinstalled windows about two weeks ago, after using Secure Erase on my SSD. I installed only the latest drivers for all the things that need drivers. The complete installation, including windows updates and drivers, was without any fault. One day later the first BSOD appeared, etc. I use the system to play Battlefield 3 only, since the fresh install. Strangely, I played more then 50 hours in the game, without any crash or BSOD!

The new AMD FX-8150 processor is the first to support native 1866 MHz DDR3. The motherboard specification showed that the board supported 1866 (OC), thus it's seen as an overclock. I set all settings in bios like the ram specificiation told, which is: 9-11-9-27 2T @1.65V. Still, it could be that the 1866 MHz is too much on standard NB voltages? It's something I couldn't find an answer to on the internet, and since I never overclock I don't have that much experience with the voltages.

All BSODs happened in different situations, like just after windows log in, or when I start a program, or when idling, or when browsing the internet.
Since I couldn't figure out any more usefull details out of the minidumps, I hope someone here with more experience could check the attached files. Thanks in advance!

My System SpecsSystem Spec
04 Feb 2012   #2
Microsoft MVP


Perfmon /report shows issues with a PS2 keyboard and mouse. If you're using USB keyboard and mouse it's OK to ignore these messages.

Only 59 updates since SP1 - most systems have 70 or more. Please check Windows Update and get any available updates.

You've done a lot towards fixing possible issues with your SSD. Have a look at this info that I've compiled:
We've seen a number of BSOD issues with SSD's recently. Here's the information that I've compiled:
There's not a whole bunch available to test SSD's. The "easiest" test is to remove the SSD, install a platter-based hard drive, install Windows and test for stability that way.

Here's some suggestions:
- Update the SSD's firmware to the latest available version (VERY IMPORTANT!!!)
- Slow the memory (RAM) down to the next slower speed (I've only seen one person who claimed that this worked for them).
- Use any manufacturer's utilities that you may have. If you don't have any, then try this free one (I haven't used it myself): Crystal Dew World
- Update chipset and storage controller drivers to the latest available from the manufacturer of the device (not the manufacturer of the motherboard). Be sure to update ALL controllers on the motherboard!
....NOTE: Recently (Nov 2011) we had BSOD issues with the Marvell 91xx controller and an SSD. You may have to switch controllers also.-
Replace the SSD with a platter based hard drive and see if that stops the BSOD's. If it does, then it's likely that there's a problem with the SSD OR an incompatibility with your system.
It's my opinion that SSD's aren't reliable enough (with current hardware) to be used on a system that needs to work reliably. Until I see reliability I will not recommend, nor will I use, SSD's for critical applications.
06 Dec 2011 - This post tends to confirm issues with certain SSD chipsets and certain controllers - [SOLVED] cant find the cause of BSOD F4 - Tech Support Forum
7 memory dumps
5 different BSOD error codes
5 different causes blamed
This is likely to be a hardware error (can also be caused by overclocking, compatibility issues, low-level driver problems, or even malware).

Don't forget to turn Driver Verifier off.

AMD OverDrive (AODDriver2.sys) is either a stand-alone application, or a component of the AMD VISION Engine Control Center.
Please uninstall all ATI stuff from Control Panel...Programs...Uninstall a program
Then, download and install a fresh copy of the ATI drivers from Global Provider of Innovative Graphics, Processors and Media Solutions | AMD
Then use the ATI uninstall manager to uninstall the Catalyst Control Center (CCC).

If the device (AODDriver or AODDriver4.01) remains a problem in perfmon /report, open Device Manager, select the "View" item.
Then select "Show hidden devices" and scroll down to the Plug and Play Drivers section.
Locate the AODDriver entry, right click on it and select "Uninstall". Reboot for changes to take affect.
If overclocking, please stop. Remove the overclock and return the system to stock/standard values while we're troubleshooting. Once the system is stable again, feel free to resume the overclocking.

Further info on BSOD error messages available at:

The following info is just FYI, I've already addressed the issues that I saw in the above paragraphs:
- Create a System Restore Point prior to doing any of this. DO NOT mess with the drivers themselves - leave the Windows\System32\drivers directory alone unless we specifically direct you to it!
- Please either update the older drivers from the device manufacturer's website - or uninstall them from your system. Reference links are included below.
- DO NOT use Windows Update or the Update Drivers function of Device Manager.
- Please feel free to post back about any drivers that you are having difficulty locating.
- Windows Update exceptions may be noted below for Windows drivers.

amd_sata.sys      Fri Oct 28 19:40:46 2011 (4EAB3D7E)
amd_xata.sys      Fri Oct 28 19:40:48 2011 (4EAB3D80)
amdxata.sys       Fri Mar 19 12:18:18 2010 (4BA3A3CA)
nusb3xhc.sys      Thu Feb 10 00:52:33 2011 (4D537D21)
usbfilter.sys     Wed Nov 16 22:35:45 2011 (4EC48111)
ctaud2k.sys       Thu Aug 11 06:08:16 2011 (4E43AA10)
atikmpag.sys      Mon Dec 05 21:12:14 2011 (4EDD79FE)
Rt64win7.sys      Tue Sep 27 10:50:33 2011 (4E81E2B9)
ctoss2k.sys       Thu Aug 11 06:04:05 2011 (4E43A915)
ctprxy2k.sys      Thu Aug 11 06:08:19 2011 (4E43AA13)
atikmdag.sys      Mon Dec 05 21:52:23 2011 (4EDD8367)
AODDriver2.sys    Wed Jun 15 04:38:35 2011 (4DF86F8B)
amdiox64.sys      Thu Feb 18 10:17:53 2010 (4B7D5A21)
nusb3hub.sys      Thu Feb 10 00:52:32 2011 (4D537D20)
ctsfm2k.sys       Thu Aug 11 06:03:48 2011 (4E43A904)
CTHWIUT.SYS       Thu Aug 11 06:10:02 2011 (4E43AA7A)
CT20XUT.SYS       Thu Aug 11 06:09:58 2011 (4E43AA76)
emupia2k.sys      Thu Aug 11 06:03:39 2011 (4E43A8FB)
ha20x22k.sys      Thu Aug 11 06:07:26 2011 (4E43A9DE)
dump_amd_sata.sys Fri Oct 28 19:40:46 2011 (4EAB3D7E)
CTEXFIFX.SYS      Thu Aug 11 06:09:50 2011 (4E43AA6E)
AtihdW76.sys      Tue Oct 18 03:09:49 2011 (4E9D263D)


Loading Dump File [C:\Users\FUBAR\_jcgriff2_\dbug\__Kernel__\020412-12870-01.dmp]
Built by: 7601.17640.amd64fre.win7sp1_gdr.110622-1506
Debug session time: Sat Feb  4 03:45:24.398 2012 (UTC - 5:00)
System Uptime: 0 days 0:02:55.507
Probably caused by : ntkrnlmp.exe ( nt!RtlDispatchException+122 )
FAILURE_BUCKET_ID:  X64_0xA_VRF_nt!RtlDispatchException+122
Bugcheck code 0000000A
Arguments fffff800`03179fee 00000000`00000002 00000000`00000000 fffff800`02f08fe2
BiosVersion = V11.8
BiosReleaseDate = 12/15/2011
Loading Dump File [C:\Users\FUBAR\_jcgriff2_\dbug\__Kernel__\020312-8299-01.dmp]
Built by: 7601.17640.amd64fre.win7sp1_gdr.110622-1506
Debug session time: Fri Feb  3 13:19:30.828 2012 (UTC - 5:00)
System Uptime: 0 days 0:02:44.921
Probably caused by : mouclass.sys ( mouclass!memmove+64 )
FAILURE_BUCKET_ID:  X64_0x1E_0_mouclass!memmove+64
Bugcheck code 0000001E
Arguments 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000
BiosVersion = V11.8
BiosReleaseDate = 12/15/2011
Loading Dump File [C:\Users\FUBAR\_jcgriff2_\dbug\__Kernel__\020212-8252-01.dmp]
Built by: 7601.17640.amd64fre.win7sp1_gdr.110622-1506
Debug session time: Thu Feb  2 10:47:41.284 2012 (UTC - 5:00)
System Uptime: 0 days 0:00:12.377
Probably caused by : ntkrnlmp.exe ( nt!CmpKcbCacheLookup+1de )
FAILURE_BUCKET_ID:  X64_0x3B_nt!CmpKcbCacheLookup+1de
Bugcheck code 0000003B
Arguments 00000000`c0000005 fffff800`0319fe6e fffff880`08db75e0 00000000`00000000
BiosVersion = V11.8
BiosReleaseDate = 12/15/2011
Loading Dump File [C:\Users\FUBAR\_jcgriff2_\dbug\__Kernel__\020212-8236-01.dmp]
Built by: 7601.17640.amd64fre.win7sp1_gdr.110622-1506
Debug session time: Thu Feb  2 10:46:34.612 2012 (UTC - 5:00)
System Uptime: 0 days 0:00:09.704
Probably caused by : ntkrnlmp.exe ( nt! ?? ::FNODOBFM::`string'+72d6 )
BUGCHECK_STR:  0x19_22
PROCESS_NAME:  svchost.exe
FAILURE_BUCKET_ID:  X64_0x19_22_nt!_??_::FNODOBFM::_string_+72d6
Bugcheck code 00000019
Arguments 00000000`00000022 20000000`00000000 00000000`00000000 00000000`00000000
BiosVersion = V11.8
BiosReleaseDate = 12/15/2011
Loading Dump File [C:\Users\FUBAR\_jcgriff2_\dbug\__Kernel__\013012-8268-01.dmp]
Built by: 7601.17640.amd64fre.win7sp1_gdr.110622-1506
Debug session time: Mon Jan 30 13:13:54.767 2012 (UTC - 5:00)
System Uptime: 0 days 0:05:57.859
Probably caused by : ntkrnlmp.exe ( nt!KiInsertQueueApc+3c )
PROCESS_NAME:  steamerrorrepo
FAILURE_BUCKET_ID:  X64_0x3B_nt!KiInsertQueueApc+3c
Bugcheck code 0000003B
Arguments 00000000`c0000005 fffff800`02eca2ec fffff880`0274cfd0 00000000`00000000
BiosVersion = V11.8
BiosReleaseDate = 12/15/2011
Loading Dump File [C:\Users\FUBAR\_jcgriff2_\dbug\__Kernel__\013012-8236-01.dmp]
Built by: 7601.17640.amd64fre.win7sp1_gdr.110622-1506
Debug session time: Mon Jan 30 13:06:14.340 2012 (UTC - 5:00)
System Uptime: 0 days 0:00:44.589
BugCheck D1, {a0, 2, 0, fffff8800100e182}
*** WARNING: Unable to verify timestamp for amd_xata.sys
*** ERROR: Module load completed but symbols could not be loaded for amd_xata.sys
Probably caused by : storport.sys ( storport!RaidpAdapterContinueScatterGather+62 )
FAILURE_BUCKET_ID:  X64_0xD1_storport!RaidpAdapterContinueScatterGather+62
Bugcheck code 000000D1
Arguments 00000000`000000a0 00000000`00000002 00000000`00000000 fffff880`0100e182
BiosVersion = V11.8
BiosReleaseDate = 12/15/2011
Loading Dump File [C:\Users\FUBAR\_jcgriff2_\dbug\__Kernel__\012912-9110-01.dmp]
Built by: 7601.17640.amd64fre.win7sp1_gdr.110622-1506
Debug session time: Sun Jan 29 04:27:19.701 2012 (UTC - 5:00)
System Uptime: 0 days 0:01:53.950
Probably caused by : win32k.sys ( win32k!RFONTOBJ::bGetGlyphMetricsPlus+216 )
PROCESS_NAME:  explorer.exe
FAILURE_BUCKET_ID:  X64_0x3B_win32k!RFONTOBJ::bGetGlyphMetricsPlus+216
Bugcheck code 0000003B
Arguments 00000000`c0000005 fffff960`000fc6f6 fffff880`09670f90 00000000`00000000
BiosVersion = V11.8
BiosReleaseDate = 12/15/2011
My System SpecsSystem Spec
04 Feb 2012   #3

Windows 7 Home Premium 64bit

Thanks for the huge amount of information and help, usama!

I noticed the issue with the PS2 keyboard and mouse too. Very strange, since I never plugged in one of those. Like you said, I also figured I could ignore that. I noticed in the Device Manager, there are entries for PS/2 mouse and keyboard with a yellow mark. The standard Microsoft driver is installed according to Device Manager. Still, I agree that this should not be a problem. Probably its normal behaviour for Windows 7.

After I do a fresh install of windows 7, first thing I do is to make sure I have all the available (optional) updates. I did install Internet Explorer 9 first, because I notice that it saves me alot of IE8 updates like this. Probably that's the reason for the low amount of updates, because there is nothing available more, and I also made sure of that since day 1.

I flashed the SSD to the latest firmware each time a new firmware was released, and also I always use the latest chipset and storage drivers from AMD, since I use the 990FX chipset made by AMD. The board manufacturer MSI is distributing older drivers.
My motherboard has 6 Sata III ports, all on the same type of controller. I put the SSD on port 1, the HDD on port 3 and the diskplayer on port 5, to avoid problems.
I tested the SSD once and I checked all performance results. All results were normal, compared to other people's result and my expectations.
I think I made my SSD as stable as possible, I even made sure to get all the powercables in my case away from the physical SSD. I agree with you that the SSD is most likely the most unstable part in PC's at the moment, and I installed the OS on it.
Only thing I could do now is to use my HDD as primary disk for a while, and unplug the SSD. On the other hand, the SSD is so extremely fast...

The seven dumbs do indicate it's an hardware error, but I ran Memtest just before this post and it showed 0 errors for 5 passes, the same result I had a month ago.
I never overclocked this PC at all, but I just try to make the most stable system at stock speeds.

I understand how Verifier works, and I shut it off after one hour of using the PC.

The AMD Overdrive crossed my mind too. You gave me good advice on how to handle it, but the problem is that I am using Crossfire. It will only work with CCC installed or I need to use 3d party software to manually enable crossfire.

The last part in the reply about updating the drivers is a good advice, but my drivers are the latest I could find. Still there could be a bad driver in there too, because the X-Fi drivers are released as beta (nothing else available from Creative) and the AMD drivers vary in stabilty.

In the end I think my system is unstable because of the SSD, especially since the OCZ vertex 3 is known to be unstable since release. The 2.15 firmware makes it alot more stable, but probably not enough, especially with OS on it.
I decided to just do a last fresh install of windows 7. The BSOD I get is rare, I played on this same setup Skyrim for 150 hours and Worms Reloaded for 250 hours. I also did alot of internet browsing and some random stuff. All in all everything is stable enough, and the setup is one of the fastest AMD setups one can buy at the moment. Most days it runs perfectly and the system is very clean and responsive, so not much to complain about. I just don't like the occassional BSOD I had, since I matched every piece of hardware to make this a perfect and stable setup.

There is only one thing I dont know for sure, and that is the stabilty of memory at 1866 MHz. This because the motherboard specification labels it as an overclock. It used to be overclocking, because no cpu's could handle more then 1600 MHz at stock speed, but for the AMD FX series 1866 is natively supported. The last thing I will try to do now is to put the Kingston 1866 MHz memory back to 1600 with the same voltage and timings they need to run on 1866. This should definately rule out the possibilty of some unstability in the DDR area.

Maybe you, usama, or someone else who reads this can try to think about another possible sollution, but it definately is a difficult problem. If I discover something myself I will post it here for information in case someone has the same problem I have now.

Usama, thanks for the big help!
My System SpecsSystem Spec

05 Feb 2012   #4

Windows 7 Home Premium 64bit

I have been searching more and I found the following solution:

On the Kingston site, as part of the general features of HyperX Genesis memory:

1.7v–1.95v voltage range for dual channel applications for AMD based systems and Intel chipsets older than X58

Since I am running an AMD Dual Channel setup I will raise the Voltage from 1.65 to 1.75. It's still weird, because there is no mention of this on the official specification sheet for my specific memory.
My System SpecsSystem Spec

 BSOD - Multiple with different STOP errors

Thread Tools

Similar help and support threads
Thread Forum
Multiple BSoD Errors on boot, different stop codes.
Hello! I recently have been having a lot of pesky BSODs all with different error codes. Ive had 3B, 1A, 1E, etc. I thought this was due to my drawing tablets out of date driver so I uninstalled it. This only made things worse. I have now had 4 Bsods in one day compared to one every so often. I...
BSOD Help and Support
BSOD dxgmms1.sys multiple stop errors playing games
This issue has been going on for about 2 months now and I have not changed anything in my computer since before the crashes. I am getting multiple stop errors, and it only crashes when i'm playing games (mainly WoW) I've attached the minidumps, any help is much appreciated. Thank you in advance!
BSOD Help and Support
BSOD; Multiple stop errors inc. 0x00000F4, 0x0000124
Hi everyone, Sorry if I'm a bit too in-depth or present too much useless information, I'm a newbie and just trying to get a fix on my OS. I have a custom build PC running Windows 7 ultimate x64. The pc has been working fine since I built it back in November a few BSOD's due to some issues...
BSOD Help and Support
BSOD every 15 mins - multiple stop errors
Hi, I'm trying to help troubleshoot my gf's laptop. This is my first BSOD experience so sorry if I do this wrong! General Info: As I've said in the thread title, the laptop has been blue screening every 10-15 mins since 25-08-2012. I've seen three stop errors so far. They are: PFN List...
BSOD Help and Support
Multiple BSOD, Multiple STOP errors
I hope someone can help. I have been recieving many random (to me) BSOD's. The (Two month old) laptop gets so many that it cannot be booted into any Windows mode (including safe mode). My only option is to restore the PC using HP's F11 (factory restore). I have managed to capture two .dmp...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

й Designer Media Ltd

All times are GMT -5. The time now is 13:48.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App