Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: The Windows Subsystem system process terminated unexpectedly

10 Feb 2012   #1

windows 7 home premium 64bit
The Windows Subsystem system process terminated unexpectedly

ok my pc has been getting BSODs quite often and i havent been able to fix it yet.. but today i got a different type of BSOD. im not big in computer tech so i didnt have a clue on what it is and disregarded the numbers..:/

Also i have been getting regular BSODs for about 2-3 months now and i even tried reformatting which didnt help...

im running free avg antivirus and some people say thats the cause.. but i run the same antivirus on my laptop and it works just fine

i have uploaded the file from C:\windows\minidump

im running win7 home premium 64bit original (full retail)
comp is about 6months old
latest re-format was about a month

anyhelp will be greatly appreciated

My System SpecsSystem Spec
11 Feb 2012   #2
Microsoft MVP


The only memory dump dates from 16 Jan 2012.

No Windows Updates after SP1 - most systems have 70 or more. Please visit Windows Update and get all available updates.

We've seen a number of BSOD issues with SSD's recently. Here's the information that I've compiled:
There's not a whole bunch available to test SSD's. The "easiest" test is to remove the SSD, install a platter-based hard drive, install Windows and test for stability that way.

Here's some suggestions:
- Update the SSD's firmware to the latest available version (VERY IMPORTANT!!!)
- Slow the memory (RAM) down to the next slower speed (I've only seen one person who claimed that this worked for them).
- Use any manufacturer's utilities that you may have. If you don't have any, then try this free one (I haven't used it myself): Crystal Dew World
- Update chipset and storage controller drivers to the latest available from the manufacturer of the device (not the manufacturer of the motherboard). Be sure to update ALL controllers on the motherboard!
....NOTE: Recently (Nov 2011) we had BSOD issues with the Marvell 91xx controller and an SSD. You may have to switch controllers also.-
Replace the SSD with a platter based hard drive and see if that stops the BSOD's. If it does, then it's likely that there's a problem with the SSD OR an incompatibility with your system.
It's my opinion that SSD's aren't reliable enough (with current hardware) to be used on a system that needs to work reliably. Until I see reliability I will not recommend, nor will I use, SSD's for critical applications.
06 Dec 2011 - This post tends to confirm issues with certain SSD chipsets and certain controllers - [SOLVED] cant find the cause of BSOD F4 - Tech Support Forum
Gigabyte ET6 (EasyTune6) is known to cause BSOD's (as are some of the other "Easy" Gigabyte utilities). Please uninstall them.

The memory dump blames AppleCharger.sys - a driver for the Gigabyte on/off charge driver. See here for details - GIGABYTE ON/OFF Charge Remove the program to see if it stops the BSOD's

Further info on BSOD error messages available at:

The following info is just FYI, I've already addressed the issues that I saw in the above paragraphs:
- Create a System Restore Point prior to doing any of this. DO NOT mess with the drivers themselves - leave the Windows\System32\drivers directory alone unless we specifically direct you to it!
- Please either update the older drivers from the device manufacturer's website - or uninstall them from your system. Reference links are included below.
- DO NOT use Windows Update or the Update Drivers function of Device Manager.
- Please feel free to post back about any drivers that you are having difficulty locating.
- Windows Update exceptions may be noted below for Windows drivers.

amdxata.sys      Fri Mar 19 12:18:18 2010 (4BA3A3CA)
avgtdia.sys      Sun Jul 10 18:46:53 2011 (4E1A2BDD)
avgrkx64.sys     Tue Sep 13 00:02:34 2011 (4E6ED5DA)
AVGIDSEH.Sys     Sun Jul 10 18:36:50 2011 (4E1A2982)
avgmfx64.sys     Sun Aug 07 23:41:46 2011 (4E3F5AFA)
Rt64win7.sys     Thu Jan 13 06:57:19 2011 (4D2EE89F)
avgldx64.sys     Thu Oct 06 23:55:41 2011 (4E8E783D)
AppleCharger.sys Mon Jan 10 04:57:29 2011 (4D2AD809)
EtronHub3.sys    Fri Feb 25 12:51:55 2011 (4D67EC3B)
nvhda64v.sys     Thu Jul 07 12:21:14 2011 (4E15DCFA)
igdkmd64.sys     Sun Apr 10 14:50:59 2011 (4DA1FC13)
HECIx64.sys      Tue Sep 21 12:59:04 2010 (4C98E458)
EtronXHCI.sys    Fri Feb 25 12:51:52 2011 (4D67EC38)
GEARAspiWDM.sys  Mon May 18 08:17:04 2009 (4A1151C0)
RTKVHD64.sys     Fri Feb 11 05:16:05 2011 (4D550C65)
IntcDAud.sys     Fri Oct 15 04:28:17 2010 (4CB810A1)
nx6000.sys       Wed Jan 27 18:36:09 2010 (4B60CDE9)
AVGIDSFilter.Sys Sun Jul 10 18:37:05 2011 (4E1A2991)
AVGIDSDriver.Sys Sun Jul 10 18:36:37 2011 (4E1A2975)
nvlddmkm.sys     Sat Oct 15 02:07:55 2011 (4E99233B)


Loading Dump File [C:\Users\FUBAR\_jcgriff2_\dbug\__Kernel__\011612-17160-01.dmp]
Built by: 7601.17640.amd64fre.win7sp1_gdr.110622-1506
Debug session time: Sun Jan 15 17:40:08.662 2012 (UTC - 5:00)
System Uptime: 0 days 0:00:36.394
*** WARNING: Unable to verify timestamp for AppleCharger.sys
*** ERROR: Module load completed but symbols could not be loaded for AppleCharger.sys
Probably caused by : AppleCharger.sys ( AppleCharger+1a93 )
FAILURE_BUCKET_ID:  X64_0x50_AppleCharger+1a93
Bugcheck code 00000050
Arguments ffffffff`ffffffd0 00000000`00000001 fffff800`0328ea4c 00000000`00000000
My System SpecsSystem Spec

 The Windows Subsystem system process terminated unexpectedly

Thread Tools

Similar help and support threads
Thread Forum
Chkdsk/R on startup process terminated twice by BSOD
I have been experiencing issues with a number of failed attempts to complete a full backup of this laptop. These result in the backup being aborted at about 60% completion. To try and resolve the issue I decided to run the Check Disk/R process. Two attempts to complete the Check Disk/R process...
BSOD Help and Support
Program Terminated Unexpectedly When Logging Into Windows 7
So as the title says....I login to my Windows 7 Box, this message pops up...I have checked the error logs and cant seem to pin the issue down. Any Help Is Appreciated
Many services "terminated unexpectedly" at random times
Hi all, I'm running windows x64 pro and in my event logger, I keep seeing the same services being "terminated unexpectedly". All these services terminate at the same time and seems to terminate randomly. Here are the services that terminates: Windows audio service DHCP client service...
BSOD Help and Support
session manager initialization system process terminated unexpectedly
BSOD: The session manager initialization system process terminated unexpectedly with a status of 0xc000003a (0x00000000, 0x00000000) I'm getting this on a shop system running Win 7 Home Premium 32 bit. The last thing I did was shutdown before going home and I believe it installed an update then...
General Discussion
Process (can't be) terminated
It is not the first time but now i want to know. Sometimes there are processes that can't be terminated. I think that it is not OK, the system should do what I am want it to do. This time I tried. Taskmanager > right click > end Process > OK Taskmanager > right click > end Processstructure >...
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

й Designer Media Ltd

All times are GMT -5. The time now is 15:26.
Twitter Facebook Google+