Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Random BSODs - no apparent causing-action (0a, c2, c5, d1)

14 Mar 2012   #11

Windows 7 Home Premium x64 OEM (have disk)

Sorry, I only just received the email notification on your reply.

No, I haven't run Driver Verifier on all as the system was relatively stable. It has blue screened twice since I last posted. A lot of this has to do with the P8P67 tips, as well as an SSD setup guide I found. I will look to run driver verifier soon and will post the results.

At this stage, I am content with one BSOD per fortnight, considering it only occurs on shutdown now.

Thanks again for all your help.

My System SpecsSystem Spec
14 Mar 2012   #12

Windows 7 Home Premium 64 Bit

Alright, Verifier will cause the system to be less stable, but the crashes should identify any driver conflicts. Also, in step 3. of the Verifier tutorial, only select Standard settings. Do not select any of the other three boxes.
My System SpecsSystem Spec
15 Mar 2012   #13

Windows 7 Home Premium x64 OEM (have disk)

OK, I ran Verifier with all drivers selected and it blue screens on startup (nice to know if I decide to ever hardware troubleshoot)
I have attached a new batch of dumps; the latest being from the Verifier run. As you can see they basically repeat themselves. So, hopefully this may shed some light on the matter further.

Attached Files
File Type: zip Mini Dumps (1.77 MB, 2 views)
My System SpecsSystem Spec

15 Mar 2012   #14

Windows 7 Home Premium 64 Bit

Loading Dump File [D:\Kingston\BSODDmpFiles\Fluent\Mini Dumps 16-03\031612-4212-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*C:\SymCache*
Executable search path is: 
Windows 7 Kernel Version 7601 (Service Pack 1) MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Built by: 7601.17727.amd64fre.win7sp1_gdr.111118-2330
Machine Name:
Kernel base = 0xfffff800`03258000 PsLoadedModuleList = 0xfffff800`0349c650
Debug session time: Thu Mar 15 22:11:08.829 2012 (UTC - 6:00)
System Uptime: 0 days 0:00:11.625
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck A, {fffff98013a0efa1, 2, 0, fffff800032cb6ac}

Unable to load image RzSynapse.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for RzSynapse.sys
*** ERROR: Module load completed but symbols could not be loaded for RzSynapse.sys
Probably caused by : USBPORT.SYS ( USBPORT!USBPORT_Core_iMapTransfer+24a )

Followup: MachineOwner

0: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If a kernel debugger is available get the stack backtrace.
Arg1: fffff98013a0efa1, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, bitfield :
	bit 0 : value 0 = read operation, 1 = write operation
	bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
Arg4: fffff800032cb6ac, address which referenced memory

Debugging Details:

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff80003506100


fffff800`032cb6ac 8a040a          mov     al,byte ptr [rdx+rcx]





TRAP_FRAME:  fffff80004b94b00 -- (.trap 0xfffff80004b94b00)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=000000000000005a rbx=0000000000000000 rcx=fffff8800bb5cfa1
rdx=0000010007eb2000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff800032cb6ac rsp=fffff80004b94c98 rbp=000000000000005a
 r8=000000000000005a  r9=fffff8800bb5cfa1 r10=fffff98013a0f000
r11=fffff8800bb5cfa1 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl nz na pe nc
fffff800`032cb6ac 8a040a          mov     al,byte ptr [rdx+rcx] ds:0001:fffff980`13a0efa1=??
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff800032d42e9 to fffff800032d4d40

fffff800`04b949b8 fffff800`032d42e9 : 00000000`0000000a fffff980`13a0efa1 00000000`00000002 00000000`00000000 : nt!KeBugCheckEx
fffff800`04b949c0 fffff800`032d2f60 : 00000000`00000000 fffff800`0345e340 00000000`00001000 00000000`0000005a : nt!KiBugCheckDispatch+0x69
fffff800`04b94b00 fffff800`032cb6ac : fffff800`03770fe8 fffffa80`0854a250 fffff980`13a0efa1 fffffa80`0000005a : nt!KiPageFault+0x260
fffff800`04b94c98 fffff800`03770fe8 : fffffa80`0854a250 fffff980`13a0efa1 fffffa80`0000005a fffff800`0375ef01 : nt!memcpy+0x1c
fffff800`04b94ca0 fffff800`0377a9ed : fffffa80`08562ea0 00000000`00000001 fffff980`13a0efa1 fffff800`00000000 : nt!ViMapDoubleBuffer+0x368
fffff800`04b94d50 fffff880`047ba586 : fffffa80`07770050 fffffa80`07770050 fffff980`157c8fc0 fffff980`13a0efa1 : nt!VfGetScatterGatherList+0x1dd
fffff800`04b94df0 fffff880`047b7ea6 : fffff980`157d2f60 fffffa80`07770050 fffff800`0377a810 01cd032a`d0aedfa9 : USBPORT!USBPORT_Core_iMapTransfer+0x24a
fffff800`04b94e70 fffff880`047a8f89 : fffffa80`07770050 00000000`00000000 fffffa80`07770d02 fffffa80`07770d28 : USBPORT!USBPORT_Core_UsbMapDpc_Worker+0x296
fffff800`04b94ed0 fffff800`032df51c : fffff800`03449e80 fffffa80`07770d28 fffffa80`07770d40 00000000`0000ffff : USBPORT!USBPORT_Xdpc_Worker+0x1d9
fffff800`04b94f00 fffff800`032d7f15 : 00000000`00000000 fffffa80`03d19680 00000000`00000000 fffff880`047a8db0 : nt!KiRetireDpcList+0x1bc
fffff800`04b94fb0 fffff800`032d7d2c : fffffa80`07771178 00000000`00000000 00000000`00000002 fffff800`032ffda0 : nt!KyRetireDpcList+0x5
fffff880`035ca190 fffff800`0331fcdc : 00000000`00000000 fffff880`035ca2e0 00000000`0000000b fffff880`00000003 : nt!KiDispatchInterruptContinue
fffff880`035ca1c0 fffff800`0376b5c8 : fffffa80`07771128 fffff800`03381364 fffff980`1561ce00 00000000`00000002 : nt!KiDpcInterrupt+0xcc
fffff880`035ca350 fffff800`03381364 : fffffa80`07770480 fffffa80`07770480 00000000`00000000 fffff980`1561ce00 : nt!VerifierKeReleaseSpinLock+0xd8
fffff880`035ca390 fffff880`047b877e : fffff980`1561cc00 fffff980`1561cc00 fffff980`149eea00 fffff980`157d2f60 : nt!IoCsqInsertIrpEx+0x74
fffff880`035ca3d0 fffff880`047c98b3 : fffffa80`07770050 fffffa80`07770050 00000000`00000000 fffffa80`07770050 : USBPORT!USBPORT_Core_QueueTransferUrb+0x192
fffff880`035ca410 fffff880`047c84b8 : fffff980`149cadf0 fffff980`1578e790 fffff980`157d2f60 fffffa80`07770050 : USBPORT!USBPORT_SCT_VendorClassCommand+0x173
fffff880`035ca480 fffff880`047d0e74 : fffff980`1578e790 fffffa80`0784001b fffff980`1578e790 fffff980`157d2f60 : USBPORT!USBPORT_ProcessURB+0xb44
fffff880`035ca530 fffff880`047aaaf4 : 00000000`00000000 fffffa80`07848050 fffff980`15760fc0 fffff980`1578e790 : USBPORT!USBPORT_PdoInternalDeviceControlIrp+0x138
fffff880`035ca570 fffff800`03779c16 : fffff980`1578e790 00000000`00000002 fffffa80`07848050 fffffa80`078a7e70 : USBPORT!USBPORT_Dispatch+0x1dc
fffff880`035ca5b0 fffff880`00e0b7a7 : fffff980`1578e790 fffffa80`093eeaf0 fffff980`1578e790 fffffa80`078a7e70 : nt!IovCallDriver+0x566
fffff880`035ca610 fffff880`00e13789 : fffff880`00e31b50 fffffa80`093eeaf0 fffff980`0019ad50 fffff980`1578e790 : ACPI!ACPIDispatchForwardIrp+0x37
fffff880`035ca640 fffff880`00e0ba3f : fffff880`00e31b50 fffff980`0019ad50 fffffa80`093eeaf0 fffff980`0019ad50 : ACPI!ACPIIrpDispatchDeviceControl+0x75
fffff880`035ca670 fffff800`03779c16 : fffff980`1578e790 00000000`00000002 fffff980`1578e790 00000000`00000002 : ACPI!ACPIDispatchIrp+0x12b
fffff880`035ca6f0 fffff800`03778c42 : fffff980`1578ece0 00000000`00000002 fffffa80`078576f0 fffffa80`08507c90 : nt!IovCallDriver+0x566
fffff880`035ca750 fffff800`03779c16 : fffff980`1578e790 00000000`00000002 fffffa80`078575a0 fffff980`1578e790 : nt!ViFilterDispatchGeneric+0x62
fffff880`035ca780 fffff880`062fb566 : fffffa80`08471050 fffffa80`0852c060 fffff980`1578e790 fffffa80`084ef110 : nt!IovCallDriver+0x566
fffff880`035ca7e0 fffff880`0632bd8f : 00000000`00000000 00000000`00000000 fffffa80`0852c060 fffff800`03775d86 : usbhub!UsbhFdoUrbPdoFilter+0xde
fffff880`035ca810 fffff880`062f9fb7 : fffff980`1578e790 00000000`00000002 fffffa80`0852c060 fffffa80`084a6b10 : usbhub!UsbhPdoInternalDeviceControl+0x373
fffff880`035ca860 fffff800`03779c16 : fffff980`1578e790 00000000`00000002 fffff980`1578e790 fffff800`0377537e : usbhub!UsbhGenDispatch+0x57
fffff880`035ca890 fffff800`03778c42 : fffff980`1578ed28 00000000`00000002 fffffa80`08538b70 fffffa80`084a6b10 : nt!IovCallDriver+0x566
fffff880`035ca8f0 fffff800`03779c16 : fffff980`1578e790 00000000`00000002 fffffa80`08538a20 00000000`00220003 : nt!ViFilterDispatchGeneric+0x62
fffff880`035ca920 fffff880`081e0ec4 : fffffa80`0854d1b8 00000000`00000000 fffff980`1578e790 fffffa80`084f8f40 : nt!IovCallDriver+0x566
fffff880`035ca980 fffff880`081dd812 : fffffa80`0854d1b8 fffff980`1578e790 00000000`00000000 fffff980`1578e790 : usbccgp!UsbcForwardIrp+0x30
fffff880`035ca9b0 fffff880`081ddaba : fffffa80`08538538 00000000`00220003 fffff980`1578e790 fffffa80`0854d1b8 : usbccgp!DispatchPdoUrb+0xfa
fffff880`035ca9f0 fffff880`081db72e : 00000000`0000000f fffffa80`0854d1b0 fffffa80`0854d1b8 fffff980`1578e790 : usbccgp!DispatchPdoInternalDeviceControl+0x17a
fffff880`035caa20 fffff800`03779c16 : fffffa80`0854d060 00000000`00000001 fffff980`1578e700 fffff800`0377537e : usbccgp!USBC_Dispatch+0x2de
fffff880`035caaa0 fffff800`03778c42 : fffff980`1578ed70 00000000`00000002 fffffa80`08518cd0 fffffa80`0846c8d0 : nt!IovCallDriver+0x566
fffff880`035cab00 fffff800`03779c16 : fffff980`1578e790 00000000`00000002 fffffa80`08518b80 fffff800`0376ef0d : nt!ViFilterDispatchGeneric+0x62
fffff880`035cab30 fffff880`08194f3f : fffff980`1578ee09 00000000`00000000 00000000`00000300 fffffa80`0850bbe0 : nt!IovCallDriver+0x566
fffff880`035cab90 fffff880`08194105 : fffffa80`085499b0 fffff980`1578ee00 fffff880`035cac60 fffff980`1578e790 : hidusb!HumGetSetReport+0x1c3
fffff880`035cabf0 fffff880`031e9517 : fffffa80`08549901 fffffa80`085499b0 00000000`00000000 fffff980`13a0efa1 : hidusb!HumInternalIoctl+0x2e1
fffff880`035cac60 fffff880`031dd3a1 : fffff980`156b6ff0 fffff980`13a0efa1 fffff880`031e63a8 00000000`00000000 : HIDCLASS!HidpCallDriverSynchronous+0x4b
fffff880`035cacc0 fffff880`031dc71e : fffffa80`08549b20 fffff980`1578e790 fffff980`1578ee48 fffff880`035cadd0 : HIDCLASS!HidpGetSetReport+0x33d
fffff880`035cad40 fffff880`031db8d3 : fffff880`031e6300 fffff980`1578e790 fffffa80`085441b0 fffffa80`000b0191 : HIDCLASS!HidpIrpMajorDeviceControl+0x47a
fffff880`035cadd0 fffff800`03779c16 : fffff980`1578e790 fffff980`1578e790 00000000`00000002 fffff800`0377537e : HIDCLASS!HidpMajorHandler+0x1c3
fffff880`035cae40 fffff800`03778c42 : fffff980`1578ee48 00000000`00000002 fffffa80`084fc190 fffffa80`084f8740 : nt!IovCallDriver+0x566
fffff880`035caea0 fffff800`03779c16 : fffff980`1578e790 00000000`00000002 fffffa80`084fc040 fffff800`037753f5 : nt!ViFilterDispatchGeneric+0x62
fffff880`035caed0 fffff880`063534b6 : 00000000`00000000 00000000`00000002 fffffa80`0854c910 fffffa80`084c73e0 : nt!IovCallDriver+0x566
fffff880`035caf30 fffff800`03779c16 : fffff980`1578e790 00000000`00000002 fffffa80`0854c7c0 fffff800`0377537e : mouhid!MouHid_PassThrough+0x6a
fffff880`035caf70 fffff800`03778c42 : fffff980`1578ee90 00000000`00000002 fffffa80`084fc450 fffffa80`084d8760 : nt!IovCallDriver+0x566
fffff880`035cafd0 fffff800`03779c16 : fffff980`1578e790 00000000`00000002 fffffa80`084fc300 fffff880`00f34e4c : nt!ViFilterDispatchGeneric+0x62
fffff880`035cb000 fffff880`00f350c2 : fffff880`00fae7c0 fffff980`1532ce90 00000000`00000025 fffffa80`0852dc30 : nt!IovCallDriver+0x566
fffff880`035cb060 fffff880`00f4a59f : fffff980`1333adf0 fffff880`00000000 00000000`00000000 0000067f`ea897188 : Wdf01000!FxIoTarget::SubmitSync+0x24a
fffff880`035cb110 fffff880`07e021f9 : fffff980`00000020 fffff980`15768e70 fffff980`1532ce90 0000067f`eac3b3a8 : Wdf01000!imp_WdfRequestSend+0x24b
fffff880`035cb160 fffff980`00000020 : fffff980`15768e70 fffff980`1532ce90 0000067f`eac3b3a8 00000002`00000010 : RzSynapse+0x21f9
fffff880`035cb168 fffff980`15768e70 : fffff980`1532ce90 0000067f`eac3b3a8 00000002`00000010 00000000`00000000 : 0xfffff980`00000020
fffff880`035cb170 fffff980`1532ce90 : 0000067f`eac3b3a8 00000002`00000010 00000000`00000000 0000067f`eac3b3a8 : 0xfffff980`15768e70
fffff880`035cb178 0000067f`eac3b3a8 : 00000002`00000010 00000000`00000000 0000067f`eac3b3a8 fffff880`07e01284 : 0xfffff980`1532ce90
fffff880`035cb180 00000002`00000010 : 00000000`00000000 0000067f`eac3b3a8 fffff880`07e01284 0000067f`ea897188 : 0x67f`eac3b3a8
fffff880`035cb188 00000000`00000000 : 0000067f`eac3b3a8 fffff880`07e01284 0000067f`ea897188 fffff980`153c8e70 : 0x2`00000010


fffff880`047ba586 4c63c0          movsxd  r8,eax



FOLLOWUP_NAME:  MachineOwner





BUCKET_ID:  X64_0xA_USBPORT!USBPORT_Core_iMapTransfer+24a

Followup: MachineOwner
Caused by a device plugged in your USB ports. Razer Synapse Engine/Razer Naga appears to be the device type. Disable Verifier if you have not already done so: Start Menu -> All Programs -> Accessories -> Right click Command Prompt -> Run as administrator ->
verifier /reset
-> restart your computer.

Start with USB Driver - General Fix for Problems to resolve the USB issues. Also, USB ports can sometimes enter a safe power state to protect the system from power surges due to USB devices. To reset the USB ports to a nominal power state, use a hard reset to resolve hardware and software issues which works for all computers, not just HP Pavilions (minus the HP driver update step).
My System SpecsSystem Spec
16 Mar 2012   #15

Windows 7 Home Premium x64 OEM (have disk)

Sir, thank you!
Though the USB tips made little difference, it prompted me to recheck my Razer peripherals by themselves. In the end, the Razer Nostromo Gamepad caused the blue screen 100% of the time. I'm still running Verifier, have reset numerous times with no blue screen. The moment I plug in the Nostromo BAM.
Cheers for your time, now to go find a replacement.

Wow, this mystery finally seems to be solved (only 4 months or so of it)
My System SpecsSystem Spec
16 Mar 2012   #16

Windows 7 Home Premium 64 Bit

You're welcome. :)
My System SpecsSystem Spec
16 Mar 2012   #17

Windows 7 Home Premium x64 OEM (have disk)

Well, I spoke too soon.
It blue screened once more while running Verifier. This is a different code to the standard x0a that has occurred many times before, most likely because I have unplugged the gamepad.
Could you please look at the latest dump (16-03 8.11pm - I forgot to clear the earlier
Razer-based dumps) and let me know what I could try?
Thanks again for all your support.

Attached Files
File Type: zip Mini Dumps (1.92 MB, 1 views)
My System SpecsSystem Spec
16 Mar 2012   #18

Windows 7 Home Premium 64 Bit

Disable Verifier with the steps indicated in my previous post. See how the system responds for a few days without the Razer gamepad and without Verifier running. Often, Verifier will cause crashes unrelated to any problem but due to user activity putting the system in situations that it normally would not crash in but that Verifier causes crashes in.

If you continue to get crashes without the gamepad and without Verifier enabled, we will need to do more troubleshooting steps.
My System SpecsSystem Spec
16 Mar 2012   #19

Windows 7 Home Premium x64 OEM (have disk)

OK. In the process of doing that now. If I encounter an error I will post, otherwise I'll confirm next week that it is likely solved.
My System SpecsSystem Spec
26 Mar 2012   #20

Windows 7 Home Premium x64 OEM (have disk)

Well, it seems slightly resolved but I'm unsure. Below are the blue screens from the last week.
BSOD 18-03 = Razer Nostromo drivers uninstalled, unknown cause, please advise.
BSOD 23-03 = Razer Nostromo still uninstalled, unknown cause, please advise.
BSOD 25-03 = Razer Nostromo fresh install as per Razer Support recommendation, please confirm it is the Razer device
BSOD 26-03 = likely same as above
BSOD 27-03 = Older Nostromo driver used as per Razer Support follow-up, please confirm it is the Razer device again
If it is the Razer device these last three times, I will return the product. If not, and links to somewhere else, could you please provide a recommended course of action (even potentially a W7 fresh install)

Thanks for your help Writhziden!

Attached Files
File Type: zip Mini Dumps (1.66 MB, 1 views)
My System SpecsSystem Spec

 Random BSODs - no apparent causing-action (0a, c2, c5, d1)

Thread Tools

Similar help and support threads
Thread Forum
Recent BSODs, no apparent pattern, last code I got was 0x7e
Hello! I've recently started getting some odd BSODs, I've been working on updating drivers but I haven't quite pinned anything down yet. Was just wondering if anyone else could take a peek and see if they saw anything obvious - I'm at the end of my first semester in graduate school and am already...
BSOD Help and Support
Expert Advice Needed: W7 x64 Software Causing Random BSODs!
My overclocked Win7 x64 system was running rock solid (24-hour stress tests with no issues) until about 2 months ago, when intermittent crashing started to occur (memory read errors, Stop 0x3b, Stop 0x124). I returned to stock hardware settings, even underclocked, upgraded drivers, installed SP1 --...
BSOD Help and Support
BSODs for no apparent reason
BCCode: deaddead BCP1: 000000000F010012 BCP2: 00000000001C0410 BCP3: 0000000012BC0000 BCP4: 0000000000000000 OS Version: 6_1_7601
BSOD Help and Support
Multiple BSODs, ntoskrnl.exe only apparent connection
Running Windows 7 Home Premium 64-bit, Full Retail version System hardware is roughly 4 months old: hardware details should be attached to this profile. Age of OS installation is about a week (attempted a complete reinstall to fix the issue) First experienced BSODs a few weeks ago while...
BSOD Help and Support
BSOD 0X0000001E No specific action causing
Hi, I'm getting BSODs - three in the last month or so. The most recent (today) was 0X00000001E. Raally not sure about the others. OS: Win 7 Home 64-bit. Really, really grateful for any help anyone can give me. I attaching all three dumps. If this is cheeky, I apologise. Forget the earlier...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:52.
Twitter Facebook Google+