Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD playing Red Faction/other Games, related to win32k.sys

15 Feb 2012   #1

Microsoft Windows 7 Ultimate 64-Bit 7601 Multiprocessor Free Service Pack 1
BSOD playing Red Faction/other Games, related to win32k.sys

Hi Sevenforum Members,
i hope you can help me with my PC problems.
My System:
Windows 7 64 Ultimate OEM Version (Installed myself)
- What is the age of system (hardware)?
Just recently bought a new mainboard,cpu,memory
- What is the age of OS installation (have you re-installed the OS?)
Reinstalled with the new hardware.

I already took some of your recommended tests to find out what is wrong. But i have not been sucessful yet.
I identified the FNETTBOH_305.sys as a problem with driver verifier. It got rid of it and my PC is already running a lot more stable.

My PC is often crashing with a BSOD when playing games. It has not happend if just browsing the Web or anything else not related to 3D graphics so I suppose the first problem is solved.

I made a zip file as described. I hope I did everything correct.

If you have any idea what causes the BSODs please get in touch.

Sincerely Alexander

My System SpecsSystem Spec
15 Feb 2012   #2

Windows 10 Pro x64, Arch Linux

Your BSODs were caused by the Creative Audio/Sound Blaster Driver
Update that driver & associated software
Creative Worldwide Support

*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If a kernel debugger is available get the stack backtrace.
Arg1: 0000000000000000, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000001, bitfield :
    bit 0 : value 0 = read operation, 1 = write operation
    bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
Arg4: fffff800030a072c, address which referenced memory

Debugging Details:

WRITE_ADDRESS: GetPointerFromAddress: unable to read from fffff800032cb100


fffff800`030a072c 4c8938          mov     qword ptr [rax],r15




PROCESS_NAME:  svchost.exe

TRAP_FRAME:  fffff8800a8384f0 -- (.trap 0xfffff8800a8384f0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000000 rbx=0000000000000000 rcx=fffffa800d3a6ee0
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff800030a072c rsp=fffff8800a838680 rbp=0000000000000000
 r8=fffff78000000008  r9=0000000000000000 r10=0000000000000000
r11=fffff880037e4180 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl zr na po nc
fffff800`030a072c 4c8938          mov     qword ptr [rax],r15 ds:c8b0:00000000`00000000=????????????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff800030981e9 to fffff80003098c40

fffff880`0a8383a8 fffff800`030981e9 : 00000000`0000000a 00000000`00000000 00000000`00000002 00000000`00000001 : nt!KeBugCheckEx
fffff880`0a8383b0 fffff800`03096e60 : 00000000`00000010 fffff8a0`04abacac fffff800`032ce500 00000000`00000000 : nt!KiBugCheckDispatch+0x69
fffff880`0a8384f0 fffff800`030a072c : fffffa80`0ed9c8b0 00000000`00000000 fffffa80`0d3a6b30 00000000`00000000 : nt!KiPageFault+0x260
fffff880`0a838680 fffff800`0306b61e : fffff880`0a838700 fffff800`00000022 fffffa80`0e83f000 fffffa80`0e83f000 : nt!KeWaitForSingleObject+0x17c
fffff880`0a838720 fffff800`030ab1c5 : 00000000`00000001 00000000`00000000 00000000`00000000 fffff880`0a8389e8 : nt!KiAcquireFastMutex+0x4e
fffff880`0a838760 fffff880`0697f2c2 : fffffa80`0ed9cae8 fffffa80`0ed9cb30 00000000`00000010 fffff880`0697f1d8 : nt!ExAcquireFastMutex+0x45
fffff880`0a838790 fffffa80`0ed9cae8 : fffffa80`0ed9cb30 00000000`00000010 fffff880`0697f1d8 00000000`00000000 : ctaud2k+0x772c2
fffff880`0a838798 fffffa80`0ed9cb30 : 00000000`00000010 fffff880`0697f1d8 00000000`00000000 00000000`00000000 : 0xfffffa80`0ed9cae8
fffff880`0a8387a0 00000000`00000010 : fffff880`0697f1d8 00000000`00000000 00000000`00000000 00000000`00000010 : 0xfffffa80`0ed9cb30
fffff880`0a8387a8 fffff880`0697f1d8 : 00000000`00000000 00000000`00000000 00000000`00000010 fffffa80`0840da10 : 0x10
fffff880`0a8387b0 00000000`00000000 : 00000000`00000000 00000000`00000010 fffffa80`0840da10 fffffa80`0ed9c8b0 : ctaud2k+0x771d8


fffff880`0697f2c2 ??              ???


SYMBOL_NAME:  ctaud2k+772c2

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: ctaud2k

IMAGE_NAME:  ctaud2k.sys


FAILURE_BUCKET_ID:  X64_0xA_ctaud2k+772c2

BUCKET_ID:  X64_0xA_ctaud2k+772c2

Followup: MachineOwner
My System SpecsSystem Spec
15 Feb 2012   #3

Microsoft Windows 7 Ultimate 64-Bit 7601 Multiprocessor Free Service Pack 1

First of all, thank you for your advice!

I found a newer Version on the Creative Homepage. Strangely the Autoupdate did not show it to me?!
Old Version was: from 04.11.2011
New Version: from 28.11.2011

I will try and see if this resolves my problem and get back in touch.
Have a pleasent day.
My System SpecsSystem Spec

20 Feb 2012   #4

Microsoft Windows 7 Ultimate 64-Bit 7601 Multiprocessor Free Service Pack 1

Hi, I hope you can help me again. Sadly I still received another bluescreen today. But it was about the dxgkrnl.sys. I have attached everything again and hope someone can give me another hint what is wrong

Things I remember I changed from the last one:
-The Creative Sound driver
-The newest ATI graphic driver
-deactivated the integrated INTEL graphics device
My System SpecsSystem Spec
21 Feb 2012   #5

Windows 10 Pro x64, Arch Linux

dxgkrnl.sys is related to your graphics card & its driver. Reinstalling those could fix your problem.
My System SpecsSystem Spec

 BSOD playing Red Faction/other Games, related to win32k.sys

Thread Tools

Similar help and support threads
Thread Forum
BSOD while playing/starting steam related games
Hey, since a few days I experience BSOD while playing/starting Steam games (noticed it the first while playing Payday 2, tried Space Engineers later and it happened there too). This only happens while playing or starting Steam games, I played WoW for hours now without any problems but as soon...
BSOD Help and Support
BSOD playing games in general, problem related to nvlddmkm.sys
Hello, I've been recently having problems and they are all apparently connected to nvlddmkm.sys and I don't know how to fix this, I've looked into this a lot and I'm not able to find any solutions. I have a NVIDIA GeForce 610M and I tried using the latest version as well (currently I have a version...
BSOD Help and Support
BSOD while playing Torchlight 2, Win32k.sys related. Help appreciated!
Hello and thanks in advance for any help! I have a great custom computer that I've been gaming on for over a year now. I had 2 blue screens today while playing Torchlight 2 (I had been playing Max Payne 3 earlier with no issues and many other games on a daily basis). I am attaching the zipped...
BSOD Help and Support
BSOD When playing games or watching stream (seems video related)
I've gotten this many times while playing video games or watching streams/video online in chrome. I got this computer 3 days ago... I downloaded dropbox, skype and some other random apps, but nothing crazy that i can think of. I feel like it is video card related, I have a NVIDIA GeForce GT...
BSOD Help and Support
BSOD When playing games - Driver related.
Good day everyone ! BEFORE READING: I updated the info of this old thread, because I found the source of the problem, read the UPDATE at the end ! As the topic title says im gettin some BSOD after playing games for like 5-10 minutes. DRIVER_IRQL_NOT_LESS_OR_EQUAL <----- This is what...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:27.
Twitter Facebook Google+