Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD when running memory intensive apps

25 Feb 2012   #11

Windows 7 Home Premium 64 Bit

An underlying driver may be incompatible\conflicting with your system. Run Driver Verifier to find any issues. To run Driver Verifier, do the following:
a. Backup your system and user files
b. Create a system restore point
c. If you do not have a Windows 7 DVD, Create a system repair disc
d. Run Driver Verifier

If Windows cannot start in normal mode with driver verifier running, start in safe mode. If it cannot start in safe mode or normal mode, restore the system restore point using System Restore OPTION TWO.

Thanks to zigzag3143 for contributing to the Verifier steps.
If you are unable to start Windows with all drivers being verified or if the blue screen crashes fail to create .dmp files, run them in groups of 5 or 10 until you find a group that causes blue screen crashes and stores the blue screen .dmp files.
The idea with Verifier is to cause the system to crash, so do the things you normally do that cause crashes. After you have a few crashes, upload the crash reports for us to take a look and try to find patterns.

My System SpecsSystem Spec
25 Feb 2012   #12

Windows 7 Ultimate x64

Thanks again writhziden,

I could not start driver verifier in "normal mode", so I ran it in "safe mode with networking" for 12 hours, and everything, including torrents downloading, worked fine without any crashes occurring. I then rebooted into "safe mode - directory services restore mode" and had three crashes and have attached their dump and performance reports to this post.

Thanks again for any help or ideas
My System SpecsSystem Spec
25 Feb 2012   #13

Windows 7 Home Premium 64 Bit

Problem devices (probably due to being in Safe Mode, so don't worry about it too much):
J:\	WPDBUSENUMROOT\UMB\2&37C186B&0&STORAGE#VOLUME#_??_USBSTOR#DISK&VEN_APPLE&PROD_SD_CARD_READER&REV_1.00#000000009833&0#	This device is not working properly because Windows cannot load the drivers required for this device.
Link-Layer Topology Discovery Mapper I/O Driver	ROOT\LEGACY_LLTDIO\0000	This device is not present, is not working properly, or does not have all its drivers installed.
Cisco AnyConnect Secure Mobility Client Virtual Miniport Adapter for Windows x64	ROOT\NET\0000	This device is disabled.
1 LACIE15GB	WPDBUSENUMROOT\UMB\2&37C186B&0&STORAGE#VOLUME#_??_USBSTOR#DISK&VEN_LACIE&PROD_WHIZKEY&REV_0.00#6381764701F04A&0#	This device is not working properly because Windows cannot load the drivers required for this device.
Link-Layer Topology Discovery Responder	ROOT\LEGACY_RSPNDR\0000	This device is not present, is not working properly, or does not have all its drivers installed.
CHRISTOPHER	WPDBUSENUMROOT\UMB\2&37C186B&0&STORAGE#VOLUME#_??_USBSTOR#DISK&VEN_APPLE&PROD_IPOD&REV_2.70#000A2700230D57DD&0#	This device is not working properly because Windows cannot load the drivers required for this device.
Security Processor Loader Driver	ROOT\LEGACY_SPLDR\0000	This device is not present, is not working properly, or does not have all its drivers installed.
Unknown Device	USB\VID_0000&PID_0000\6&112A0DF4&0&3	43
IDMWFP	ROOT\LEGACY_IDMWFP\0000	This device is not present, is not working properly, or does not have all its drivers installed.

Microsoft (R) Windows Debugger Version 6.12.0002.633 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [D:\Kingston\BSODDmpFiles\cornc5\Driver Verify Crash 3 Dump Files\022512-17924-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*C:\SymCache*
Executable search path is: 
Windows 7 Kernel Version 7601 (Service Pack 1) MP (2 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7601.17640.amd64fre.win7sp1_gdr.110622-1506
Machine Name:
Kernel base = 0xfffff800`01c19000 PsLoadedModuleList = 0xfffff800`01e5e670
Debug session time: Sat Feb 25 20:26:06.107 2012 (UTC - 7:00)
System Uptime: 0 days 0:22:03.091
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck D1, {28, 2, 0, fffff88001779b2d}

Probably caused by : NETIO.SYS ( NETIO!RtlCopyBufferToMdl+1d )

Followup: MachineOwner

1: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arg1: 0000000000000028, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, value 0 = read operation, 1 = write operation
Arg4: fffff88001779b2d, address which referenced memory

Debugging Details:

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff80001ec8100


fffff880`01779b2d 448b5228        mov     r10d,dword ptr [rdx+28h]





TRAP_FRAME:  fffff880021db7f0 -- (.trap 0xfffff880021db7f0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=fffff880021dba10 rbx=0000000000000000 rcx=0000000000000000
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff88001779b2d rsp=fffff880021db980 rbp=fffff880021dbab0
 r8=00000000ffffffbc  r9=0000000000000044 r10=0000000000000000
r11=fffffa80077e2160 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl zr na po nc
fffff880`01779b2d 448b5228        mov     r10d,dword ptr [rdx+28h] ds:00000000`00000028=????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80001c951e9 to fffff80001c95c40

fffff880`021db6a8 fffff800`01c951e9 : 00000000`0000000a 00000000`00000028 00000000`00000002 00000000`00000000 : nt!KeBugCheckEx
fffff880`021db6b0 fffff800`01c93e60 : fffffa80`0a837098 fffff880`018b0dd2 00000000`00000246 00000000`00000044 : nt!KiBugCheckDispatch+0x69
fffff880`021db7f0 fffff880`01779b2d : 00000000`0000001c fffff880`01867fec 00000000`0000000a fffffa80`0c338ae8 : nt!KiPageFault+0x260
fffff880`021db980 fffff880`018efbac : 00000000`00000000 fffff880`018be906 00000000`00000001 fffff880`0146d00f : NETIO!RtlCopyBufferToMdl+0x1d
fffff880`021db9e0 fffff880`018bbef3 : fffffa80`077e2160 00000000`00000001 fffffa80`0bdf1bf0 00000000`00000000 : tcpip! ?? ::FNODOBFM::`string'+0x1d5cf
fffff880`021dba50 fffff880`018aed54 : fffff880`021dbf08 fffff800`00000029 fffffa80`0bdf1bf0 00000000`00000001 : tcpip!TcpTcbCarefulDatagram+0x543
fffff880`021dbc00 fffff880`018ad67a : fffffa80`07763a50 fffff880`018a5b34 fffffa80`0771a158 00000000`00000000 : tcpip!TcpTcbReceive+0x694
fffff880`021dbdb0 fffff880`018af2ab : fffffa80`093fc940 fffffa80`07759000 00000000`00000000 fffff880`021dc100 : tcpip!TcpMatchReceive+0x1fa
fffff880`021dbf00 fffff880`018a61c7 : fffffa80`07763a50 fffffa80`07760bc4 fffffa80`0000406a 00000000`0000406a : tcpip!TcpPreValidatedReceive+0x36b
fffff880`021dbfd0 fffff880`018a5d3a : 00000000`00000000 fffff880`019c0800 fffff880`021dc190 fffffa80`07d2a440 : tcpip!IppDeliverListToProtocol+0x97
fffff880`021dc090 fffff880`018a5339 : fffffa80`07d2a440 fffffa80`07d2a440 00000000`00000000 fffff880`021dc180 : tcpip!IppProcessDeliverList+0x5a
fffff880`021dc130 fffff880`018a30af : 00000000`00000000 00000000`088d4b00 fffff880`019c0800 fffff880`019c0800 : tcpip!IppReceiveHeaderBatch+0x23a
fffff880`021dc210 fffff880`018a26a2 : fffffa80`088ce330 00000000`00000000 fffffa80`088d4b00 fffff880`00000001 : tcpip!IpFlcReceivePackets+0x64f
fffff880`021dc410 fffff880`0192134a : 00000000`00000001 00000000`00000014 fffffa80`088d4ba0 fffff880`011a7f4f : tcpip!FlpReceiveNonPreValidatedNetBufferListChain+0x2b2
fffff880`021dc4f0 fffff800`01ca2618 : fffffa80`07740c38 00000000`00000000 fffffa80`06d51680 00000000`00000001 : tcpip! ?? ::FNODOBFM::`string'+0x55122
fffff880`021dc540 fffff880`018a2202 : fffff880`018a1a60 00000000`00000240 fffff8a0`00010900 00000000`00000001 : nt!KeExpandKernelStackAndCalloutEx+0xd8
fffff880`021dc620 fffff880`017340eb : fffffa80`088d4010 00000000`00000000 fffffa80`085921a0 00000000`00000000 : tcpip!FlReceiveNetBufferListChain+0xb2
fffff880`021dc690 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : ndis!ndisMIndicateNetBufferListsToOpen+0xdb


fffff880`01779b2d 448b5228        mov     r10d,dword ptr [rdx+28h]


SYMBOL_NAME:  NETIO!RtlCopyBufferToMdl+1d

FOLLOWUP_NAME:  MachineOwner




FAILURE_BUCKET_ID:  X64_0xD1_NETIO!RtlCopyBufferToMdl+1d

BUCKET_ID:  X64_0xD1_NETIO!RtlCopyBufferToMdl+1d

Followup: MachineOwner
Driver verified crashes point toward the network adapter being the issue.

Also, if it is crashing on startup in normal mode with Verifier enabled, you should run driver verifier on one non-Microsoft driver at a time to determine which driver is causing the crash at startup.
My System SpecsSystem Spec

27 Feb 2012   #14

Windows 7 Professional 64 bit
Sorry to barge in on this but having exact same problem

Sorry to just barge in on this thread but I too have this exact issue and have done so for months.

Once crash happens get report "Probably caused by : NETIO.SYS"

I've used Vuze instead for the last year with no issue but wanted to go back to Utorrent so have used it this weekend and suffered 4 crashes.

I would love it if this thread solves this issue and please let me know if any of my info would help.

My PC is Acer Aspire desk top Media Centre.

Regards, tj
My System SpecsSystem Spec
27 Feb 2012   #15

Windows 7 Home Premium 64 Bit

tjpearson, please start your own thread following the to get dedicated help. All systems are different, so your crashes may not be due to the exact same causes. Systems have different hardware, software, and drivers, so there are too many factors to assume the solution in this thread will work for you. You are welcome to follow this thread while getting help in your own, of course.
My System SpecsSystem Spec
28 Feb 2012   #16

Windows 7 Professional 64 bit
I'm so sorry

I do apologise, didn't notice the BSOD rule till after post, it makes sense. Sorry again. Regards, tj
My System SpecsSystem Spec
20 Mar 2012   #17

Windows 7 Home Premium 64 Bit

cornc5: did you resolve your network adapter crashes and the Verifier crashes on startup?
My System SpecsSystem Spec

 BSOD when running memory intensive apps

Thread Tools

Similar help and support threads
Thread Forum
BSOD while running CPU and RAM intensive simulations
Greetings, I have a desktop PC with Windows 7 64-bit installed, and I use the package FDTD Solutions from Lumerical Company on this computer in order to calculate electromagnetic fields for a particular structure. My simulations last for 2-3 hours and usually when the simulation is around 20% of...
BSOD Help and Support
BSOD while using more memory-intensive programs
Hello, I have been experience multiple BSODs, especially when using more memory-intensive programs, and have yet to determine the cause. I have run Windows Memory Diagnostic Tool after the last one, and it reported no errors. I have downloaded the Windbg Toolkit, and have followed the...
BSOD Help and Support
BSOD while running graphically intensive games.
Hello! My brother recently upgraded his rig and passed down his GTX 690 to because he no longer has a use for it, and I can't seem to play any intensive games on this rig at all, on any graphical settings. I can play Path of Exile and League of Legends with no trouble at all, however I think...
BSOD Help and Support
BSOD when running cpu intensive software
Hi all Hope someone can help. I've had a BSOD for several months, but very infrequently (once every couple of weeks). Stupidly I've just been ignoring it, but I'm trying to render a HD video in Sony Vegas and I now keep getting the BSOD at every attempt. I also get the same problem when trying...
BSOD Help and Support
BSOD running graphic intensive applications
Hello, my pc specs are: windows 7 professional x64 ASUS M4A890GTD PRO/USB3 mobo AMD 1090T @ stock clock 2x2GB GSkill ddr3 @ 1600Mhz 1.6V nVidia GTX 460 @ (heavily overclocked in that past, currently at stock) 2x SATA IDE HDDs Corsair 850TX 850W PSU
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:34.
Twitter Facebook Google+