Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: random bluescreens ntoskrnl.exe

19 Mar 2012   #21

Windows Seven Ultimate x64

well, i reformatted and decided 6 gigs wasnt enough, so i bought 8gigs and used the 2 newer sticks of the 2 gig ram for a total of 12 gigs. this has been running well for a couple days. the only issue i have had now was a bluescreen caused by device manager, when i try to open it i get an error message microsoft manangement console has stopped working. and shortly there after i get a black screen (no blue) and on restart it says that there was a crash and nirsofts program pointed me to the management program.

attached is the dump.

ps. the ram testing showed no errors, faults, or anything, so I'm not sure if it was the reformat, or the ram change.

My System SpecsSystem Spec
19 Mar 2012   #22

Windows 7 Home Premium 64 Bit

Possible out of date driver:
netr28x	fffff880`04811000	fffff880`048b0000	Wed Feb 25 20:02:09 2009 (49a60631)	000a3bdb		netr28x.sys

Microsoft (R) Windows Debugger Version 6.12.0002.633 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [D:\Kingston\BSODDmpFiles\squat251\031112-20748-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*C:\SymCache*
Executable search path is: 
Windows 7 Kernel Version 7601 (Service Pack 1) MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7601.17514.amd64fre.win7sp1_rtm.101119-1850
Machine Name:
Kernel base = 0xfffff800`02a16000 PsLoadedModuleList = 0xfffff800`02c5be90
Debug session time: Sun Mar 11 19:53:14.781 2012 (UTC - 6:00)
System Uptime: 0 days 5:24:03.373
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 19, {3, fffff80002c1dc30, 5420000, fffff80002c1dc30}

Probably caused by : Pool_Corruption ( nt!ExDeferredFreePool+a53 )

Followup: Pool_corruption

3: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

The pool is already corrupt at the time of the current request.
This may or may not be due to the caller.
The internal pool links must be walked to figure out a possible cause of
the problem, and then special pool applied to the suspect tags or the driver
verifier to a suspect driver.
Arg1: 0000000000000003, the pool freelist is corrupt.
Arg2: fffff80002c1dc30, the pool entry being checked.
Arg3: 0000000005420000, the read back flink freelist value (should be the same as 2).
Arg4: fffff80002c1dc30, the read back blink freelist value (should be the same as 2).

Debugging Details:






LAST_CONTROL_TRANSFER:  from fffff80002bc04b3 to fffff80002a96640

fffff880`02ffd3d8 fffff800`02bc04b3 : 00000000`00000019 00000000`00000003 fffff800`02c1dc30 00000000`05420000 : nt!KeBugCheckEx
fffff880`02ffd3e0 fffff880`0539e045 : 00000009`00000000 fffff880`02ffd530 00000000`0000032d fffffa80`00000000 : nt!ExDeferredFreePool+0xa53
fffff880`02ffd4d0 fffff880`053af2fd : 00000000`00000001 fffffa80`080d7160 00000000`00000002 fffffa80`0634f168 : USBPORT!UsbAllocPool_Z+0x3d
fffff880`02ffd500 fffff880`053bf278 : fffffa80`0634e050 fffffa80`00000380 fffffa80`0757bdf0 fffffa80`074e9560 : USBPORT!USBPORT_Core_AllocTransferEx+0x17d
fffff880`02ffd590 fffff880`053c7e34 : fffffa80`074e9560 fffffa80`06ff0009 fffffa80`074e9560 fffffa80`080d7160 : USBPORT!USBPORT_ProcessURB+0x944
fffff880`02ffd640 fffff880`053a1af4 : 00000000`00000000 fffffa80`06ff1050 fffffa80`059d1130 fffffa80`074e9560 : USBPORT!USBPORT_PdoInternalDeviceControlIrp+0x138
fffff880`02ffd680 fffff880`05776566 : fffffa80`06ff7050 fffffa80`0757b060 fffffa80`074e9560 fffffa80`06ff71a0 : USBPORT!USBPORT_Dispatch+0x1dc
fffff880`02ffd6c0 fffff880`057a6d8f : 00000000`00000000 00000000`00000000 fffffa80`0757b060 00000000`00000801 : usbhub!UsbhFdoUrbPdoFilter+0xde
fffff880`02ffd6f0 fffff880`05774fb7 : fffffa80`075a1b58 00000000`00000000 fffffa80`074e9560 fffffa80`0771bb58 : usbhub!UsbhPdoInternalDeviceControl+0x373
fffff880`02ffd740 fffff880`0753bec4 : 00000000`00000000 fffffa80`0771bc58 00000000`00000002 fffffa80`0771bb58 : usbhub!UsbhGenDispatch+0x57
fffff880`02ffd770 fffff880`07538812 : fffffa80`075a1b58 fffffa80`074e9560 fffffa80`00000324 fffffa80`074e9560 : usbccgp!UsbcForwardIrp+0x30
fffff880`02ffd7a0 fffff880`07538aba : fffffa80`0771bb58 00000000`00220003 fffffa80`074e9560 fffffa80`075a1b58 : usbccgp!DispatchPdoUrb+0xfa
fffff880`02ffd7e0 fffff880`0753672e : 00000000`0000000f fffffa80`075a1b50 fffffa80`075a1b58 fffffa80`074e9560 : usbccgp!DispatchPdoInternalDeviceControl+0x17a
fffff880`02ffd810 fffff880`0757c48f : fffffa80`075a1a00 fffffa80`074e9501 00000000`00000000 00000000`000007ff : usbccgp!USBC_Dispatch+0x2de
fffff880`02ffd890 fffff880`0757bf5b : fffffa80`074e97e0 fffffa80`0774d101 fffff880`02ffd950 fffffa80`0774d060 : hidusb!HumReadReport+0x13f
fffff880`02ffd8e0 fffff880`0758c555 : fffffa80`075a4f01 fffffa80`075a4f20 fffffa80`074e9560 00000000`00000007 : hidusb!HumInternalIoctl+0x137
fffff880`02ffd950 fffff880`0758cd75 : fffffa80`075a4f20 fffffa80`0774d1d0 00000000`00000000 00000000`00000007 : HIDCLASS!HidpSubmitInterruptRead+0xdd
fffff880`02ffd9b0 fffff800`02a99a91 : fffffa80`074e97e3 00000000`00000000 fffffa80`0774d001 fffffa80`074e9500 : HIDCLASS!HidpInterruptReadComplete+0x37d
fffff880`02ffda40 fffff880`053b0631 : fffffa80`0634e050 fffffa80`080d7100 00000000`00000000 00000000`00000000 : nt!IopfCompleteRequest+0x3b1
fffff880`02ffdb20 fffff880`053b0b0f : fffffa80`07c11802 fffffa80`074e9560 00000000`ffffffff fffffa80`0634eeb0 : USBPORT!USBPORT_Core_iCompleteDoneTransfer+0xa15
fffff880`02ffdc00 fffff880`053ae66f : fffffa80`0634eeb0 fffffa80`0634e1a0 fffffa80`0634f050 00000000`00000000 : USBPORT!USBPORT_Core_iIrpCsqCompleteDoneTransfer+0x3a7
fffff880`02ffdc60 fffff880`0539ff89 : fffffa80`0634e050 00000000`00000000 fffffa80`0634ee02 fffffa80`0634eeb0 : USBPORT!USBPORT_Core_UsbIocDpc_Worker+0xf3
fffff880`02ffdca0 fffff800`02aa1b1c : fffff880`02fd5180 fffffa80`0634eeb0 fffffa80`0634eec8 00000000`00000000 : USBPORT!USBPORT_Xdpc_Worker+0x1d9
fffff880`02ffdcd0 fffff800`02a8e36a : fffff880`02fd5180 fffff880`02fdffc0 00000000`00000000 fffff880`0539fdb0 : nt!KiRetireDpcList+0x1bc
fffff880`02ffdd80 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiIdleLoop+0x5a


fffff800`02bc04b3 cc              int     3


SYMBOL_NAME:  nt!ExDeferredFreePool+a53

FOLLOWUP_NAME:  Pool_corruption

IMAGE_NAME:  Pool_Corruption


MODULE_NAME: Pool_Corruption

FAILURE_BUCKET_ID:  X64_0x19_3_nt!ExDeferredFreePool+a53

BUCKET_ID:  X64_0x19_3_nt!ExDeferredFreePool+a53

Followup: Pool_corruption
The crash was from eight days ago. It points to a USB device or port problem.

I also see
AODDriver2	fffff880`03824000	fffff880`03855000	Mon Dec 19 00:30:03 2011 (4eeee7fb)	00018588		AODDriver2.sys
on your system, which is known to cause conflicts. Remove AMD Overdrive, EasyTune6, or Vision Engine Control Center, whichever applies.

For the USB issues:
My System SpecsSystem Spec
19 Mar 2012   #23

Windows Seven Ultimate x64

yeah, the usb thing wont work, because i cannot open device manager and that might have been an isolated event due to not having the usb3 drivers installed.

and netr28x.sys is the ralink wireless card, that i forgot to unplug when i reformatted (it never worked right)
My System SpecsSystem Spec

19 Mar 2012   #24

Windows 7 Home Premium 64 Bit

A few things that might cause device manager to fail:
  • Registry corruption (usually due to running a registry cleaner)
  • A bad install or corrupted Windows files
  • Application or service conflicting with the system

Have you run any registry cleaners that might have caused Windows to stop working properly?

Check for corrupted Windows files:
  • Run SFC /SCANNOW Command - System File Checker up to three times to fix all errors with a restart in between each. Post back if it continues to show errors after a fourth run or if the first run comes back with no integrity violations.

Troubleshoot Application Conflicts by Performing a Clean Startup to see if there is an application or service preventing device manager from running.
My System SpecsSystem Spec
19 Mar 2012   #25

Windows Seven Ultimate x64

no registry cleaners, would have not been necessary i got that bsod the day i reformatted running the scan.
My System SpecsSystem Spec
19 Mar 2012   #26

Windows 7 Home Premium 64 Bit

I thought as much, but I wanted to make sure anyway. Thanks. Let us know how the other steps go.
My System SpecsSystem Spec
19 Mar 2012   #27

Windows Seven Ultimate x64

scan found corrupt files and on restart i was able to open device manager
My System SpecsSystem Spec
19 Mar 2012   #28

Windows 7 Home Premium 64 Bit

Excellent news! See how the system responds during your typical use for a while and post back whether the problems are solved. Let us know if you need anything further. :)
My System SpecsSystem Spec
19 Mar 2012   #29

Windows Seven Ultimate x64

will do, and thanks for all the help! you have been most patient.
My System SpecsSystem Spec
19 Mar 2012   #30

Windows 7 Home Premium 64 Bit

You're welcome. :) Glad I could help.
My System SpecsSystem Spec

 random bluescreens ntoskrnl.exe

Thread Tools

Similar help and support threads
Thread Forum
Random Bluescreens, ntoskrnl.exe (0x1000007e,0x1000003b)
Hey there, I appear to randomly get some Bluescreens lately, I really dont know why this is happening. My System: AMD Fx 8350 8x 4.0GHz GTX 660 Ti OC Samsung 830er Series 250gb a Seagate Hard Drive with 500gb External 3 TB Western Digital Essentials
BSOD Help and Support
Random Bluescreens - ntoskrnl.exe (Computer is really loud while BSOD)
Hey guys, I randomly get BSOD while playing a game or just doing nothing but listening to music and watching youtube videos. My drivers are all up to date. I uploaded a file which i made with SF Diagnostic Tool. My computer specs are written on my profile too. It's getting annoying and I don't...
BSOD Help and Support
random freezing and random bluescreens with various error codes
I've contacted tech support at cyberpowerpc where I bought my computer, but after reading their tech support forums my faith in getting a quick response is kind of low, so I came here as many bluescreen search results lead here and I figure it's probably a good place to get more help. I've been...
BSOD Help and Support
ntoskrnl bluescreens
Windows 7 . . . - x86 x64 patched to date - the original installed OS on the system? - an OEM or full retail version? - OEM = came pre-installed on system as Vista upgrade - What is the age of system (hardware)? : 2 years - What is the age of OS installation ~ 1 year
BSOD Help and Support
BlueScreens caused by ntoskrnl.exe driver on Windows 7 Ultimate 64-bit
Hi, just registered on this site which seems awesome! I'm having difficulties with a couple of bluescreens lately, and 3 of them (got 4 total) have been said to be caused by the ntoskrnl.exe driver. And I just recently reinstalled my whole computer. Had Vista before. Motherboard: ASUS P5N-E...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:47.
Twitter Facebook Google+