Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD, crashing when plugging in a USB device

24 Feb 2012   #1

Windows 7 Professional 64 bit
BSOD, crashing when plugging in a USB device

Hi all!

My computer crashes whenever I plug a USB device in it. I first noticed it when I plugged in a camera, thinking it was the camera, I then tried my own flash drive which worked fine (Possibly using fat32 format); but yesterday I tried my mates flash drive (NTFS) and that crashed it, I've also tried a bunch of other flash drives around the house and they also crash my computer.

I'm running windows 7 64 bit, ASUS p8z68-v pro mobo, i5 2500k, 4GB DDR3 1600MHz ripjaw, Sapphire HD6950.

I have tried running memtest which passed 13 times flawlessly. I also tried running driver verifier, which seemed to really screw me over. At the start, when the windows logo first appears, it hangs a little bit and then blue screens. Luckily I had made a system repair disk the night before. I also don't know why but when I tried to start in safe mode (pressing f8 while booting) all it gave me was the option to choose which device to boot from, which I'm guessing is some sort of feature on my mobo, but I digress. So I'm guessing it's something to do with USB drivers?

I have attached all the needed information, perfmon and minidumps etc.
Any information and/or help would be greatly appreciated.

Thanks in advance!

My System SpecsSystem Spec
24 Feb 2012   #2

Windows 7 Ultimate x64

Ah.. my friend, Driver Verifier did not screw you over, it's what is about to give you the answer!

All three non-verifier enabled dump files were ntkrnlmp.exe, it says that because it does not know what is causing it, so it shoots a false positive process fault. The driver verifier enabled dump file however showed exactly what is causing it!

dtsoftbus01.sys, which is a driver for Daemon Tools. Daemon Tools is legendary for causing BSODs, so please uninstall that. Once you've uninstalled that, please report back and let us know how things are running :)

*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

The IO manager has caught a misbehaving driver.
Arg1: 000000000000023e, A driver has marked an IRP pending but didn't return STATUS_PENDING.
Arg2: fffff88001001308, The address in the driver's code where the error was detected.
Arg3: fffff98004b5aee0, IRP address.
Arg4: 0000000000000000, Status code.

Debugging Details:

BUGCHECK_STR:  0xc9_23e


fffff880`01001308 4053            push    rbx

fffff880`01001308 4053            push    rbx

IRP_ADDRESS:  fffff98004b5aee0

DEVICE_OBJECT: fffffa8006f045a0





LAST_CONTROL_TRANSFER:  from fffff800035533dc to fffff800030c9c40

fffff880`031a05f8 fffff800`035533dc : 00000000`000000c9 00000000`0000023e fffff880`01001308 fffff980`04b5aee0 : nt!KeBugCheckEx
fffff880`031a0600 fffff800`0355d47a : fffff800`035519f0 fffff880`01001308 fffff980`04b5aee0 00000000`00000000 : nt!VerifierBugCheckIfAppropriate+0x3c
fffff880`031a0640 fffff800`0355e34e : 00000000`0000023e 00000000`00000000 fffff980`04b5aee0 00000000`ffffffff : nt!ViErrorFinishReport+0xda
fffff880`031a0690 fffff800`0356971f : fffffa80`06bfdc50 fffffa80`05d0a840 fffffa80`05d0a8f8 fffff880`01004fd0 : nt!VfErrorReport6+0x6e
fffff880`031a0760 fffff800`03569b63 : fffffa80`05d0a840 00000000`00000002 fffffa80`06f045a0 fffff880`010013d8 : nt!IovpCallDriver2+0x13f
fffff880`031a07c0 fffff800`0356fc2e : fffff980`04b5aee0 fffff980`04b5aee0 00000000`00000002 fffffa80`06f045a0 : nt!VfAfterCallDriver+0x353
fffff880`031a0810 fffff880`00e0e0c2 : fffff880`00e877c0 fffffa80`072cb5d0 00000000`00000025 fffffa80`05d0a840 : nt!IovCallDriver+0x57e
fffff880`031a0870 fffff880`00e2359f : fffffa80`073ebb20 00000000`00000000 fffff880`00000000 fffff880`076925d5 : Wdf01000!FxIoTarget::SubmitSync+0x24a
fffff880`031a0920 fffff880`076a6e95 : fffffa80`00000020 fffffa80`073ebb20 fffffa80`072cb5d0 00000000`00000001 : Wdf01000!imp_WdfRequestSend+0x24b
fffff880`031a0970 fffff880`076a72f4 : 00000000`00000000 00000000`00000024 00000000`00000001 fffff880`031a0b30 : cdrom!DeviceSendRequestSynchronously+0xc9
fffff880`031a09d0 fffff880`076a5f04 : 0000057f`f8d35fd8 fffff880`031a0b30 fffffa80`073a5680 00000000`00000024 : cdrom!DeviceSendSrbSynchronously+0x3ec
fffff880`031a0b00 fffff880`076a4825 : fffffa80`00000002 fffffa80`072ca390 fffff880`0769c3b8 0000057f`f8d35fd8 : cdrom!DeviceCacheDeviceInquiryData+0xbc
fffff880`031a0bd0 fffff880`00e789d4 : 00000000`00000000 fffff880`00000010 00000000`0000000c fffff880`00e81620 : cdrom!DeviceEvtSelfManagedIoInit+0x105
fffff880`031a0c10 fffff880`00e7894e : fffffa80`072cb020 00000000`0000000c fffff880`00e81620 fffff880`00e81600 : Wdf01000!FxSelfManagedIoMachine::Init+0x34
fffff880`031a0c40 fffff880`00e6cb9b : 00000000`00000000 00000000`00000000 00000000`00000000 fffff880`00e81620 : Wdf01000!FxSelfManagedIoMachine::ProcessEvent+0x14a
fffff880`031a0cb0 fffff880`00e6c6eb : 00000000`00000312 00000000`00000000 fffff880`00e81600 fffff6fc`c0025a10 : Wdf01000!FxPkgPnp::PowerD0StartingStartSelfManagedIo+0x2f
fffff880`031a0ce0 fffff880`00e6c38e : fffffa80`072ca8a0 00000000`00000040 fffff880`00e813e0 00000000`00000040 : Wdf01000!FxPkgPnp::PowerEnterNewState+0x1db
fffff880`031a0e10 fffff880`00e6c06c : 00000000`00000000 00000000`00000040 00000000`00000501 fffffa80`072ca8a0 : Wdf01000!FxPkgPnp::PowerProcessEventInner+0x13e
fffff880`031a0e80 fffff880`00e79b5e : 00000000`00000000 00000000`00000501 00000000`00000000 00000000`00000501 : Wdf01000!FxPkgPnp::PowerProcessEvent+0x1d4
fffff880`031a0f10 fffff880`00e79abb : 00000000`00000501 00000000`00000000 00000000`00000500 fffff800`0356e5ec : Wdf01000!FxPkgPnp::NotPowerPolOwnerStarting+0xe
fffff880`031a0f40 fffff880`00e75950 : fffffa80`072ca8a0 00000000`00000001 00000000`00000000 fffff880`00e7dff0 : Wdf01000!FxPkgPnp::NotPowerPolicyOwnerEnterNewState+0x1c7
fffff880`031a0fc0 fffff880`00e75372 : 00000000`00000000 00000000`00000001 00000000`00000000 fffffa80`072c7040 : Wdf01000!FxPkgPnp::PowerPolicyProcessEventInner+0x3f8
fffff880`031a1030 fffff880`00e71a45 : 00000000`00000000 fffffa80`072c7040 00000000`00000108 00000000`00000000 : Wdf01000!FxPkgPnp::PowerPolicyProcessEvent+0x1e2
fffff880`031a10c0 fffff880`00e71841 : 00000000`00000101 00000000`00000108 00000000`00000108 07800000`77f00860 : Wdf01000!FxPkgPnp::PnpEventHardwareAvailable+0x111
fffff880`031a1100 fffff880`00e714fe : fffffa80`072ca8a0 fffff880`031a1230 00000000`00000004 fffff880`00e80390 : Wdf01000!FxPkgPnp::PnpEnterNewState+0x1a5
fffff880`031a1170 fffff880`00e71201 : 00000000`00000000 00000000`00000002 00000000`00000000 fffffa80`072ca8a0 : Wdf01000!FxPkgPnp::PnpProcessEventInner+0x122
fffff880`031a11e0 fffff880`00e68d9c : 00000000`00000000 fffffa80`072ca8a0 00000000`00000002 00000000`00000000 : Wdf01000!FxPkgPnp::PnpProcessEvent+0x1b1
fffff880`031a1270 fffff880`00e67dd6 : fffffa80`05d3dc60 00000000`00000002 00000000`00000000 fffffa80`072ca8a0 : Wdf01000!FxPkgPnp::_PnpStartDevice+0x20
fffff880`031a12a0 fffff880`00e37245 : fffff980`04b44d80 fffff980`04b44d80 fffffa80`072cbbd0 00000000`00000000 : Wdf01000!FxPkgPnp::Dispatch+0x1b2
fffff880`031a1310 fffff880`00e3714b : fffff880`031a13f8 fffff980`04b44d80 00000000`00000002 fffffa80`072cbbd0 : Wdf01000!FxDevice::Dispatch+0xa9
fffff880`031a1340 fffff800`0356fc16 : fffff980`04b44d80 00000000`00000002 fffffa80`072cbbd0 fffff800`0356b37e : Wdf01000!FxDevice::DispatchWithLock+0x93
fffff880`031a1380 fffff800`0357252a : fffff980`04b44ee0 fffffa80`072cbbd0 fffffa80`072c6cf0 fffffa80`05cf2840 : nt!IovCallDriver+0x566
fffff880`031a13e0 fffff800`0356fc16 : fffff980`04b44d80 00000000`00000002 fffffa80`072c6cf0 fffffa80`057f3d70 : nt!ViFilterDispatchPnp+0x13a
fffff880`031a1410 fffff880`07ddd202 : fffffa80`072c6cf0 00000000`00000000 fffffa80`072c62e0 fffffa80`057f3d70 : nt!IovCallDriver+0x566
fffff880`031a1470 fffffa80`072c6cf0 : 00000000`00000000 fffffa80`072c62e0 fffffa80`057f3d70 fffff980`04b44fb8 : GEARAspiWDM+0x7202
fffff880`031a1478 00000000`00000000 : fffffa80`072c62e0 fffffa80`057f3d70 fffff980`04b44fb8 fffffa80`071702b8 : 0xfffffa80`072c6cf0

STACK_COMMAND:  .bugcheck ; kb

SYMBOL_NAME:  dtsoftbus01+1308

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: dtsoftbus01

IMAGE_NAME:  dtsoftbus01.sys


FAILURE_BUCKET_ID:  X64_0xc9_23e_VRF_dtsoftbus01+1308

BUCKET_ID:  X64_0xc9_23e_VRF_dtsoftbus01+1308

Followup: MachineOwner
My System SpecsSystem Spec
24 Feb 2012   #3

Windows 7 Professional 64 bit

Quote   Quote: Originally Posted by ePeen View Post
The driver verifier enabled dump file however showed exactly what is causing it!

dtsoftbus01.sys, which is a driver for Daemon Tools. Daemon Tools is legendary for causing BSODs, so please uninstall that. Once you've uninstalled that, please report back and let us know how things are running :)
Mate, you are an absolute legend! I tried the flash drive that caused a BSOD yesterday I've tried every other USB device in my house and so far no BSOD's.

Thanks heaps mate!!
My System SpecsSystem Spec

24 Feb 2012   #4

Windows 7 Ultimate x64

Glad to hear you're up & running again, it was my pleasure :)
My System SpecsSystem Spec
27 Feb 2012   #5

Windows 7 Professional 64 bit

Hi again

Unfortunately while this fix did indeed help for other flash drives and USB devices, it didn't help when I plugged my mates flash drive into it.
Again I have attached the new mini dump file and any other needed info.

Thanks in advance for any help.
My System SpecsSystem Spec
27 Feb 2012   #6

Windows 7 Home Premium 64 Bit

Remove PerfectDisk. Third part degragmenting tools often cause crashes, and since you are plugging in a storage device, this may very well be the cause. It is the process running during the crash report.

My System SpecsSystem Spec

 BSOD, crashing when plugging in a USB device

Thread Tools

Similar help and support threads
Thread Forum
Computer Freezes after Plugging In USB Device
Hello, everyone! I would like to request for assistance regarding the stated problem above. Whenever I plug-in my flash drive into the front USB port of my CPU casing, my computer suddenly stops responding to the point that you cannot do anything without pressing the RESTART button. Then, after...
Hardware & Devices
BSOD When Plugging in USB Device
Hello Windows 7 Community, I am having a problem with a novatel usb760 aircard modem. I installed this device properly. The drivers, and firmware updates all installed successfully. I was able to use it fine right after installation. The next day when I plugged it into my usb port, I got a...
BSOD Help and Support
BSOD when plugging in usb device
When ever i plug my xbox 360 wireless receiver device, my pc gets the blue screen and restarts itself, when its unplugged, everything is fine and no crashes ive attached the DMP file My PC spec is Windows 7 pro 32 bit, e8500 3.5ghz, ATI 6850, 4gb RAM
BSOD Help and Support
Plugging in USB device causes display to go blank
Whenever I plug in any USB device, the monitor will go blank, but the case fans and lights will continue operating. The computer remains like this until I hold down the power button to turn it off and then restart it. It will restart fine. In addition to the monitor going blank, all power is turned...
BSOD Help and Support
BSOD Plugging in USB device, error 0x3b
Hi all! So I built my own PC late last year and have had absolutely no problems with it whatsoever, until my brother plugged in his JVC HD GC-FM2 camera. This camera is supposed to be able to be plugged into any PC without issue and without the need to install software/drivers, but for me it...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:54.
Twitter Facebook Google+