Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: SYSTEM_SERVICE_EXCEPTION afd.sys and other BSOD issues

26 Feb 2012   #1

Windows 7 Home Prenium 64bit
SYSTEM_SERVICE_EXCEPTION afd.sys and other BSOD issues

Been having a bunch of strange BSODs lately, I think it has something to do with my wireless drivers, but I really don't know

All of them seem to be related to ntoskrnl.exe, each BSOD either has something along the lines of "ntoskrnl.exe+7c1e9, ntoskrnl.exe+7cc10" and other ntoskrnl.exe comands

The most recent one has been "SYSTEM_SERVICE_EXCEPTION afd.sys"

I've updated one driver for my Intel Centrino Advanced-N 6250 agn + WiMax, which has been giving me tons of wireless problems recently.

Does anyone know what the exact problem is? I've read that it could also be due to physical damage to my RAM, but I have no clue.

Windows Home Prem. x64
Original OS

Laptop is about a year old
I just reformatted for the fourth or fifth time in a week yesterday. So this installation is less than a day old.

Thanks a lot guys, sorry if this isn't descriptive enough

My System SpecsSystem Spec
26 Feb 2012   #2

Win 8 Release candidate 8400

My System SpecsSystem Spec
26 Feb 2012   #3

Windows 7 Ultimate x64

Hello, welcome to SevenForums!

Both of the attached dumps point to and blame afd.sys which is the Ancillary Function Driver for WinSock. Most likely network related, so I commend updating your NIC drivers to its latest version.

*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 3B, {c0000005, fffff8800151443a, fffff8800a1a3a50, 0}

Probably caused by : afd.sys ( afd!AfdTLReleaseIndications+1a )

Followup: MachineOwner

0: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An exception happened while executing a system service routine.
Arg1: 00000000c0000005, Exception code that caused the bugcheck
Arg2: fffff8800151443a, Address of the instruction which caused the bugcheck
Arg3: fffff8800a1a3a50, Address of the context record for the exception that caused the bugcheck
Arg4: 0000000000000000, zero.

Debugging Details:

EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

fffff880`0151443a 488b4108        mov     rax,qword ptr [rcx+8]

CONTEXT:  fffff8800a1a3a50 -- (.cxr 0xfffff8800a1a3a50)
rax=fffff88001516ba0 rbx=fffff8800a1a4790 rcx=0000000000000000
rdx=fffff8800a1a4450 rsi=fffffa800496e2f0 rdi=fffffa800aa7c200
rip=fffff8800151443a rsp=fffff8800a1a4430 rbp=fffff8800a1a4ca0
 r8=0000000000000000  r9=0000000000000000 r10=0000000000000000
r11=0000000009a4cf3c r12=0000000000000000 r13=0000000000000000
r14=00000000ffffffff r15=fffff8800a1a4a88
iopl=0         nv up ei ng nz na po nc
cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00010286
fffff880`0151443a 488b4108        mov     rax,qword ptr [rcx+8] ds:002b:00000000`00000008=????????????????
Resetting default scope




PROCESS_NAME:  firefox.exe


LAST_CONTROL_TRANSFER:  from 0000000000000000 to fffff8800151443a

fffff880`0a1a4430 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : afd!AfdTLReleaseIndications+0x1a

fffff880`0151443a 488b4108        mov     rax,qword ptr [rcx+8]


SYMBOL_NAME:  afd!AfdTLReleaseIndications+1a

FOLLOWUP_NAME:  MachineOwner


IMAGE_NAME:  afd.sys


STACK_COMMAND:  .cxr 0xfffff8800a1a3a50 ; kb

FAILURE_BUCKET_ID:  X64_0x3B_afd!AfdTLReleaseIndications+1a

BUCKET_ID:  X64_0x3B_afd!AfdTLReleaseIndications+1a

Followup: MachineOwner
My System SpecsSystem Spec

26 Feb 2012   #4

Windows 7 Home Prenium 64bit

Thank you two so much! Doing as instructed right now
My System SpecsSystem Spec

 SYSTEM_SERVICE_EXCEPTION afd.sys and other BSOD issues

Thread Tools

Similar help and support threads
Thread Forum
Bsod system_service_exception
This happens at random times. I can be playing games or just browsing the web. Unsure of what to do. If you need anymore info let me know. It is more frequent when playing games, can happen every few hours. When playing games like COD:AW or other games that i guess require a lot of memory and power...
BSOD Help and Support
Bsod - system_service_exception
I got a BSOD at windows 7 x64. 011112-16364-01.dmp 2012-01-11 PM 8:41:16 SYSTEM_SERVICE_EXCEPTION 0x0000003b 00000000`c0000005 fffff960`001241be fffff880`03d5d0c0 00000000`00000000 win32k.sys win32k.sys+c41be x64 ...
BSOD Help and Support
Hi there guys,i've been using this new pc for a couple of weeks,not longer than a month.Till when i started gaming on it,it has been crashing on me in more recent games like Crysis 2. Please tell me what's wrong with the pc :cry: Attached is the dump file...
BSOD Help and Support
System_service_Exception BSoD. Please help.
Hello there fellow and friendly bug-hunters. A few minutes ago I got a BSoD I've never seen before. System_Service_Exception it said. I got it when I opened a new tab in the webbrowser Firefox. I've uploaded the dumps but only read the last one please. I know the previous ones are caused by...
BSOD Help and Support
BSOD System_Service_Exception
Hi! I have had MANY BSOD issues since installing Win7 and have slowly worked through most of the issues. This last one has me stumped. My system specs: Win7 x64 - clean install new HD Intel Core 2 Duo E6600 Asus Striker Extreme MB lates bios (1505) 4 GB Crucial DDR2 PC2-6400 NVIDIA...
BSOD Help and Support
BSOD System_Service_Exception help!
Windows 7 x64 - clean install Raid 0 Intel i7 920 Intel Mobo BOXDX58S0 4 GB OCZ DDR3 1600 EVGA 9800GT i keep getting the same error. I'm not sure what i'm doing wrong and it happens mostly when i'm browsing the web. Here is the dump file if anybody can help me please, I would appreciate...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:01.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App