Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD Hosting WC3 + A game emulator

03 Mar 2012   #1

Windows 7 32
BSOD Hosting WC3 + A game emulator

Windows 7 Ultimate x86 Full Retail Hardware 1-2 years Installation around 7month old

Attatched info

My System SpecsSystem Spec
03 Mar 2012   #2

Windows 7 Home Premium 64 Bit

Problem Devices:
Hamachi Network Interface	ROOT\NET\0001	This device is disabled.

Antivirus Software:
avp.exe	c:\program files\kaspersky lab\kaspersky internet security 2012\avp.exe	476	8	200	1380	03/03/2012 00:34	197.55 KB (202,296 bytes)	24/04/2011 23:15
avp.exe	c:\program files\kaspersky lab\kaspersky internet security 2012\avp.exe	3404	8	200	1380	03/03/2012 00:35	197.55 KB (202,296 bytes)	24/04/2011 23:15

Possible out of date drivers:
nvstor32	8b6cb000	8b702000	Tue Jun 30 18:17:14 2009 (4a4aab0a)	00041012		nvstor32.sys

Microsoft (R) Windows Debugger Version 6.12.0002.633 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [D:\Kingston\BSODDmpFiles\lxlramlxl\Windows_NT6_BSOD_jcgriff2\030312-27830-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Mini Kernel Dump does not have process information
Symbol search path is: SRV*C:\SymCache*
Executable search path is: 
Windows 7 Kernel Version 7601 (Service Pack 1) MP (4 procs) Free x86 compatible
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7601.17713.x86fre.win7sp1_gdr.111025-1505
Machine Name:
Kernel base = 0x82c53000 PsLoadedModuleList = 0x82d9c4d0
Debug session time: Fri Mar  2 17:33:12.431 2012 (UTC - 7:00)
System Uptime: 0 days 0:04:42.350
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck D1, {2000025, 2, 0, 8b78c19d}

Probably caused by : tdx.sys ( tdx!TdxCallConnectionHandler+131 )

Followup: MachineOwner

3: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arg1: 02000025, memory referenced
Arg2: 00000002, IRQL
Arg3: 00000000, value 0 = read operation, 1 = write operation
Arg4: 8b78c19d, address which referenced memory

Debugging Details:

READ_ADDRESS: GetPointerFromAddress: unable to read from 82dbc848
Unable to read MiSystemVaType memory at 82d9be20


8b78c19d 8b700c          mov     esi,dword ptr [eax+0Ch]




TRAP_FRAME:  a3b3f5d0 -- (.trap 0xffffffffa3b3f5d0)
ErrCode = 00000000
eax=02000019 ebx=a3b3f6ec ecx=86d4d960 edx=00000002 esi=8602cde0 edi=82c1f7a0
eip=8b78c19d esp=a3b3f644 ebp=a3b3f698 iopl=0         nv up ei pl zr na pe nc
cs=0008  ss=0010  ds=0023  es=0023  fs=0030  gs=0000             efl=00010246
8b78c19d 8b700c          mov     esi,dword ptr [eax+0Ch] ds:0023:02000025=????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from 8b78c19d to 82c945fb

a3b3f5d0 8b78c19d badb0d00 00000002 861cb410 nt!KiTrap0E+0x2cf
a3b3f698 8b78d7a5 8602cde0 a3b3f6ec 00000000 tdx!TdxCallConnectionHandler+0x131
a3b3f6d0 8bcddc74 8602cde0 a3b3f602 a3b3f7d8 tdx!TdxEventInspectTransportAddress+0xff
a3b3f740 8bc77cbf 860d3f60 88c627c0 8697e448 tcpip!TcpInspectConnectionOnListener+0xe7
a3b3f760 8bcad810 8697e448 860b5008 00b3f7d8 tcpip!TcpListenerReceive+0x249
a3b3f7cc 8bcadc6a 862aa8b0 869bf000 00000000 tcpip!TcpMatchReceive+0x60f
a3b3f81c 8bcadcab 8697e448 869bf000 000013d1 tcpip!TcpPreValidatedReceive+0x293
a3b3f838 8bca7fd5 8697e448 869bf000 a3b3f874 tcpip!TcpReceive+0x2d
a3b3f848 8bcb020b a3b3f85c c000023e 00000000 tcpip!TcpNlClientReceiveDatagrams+0x12
a3b3f874 8bcafb56 8bd27f90 a3b3f8c8 c000023e tcpip!IppDeliverListToProtocol+0x49
a3b3f894 8bcadf18 8bd27da0 00000006 a3b3f8c8 tcpip!IppProcessDeliverList+0x2a
a3b3f8ec 8bcaf9ff 8bd27da0 00000006 00000000 tcpip!IppReceiveHeaderBatch+0x1fb
a3b3f980 8bcbde2c 87a027f0 00000000 88e8ea01 tcpip!IpFlcReceivePackets+0xbe5
a3b3f9fc 8bcb845e 87b1b688 85cb5248 00000000 tcpip!FlpReceiveNonPreValidatedNetBufferListChain+0x746
a3b3fa30 82cdc654 85cb5248 84bbbe9e 86976720 tcpip!FlReceiveNetBufferListChainCalloutRoutine+0x11e
a3b3fa98 8bcb85cc 8bcb8340 a3b3fac0 00000000 nt!KeExpandKernelStackAndCalloutEx+0x132
a3b3fad4 8ba6818d 87b1b602 85cb5200 00000000 tcpip!FlReceiveNetBufferListChain+0x7c
a3b3fb0c 8ba565be 87be1008 85cb5248 00000000 ndis!ndisMIndicateNetBufferListsToOpen+0x188
a3b3fb34 8ba564b2 00000000 871ac0e0 871ac0e0 ndis!ndisIndicateSortedNetBufferLists+0x4a
a3b3fcb0 8ba07cf0 871ac0e0 00000000 00000000 ndis!ndisMDispatchReceiveNetBufferLists+0x129
a3b3fce4 8ba07dc2 00000001 85cb5248 871acd8c ndis!ndisDoPeriodicReceivesIndication+0x125
a3b3fd0c 8ba078c9 870103e0 00000000 85db2030 ndis!ndisPeriodicReceivesWorker+0x5b
a3b3fd50 82e5bfda 00000003 84bbb996 00000000 ndis!ndisReceiveWorkerThread+0x161
a3b3fd90 82d041f9 8ba07768 00000003 00000000 nt!PspSystemThreadStartup+0x9e
00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x19


8b78c19d 8b700c          mov     esi,dword ptr [eax+0Ch]


SYMBOL_NAME:  tdx!TdxCallConnectionHandler+131

FOLLOWUP_NAME:  MachineOwner


IMAGE_NAME:  tdx.sys


FAILURE_BUCKET_ID:  0xD1_tdx!TdxCallConnectionHandler+131

BUCKET_ID:  0xD1_tdx!TdxCallConnectionHandler+131

Followup: MachineOwner
The crashes are all network related, so I suspect Kaspersky.

Begin with the following steps to resolve the crashes.
My System SpecsSystem Spec

 BSOD Hosting WC3 + A game emulator

Thread Tools

Similar help and support threads
Thread Forum
Connection disconnecting when hosting any personal game/server.
Ive recently begun having this issue where my friend and I will host a personal server/game and we cannot connect to each other regardless of who hosts. Other people can connect to our personal game/servers just fine. But I cant join his or he cant join mine. I have tried port forwarding, Hamachi,...
Network & Sharing
BSOD while starting a game in an emulator
Just new minutes ago , i download an emulator "Project 64" and start a game "Mario Kart 64". after i click the start, my screen goes black then BSOD screen appears. Can you help me whats wrong with my system?
BSOD Help and Support
recomendations for game pad emulator for battlefield 3
Hi all when it comes to pc gaming I'm a total noob,and still like the feel ov a gamepad,over keyboard and mouse for mw3 i'm using joystix pro,and it works like a dream,but I can't seem to find a decent one for bf3,iv'e tried pinacle and it sucks can any body help me out,I better add a free one...
Hosting / Joining lan game
Hi There, With Windows 7 (rc1) & Windows 7 (build 7600) I have a real hard time of playing lan games, I cant join games hosted on Vista + Win 7. No I have disabled the UPnP device host, that made my friends pop-up in Worms Mayhem, Joining the game then failed (concetion lost) After...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:57.
Twitter Facebook