Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD after recent Logitech/Sidewinder X4 installs

13 Mar 2012   #1

Windows 7 Ultimate x64
BSOD after recent Logitech/Sidewinder X4 installs

Hello everyone,

I have recently started having an issue with the infamous BSOD after installing the progs mentioned in the title. There were a few random BSOD prior to that, but only 1 or 2 since the past 2 months I've used my new computer (fyi, one of them was "BAD_POOL_HEADER" or the like).

Anyways, to my most recent troubles:

Basic Specs:
OS - Windows 7 Ultimate x64
Motherboard - ASRock P67 Extreme4 LGA 1155
CPU - Intel Core i7 2600K @ 3.4 GHz
Memory - 16 GB G.Skill Ripjaws 1600 DDR3
Graphics Card - ATI Radeon 6870 HD 1 GB DDR
Sound Card - (OEM/default)
Monitor - Acer 23" LCD
Screen Resolution - 1920x1080
Hard Drives - (boot: Intel X25-M 160GB SSD /// secondary: WD Caviar Black 2 TB)
PSU - Corsair 650 TX
Case - Cooler Master HAF 932
Cooling - Thermaltake Bigwater 760 Plus
Keyboard - Microsoft Sidewinder X4
Mouse - Logitech G400
Internet Speed - FiOS

Any and all help will be appreciated!

Thank you,

My System SpecsSystem Spec
13 Mar 2012   #2

Windows 7 Ultimate x64

Hello, welcome to SevenForums!

There's no dump file located in the zip you've attached. Please reattach the zip accordingly once you've added the dump file(s).
My System SpecsSystem Spec
13 Mar 2012   #3

Windows 7 Ultimate x64

Ah, thanks. The edit has been made and the crashdump file is also attached.

Also, update on the current status: during the most recent reboot, the computer automatically brought up the "startup repair" screen. I tried that, and the comp finally restarted successfully without any hiccups (though it was a bit slow at first, everything took a minute or so to finally go at full speed).

I still believe the pc has some driver issues, especially since when I check device manager, I see a couple different listings under keyboard and mouse (like, one is "HID compliant mouse" and the other is "Logitech G400" - one is OEM driver-installed and the other manufacturer-driver? Not sure why there would be two records of that..).

I really would like to understand the crashdump file and the other info. Thanks!
My System SpecsSystem Spec

13 Mar 2012   #4

Windows 7 Ultimate x64

The dump provided points to the avast! Virtualization Driver (aswSnx.SYS). Please remove / uninstall Avast and install Microsoft Security Essentials for testing purposes.

Microsoft (R) Windows Debugger Version 6.12.0002.633 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Users\Icarus\Downloads\Dumps\031312-9328-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is:
Executable search path is: 
Windows 7 Kernel Version 7601 (Service Pack 1) MP (8 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7601.17640.amd64fre.win7sp1_gdr.110622-1506
Machine Name:
Kernel base = 0xfffff800`02e1d000 PsLoadedModuleList = 0xfffff800`03062670
Debug session time: Tue Mar 13 07:22:31.079 2012 (UTC - 4:00)
System Uptime: 0 days 0:00:58.891
Loading Kernel Symbols
Loading User Symbols
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 3B, {c0000005, fffff800031b39bf, fffff880021e6230, 0}

Unable to load image \SystemRoot\System32\Drivers\aswSnx.SYS, Win32 error 0n2
*** WARNING: Unable to verify timestamp for aswSnx.SYS
*** ERROR: Module load completed but symbols could not be loaded for aswSnx.SYS
Probably caused by : aswSnx.SYS ( aswSnx+1d6d2 )

Followup: MachineOwner

6: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An exception happened while executing a system service routine.
Arg1: 00000000c0000005, Exception code that caused the bugcheck
Arg2: fffff800031b39bf, Address of the instruction which caused the bugcheck
Arg3: fffff880021e6230, Address of the context record for the exception that caused the bugcheck
Arg4: 0000000000000000, zero.

Debugging Details:

EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at 0x%08lx referenced memory at 0x%08lx. The memory could not be %s.

fffff800`031b39bf 0fba66380a      bt      dword ptr [rsi+38h],0Ah

CONTEXT:  fffff880021e6230 -- (.cxr 0xfffff880021e6230)
rax=0000000000000000 rbx=000000000000000c rcx=fffff8a002602400
rdx=fffff880021e6de0 rsi=0000000000000000 rdi=fffff8a002602400
rip=fffff800031b39bf rsp=fffff880021e6c10 rbp=fffffa800e66b198
 r8=0000000000000000  r9=fffffa800ccf0340 r10=fffffa800ccf0148
r11=fffff880021e6d20 r12=fffff8a002602418 r13=fffffa800e660048
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz na pe nc
cs=0010  ss=0018  ds=002b  es=002b  fs=0053  gs=002b             efl=00010282
fffff800`031b39bf 0fba66380a      bt      dword ptr [rsi+38h],0Ah ds:002b:00000000`00000038=????????
Resetting default scope




PROCESS_NAME:  winlogon.exe


LAST_CONTROL_TRANSFER:  from fffff80003196cc6 to fffff800031b39bf

fffff880`021e6c10 fffff800`03196cc6 : 00000000`0000000c 00000000`0000000c 00000000`08000000 00000000`00004080 : nt!MmExtendSection+0x1f
fffff880`021e6d40 fffff800`03175596 : fffff880`021e6f90 00000000`000aeb78 00000000`00000000 fffff880`021e6f88 : nt!MmCreateSection+0x5a6
fffff880`021e6f40 fffff880`02cef6d2 : 00000000`00000000 00000000`c0000001 00000000`00000008 00000000`00000000 : nt!NtCreateSection+0x171
fffff880`021e6fc0 00000000`00000000 : 00000000`c0000001 00000000`00000008 00000000`00000000 00000000`00000002 : aswSnx+0x1d6d2

fffff880`02cef6d2 ??              ???


SYMBOL_NAME:  aswSnx+1d6d2

FOLLOWUP_NAME:  MachineOwner




STACK_COMMAND:  .cxr 0xfffff880021e6230 ; kb

FAILURE_BUCKET_ID:  X64_0x3B_aswSnx+1d6d2

BUCKET_ID:  X64_0x3B_aswSnx+1d6d2

Followup: MachineOwner
My System SpecsSystem Spec
13 Mar 2012   #5

Windows 7 Ultimate x64

Excellent, thank you for the suggestion. I will do the uninstall on the pc next time I start it up (working from laptop atm).

Will report back soon as that happen.
My System SpecsSystem Spec
13 Mar 2012   #6

Windows 7 Ultimate x64

Uninstalled Avast and installed Microsoft Security Essentials.

PC restarts relatively normally, except there 2 issues:

1) It takes about 20 seconds at the BIOS screen to load up, whereas before it took about 5
2) The second DVD drive is missing (does not show up while loading, or in Windows) - However, it was showing up previously, in prior boots, in both the BIOS load screen as well as Windows. Why would it randomly show up or not? Could this be a jumper/boot order conflict issue? I am thinking that maybe both of the DVD drives are set to "master" and this may be causing confusion. Or is the issue with the SATA cable for the second DVD drive? - though if it were, then why would it work only *sometimes*, not malfunction all the time?

I am fairly confused as to why the pc takes much longer to boot (normally, 10-12 seconds, now 30-40 seconds).
My System SpecsSystem Spec
13 Mar 2012   #7

Windows 7 Home Premium 64 Bit

How many hard disks do you have in your PC? If you have only one, I would recommend that you clear the CMOS using either of the three methods (preferably the simplest method which is to load setup defaults through the BIOS) in How To Clear CMOS (Reset BIOS)
My System SpecsSystem Spec
17 Mar 2012   #8

Windows 7 Ultimate x64

Thanks to both of you for your help, but I was able to fix the problem.

After looking in a few other forums about the issue, specifically about the hard drives being configured on different SATA cables (as in, the boot drive was not set on SATA-00, but the secondary hard drive was). I found out that if those cables aren't set properly, it can cause serious problems.

As it turned out, I rearranged all of the SATA cables for both hard drives and both dvd drives - everything turned out fine after that!

I believe the issue was twofold: one, replacing Avast with MS Security Essentials, and two, arranging the SATA cables as they should be for boot drives/etc. Since then, I haven't had any issues with my desktop, and everything's been working fine.

My System SpecsSystem Spec
17 Mar 2012   #9

Windows 7 Home Premium 64 Bit

Glad the cable swapping resolved the stability problems. Thanks for posting back your steps.

Feel free to mark the thread solved when you are comfortable doing so. :)
My System SpecsSystem Spec
17 Mar 2012   #10

Windows 7 Ultimate x64

You have no idea how relieved I was! It was my "dream pc" after all.

Anyways, I'll try to stick around and help out other people with bsod issues. Who knows, it might be as easy as putting the right cables in the right spots.
My System SpecsSystem Spec

 BSOD after recent Logitech/Sidewinder X4 installs

Thread Tools

Similar help and support threads
Thread Forum
Logitech-other hardware-Logitech USB Input Device, should I install?
Hallo! It is shown at the updates of Windows, but it doesn't say what is for...
Windows Updates & Activation
Strange behavior of Updates during recent installs
I've started noticing this recently and I don't know whether it has to do with an Update that was pushed through which changed the way Updates are delivered into new installs, or whether the slipstreaming method used in Update 7 installation media is fouling out Updates actual delivery. Let me...
Windows Updates & Activation
Clearing Windows 7 Recent Places list (not Recent Items or Programs)
I have searched everywhere on the Internet, including Microsoft Support and Community, for a solution to this problem. I am looking for a way to clear the Recent Places list. I can clear Recent Items. In fact, almost all of the solutions for clearing Recent Places that a search turns up actually...
General Discussion
BSOD randomly, no recent hardware installs
Hey y'all! New member here looking for some help with random BSODs. It seems like it happens the most when I'm playing music on my computer, the music being stored on my primary hard drive. Sometimes it will happen as Windows is loading, before the computer has a chance to load the login...
BSOD Help and Support
KB973688 & KB954430 Installs, and install, and installs...
Hello, These 2 updates are in Windows update awaiting to install. Once (and it wasn't at first install) there was an error message and i deleted some files as directed by MS help page. Now they are always in the Windows update page, I install, no error, they are still there... Thanks for...
Windows Updates & Activation

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:29.
Twitter Facebook Google+