Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: No Wake From Sleep Ė BlockedI have an issue with the sleep function. T

21 Mar 2012   #11

Microsoft Community Contributor Award Recipient

Windows 7 x64

sorry I've been terribly busy and you've gone and gotten ignored because of it, I'll drop a friend a line to make sure you get taken care of.

My System SpecsSystem Spec
21 Mar 2012   #12

Windows 7 Ultimate 64-bit SP1

Thank you Meguscreed. I thought it could be that, but someone might go on. I think I can fix if I know the culprit. In that case I only have to search for the right driver and install.
My System SpecsSystem Spec
22 Mar 2012   #13

Windows 7 Home Premium 64 Bit

The .dmp file was corrupt, unfortunately. That is one of the reasons we prefer a set of minidump .dmp files in case some are corrupt. Have you had crashes since the one that you uploaded?

Check your system for corrupted data:
  • If you are overclocking any hardware, please stop.

  • Run Disk Check with both boxes checked for all HDDs and with Automatically fix file system errors checked for all SSDs. Post back your logs for the checks after finding them using Check Disk (chkdsk) - Read Event Viewer Log.
    For any drives that do not give the message:
    Windows has checked the file system and found no problems
    run disk check again as above. In other words, if it says:
    Windows has made corrections to the file system
    after running the disk check, run the disk check again.

  • Run SFC /SCANNOW Command - System File Checker up to three times to fix all errors with a restart in between each. Post back if it continues to show errors after a fourth run or if the first run comes back with no integrity violations.
My System SpecsSystem Spec

22 Mar 2012   #14

Windows 7 Ultimate 64bit SP1

You need to enable minidump the right way,so follow these steps,

Select the Small memory dump

OPTION TWO, step 2.

Dump Files - Configure Windows to Create on BSOD

And always follow these steps and upload here the crash\bsod files.

Also,run RAM - Test with Memtest86+
Let it run until at least 9 passes are completed, or errors are found (whichever comes first). The longer you run it, the better.
My System SpecsSystem Spec
22 Mar 2012   #15

Windows 7 Ultimate 64-bit SP1

Thank you very much for the instructions. As this will take some time to do I will come back later after performing and compiling all the required information.
My System SpecsSystem Spec
18 Apr 2012   #16

Windows 7 Ultimate 64-bit SP1

I did not have normal crashes as when you get a blue screen and the computer stops or reboots, but only as I described: It doesnít come back from sleep, the screen stays black with the power saving monitor on, and both keyboard and mouse are dead. I have to reboot, and when I do it I get a warning of a blue screen and a memory dump just as if it had happened, but sometimes I get nothing after rebooting. The computer does awake normally from sleep about once out of four or five times. However, now I started getting sporadic normal blue scree crashes.

I set the ChkDsk on the registry and uploaded the logs from System Volume Information, the Minidumps, the Kernel dumps, the Memtest86+ and the Powercfg -energy report. This is the download link: TestsResults.7z - 206.3 Mb.

I left Memtest85+ working and when I came back it was on the 9th pass (8 complete). It didnít find any problem, but I couldnít find a way to save the results. There is a bad quality picture of it in the upload.

SFC scan shows no integrity violations.

I downloaded Windows_NT6_BSOD_v3.03_jcgriff2_.exe before I had to pause this thread, but I canít remember where I read the recommendation and usage in the forum and what it was for. The search with the file name gets no matches. I run it and at the end it produced a file, what looks like a Firefox extension, but I donít know what to do with it.

Thank you for the support.
My System SpecsSystem Spec
18 Apr 2012   #17

Windows 7 Home Premium 64 Bit

The instructions for Windows_NT6_BSOD_v3.30_jcgriff2_.exe are the

Loading Dump File [D:\Kingston\BSODDmpFiles\Neophile\Minidump\MiniDump(sleep)2.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*C:\SymCache*
Executable search path is: 
Windows 7 Kernel Version 7601 (Service Pack 1) MP (3 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7601.17790.amd64fre.win7sp1_gdr.120305-1505
Machine Name:
Kernel base = 0xfffff800`03866000 PsLoadedModuleList = 0xfffff800`03aaa650
Debug session time: Wed Apr 18 07:54:54.229 2012 (UTC - 6:00)
System Uptime: 0 days 0:48:48.649
Loading Kernel Symbols

Loading User Symbols
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck C2, {7, 109b, 4440005, fffffa8004e6bb10}

Unable to load image \SystemRoot\system32\DRIVERS\HssDrv.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for HssDrv.sys
*** ERROR: Module load completed but symbols could not be loaded for HssDrv.sys
GetPointerFromAddress: unable to read from fffff80003b14100
Probably caused by : HssDrv.sys ( HssDrv+2bac )

Followup: MachineOwner

2: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

The current thread is making a bad pool request.  Typically this is at a bad IRQL level or double freeing the same allocation, etc.
Arg1: 0000000000000007, Attempt to free pool which was already freed
Arg2: 000000000000109b, (reserved)
Arg3: 0000000004440005, Memory contents of the pool block
Arg4: fffffa8004e6bb10, Address of the block of pool being deallocated

Debugging Details:

POOL_ADDRESS:  fffffa8004e6bb10 


BUGCHECK_STR:  0xc2_7_aPmI




LAST_CONTROL_TRANSFER:  from fffff80003a0fbe9 to fffff800038e2c80

fffff880`0319e2c8 fffff800`03a0fbe9 : 00000000`000000c2 00000000`00000007 00000000`0000109b 00000000`04440005 : nt!KeBugCheckEx
fffff880`0319e2d0 fffff880`01413195 : 00000000`00000000 00000000`00000000 00000000`6370444e 00000000`00000000 : nt!ExDeferredFreePool+0x1201
fffff880`0319e380 fffff880`03dc0bac : fffff880`0319e5c0 fffffa80`045cebe8 fffffa80`045cebe8 fffffa80`045cebe8 : ndis!NdisFreeMemory+0x15
fffff880`0319e3b0 fffff880`0319e5c0 : fffffa80`045cebe8 fffffa80`045cebe8 fffffa80`045cebe8 fffff880`03dca100 : HssDrv+0x2bac
fffff880`0319e3b8 fffffa80`045cebe8 : fffffa80`045cebe8 fffffa80`045cebe8 fffff880`03dca100 00000000`00000004 : 0xfffff880`0319e5c0
fffff880`0319e3c0 fffffa80`045cebe8 : fffffa80`045cebe8 fffff880`03dca100 00000000`00000004 fffffa80`04de07b0 : 0xfffffa80`045cebe8
fffff880`0319e3c8 fffffa80`045cebe8 : fffff880`03dca100 00000000`00000004 fffffa80`04de07b0 fffffa80`04e6bb10 : 0xfffffa80`045cebe8
fffff880`0319e3d0 fffff880`03dca100 : 00000000`00000004 fffffa80`04de07b0 fffffa80`04e6bb10 fffffa80`045cebe8 : 0xfffffa80`045cebe8
fffff880`0319e3d8 00000000`00000004 : fffffa80`04de07b0 fffffa80`04e6bb10 fffffa80`045cebe8 fffffa80`00000000 : HssDrv+0xc100
fffff880`0319e3e0 fffffa80`04de07b0 : fffffa80`04e6bb10 fffffa80`045cebe8 fffffa80`00000000 00000000`00000000 : 0x4
fffff880`0319e3e8 fffffa80`04e6bb10 : fffffa80`045cebe8 fffffa80`00000000 00000000`00000000 fffff880`01412723 : 0xfffffa80`04de07b0
fffff880`0319e3f0 fffffa80`045cebe8 : fffffa80`00000000 00000000`00000000 fffff880`01412723 00000000`00000000 : 0xfffffa80`04e6bb10
fffff880`0319e3f8 fffffa80`00000000 : 00000000`00000000 fffff880`01412723 00000000`00000000 fffffa80`04e6bb10 : 0xfffffa80`045cebe8
fffff880`0319e400 00000000`00000000 : fffff880`01412723 00000000`00000000 fffffa80`04e6bb10 fffffa80`079f1168 : 0xfffffa80`00000000


fffff880`03dc0bac ??              ???


SYMBOL_NAME:  HssDrv+2bac

FOLLOWUP_NAME:  MachineOwner


IMAGE_NAME:  HssDrv.sys


FAILURE_BUCKET_ID:  X64_0xc2_7_aPmI_HssDrv+2bac

BUCKET_ID:  X64_0xc2_7_aPmI_HssDrv+2bac

Followup: MachineOwner
Crash caused by Hotspot Shield. Remove the VPN software to test. If it is needed, try to obtain an update for the software. You had two crashes like this.
My System SpecsSystem Spec
18 Apr 2012   #18

Windows 7 Ultimate 64-bit SP1

Thank you for analysing.

It is very interesting. That file is from Hotspot Shield's based Expat Shield, an application used to watch BBC TV channels. It is still the latest version. It is strange because it is installed but I only use it for what it is meant, and it was not working at the moment when these crashes happened and their dump files where generated. Nevertheless, it is clearly on the dump file. I am going to uninstall, try what happens when waking from sleep and post it here. Afterwards I will also contact Expat Shield because it causes another issue: POP mail client programs do not receive or send mail when the application is connected/on (at least MS Outlook, Incredimail and Mailwasher).
My System SpecsSystem Spec
19 Apr 2012   #19

Windows 7 Home Premium 64 Bit

You're welcome. Let us know how things go with it removed. I also look forward to seeing what Expat Shield's representative says in response to your inquiry.
My System SpecsSystem Spec
21 Apr 2012   #20

Windows 7 Ultimate 64-bit SP1

I uninstalled Expat Shield and waited these few past days to tell about what happened afterwards. Since then I put the computer to sleep many times, but only twice happened something similar, but not quite the same. It was only when I put it to sleep shortly after starting (or rebooting). It might not have finished to load everything before sleeping. Not sure why.

Once, Instead of waking the screen remained black, even if On, on a power saving monitor that goes automatically to standby when with no signal input. The keyboard was not completed blocked because the leds went On/Off with their keys, but Ctrl+Alt+Del didnít work. I canít know about the mouse because there was no cursor. When rebooting there was no notice about a blue screen, but this did not happened all the time before either.

The second time was like before and after rebooting there was a BSOD notice with corresponding dump files. These dump files were not where I expected, but under C:\Windows\SysWOW64\. The zip file and the OLD one are attached. The Minidumps, the Kernel dump and the Powercfg -energy report are at the same place as the other set, but they are fewer. Will this issue be the same?

I wrote to Expat Shield, but didnít receive any answer up to this date, but I gave the them the link to this thread, so they must be fully informed.

Thank you for helping.
My System SpecsSystem Spec

 No Wake From Sleep Ė BlockedI have an issue with the sleep function. T

Thread Tools

Similar help and support threads
Thread Forum
Uncommanded wake from sleep yet no wake devices or wake timers exist
W7 PC wakes up from sleep every few minutes. It didn't use to. I am the builder / owner / sole user. Investigation done so far at the DOS prompt to establish the cause: powercfg -devicequery wake_armed (no results returned) powercfg -waketimers There are no active wake timers in the...
General Discussion
Laptop extremely slow to wake up from sleep mode, 5+ minutes to wake
Hi, I am new here. Hoping someone can help me out with this issue. I work in IT so am not a complete computer bonehead and am at my wits end with this. My laptop is about 4 years old, it's a toshiba. For whatever reason, it started taking 5+ minutes to wake up from sleeping. If it sleeps...
Performance & Maintenance
Help with sleep wake up
My computer can go to sleep mode. But upon wake up, it will stuck there with no video signal. I can see the fans are moving, cd and hd seems working. I have the latest bios installed and have tried different settings. Any thoughts? This is my spec: MSI Neo2 P35 with intel e2180 evga 8600gts 4gb...
General Discussion
PC Won't wake from sleep
Hi, Hoping someone can help me with this. I installed 7RC a couple of months ago. Since then whenever my pc sleeps I can not wake it up. It used to wake up fine in XP. To get it going again I have to cold reboot or pull the plug. When it comes back up everything I was doing is still...
Space bar wake from sleep issue
I have a Logitech USB keyboard. Since I installed W7,I could wake the computer from sleep by pressing the space bar. About 3 days ago that function no longer works. I have to press the power button in order to wake the computer. Would like to go back to using the space bar, any ideas why and how to...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 23:04.
Twitter Facebook Google+