Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: No Wake From Sleep – BlockedI have an issue with the sleep function. T

21 Apr 2012   #21

Windows 7 Home Premium 64 Bit

Problem Devices:
sptd	ROOT\LEGACY_SPTD\0000	This device is not present, is not working properly, or does not have all its drivers installed.
Please remove any CD/DVD virtualization software, such as Daemon Tools/Alcohol 120%, as they use a driver called sptd.sys that is known to cause BSODs. Use add/remove programs to remove the software. After removing the software, use the sptd.sys uninstaller to remove sptd.sys from the system.

I prefer TotalMounter as my CD/DVD virtualization software as it allows me to burn images to a virtual CD/DVD if I just want an ISO file instead of a disc, and it is free.

Many use MagicISO - Convert BIN to ISO, Create, Edit, Burn, Extract ISO file, ISO/BIN converter/extractor/editor as well, which is also free.

Loading Dump File [D:\Kingston\BSODDmpFiles\Neophile\Windows_NT6_BSOD_jcgriff2\042112-21543-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*C:\SymCache*
Executable search path is: 
Windows 7 Kernel Version 7601 (Service Pack 1) MP (3 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7601.17790.amd64fre.win7sp1_gdr.120305-1505
Machine Name:
Kernel base = 0xfffff800`0384b000 PsLoadedModuleList = 0xfffff800`03a8f650
Debug session time: Sat Apr 21 01:12:15.419 2012 (UTC - 6:00)
System Uptime: 0 days 0:09:17.839
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck A, {0, 2, 0, fffff800038cc415}

Unable to load image \SystemRoot\System32\Drivers\aswSP.SYS, Win32 error 0n2
*** WARNING: Unable to verify timestamp for aswSP.SYS
*** ERROR: Module load completed but symbols could not be loaded for aswSP.SYS
Probably caused by : aswSP.SYS ( aswSP+5ff1 )

Followup: MachineOwner

2: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If a kernel debugger is available get the stack backtrace.
Arg1: 0000000000000000, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, bitfield :
	bit 0 : value 0 = read operation, 1 = write operation
	bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
Arg4: fffff800038cc415, address which referenced memory

Debugging Details:

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff80003af9100


fffff800`038cc415 488b00          mov     rax,qword ptr [rax]





TRAP_FRAME:  fffff880030cb840 -- (.trap 0xfffff880030cb840)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000000 rbx=0000000000000000 rcx=fffff88006c3e4e0
rdx=0000000000000001 rsi=0000000000000000 rdi=0000000000000000
rip=fffff800038cc415 rsp=fffff880030cb9d0 rbp=0000000000000002
 r8=0000000000000000  r9=0000000000000000 r10=0000000000000000
r11=fffffa8003760560 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl nz na pe cy
fffff800`038cc415 488b00          mov     rax,qword ptr [rax] ds:00000000`00000000=????????????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff800038c7229 to fffff800038c7c80

fffff880`030cb6f8 fffff800`038c7229 : 00000000`0000000a 00000000`00000000 00000000`00000002 00000000`00000000 : nt!KeBugCheckEx
fffff880`030cb700 fffff800`038c5ea0 : 00000000`00000202 fffff800`038e6a43 fffffa80`000000ff fffff880`06c3e4d8 : nt!KiBugCheckDispatch+0x69
fffff880`030cb840 fffff800`038cc415 : 00000000`00000000 00000000`00000000 00000000`00000014 00000000`00000000 : nt!KiPageFault+0x260
fffff880`030cb9d0 fffff880`0453aff1 : fffffa80`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KeSetEvent+0x1e3
fffff880`030cba40 fffffa80`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 fffffa80`03f011b0 : aswSP+0x5ff1
fffff880`030cba48 00000000`00000000 : 00000000`00000000 00000000`00000000 fffffa80`03f011b0 fffff800`038cb6c1 : 0xfffffa80`00000000


fffff880`0453aff1 ??              ???


SYMBOL_NAME:  aswSP+5ff1

FOLLOWUP_NAME:  MachineOwner




FAILURE_BUCKET_ID:  X64_0xA_aswSP+5ff1

BUCKET_ID:  X64_0xA_aswSP+5ff1

Followup: MachineOwner
Appears to be related to avast! which has been common of late... Not sure if it is due to an issue with avast! itself, or if it is conflicting with certain systems, or maybe an update caused it to be corrupted. Try installing the latest version of avast! after uninstalling it using the avast! Uninstall Utility | Download aswClear for avast! Removal

My System SpecsSystem Spec
22 Apr 2012   #22

Windows 7 Ultimate 64-bit SP1

Thank you for further information.
I don’t have CD/DVD virtualization software, so this point was easy – nothing to do. I have VMware installed (mounted) on a HD (B:\) with Windows 98, 8 and Suze ISOs copied on another HD (D:\). Can this be a problem? However, searching for SPTD (sptd.sys) produced quite a few results, all related with Backup4All. As I no longer use it often, but other ways to backup, I uninstalled and cleaned registry and system from all files and entries left, which were many. I waited to see the results before attacking Avast.

The real BSODs with blue screens happened lastly, only after my first post, as well as some idiosyncrasies on the computer behaviour, like taking longer time to react, even on scrolling Firefox, or the cursor sometimes stopping to respond for short moments. So I don’t think they were related to the computer failing to wake from sleep. This seems to be confirmed for your discovery of the STDP issue, and did go away after uninstalling Backup4All. So I didn't do anything with Avast. I tried to put it to sleep shortly after starting/rebooting and no blue screen followed, but I still get errors on Event Viewer when starting/rebooting. I am only transcribing details that seem significant, unless you want them all. They are related to SPTD and Bluetoth.

Error 1
The mutual authentication between the local Bluetooth adapter and a device with Bluetooth adapter address (00:0f:de:27:19:84) failed.
Source: BTHUSB .. Event ID: 16 .. User: N/A
Event Log Online Help: Event Source: sptd

Error 2
Driver detected an internal error in its data structures for .
Source: sptd .. Event ID: 4 .. User: N/A
Event Log Online Help: Event Source: sptd

Error 3
The Bluetooth driver expected an HCI event with a certain size but did not receive it.
Source: BTHUSB .. Event ID: 5 .. User: N/A
Event Log Online Help: Event Source: BTHUSB

Error 4
The AMD FUEL Service service failed to start due to the following error:
The system cannot find the path specified.
Source: Service Control Manager .. Event ID: 7000 .. User: N/A
Event Log Online Help: Goes to a long page: Event ID 7000
I tried the suggested command line query (sc query AMD_FUEL), but the system answer was: The specified service does not exist as an installed service.

All I found on the computer searching for SPDT was on files contained in the uploaded Windows_NT6_BSOD_jcgriff2 zipped folder that I still have.

I try to keep the computer running easily, cleaned and backed up with simple batches, but I think software are bunches of shit. PCs didn’t use to have BSODs and issues at all, at least for me, but issues just get more and worse with every year. I spend more time taking care of my computer that using it!

This is long because I have tried to explain as good as I could. Thank you for your help.
My System SpecsSystem Spec
22 Apr 2012   #23

Windows 7 Home Premium 64 Bit

Did you run the SPTD uninstall tool I linked to in my previous post? Windows does not seem to know it was uninstalled.

What other registry changes have you made besides those for SPTD, and how did you "clean" the registry?

The more tweaks (such as registry cleaning) you make to Windows, the further it will degrade until it stops working properly. Windows 7 handles its own maintenance very well, and unlike its predecessors, it is a lot more lightweight, resulting in less/no need for optimization tools. Unless you are very well versed with how the registry works, it is best to avoid cleaning it with any automated registry cleaning programs. They will slowly strip down the already lightweight Windows 7 system and eventually cause it to stop functioning.
My System SpecsSystem Spec

23 Apr 2012   #24

Windows 7 Ultimate 64-bit SP1

No, sorry, I did not understand that I should use sptd.sys uninstaller even after having removed Backup4All with all its files and registry entries, which according to your description were the culprit, and sptd.sys no longer existed in the system. I did not understand that sptd.sys should be used after all this, anyway. Now that I did it, there are no more errors on Event Viewer concerning STDP, but the Bluetooth ones persist at every start-up/reboot. When trying to use Bluetooth with a mobile phone, for instance, the modem connection tests OK, but the computer does not see files or anything else in the mobile.

I don’t use tweaking applications, boosters, optimizers, fixers (except MS FixIt), enhancers or whatever because I don’t trust them and have no use to what they do, and it is true that registry cleaners are both a waste of money and registry destroyers, so I use an efficient uninstaller which almost always finds and cleans lots of stuff left from uninstalling programs, just as I said about the very long list left when I uninstalled Backup4All. I honestly ignore if Win7 registry is lightweight. What I do know is that with every new OS version the registry is much larger and grows a lot in time, mostly because it records everything computer users do, including what nobody wants to be recorded. I understand that the registry size is not as important as it used to be with version 4, but I believe it is not good to leave all uninstall leftovers in there. I know how the registry works, but not enough to do most thing because you need to know much more than just that, so that I limit my intervention to what I am sure only. Some things are very useful, like saving branches with the settings of programs that are impossible to save otherwise, and merge them when they are reinstalled. Outlook is an example, and you can save hours on configuration and e-mail accounts settings after reinstallation. Even so, this cannot always be done.

Thank you for the suggestions, and sorry if I didn’t explain well because I am already writing too long. Let us see if I can solve this Bluetooth driver issue not yet going away.
My System SpecsSystem Spec
23 Apr 2012   #25

Windows 7 Home Premium 64 Bit

Have you attempted to re-install the Bluetooth drivers? Do your Bluetooth devices show up in Device Manager under Network adapters or Human Interface Devices?

To re-install the device drivers, download them from your motherboard site (that may currently be impossible since the ASUS sites crashed over the weekend and do not seem to have all the downloads available at the moment)... We may have to hold off fixing that error.
My System SpecsSystem Spec
24 Apr 2012   #26

Windows 7 Ultimate 64bit

i have the same exact problem, heres a thread ive made about it recently Resume from sleep mode fails, boot loops. - NVIDIA Forums, and i have tons of unsolved threads started about the same issue on these forums, no one knows how to fix it. Ive seen on some forum posts in other websites that say SP1 is the cause of it. If you're willing to uninstall SP1 and try sleep that will most likely fix your problem (not really because u wont have SP1 then).
My System SpecsSystem Spec
24 Apr 2012   #27

Windows 7 Ultimate 64-bit SP1

I attempted just before my first post, as I wrote it there, but nothing changed. Yes, they all show up, both under Network adapters and Human Interface Devices. Maybe I should try and clean all drivers files completely, not just uninstalling. How?

I couldn’t find anything for Bluetooth on Asus site or on my motherboard drivers and support page, except for Asus Dongle. Have I missed something?

Now, this is difficult because the Bluetooth manufacturer adapter (15542-02) instructions say it works with two driver sets: Broadcom and CSR. To choose (1st FAQ subject line on the page), they tell to plug it in and let Windows start loading the driver and read which one Windows chose; then download that one and install it. I can’t remember now, but if I use Broadcom must be because it was the result of the initial choice. So I uninstalled all under Human Interface Devices, but when I plugged the transmitter back it didn’t tell me which one was chosen (see attached images). Anyway, both presently available drivers are of the same date as the one I have for Win7-64bit, 29 Oct. 2009, maybe a bit old but still the latest.

It does resume from sleep for me now, but I still have a problem with a Bluetooth driver. Please, see the previous posts on what regards the sleep resume issue.
My System SpecsSystem Spec
24 Apr 2012   #28

Windows 7 Home Premium 64 Bit

I see there it is Searching Windows Update... What drivers did it end up eventually installing for those three devices?
My System SpecsSystem Spec
25 Apr 2012   #29

Windows 7 Ultimate 64-bit SP1

A bit difficult to answer. I have these entries under Human Interface Devices:

Bluetooth HID Device — Bt – hidbth.sys, hidclass.sys, hidparse.sys & hidusb.sys
HID-compliant consumer control device — Lm - n/d
HID-compliant consumer control device – Bt - n/d
HID-compliant device — Lm - n/d
HID-compliant device — Lm - n/d
USB Human Interface Device — Bt – hidclass.sys, hidparse.sys & hidusb.sys
USB Human Interface Device — Bt – hidclass.sys, hidparse.sys & hidusb.sys
USB Input Device — Lm } Same on both:
USB Input Device — Lm } hidclass.sys, hidparse.sys & hidusb.sys

Lm- Logitech mouse
Bt- Bluetoth device
n/d = no drivers
All drivers are Microsoft OS

The searching window that you mention was after I unplugged and unistalled the Bt device, and then plugged it back again. As I said, that window didn't show it was applying the Broadcom or CSR drivers, as the manufacturer says, but also as I said, if I had installed Broadcom drivers before, it was because the searching window showed it up when I first plugged the Bt in.

Just to remember my first post, I started by uninstalling and reinstalling the Broadcom drivers before I posted, and I posted because I got no results. This time I left the installation as Windows did without adding the Broadcom drivers, but Bt still not seeing files, even if the modem on the mobile tests OK. This last one is very difficult for me to understand. The whole thing. I only post difficult things because the easy ones I can most often solve them myself.
My System SpecsSystem Spec
25 Apr 2012   #30

Windows 7 Home Premium 64 Bit

Are you suffering any performance issues with the errors? If not, I would just leave it be unless you really want it sorted.

Are there any applications that come with the Bluetooth dongle?

I had a Bluetooth dongle at one point, but I never used it and eventually just tossed it because it was too much of a hassle to get it working at that time... Mine was prior to Bluetooth devices becoming common. What I am getting at is: I am not really the best person to ask regarding these errors.

I did do some research and found other people with your problem, and theirs ended up being their Bluetooth devices themselves were not connecting to the Bluetooth device in the system. Do your Bluetooth devices work with the dongle?
My System SpecsSystem Spec

 No Wake From Sleep – BlockedI have an issue with the sleep function. T

Thread Tools

Similar help and support threads
Thread Forum
Uncommanded wake from sleep yet no wake devices or wake timers exist
W7 PC wakes up from sleep every few minutes. It didn't use to. I am the builder / owner / sole user. Investigation done so far at the DOS prompt to establish the cause: powercfg -devicequery wake_armed (no results returned) powercfg -waketimers There are no active wake timers in the...
General Discussion
Laptop extremely slow to wake up from sleep mode, 5+ minutes to wake
Hi, I am new here. Hoping someone can help me out with this issue. I work in IT so am not a complete computer bonehead and am at my wits end with this. My laptop is about 4 years old, it's a toshiba. For whatever reason, it started taking 5+ minutes to wake up from sleeping. If it sleeps...
Performance & Maintenance
Help with sleep wake up
My computer can go to sleep mode. But upon wake up, it will stuck there with no video signal. I can see the fans are moving, cd and hd seems working. I have the latest bios installed and have tried different settings. Any thoughts? This is my spec: MSI Neo2 P35 with intel e2180 evga 8600gts 4gb...
General Discussion
PC Won't wake from sleep
Hi, Hoping someone can help me with this. I installed 7RC a couple of months ago. Since then whenever my pc sleeps I can not wake it up. It used to wake up fine in XP. To get it going again I have to cold reboot or pull the plug. When it comes back up everything I was doing is still...
Space bar wake from sleep issue
I have a Logitech USB keyboard. Since I installed W7,I could wake the computer from sleep by pressing the space bar. About 3 days ago that function no longer works. I have to press the power button in order to wake the computer. Would like to go back to using the space bar, any ideas why and how to...
Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 18:53.
Twitter Facebook Google+