Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: COM surrogate stopped working error - no solution seems to work

21 Mar 2012   #1

Windows 7 Professional x64
COM surrogate stopped working error - no solution seems to work

Hi all,

I have Windows 7 professional and a minimal set of software installed.

I have pretty much exactly the same problem then the one posted here:
COM Surrogate Windows 7 64bit

I keep getting a "COM Surrogate has stopped working" error when viewing JPEGs with Windows Photo Viewer. This happens at random times when I view the photos. Sometimes it happens when I open the first image but mostly it is at some point when I change to the next picture.

Just as above problem wasn't solved, mine isn't either. I just wondered if anyone had a new idea.

Just to make sure:
  • I have seen the page at and:
    • I have no Nero or Divx
    • I tried to add dllhost.exe to the DEP exception but I get the message "you cannot set DEP attributes on 64-bit executables". I did this under Advanced Settings-> Performance tab: Settings->Data Execution Prevention->Turn on DEP for all programs and services except those I select:->add.... Also I read somewhere that changing the DEP isn't the best solution for security.
    • I will probably have to try disabling thumbnails but this isn't the ideal solution. Also it didn't work for the person that posted the same problem a year ago.
    • I am not aware of any Windows 7 codec update (my Windows says there are no updates)
  • I have seen 'COM Surrogate has stopped working' - Microsoft Answers
    • I tried the "clean boot" and with everything disabled, the error still occurred.

I don't know when it started. recently installed Adobe CS5.5 and I am not sure if the error occurred before (because I didn't really looked at pictures). The computer is newly built so I am really not quite sure when this started or if this was there, from the beginning.

Is anyone aware of a solution to this problem?

Thanks for your help!

My System SpecsSystem Spec
22 Mar 2012   #2

Windows 7 Home Premium 64 Bit

First, make sure Windows files are as they should be:
  • Run SFC /SCANNOW Command - System File Checker up to three times to fix all errors with a restart in between each. Post back if it continues to show errors after a fourth run or if the first run comes back with no integrity violations.

Also, do you have ANY codecs installed beyond what comes with Windows 7?

Please provide us with your Event Viewer administrative logs by following these steps:
  1. Click Start Menu
  2. Type eventvwr into Search programs and files (do not hit enter)
  3. Right click eventvwr.exe and click Run as administrator
  4. Expand Custom Views
  5. Click Administrative Events
  6. Right click Administrative Events
  7. Save all Events in Custom View As...
  8. Save them in a folder where you will remember which folder and save as Errors.evtx
  9. When asked, save the display information in English.
  10. Go to where you saved Errors.evtx
  11. Create a new folder by right clicking in a blank area within the folder Errors.evtx is saved in. You could also click New Folder at the top of the directory under the directory path box.
  12. Name the new folder Errors.
  13. Place Errors.evtx and the LocaleMetaData folder into the new Errors folder.
  14. Right click the Errors folder -> send to -> compressed (zipped) folder
  15. Upload the .zip file here.
My System SpecsSystem Spec
22 Mar 2012   #3

Windows 7 Professional x64

EDIT: Sorry, I tried to include screenshots...

Thank you for the answer

I tried repairing and I don't think it helped. I did a verify only after the repair and it didn't find anything.

I also attached the Event-viewer. Most of the errors occurred yesterday March 21 when I tried different things.

I am not aware of any codecs other than the windows install.

A list of software installed is attached as well:

All proprietary software is genuine and no hacks etc.

Hmm. I am going to restart and try the fix one more time.

Thanks for the help
My System SpecsSystem Spec

22 Mar 2012   #4

Windows 7 Professional x64

Updated attachment with list of software etc

Looks like there are quite a few errors that I never see... This WMI error seems pretty persistent. Has that got anything to do with it?
My System SpecsSystem Spec
22 Mar 2012   #5

Windows 7 Home Premium 64 Bit

Event filter with query "SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 99" could not be reactivated in namespace "//./root/CIMV2" because of error 0x80041003. Events cannot be delivered through this filter until the problem is corrected.
Can be fixed with Event ID 10 is logged in the Application log after you install Service Pack 1 for Windows 7 or Windows Server 2008 R2

An error was detected on device \Device\Harddisk2\DR2 during a paging operation.
The system failed to flush data to the transaction log. Corruption may occur.
Suggest that you check your hard disks for errors:
  • Run Disk Check with both boxes checked for all HDDs and with Automatically fix file system errors checked for all SSDs. Post back your logs for the checks after finding them using Check Disk (chkdsk) - Read Event Viewer Log.
    For any drives that do not give the message:
    Windows has checked the file system and found no problems
    run disk check again as above. In other words, if it says:
    Windows has made corrections to the file system
    after running the disk check, run the disk check again.
My System SpecsSystem Spec
22 Mar 2012   #6

Windows 7 Professional x64

Cool. Thanks.
It seems like the ID 10 error shouldn't cause a problem

I am just running one of the hard disk scans. It is taking a while...
The problem viewing the pics occurred on both my Internal HDD and External HD however. Just to let you know.
My System SpecsSystem Spec
22 Mar 2012   #7

Windows 7 Home Premium 64 Bit

No problem. If the hard disk checks do not resolve it, there are a few other options.
My System SpecsSystem Spec
23 Mar 2012   #8

Windows 7 Professional x64

Hi writhziden,

I finished the disk checks. Nothing on E was found. However, at file number 1781 it took a long time to proceed. Then there was a black screen and I had to click "OK" on an error message. Stupidly I didn't note that down (i think it was something about an empty something?). It still said it didn't find any problems. I reran it again and it took a long while at 1781 again. I am not sure if the black screen appeared. I ran it remotely and when I checked again the run was finished. Sorry; that isn't really helpful...

I ran the C drive (SSD) and apparently an error was fixed (ChkdiskCdriveNr1). I ran it another time (ChkdiskCdriveNr2) and nothing was detected. Then I tried viewing the pics but the COM surrogate error returned. It took a long time of flicking rapidly back and forth through pics (I guess about 30-40seconds) where before it occured often much earlier. Afterwards I ran the C drive again (ChkdiskCdriveNr3) but nothing was detected.

Hmm. I am not sure if that is clear...

PS: I also found a VSS error (message attached) that happened at night when I wasn't using the computer. Not sure if that is important.

Thanks so much
My System SpecsSystem Spec
23 Mar 2012   #9

Windows 7 Professional x64

Forgot attachment
My System SpecsSystem Spec
23 Mar 2012   #10

Windows 7 Home Premium 64 Bit

If the VSS error only happened once, it is not anything to worry about. Stalls on file numbers usually mean large files are being examined and are nothing to worry about. The fact that you received an error is somewhat concerning, but without knowing the exact error, I cannot determine the nature of it and whether it is significant. Might be worth running a diagnostic on the drive.

At some point, run the short and long tests with SeaTools on the Barracuda drive.

Also, the Crucial M4 drives have seen some crashes and other problems on this forum that were resolved with a firmware update. Is your firmware up to date for the drive? Product Downloads - Firmware Updates
My System SpecsSystem Spec

 COM surrogate stopped working error - no solution seems to work

Thread Tools

Similar help and support threads
Thread Forum
COM surrogate has stopped working
I have machine with Windows 7 64 bit installed and recently started receiving the Message above about the COM Surrogate. I have tried numerous suggestions I found online with no success I rolled back the video driver I removed dllhost.exe from "C:\Windows\Syswow64" I did a windows recovery...
General Discussion
COM Surrogate has stopped working...
is there any proper solution for this problem...whenever i open pictures the "COM Surrogate has stopped working" comes.i set it with some ways after searching from google but it comes again..
Hardware & Devices
COM Surrogate has Stopped Working
Hi, I keep getting this message: After this warning I choose to Close the program, and when I click "My Computer" windows explorer won't show any of the disks (C, etc), instead it shows a green bar at the top that slowly...
General Discussion
COM Surrogate stopped working
Whenever I launch a RECORDED video (by DXtory), or simply open the folder of where the videos are located I get this annoying error "COM Surrogate has stopped working" I tried to download several different codecs. but I still have this problem. Description Faulting Application Path: ...
General Discussion
Com Surrogate has stopped working
Any ideas what this means? It keeps popping up ever few seconds. I THINK ever since i un installed Bitcomet. Using build 7077. Thanks Dave.
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:16.
Twitter Facebook Google+