Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD playing Battlefield 3, Star Trek Online after adding bluray burne

23 Mar 2012   #11

Windows 7 Ultimate x64

here's the jcgriff output zip

My System SpecsSystem Spec
23 Mar 2012   #12

Windows 7 Ultimate x64

Ah ha! I finally got a BSOD and it did dump memory! Please help me! I tried to reinstall windows but it kept saying "CD/DVD driver required" or something, even with my bluray burner disconnected from power and sata... The AHCI driver from Asus for X58/ICH10R didn't work and neither did the Marvell 92xx driver. I'd still like to save the present installation if at all possible. Here's the new report. Again, please disregard the BSODs from February; they are a result of stress testing before I figured out that 1.2875 volts is my happy place. The applicable one is the one on 3/23/11 @ ~11:45ish GMT-6. You guys are freakin' awesome and I hope this forum and it's BSOD analyzers live on forever.
My System SpecsSystem Spec
24 Mar 2012   #13

Windows 7 Ultimate x64

Hey buddy :)

I've taken a look at the latest dump you've attached. The culprit is labeled dxgkrnl.sys, which is the DirectX Graphics Kernel. This is a core Windows file, so I doubt this was actually the cause of the crash, but regardless I'd recommend repairing DirectX. Video card drivers may also be a cause of this, so if you'd like you can go ahead and uninstall / reinstall video card drivers for safe measure. I noticed yours are dated from 2012, so they're recent and most likely up to date, but just for good measure and diagnostic purposes it'd probably be a good idea.

Another thing I would really recommend is enabling Driver Verifier. I have a feeling your issue is related to software if the overclock you're so graciously upholding is not unstable, and the system even crashed at stock.. so it may be hardware as well, but I have a feeling it's a driver.

You can read on how to enable & disable Driver Verifier here:

Driver Verifier - Enable and Disable

If Driver Verifier finds a fault, it will force a BSOD and generate a detailed dump with the specific driver that caused the crash. Before enabling this though, I would recommend creating a restore point or a back up. 9/10 times the driver that Driver Verifier identifies as the faulting driver is on start up, so that will cause Windows to freeze / crash / BSOD as intended sometimes before actually getting into Windows. In rare cases, this will cause data corruption / loss, just as any other crash / BSOD would.. so for safe measure :)

Dump file for reference:

Microsoft (R) Windows Debugger Version 6.12.0002.633 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Users\Icarus\Downloads\Windows_NT6_BSOD_jcgriff2\032312-22198-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is:
Executable search path is: 
Windows 7 Kernel Version 7601 (Service Pack 1) MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7601.17727.amd64fre.win7sp1_gdr.111118-2330
Machine Name:
Kernel base = 0xfffff800`0305b000 PsLoadedModuleList = 0xfffff800`0329f650
Debug session time: Sat Mar 24 00:43:15.319 2012 (UTC - 4:00)
System Uptime: 0 days 1:07:56.583
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck C2, {7, 109b, 44051f02, fffff8a008afbcb1}

Probably caused by : dxgkrnl.sys ( dxgkrnl!DXGSHAREDRESOURCE::`scalar deleting destructor'+87 )

Followup: MachineOwner

1: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

The current thread is making a bad pool request.  Typically this is at a bad IRQL level or double freeing the same allocation, etc.
Arg1: 0000000000000007, Attempt to free pool which was already freed
Arg2: 000000000000109b, (reserved)
Arg3: 0000000044051f02, Memory contents of the pool block
Arg4: fffff8a008afbcb1, Address of the block of pool being deallocated

Debugging Details:




PROCESS_NAME:  csrss.exe


LAST_CONTROL_TRANSFER:  from fffff80003204be9 to fffff800030d7d40

fffff880`02d342e8 fffff800`03204be9 : 00000000`000000c2 00000000`00000007 00000000`0000109b 00000000`44051f02 : nt!KeBugCheckEx
fffff880`02d342f0 fffff880`05a1b873 : fffff8a0`03c1d110 00000000`00000000 fffff8a0`4b677844 00000000`00000799 : nt!ExDeferredFreePool+0x1201
fffff880`02d343a0 fffff880`05a51230 : fffff8a0`0881aca0 00000000`00000000 fffff8a0`00ef2000 00000000`00000799 : dxgkrnl!DXGSHAREDRESOURCE::`scalar deleting destructor'+0x87
fffff880`02d343d0 fffff880`05a513ac : 00000000`00000001 00000000`00000000 fffff8a0`00000001 fffff8a0`00ef2000 : dxgkrnl!DXGDEVICE::DestroyAllocations+0x7ac
fffff880`02d344c0 fffff880`05a50a59 : fffffa80`00000000 fffff8a0`00ef2000 fffff8a0`0263a730 fffff8a0`0881aca0 : dxgkrnl!DXGDEVICE::DestroyResource+0x84
fffff880`02d344f0 fffff880`05a543e7 : fffff900`c00fc79c fffff8a0`0263a730 fffffa80`09d0b918 fffffa80`09d0bf11 : dxgkrnl!DXGDEVICE::TerminateAllocations+0x231
fffff880`02d34540 fffff880`05a5b8c6 : fffff8a0`00ef2000 fffff880`02d34870 00000000`00000000 0000057f`f62f5270 : dxgkrnl!DXGDEVICE::DestroyAllocation+0x93
fffff880`02d345d0 fffff960`0070682d : fffff900`c00fc020 00000000`00000001 fffff880`02d34cd0 00000000`00000001 : dxgkrnl!DxgkCddEnable+0x7ea
fffff880`02d34920 fffff960`00705ce1 : ffffffff`00000004 ffffffff`fffd74f6 00000000`00000002 00000000`00000000 : cdd!CreateAndEnableDevice+0x1e1
fffff880`02d349b0 fffff800`03371f7a : 00000000`01e9bd21 fffffa80`09edc740 00000000`00000080 fffffa80`09d60a90 : cdd!PresentWorkerThread+0x975
fffff880`02d34d40 fffff800`030c89c6 : fffff880`033d5180 fffffa80`09edc740 fffff880`033dffc0 fffff880`01643cb0 : nt!PspSystemThreadStartup+0x5a
fffff880`02d34d80 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KxStartSystemThread+0x16


dxgkrnl!DXGSHAREDRESOURCE::`scalar deleting destructor'+87
fffff880`05a1b873 488b7350        mov     rsi,qword ptr [rbx+50h]


SYMBOL_NAME:  dxgkrnl!DXGSHAREDRESOURCE::`scalar deleting destructor'+87

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: dxgkrnl

IMAGE_NAME:  dxgkrnl.sys


FAILURE_BUCKET_ID:  X64_0xc2_7_dxgkrnl!DXGSHAREDRESOURCE::_scalar_deleting_destructor_+87

BUCKET_ID:  X64_0xc2_7_dxgkrnl!DXGSHAREDRESOURCE::_scalar_deleting_destructor_+87

Followup: MachineOwner
My System SpecsSystem Spec

24 Mar 2012   #14

Windows 7 Ultimate x64

I nuked and am reinstalling windows. The dump came at stock speeds and voltages. Hopefully this goes away. I updated the driver to 295.xx whql from 295.xx beta and that's when I got a bsod instead of just a reboot with no dump.


I went out and got a 2TB seagate 5900 RPM/64MB cache drive and used it to backup all my steam stuff, music, movies, and crap before reformatting and reinstalling Windows. I got a BSOD while copying 200GB of steam information to C:/Program Files x86/Steam and installing .net 4 via windows update. It did a successful BSOD and dump, here are the results. My perfmon report is strange. I have drivers installed for everything that I use and it says my CPU is a weakling. Granted, it's stock right now but it's still a D0 i7 920...

Now I'm going to try Driver Verifier, thanks for that tip ePeen. If it BSODs during that I'm going to try reverting my GPU driver back to a known good driver from January.
My System SpecsSystem Spec
24 Mar 2012   #15

Windows 7 Ultimate x64

I accidentally edited the new debug info into the above post, please help me ePeen. I'll totally paypal you some money if you can help me get this figured out.
My System SpecsSystem Spec
24 Mar 2012   #16

Windows 7 Ultimate x64

Hi my friend. In the attached dump file above, that's not verifier enabled, it's the same dump we've been through earlier (the dxgkrnl one).

Once you get a new verifier enabled dump, please attach it and I'll take a look :)
My System SpecsSystem Spec
25 Mar 2012   #17

Windows 7 Ultimate x64

I'm quite certain that the issue stems from the last two nvidia WHQL drivers. I used Revo Uninstaller Pro to remove the latest one completely and then I installed the last beta before the WHQLs. I haven't had a BSOD since. Star Trek Online crashed, but Battlefield 3 doesn't and Windows as a whole stays up. I will keep a close eye on it. Thank you very much for your assistance.
My System SpecsSystem Spec
25 Mar 2012   #18

Windows 7 Ultimate x64

My pleasure, keep me updated.
My System SpecsSystem Spec
25 Mar 2012   #19

Windows 7 Ultimate x64

Hey ePeen, I am getting crashes in Star Trek Online but it isn't taking Windows with it so that's progress. I finally got around to running Memtest86+ v 4.20 and my RAM failed on 2 out of three sticks so that's awesome because my Corsair warranty expires in exactly 29 days!
My System SpecsSystem Spec
25 Mar 2012   #20

Windows 7 Ultimate x64

Very cool! Replace that RAM!
My System SpecsSystem Spec

 BSOD playing Battlefield 3, Star Trek Online after adding bluray burne

Thread Tools

Similar help and support threads
Thread Forum
BSOD after exiting Star Trek Online, DRIVER_POWER_STATE_FAILURE, 0x9F
Greetings everyone, Recently I start having random DRIVER_POWER_STATE_FAILURE BSODs generally after exiting Star Trek Online. I used to have a TDR 0x116 BSOD error which I solved by reverting to a previous version of my GPU driver and deactivating the TDR from registry. The new 0x9F error happens...
BSOD Help and Support
BSOD While Gaming! (Star Trek Online)
Hello! This is my first time posting on here.. I've been getting BSOD while Gaming.. I read through the BSOD Post - here is to hoping I got it correct. Thank you for looking and all your help! Windows 7 . . . - x64 Home Premium - the original installed OS on the system? - Yes - OEM ...
BSOD Help and Support
bsod playing star trek online error 0x0000001e
having random bsod crashes while playing star trek online
BSOD Help and Support
star trek online not connecting to server.
everytime i try to connect to the server i time out. all firewalls, antivirus, and other software sniffer stuff is off. i need help! getting pissed cause i cant play my f'kin game.
Star Trek Online
YouGamers - Previews - Star Trek Online First Look

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:10.
Twitter Facebook Google+