Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 crashes on anything related to Direct3D it seems?

06 Apr 2012   #1

Windows 7 Ultimate 32-bit
Windows 7 crashes on anything related to Direct3D it seems?


I've recently reinstalled Windows 7 (32-bit Ultimate). It seems there is some problem with 3D stuff on any OS I try. After the setup, when it was checking the video performance it crashed as well. And now every time I try to run that program which gives you system's rating in Win7 it crashes within a few seconds (on Running Direct3D Aero Assessment). If I try to play any games it crashes almost immediately as well but other than that everything seems to be working perfectly fine. I can watch movies and browse the internet on Chrome for hours (weirdly it crashes on Firefox after some time...) I had the same problem on Windows 7 Ultimate x64 and Windows Vista Home Premium x32 as well... And all Event Viewer is showing is that ID 41 Error which doesn't really tell anything. :/ Before all these Vista and Win7 installations I used Windows XP and it seemed to be working pretty good but it would crash on certain games too. I've tried changing back to XP but everytime I try to install it I get a BSOD telling me to run checkdisk (I've used 2 different CDs to try and install it because I thought maybe some files on my CD were corrupt or something but I got the same BSOD). I ran chkdsk and it didn't find any problems. I'm not really good with computers so if anyone could help me with this, I would really appreciate it because I'm starting to lose my mind here. :|

My computer specs:
Intel Core Duo 2.20Ghz
ATI Mobility Radeon HD 4570
Windows 7 Ultimate 32-Bit

My System SpecsSystem Spec
06 Apr 2012   #2

Windows 7 Home Premium 64 Bit

Problem Devices:
Integrated Webcam	USB\VID_0C45&PID_63EA&MI_00\6&268916F1&0&0000	This device is disabled.
Does not look like a problem. This was likely deliberate, so I doubt it is causing any conflicts.

Security Software (just to check it is installed and working; nothing needs to be done at this time):
avastsvc.exe	c:\program files\avast software\avast\avastsvc.exe	1512	8	200	1380	06/04/2012 12:20	7.0.1426.0	43.72 KB (44,768 bytes)	05/04/2012 20:04
avastui.exe	c:\program files\avast software\avast\avastui.exe	3036	8	200	1380	06/04/2012 12:21	7.0.1426.0	4.05 MB (4,241,512 bytes)	05/04/2012 20:04
mbamgui.exe	c:\program files\malwarebytes' anti-malware\mbamgui.exe	3024	8	200	1380	06/04/2012 12:21	Not Available	Not Available	Not Available
mbamservice.exe	c:\program files\malwarebytes' anti-malware\mbamservice.exe	2916	8	80	80	06/04/2012 12:22	Not Available	Not Available	Not Available

No .dmp files attached. I will look through your error logs to see if bugchecks are being generated and deleted (ccleaner and Windows disk cleanup can delete these), or if they are not registering in Windows. There were no bugcheck IDs given in the error logs...

See Dump Files - Configure Windows to Create on BSOD OPTION TWO step 2. and setup your system to create the .dmp files.
My System SpecsSystem Spec
07 Apr 2012   #3

Windows 7 Ultimate 32-bit

I've disabled the webcam myself because when I try to video chat on skype it crashes as well.
All those options in systemsadvancedsettings were already checked. Maybe it doesn't create the .dmp files because I don't actually get a BSOD? My laptop just shuts down completely as a desktop PC would do if it lost a power source.

Thank you for helping. :)
My System SpecsSystem Spec

07 Apr 2012   #4

Windows 7 Home Premium 64 Bit

Alright, that gives a bit more info; I was not aware it was a hard crash. Thank you. :)

Hard crashes generally mean hardware problems, so do some hardware checks.
  • If you are overclocking any hardware, please stop.

  • Monitor temperatures during the following tests.
    Use the following programs to monitor the temperatures.
  • Run the boot version of Memtest86+ paying close attention to Parts 2 and 3 of the tutorial. Also, in case Memtest86+ misses anything and comes up with no errors, run the extended version of the Windows Memory Diagnostics Tool for at least five passes. These you may want to run overnight since they take a long time to complete (run them an hour before bed each of the next two nights and check before going to sleep that they are still running).

    If you swap any memory components, follow these steps for ESD safety:
    1. Shut down and turn off your computer.
    2. Unplug all power supplies to the computer (AC Power then battery for laptops, AC power for desktops)
    3. Hold down the power button for 30 seconds to close the circuit and ensure all power drains from components.
    4. Make sure you are grounded by using proper grounding techniques, i.e. work on an anti-static workbench, anti-static desk, or an anti-static pad. Hold something metallic while touching it to the anti-static surface, or use an anti-static wristband to attach to the anti-static material while working.
    Once these steps have been followed, it is safe to remove and replace components within your computer.
My System SpecsSystem Spec
08 Apr 2012   #5

Windows 7 Ultimate 32-bit

Thanks for the helpful links.

I ran driver verifier last night and it resulted in a BSOD. BlueScreenView says it was caused by mcdbus.sys + ntkrnlpa.exe?
After that I also let memtest run overnight. But after I woke up I found the laptop completely shut down... I'm not sure what happened - maybe it had a hard crash overnight as well? Can memtest do that? I let it run in the morning as well, but I had to stop it as I really needed to use the laptop. After I booted it up, I got another BSOD without even getting to Windows logon. It seems to have been caused by just ntkrnlpa.exe. Can I fix this somehow? :)
My System SpecsSystem Spec
08 Apr 2012   #6

Windows 7 Home Premium 64 Bit

memtest86+ will not stop unless it is given the command to do so. If the system rebooted while running memtest86+, a hardware error likely occurred to cause it (or a power outage).

  1. Loading Dump File [D:\Kingston\BSODDmpFiles\Demonocracy\Minidump\040812-13930-01.dmp] Mini Kernel Dump File: Only registers and stack trace are available Symbol search path is: SRV*C:\SymCache* Executable search path is: Windows 7 Kernel Version 7601 (Service Pack 1) MP (2 procs) Free x86 compatible Product: WinNt, suite: TerminalServer SingleUserTS Built by: 7601.17727.x86fre.win7sp1_gdr.111118-2330 Machine Name: Kernel base = 0x82c50000 PsLoadedModuleList = 0x82d994d0 Debug session time: Sun Apr 8 05:05:35.463 2012 (UTC - 6:00) System Uptime: 0 days 0:00:14.539 Loading Kernel Symbols ............................................................... ................................................................ ........... Loading User Symbols Loading unloaded module list .... 0: kd> !analyze -v ******************************************************************************* * * * Bugcheck Analysis * * * ******************************************************************************* WINLOGON_FATAL_ERROR (c000021a) The Winlogon process terminated unexpectedly. Arguments: Arg1: 9aeb2e50, String that identifies the problem. Arg2: 00000000, Error Code. Arg3: c0000001 Arg4: 00100524 Debugging Details: ------------------ BUGCHECK_STR: 0xc000021a_0 ERROR_CODE: (NTSTATUS) 0xc000021a - {Fatal System Error} The %hs system process terminated unexpectedly with a status of 0x%08x (0x%08x 0x%08x). The system has been shut down. EXCEPTION_CODE: (NTSTATUS) 0xc000021a - {Fatal System Error} The %hs system process terminated unexpectedly with a status of 0x%08x (0x%08x 0x%08x). The system has been shut down. EXCEPTION_PARAMETER1: 9aeb2e50 EXCEPTION_PARAMETER2: 00000000 EXCEPTION_PARAMETER3: c0000001 EXCEPTION_PARAMETER4: 100524 ADDITIONAL_DEBUG_TEXT: initial session process or CUSTOMER_CRASH_COUNT: 1 DEFAULT_BUCKET_ID: VISTA_DRIVER_FAULT CURRENT_IRQL: 0 LAST_CONTROL_TRANSFER: from 82f29427 to 82d2ef04 STACK_TEXT: 8d0418e4 82f29427 0000004c c000021a 8d04196c nt!KeBugCheckEx+0x1e 8d041934 82f7b9f1 00000001 0000004c c000021a nt!PoShutdownBugCheck+0x81 8d041af4 82e28dae c000021a 00000004 00000001 nt!ExpSystemErrorHandler+0x567 8d041ca4 82e2820e c000021a 00000004 00000001 nt!ExpRaiseHardError+0xbf 8d041d14 82c8e28a c000021a 00000004 00000001 nt!NtRaiseHardError+0x11a 8d041d14 776d7094 c000021a 00000004 00000001 nt!KiFastCallEntry+0x12a WARNING: Frame IP not in any known module. Following frames may be wrong. 0048f500 00000000 00000000 00000000 00000000 0x776d7094 STACK_COMMAND: kb FOLLOWUP_IP: nt!KiFastCallEntry+12a 82c8e28a f6456c01 test byte ptr [ebp+6Ch],1 SYMBOL_STACK_INDEX: 5 SYMBOL_NAME: nt!KiFastCallEntry+12a FOLLOWUP_NAME: MachineOwner MODULE_NAME: nt IMAGE_NAME: ntkrpamp.exe DEBUG_FLR_IMAGE_TIMESTAMP: 4ec79850 FAILURE_BUCKET_ID: 0xc000021a_0_nt!KiFastCallEntry+12a BUCKET_ID: 0xc000021a_0_nt!KiFastCallEntry+12a Followup: MachineOwner ---------
  2. Loading Dump File [D:\Kingston\BSODDmpFiles\Demonocracy\Minidump\040812-31590-01.dmp] Mini Kernel Dump File: Only registers and stack trace are available Symbol search path is: SRV*C:\SymCache* Executable search path is: Windows 7 Kernel Version 7601 (Service Pack 1) MP (2 procs) Free x86 compatible Product: WinNt, suite: TerminalServer SingleUserTS Built by: 7601.17727.x86fre.win7sp1_gdr.111118-2330 Machine Name: Kernel base = 0x82c53000 PsLoadedModuleList = 0x82d9c4d0 Debug session time: Sat Apr 7 18:19:38.924 2012 (UTC - 6:00) System Uptime: 0 days 0:52:14.673 Loading Kernel Symbols ............................................................... ................................................................ ........................................ Loading User Symbols Loading unloaded module list ..... 1: kd> !analyze -v ******************************************************************************* * * * Bugcheck Analysis * * * ******************************************************************************* DRIVER_VERIFIER_DETECTED_VIOLATION (c4) A device driver attempting to corrupt the system has been caught. This is because the driver was specified in the registry as being suspect (by the administrator) and the kernel has enabled substantial checking of this driver. If the driver attempts to corrupt the system, bugchecks 0xC4, 0xC1 and 0xA will be among the most commonly seen crashes. Arguments: Arg1: 00000081, MmMapLockedPages called without MDL_MAPPING_CAN_FAIL Arg2: a143e378, MDL address. Arg3: 00000082, MDL flags. Arg4: 00000000, 0. Debugging Details: ------------------ *** WARNING: Unable to verify timestamp for mcdbus.sys *** ERROR: Module load completed but symbols could not be loaded for mcdbus.sys BUGCHECK_STR: 0xc4_81 CUSTOMER_CRASH_COUNT: 1 DEFAULT_BUCKET_ID: VERIFIER_ENABLED_VISTA_MINIDUMP CURRENT_IRQL: 0 LAST_CONTROL_TRANSFER: from 82f89f03 to 82d31f04 STACK_TEXT: 87f1b958 82f89f03 000000c4 00000081 a143e378 nt!KeBugCheckEx+0x1e 87f1b978 82f96edb a143e378 a145e598 a07c4c20 nt!VerifierBugCheckIfAppropriate+0x30 87f1b990 8fc2c33f a143e378 00000000 a07c4c20 nt!VerifierMmMapLockedPages+0x3e WARNING: Stack unwind information not available. Following frames may be wrong. 87f1bc40 833def3a 69d39500 87f1bcac 87f1bc84 mcdbus+0x1533f 87f1bc5c 833dc51d 962c6cc0 00000000 00000018 cdrom!RequestHandleGetDriveGeometry+0x40 87f1bcb0 833dc85d 962c6cc0 7a28beb0 953c6f80 cdrom!RequestProcessSerializedIoctl+0x518 87f1bcc4 85450042 6ac39078 9499efe0 953c6f80 cdrom!IoctlWorkItemRoutine+0x4b 87f1bce0 854500aa 9182a2d8 87f1bd00 82e67524 Wdf01000!FxWorkItem::WorkItemHandler+0xad 87f1bcec 82e67524 9182a2d8 953c6f80 85391d48 Wdf01000!FxWorkItem::WorkItemThunk+0x19 87f1bd00 82cd0aab 9499efe0 00000000 85391d48 nt!IopProcessWorkItem+0x23 87f1bd50 82e5c022 00000001 af7ecd0e 00000000 nt!ExpWorkerThread+0x10d 87f1bd90 82d04219 82cd099e 00000001 00000000 nt!PspSystemThreadStartup+0x9e 00000000 00000000 00000000 00000000 00000000 nt!KiThreadStartup+0x19 STACK_COMMAND: kb FOLLOWUP_IP: mcdbus+1533f 8fc2c33f ?? ??? SYMBOL_STACK_INDEX: 3 SYMBOL_NAME: mcdbus+1533f FOLLOWUP_NAME: MachineOwner MODULE_NAME: mcdbus IMAGE_NAME: mcdbus.sys DEBUG_FLR_IMAGE_TIMESTAMP: 49a3cf05 FAILURE_BUCKET_ID: 0xc4_81_VRF_mcdbus+1533f BUCKET_ID: 0xc4_81_VRF_mcdbus+1533f Followup: MachineOwner ---------
  1. Indicates data corruption.
  2. Caused by MagicISO.
Disable Verifier for now: Start Menu -> All Programs -> Accessories -> Right click Command Prompt -> Run as administrator -> Type the following command and then Enter:
verifier /reset
-> Restart your computer.

Do you have the latest version of MagicISO? If you do not, I would recommend uninstalling your current version and downloading the latest version. It may provide more stability.

For the data corruption...
  • Run Disk Check with both boxes checked for all HDDs and with Automatically fix file system errors checked for all SSDs. Post back your logs for the checks after finding them using Check Disk (chkdsk) - Read Event Viewer Log.
    For any drives that do not give the message:
    Windows has checked the file system and found no problems
    run disk check again as above. In other words, if it says:
    Windows has made corrections to the file system
    after running the disk check, run the disk check again.

  • Run SFC /SCANNOW Command - System File Checker up to three times to fix all errors with a restart in between each. Post back if it continues to show errors after a fourth run or if the first run comes back with no integrity violations.
My System SpecsSystem Spec

 Windows 7 crashes on anything related to Direct3D it seems?

Thread Tools

Similar help and support threads
Thread Forum
User Experience Rating crashes at Direct3D 10 Texture Load Assessment
Hello, I just finished building a new computer last week. It runs very well, and it scored a 7.8 out of 7.9 overall on the Windows User Experience Rating. The problem I am having is that I had to reinstall windows (I messed up the first installation) and now when I try to run the assessment...
Performance & Maintenance
Crashes related to storport.sys Windows 8 x64 Pro
Hey folks. Have banged my head on this and think I need some help with this. My system was previously completely stable under Windows 7 Ultimate x64. Now since my Windows 8 x64 pro install I am getting crashes about once every eight hours related to storport.sys ever time. Please find my...
BSOD Help and Support
Random BSOD crashes, possible related to windows file corruption
Hi, My laptop tild with an BSOD now and then, I somehow pinpointed the problem to the AudioEndpointBuilder service after the sound stop working, so I disabled the service but now I don't have any sound (as expected). It hasn't resolved all the BSOD problem but now aren't that frequent. I have...
BSOD Help and Support
New rig crashes to restart when using Direct3D
Hi there I have just built a new rig and am experiencing continuing crashes when using any DX app, even the Nvidia control panel when previewing Direct3D - screen goes black after a number of seconds, then the computer restarts. I have run Video Memory Tester and the GPU fails crashing to...
BSOD Help and Support
Flash player related application crashes on windows 7
:( I just installed windows 7 today, and I just find out that the flash-related application - you tube and Facebook flash game crashes whenever I tried to launch them. I had followed the instructions in adobe, uninstall and reinstall adobe player 10, but it doesn't solve the problem... Also,...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:31.
Twitter Facebook Google+