Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD playing Starcraft 2, BCCode: 101

10 Apr 2012   #11

windows 7 pro x64

i ran veryfier annndddd.. my windows havent pas it! jackpa!!

win crased befor even started.

i atach minidump (dont know if it is proper, if not plese tell me)

My System SpecsSystem Spec
11 Apr 2012   #12

Windows 10 Pro x64, Arch Linux

A misbehaving driver is likely the cause, probably FNETURPX.SYS associated with FNet User Proxy Driver
FNet Corporation -
Uninstalling this software might help.
My System SpecsSystem Spec
11 Apr 2012   #13

windows 7 pro x64

hmmm i lookt at this, and i assumed that was cdrom.sys; after uninstallind deamon tools it seems like fixed (i played SC2 by 25min and it wont crshed...

But i uninstall also this

i dont see FNet proxy driver in my computer ;/
My System SpecsSystem Spec

11 Apr 2012   #14

windows 7 pro x64

but dll is - deleted

BIIIG thanks all
My System SpecsSystem Spec
11 Apr 2012   #15
Vir Gnarus

Microsoft Community Contributor Award Recipient

Windows 7 64-bit

That would explain it. The minidump didn't manage to retain much in the pending IRP that was causing the problems, but I did see Daemon Tool's dtsoftbus01.sys driver sitting in the raw stack of the running thread in which it was calling that driver. It's dated from Jan 2012, so unless they have a most recent bugfix of Daemon Tools, it would probably be best to use an alternative right now.


2: kd> !thread
GetPointerFromAddress: unable to read from fffff80003515000
THREAD fffffa80039d6680  Cid 0004.0040  Teb: 0000000000000000 Win32Thread: 0000000000000000 RUNNING on processor 2
Not impersonating
GetUlongFromAddress: unable to read from fffff80003454ba4
Owning Process            fffffa80039b8740       Image:         System
Attached Process          N/A            Image:         N/A
fffff78000000000: Unable to get shared data
Wait Start TickCount      1064         
Context Switch Count      4460           IdealProcessor: 2             
ReadMemory error: Cannot get nt!KeMaximumIncrement value.
UserTime                  00:00:00.000
KernelTime                00:00:00.000
Win32 Start Address nt!ExpWorkerThread (0xfffff800032ecef0)
Stack Init fffff880033c4db0 Current fffff880033c3840
Base fffff880033c5000 Limit fffff880033bf000 Call 0
Priority 13 BasePriority 12 UnusualBoost 0 ForegroundBoost 0 IoPriority 2 PagePriority 5
Child-SP          RetAddr           : Args to Child                                                           : Call Site
fffff880`033c39a8 fffff800`0376c3dc : 00000000`000000c9 00000000`0000023e fffffa80`05aea2c0 fffff980`0a9aaee0 : nt!KeBugCheckEx
fffff880`033c39b0 fffff800`0377647a : fffff800`0376a9f0 fffffa80`05aea2c0 fffff980`0a9aaee0 00000000`00000000 : nt!VerifierBugCheckIfAppropriate+0x3c
fffff880`033c39f0 fffff800`0377734e : 00000000`0000023e 00000000`00000000 fffff980`0a9aaee0 00000000`ffffffff : nt!ViErrorFinishReport+0xda
fffff880`033c3a40 fffff800`0378271f : fffffa80`061af820 fffffa80`0617fab0 fffffa80`0617fb68 fffff880`015a8228 : nt!VfErrorReport6+0x6e
fffff880`033c3b10 fffff800`03782b63 : fffffa80`0617fab0 00000000`00000002 fffffa80`05f0b060 fffff880`015a43f4 : nt!IovpCallDriver2+0x13f
fffff880`033c3b70 fffff800`03788c2e : fffff980`0a9aaee0 fffff980`0a9aaee0 00000000`00000002 fffffa80`05f0b060 : nt!VfAfterCallDriver+0x353
fffff880`033c3bc0 fffff880`00d680c2 : fffff880`00de17c0 fffffa80`0614ea20 00000000`00000025 fffffa80`0617fab0 : nt!IovCallDriver+0x57e
fffff880`033c3c20 fffff880`00d7d59f : fffffa80`063b8da0 00000000`00000000 fffff880`00000000 fffff880`083775d5 : Wdf01000!FxIoTarget::SubmitSync+0x24a
fffff880`033c3cd0 fffff880`0838be95 : fffffa80`00000020 fffffa80`063b8da0 fffffa80`0614ea20 00000000`00000001 : Wdf01000!imp_WdfRequestSend+0x24b
fffff880`033c3d20 fffff880`0838c2f4 : 00000000`00000000 00000000`00000024 00000000`00000001 fffff880`033c3ee0 : cdrom!DeviceSendRequestSynchronously+0xc9
fffff880`033c3d80 fffff880`0838af04 : 0000057f`f9f447e8 fffff880`033c3ee0 fffffa80`060eb830 00000000`00000024 : cdrom!DeviceSendSrbSynchronously+0x3ec
fffff880`033c3eb0 fffff880`08389825 : fffffa80`00000002 fffffa80`060bbb80 fffff880`083813b8 0000057f`f9f447e8 : cdrom!DeviceCacheDeviceInquiryData+0xbc
fffff880`033c3f80 fffff880`00dd29d4 : 00000000`00000000 fffff880`00000010 00000000`0000000c fffff880`00ddb620 : cdrom!DeviceEvtSelfManagedIoInit+0x105
fffff880`033c3fc0 fffff880`00dd294e : fffffa80`0612aeb0 00000000`0000000c fffff880`00ddb620 fffff880`00ddb600 : Wdf01000!FxSelfManagedIoMachine::Init+0x34
fffff880`033c3ff0 fffff880`00dc6b9b : 00000000`00000000 00000000`00000000 00000000`00000000 fffff880`00ddb620 : Wdf01000!FxSelfManagedIoMachine::ProcessEvent+0x14a
fffff880`033c4060 fffff880`00dc66eb : 00000000`00000312 00000000`00000000 fffff880`00ddb600 fffff6fc`c00544e0 : Wdf01000!FxPkgPnp::PowerD0StartingStartSelfManagedIo+0x2f
fffff880`033c4090 fffff880`00dc638e : fffffa80`0614db60 00000000`00000040 fffff880`00ddb3e0 00000000`00000040 : Wdf01000!FxPkgPnp::PowerEnterNewState+0x1db
fffff880`033c41c0 fffff880`00dc606c : 00000000`00000000 00000000`00000040 00000000`00000501 fffffa80`0614db60 : Wdf01000!FxPkgPnp::PowerProcessEventInner+0x13e
fffff880`033c4230 fffff880`00dd3b5e : 00000000`00000000 00000000`00000501 00000000`00000000 00000000`00000501 : Wdf01000!FxPkgPnp::PowerProcessEvent+0x1d4
fffff880`033c42c0 fffff880`00dd3abb : 00000000`00000501 00000000`00000000 00000000`00000500 fffff800`037875ec : Wdf01000!FxPkgPnp::NotPowerPolOwnerStarting+0xe
fffff880`033c42f0 fffff880`00dcf950 : fffffa80`0614db60 00000000`00000001 00000000`00000000 fffff880`00dd7ff0 : Wdf01000!FxPkgPnp::NotPowerPolicyOwnerEnterNewState+0x1c7
fffff880`033c4370 fffff880`00dcf372 : 00000000`00000000 00000000`00000001 00000000`00000000 fffffa80`0614ee20 : Wdf01000!FxPkgPnp::PowerPolicyProcessEventInner+0x3f8
fffff880`033c43e0 fffff880`00dcba45 : 00000000`00000000 fffffa80`0614ee20 00000000`00000108 00000000`00000000 : Wdf01000!FxPkgPnp::PowerPolicyProcessEvent+0x1e2
fffff880`033c4470 fffff880`00dcb841 : 00000000`00000101 00000000`00000108 00000000`00000108 fffff800`00000006 : Wdf01000!FxPkgPnp::PnpEventHardwareAvailable+0x111
fffff880`033c44b0 fffff880`00dcb4fe : fffffa80`0614db60 fffff880`033c45e0 00000000`00000004 fffff880`00dda390 : Wdf01000!FxPkgPnp::PnpEnterNewState+0x1a5
fffff880`033c4520 fffff880`00dcb201 : 00000000`00000000 00000000`00000002 00000000`00000000 fffffa80`0614db60 : Wdf01000!FxPkgPnp::PnpProcessEventInner+0x122
fffff880`033c4590 fffff880`00dc2d9c : 00000000`00000000 fffffa80`0614db60 00000000`00000002 00000000`00000000 : Wdf01000!FxPkgPnp::PnpProcessEvent+0x1b1
fffff880`033c4620 fffff880`00dc1dd6 : fffffa80`0614cd30 00000000`00000002 00000000`00000000 fffffa80`0614db60 : Wdf01000!FxPkgPnp::_PnpStartDevice+0x20
fffff880`033c4650 fffff880`00d91245 : fffff980`0a82ee50 fffff980`0a82ee50 fffffa80`0614ee20 00000000`00000000 : Wdf01000!FxPkgPnp::Dispatch+0x1b2
fffff880`033c46c0 fffff880`00d9114b : fffffa80`0614ee20 fffff980`0a82ee50 00000000`00000002 fffffa80`0614ee20 : Wdf01000!FxDevice::Dispatch+0xa9
fffff880`033c46f0 fffff800`03788c16 : fffff980`0a82ee50 00000000`00000002 fffffa80`0614ee20 fffffa80`0614ee20 : Wdf01000!FxDevice::DispatchWithLock+0x93
fffff880`033c4730 fffff800`0369bd6e : fffff980`0a82ee50 fffffa80`06186830 fffffa80`0614ee20 fffffa80`061b9a40 : nt!IovCallDriver+0x566
fffff880`033c4790 fffff800`033d387d : fffffa80`05f0b060 fffffa80`06186830 fffff800`033dcfa0 00000000`00000000 : nt!PnpAsynchronousCall+0xce
fffff880`033c47d0 fffff800`036ab0b6 : fffff800`034e1940 fffffa80`0614a890 fffffa80`06186830 fffffa80`0614aa38 : nt!PnpStartDevice+0x11d
fffff880`033c4890 fffff800`036ab354 : fffffa80`0614a890 fffffa80`039e002b fffffa80`039ef010 00000000`00000001 : nt!PnpStartDeviceNode+0x156
fffff880`033c4920 fffff800`036cea86 : fffffa80`0614a890 fffffa80`039ef010 00000000`00000002 00000000`00000000 : nt!PipProcessStartPhase1+0x74
fffff880`033c4950 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!PipProcessDevNodeTree+0x296

2: kd> dps fffff880033bf000 fffff880033c5000
fffff880`033bf000  ????????`????????
fffff880`033bf008  ????????`????????
fffff880`033bf010  ????????`????????
fffff880`033bf018  ????????`????????
fffff880`033bf020  ????????`????????
fffff880`033bf028  ????????`????????


fffff880`033c3b28  fffff880`015a8228Unable to load image \SystemRoot\system32\DRIVERS\dtsoftbus01.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for dtsoftbus01.sys
*** ERROR: Module load completed but symbols could not be loaded for dtsoftbus01.sys
My System SpecsSystem Spec
11 Apr 2012   #16

windows 7 pro x64


is it everythink ok with my computer now, or should i do somethik?
My System SpecsSystem Spec
11 Apr 2012   #17
Vir Gnarus

Microsoft Community Contributor Award Recipient

Windows 7 64-bit

If you're not experiencing crashing anymore, than we can consider this a done deal. Daemon Tools did appear involved with the crash that DV discovered.
My System SpecsSystem Spec
11 Apr 2012   #18

windows 7 pro x64

today i played about 1hour and happen the same (only later)

now im checking drivest but it seems ok

ataching latest dump

Microsoft (R) Windows Debugger Version 6.2.8229.0 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Windows\Minidump\041112-17721-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*c:\symbols*
Executable search path is: 
Windows 7 Kernel Version 7601 (Service Pack 1) MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7601.17640.amd64fre.win7sp1_gdr.110622-1506
Machine Name:
Kernel base = 0xfffff800`03267000 PsLoadedModuleList = 0xfffff800`034ac670
Debug session time: Wed Apr 11 19:25:45.035 2012 (UTC + 2:00)
System Uptime: 0 days 9:01:19.892
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
TRIAGER: Could not open triage file : D:\programyWindows Kits\8.0\Debuggers\x64\triage\oca.ini, error 2
TRIAGER: Could not open triage file : D:\programyWindows Kits\8.0\Debuggers\x64\winxp\triage.ini, error 2
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 101, {31, 0, fffff880009f3180, 1}

Probably caused by : Unknown_Image ( ANALYSIS_INCONCLUSIVE )

Followup: MachineOwner

0: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An expected clock interrupt was not received on a secondary processor in an
MP system within the allocated interval. This indicates that the specified
processor is hung and not processing interrupts.
Arg1: 0000000000000031, Clock interrupt time out interval in nominal clock ticks.
Arg2: 0000000000000000, 0.
Arg3: fffff880009f3180, The PRCB address of the hung processor.
Arg4: 0000000000000001, 0.

Debugging Details:






fffff800`00b9ca28 fffff800`0333b8c9 : 00000000`00000101 00000000`00000031 00000000`00000000 fffff880`009f3180 : nt!KeBugCheckEx
fffff800`00b9ca30 fffff800`032ee497 : fffffa80`00000000 fffff800`00000001 00000000`00002711 00000000`20004b82 : nt! ?? ::FNODOBFM::`string'+0x4e2e
fffff800`00b9cac0 fffff800`03228895 : fffff800`0324e460 fffff800`00b9cc70 fffff800`0324e460 fffff800`00000000 : nt!KeUpdateSystemTime+0x377
fffff800`00b9cbc0 fffff800`032e0173 : fffff800`03459e80 fffffa80`0548d001 fffffa80`05406840 00000000`00000000 : hal!HalpHpetClockInterrupt+0x8d
fffff800`00b9cbf0 fffff800`032db990 : fffff800`03459e80 fffff800`00000001 00000000`00000001 fffff880`00000000 : nt!KiInterruptDispatchNoLock+0x163
fffff800`00b9cd80 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiIdleLoop+0x80



FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: Unknown_Module

IMAGE_NAME:  Unknown_Image




Followup: MachineOwner
My System SpecsSystem Spec
11 Apr 2012   #19
Vir Gnarus

Microsoft Community Contributor Award Recipient

Windows 7 64-bit

I'm sorry, I shoulda realized we were chasing after shadows.

The 0x101 bugchecks had nothing to do with Daemon Tools. What happened with Daemon Tools is that when you turned Driver Verifier on, one of the checks you used was Force Pending I/O Requests. This is not a good check, and is known for causing false positives like what we experienced. While it does show a potential bug in Daemon Tools, it is not the cause of your problems.

Did you run Prime95 for over 7 hours? Did you remove or update the driver that Yowanvista mentioned?

Also, please provide us temps/voltages using HWInfo with Sensors only option checked. Log two 30-minute instances: one for idle, and one for high load. It's preferred that for the high load one that you run it until your system crashes. It will still save what was left of the log. Send them to us to check.

You may also send us a kernel dump (MEMORY.DMP in Windows directory) by zipping it up and uploading it to a third party website. This will give us enough information to look at. I cannot guarantee that I know enough to analyze the crashdump and find an answer but it's far better than the minidumps you've been giving us.
My System SpecsSystem Spec
11 Apr 2012   #20

windows 7 pro x64

Did you run Prime95 for over 7 hours?
no not yet

Did you remove or update the driver that Yowanvista mentioned?

You may also send us a kernel dump (MEMORY.DMP in Windows directory)
Cant find this file. theres no such file in windows folder

rest when i do this
My System SpecsSystem Spec

 BSOD playing Starcraft 2, BCCode: 101

Thread Tools

Similar help and support threads
Thread Forum
BSOD when playing Starcraft 2
Some Specs AMD Athlon(tm) II X4 630 Processor Microsoft Windows 7 Home Premium 4.0 GB RAM NVIDIA GeForce GTX 550 Ti 1GB 589 GB / 916 GB HDD
BSOD Help and Support
BSOD playing starcraft
Hi all, I have had some BSOD. My game comes to a screaching halt, the audio screams, i get the BSOD but not long enough to read. Neither is there a dump file. I ran memtest a few times, all passes, no errors. I ran driver verifier a whole day, without getting a bsod. I cleaned my pc, checked for...
BSOD Help and Support
BSOD When Playing StarCraft 2
Hello, I am receiving BSOD when playing starcraft 2. I have reinstalled Windows and am still receiving BSOD. Attached you will find the latest DMP file available. Thank you kindly for your assistance. Specs: Windows 7 Home Premium 64 Bit SP1 HP
BSOD Help and Support
BSOD playing Starcraft 2 (BCCode: 1a and 1e although mainly 1a)
Greetings, I'm encountering random BSODs mostly playing Starcraft 2. The errors tend to occur later in games with more complex play (more units, more interaction among units). I've attached the recommended information. I put this computer together last November. Here are the specs: PSU...
BSOD Help and Support
BSOD playing Starcraft 2
Hi everyone I've been having problems for a while now getting BSOD playing Starcraft 2 (and I think on skyrim as well although I don't play it as much) I'm not entirely clear what I'm supposed to write here to accompany the zipped folders so tell me if you need to know something else please. ...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:13.
Twitter Facebook Google+