Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD during casual surfing on the web, error 0000000000000018

15 Apr 2012   #1

Windows 7 home premium 64bit
BSOD during casual surfing on the web, error 0000000000000018

Heya !

So I just bought this machine a few days ago and have gotten several BSOD's here during these few days.

Is Windows 7 . . .
- 64bit
- the original installed OS on the system?
Windows 7 home premium 64bit, the same I'm using
- an OEM or full retail version?
Came pre-installed

- What is the age of system (hardware)? Been in use for several days, was on display for everyone to try in the store most likely for a couple months.
- What is the age of OS installation (have you re-installed the OS?) A couple months.

My System SpecsSystem Spec
15 Apr 2012   #2

Windows 7 Home Premium 64 Bit

Security Software (this is just to check it is installed and working properly; nothing needs to be done with this information at this time):
fsav32.exe	c:\program files (x86)\f-secure\anti-virus\fsav32.exe	3932	8	200	1380	15.4.2012 19:41	10.20.17170.93	476,69 kt (488*128 tavua)	12.4.2012 20:13
fsgk32.exe	c:\program files (x86)\f-secure\anti-virus\fsgk32.exe	1692	8	200	1380	15.4.2012 19:40	10.60.17500.39	535,66 kt (548*520 tavua)	12.4.2012 20:13
fsgk32st.exe	c:\program files (x86)\f-secure\anti-virus\fsgk32st.exe	1532	8	200	1380	15.4.2012 19:40	8.91.15380.7	216,69 kt (221*888 tavua)	12.4.2012 20:13
fssm32.exe	c:\program files (x86)\f-secure\anti-virus\fssm32.exe	2928	8	200	1380	15.4.2012 19:41	10.60.17500.39	991,66 kt (1*015*464 tavua)	12.4.2012 20:13
fih32.exe	c:\program files (x86)\f-secure\common\fih32.exe	3036	8	200	1380	15.4.2012 19:41	128,69 kt (131*776 tavua)	12.4.2012 20:13
fnrb32.exe	c:\program files (x86)\f-secure\common\fnrb32.exe	2888	8	200	1380	15.4.2012 19:41	184,69 kt (189*120 tavua)	12.4.2012 20:13
fshdll32.exe	c:\program files (x86)\f-secure\common\fshdll32.exe	1924	6	200	1380	15.4.2012 19:40	88,69 kt (90*816 tavua)	12.4.2012 20:13
fshdll64.exe	c:\program files (x86)\f-secure\common\fshdll64.exe	2492	8	200	1380	15.4.2012 19:41	104,19 kt (106*688 tavua)	12.4.2012 20:13
fsm32.exe	c:\program files (x86)\f-secure\common\fsm32.exe	4708	8	200	1380	15.4.2012 19:41	296,69 kt (303*808 tavua)	12.4.2012 20:13
fsma32.exe	c:\program files (x86)\f-secure\common\fsma32.exe	1684	8	200	1380	15.4.2012 19:40	184,69 kt (189*120 tavua)	12.4.2012 20:13
fsdevcon64.exe	c:\program files (x86)\f-secure\device control\fsdevcon64.exe	1652	8	200	1380	15.4.2012 19:40	1.0.17436.0	505,69 kt (517*824 tavua)	12.4.2012 20:17
fsdfwd.exe	c:\program files (x86)\f-secure\fwes\program\fsdfwd.exe	2860	8	200	1380	15.4.2012 19:41	835,19 kt (855*232 tavua)	12.4.2012 20:17
fsorsp.exe	c:\program files (x86)\f-secure\orsp client\fsorsp.exe	2788	8	200	1380	15.4.2012 19:41	60,69 kt (62*144 tavua)	12.4.2012 20:13

Problem Software:
dsmonitor.exe	c:\program files (x86)\uniblue\driverscanner\dsmonitor.exe	1560	8	200	1380	15.4.2012 19:40	24,87 kt (25*464 tavua)	13.4.2012 12:55
Automated driver updating software often installed updated drivers for devices that are similar to those installed on the system being updated. This can cause conflicts and system crashes. If you want to continue using the software, make sure to create system restore points regularly before updating drivers. Also, make sure you have enough space available for the restore points. 20 GB is recommended if you continue to use the software: System Protection - Change Disk Space Usage

Microsoft (R) Windows Debugger Version 6.12.0002.633 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [D:\Kingston\BSODDmpFiles\xanterr\Windows_NT6_BSOD_jcgriff2\041512-14929-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*C:\SymCache*
Executable search path is: 
Windows 7 Kernel Version 7601 (Service Pack 1) MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Built by: 7601.17790.amd64fre.win7sp1_gdr.120305-1505
Machine Name:
Kernel base = 0xfffff800`03264000 PsLoadedModuleList = 0xfffff800`034a8650
Debug session time: Sun Apr 15 10:39:50.946 2012 (UTC - 6:00)
System Uptime: 0 days 0:37:11.243
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck D1, {18, 2, 1, fffff88008450d16}

Unable to load image \SystemRoot\system32\DRIVERS\athrx.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for athrx.sys
*** ERROR: Module load completed but symbols could not be loaded for athrx.sys
Probably caused by : athrx.sys ( athrx+18d16 )

Followup: MachineOwner

0: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arg1: 0000000000000018, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000001, value 0 = read operation, 1 = write operation
Arg4: fffff88008450d16, address which referenced memory

Debugging Details:

WRITE_ADDRESS: GetPointerFromAddress: unable to read from fffff80003512100


fffff880`08450d16 c7401800000000  mov     dword ptr [rax+18h],0





TRAP_FRAME:  fffff8800e2396b0 -- (.trap 0xfffff8800e2396b0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000000 rbx=0000000000000000 rcx=fffffa8008679030
rdx=fffffa8008a16440 rsi=0000000000000000 rdi=0000000000000000
rip=fffff88008450d16 rsp=fffff8800e239840 rbp=0000000000000000
 r8=0000000000000001  r9=fffffa800998f360 r10=0000000000015c12
r11=0000000000000000 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz na po nc
fffff880`08450d16 c7401800000000  mov     dword ptr [rax+18h],0 ds:7110:00000000`00000018=????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff800032e0229 to fffff800032e0c80

fffff880`0e239568 fffff800`032e0229 : 00000000`0000000a 00000000`00000018 00000000`00000002 00000000`00000001 : nt!KeBugCheckEx
fffff880`0e239570 fffff800`032deea0 : fffffa80`055bceb0 fffff880`0167c8d0 fffff880`08c525c0 fffffa80`0823f1a0 : nt!KiBugCheckDispatch+0x69
fffff880`0e2396b0 fffff880`08450d16 : fffffa80`0823f1a0 fffffa80`08a16300 fffffa80`08a16300 00000000`00000001 : nt!KiPageFault+0x260
fffff880`0e239840 fffffa80`0823f1a0 : fffffa80`08a16300 fffffa80`08a16300 00000000`00000001 00000000`00000000 : athrx+0x18d16
fffff880`0e239848 fffffa80`08a16300 : fffffa80`08a16300 00000000`00000001 00000000`00000000 fffffa80`08a16478 : 0xfffffa80`0823f1a0
fffff880`0e239850 fffffa80`08a16300 : 00000000`00000001 00000000`00000000 fffffa80`08a16478 00000000`00000000 : 0xfffffa80`08a16300
fffff880`0e239858 00000000`00000001 : 00000000`00000000 fffffa80`08a16478 00000000`00000000 fffffa80`08a5ba78 : 0xfffffa80`08a16300
fffff880`0e239860 00000000`00000000 : fffffa80`08a16478 00000000`00000000 fffffa80`08a5ba78 fffffa80`08a5ba50 : 0x1


fffff880`08450d16 c7401800000000  mov     dword ptr [rax+18h],0


SYMBOL_NAME:  athrx+18d16

FOLLOWUP_NAME:  MachineOwner


IMAGE_NAME:  athrx.sys


FAILURE_BUCKET_ID:  X64_0xD1_athrx+18d16

BUCKET_ID:  X64_0xD1_athrx+18d16

Followup: MachineOwner
It appears your Atheros wireless network adapter driver is corrupted. Did you update it with the automated software, by chance? This may be an example of what I was saying before...

Download the latest driver for your wireless card from ATHEROS Wireless drivers for Windows by selecting the blue check mark furthest to the right for AR9285. Then click the Click for Download button. The download should start automatically on the next page. Do not click any of the links on that page as they will take you to unsecure sites.

Now, I will give some information that most do not know because they have not had an Atheros driver on their systems themselves or maybe they were just lucky not to have the problem that many have updating these drivers. The Atheros drivers for some reason cause problems in Windows. When you install them to overwrite the current drivers via the install package that vendors provide, they don't stick. I do not know why. Also, if a user tries to update them through device manager, for some reason, Windows informs the user that the system already has the most up to date drivers. Again, I do not know why. There is a special procedure that must be followed for these devices to update them properly.

Now that you have downloaded the latest Atheros package, here are the steps to install it so it sticks and actually updates the drivers for the device.
  1. Click Start Menu
  2. Right Click My Computer/Computer
  3. Click Manage
  4. Click Device Manager from the list on the left
  5. Expand Network adapters
  6. Right click the Atheros network device
  7. Click Uninstall (do not click OK in the dialog box that pops up after hitting Uninstall)
  8. Put a tick in Delete driver software for this device and hit OK
  9. Do not restart your computer
  10. Install the downloaded driver for the Atheros network device.

  1. Login as an adminstrative user.
  2. First, download the latest driver. Then do the next steps.
  3. Click Start Menu
  4. Click Control Panel
  5. Click Hardware and Sound
  6. Click Device Manager (the last link under Devices and Printers)
  7. Expand Network adapters
  8. Right click the Atheros network device
  9. Click Uninstall (do not click OK in the dialog box that pops up after hitting Uninstall)
  10. Put a tick in Delete driver software for this device and hit OK
  11. Do not restart your computer
  12. Install the downloaded driver for the Atheros network device.
To install the downloaded driver, follow the steps in Driver Install - Add Hardware Wizard ; follow steps 1-6 exactly, then browse for where you saved the Atheros drivers and install as in steps 7-14 but for the Atheros drivers instead of the NETOEM driver.
My System SpecsSystem Spec
16 Apr 2012   #3

Windows 7 home premium 64bit

Thanks heaps for your reply ! And yeah, I had tried installing a new Atheros driver using that driver scanner thingy, though it failed in updating the driver, can't remember whether it gave a reason for failing, or not. Anyway I went and downloaded the new driver you gave a link to, but when trying to install it the manual way, the tutorial was about, I got all the way to the step where you select your driver from the location you downloaded them to. I then found two .inf files from the folder, but neither then gave me any manufacturers nor network adapters to choose from. I then tried installing them through device manager and it seems like it succeeded in doing it. Assuming that when looking at my network adapters, and their installed drivers, it does say it's the new one found behind the link you gave me. Guess all there is to do is wait and see whether the problem still persist.
My System SpecsSystem Spec

16 Apr 2012   #4

Windows 7 Home Premium 64 Bit

Alright, see how the system responds for a few days and post back. Also, who manufactured your system and what model is it? The Atheros driver is likely provided by the manufacturer, as well, and should be easier to install if you have further problems with it.
My System SpecsSystem Spec

 BSOD during casual surfing on the web, error 0000000000000018

Thread Tools

Similar help and support threads
Thread Forum
BSOD surfing on web, error 0x0000000a
Im getting random blue screens while surfing on internet.
BSOD Help and Support
BSOD surfing web, error 0x0000003B
Hi! System crashed when I surfing web. On BSOD was L1C60x64.sys BSOD so often... usually with code 01E Dump scanned with SF Diagnostic attached.
BSOD Help and Support
BSOD while casual surfing
The logs are made via SF_Diagnostic_Tool and attached, please help. :cry:
BSOD Help and Support
BSOD while surfing the web or leaving it idle, error 7a
Hi, I randomly get the BSOD error 7a while surfing the internet or just leaving it idle. I have no idea what causes it since it seems to be random.
BSOD Help and Support
BSOD while surfing, error 000000F4
Had this comp for 2 years with no problems until April then the BSOD started. Had just started playing Fiesta and having problems with game and over next couple months BSOD became more frequent. Decided game was at fault so quit playing, followed by a period with no BSOD, then it started again. Had...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:10.
Twitter Facebook Google+