Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD When Playing StarCraft 2

19 Apr 2012   #1

Windows 7 Home Premium 64-bit
BSOD When Playing StarCraft 2


I am receiving BSOD when playing starcraft 2. I have reinstalled Windows and am still receiving BSOD. Attached you will find the latest DMP file available.

Thank you kindly for your assistance.


Windows 7 Home Premium 64 Bit SP1
Model: p6813w

Processor: AMD Athlon II X4 645 Processor 3.10Ghz
RAM: 6.00GB
Motherboard: Alvorix RS880
Video Card: PNY XLR8 GeForce GTX 550 Ti
Audio: Onboard

My System SpecsSystem Spec
19 Apr 2012   #2

Windows 7 Home Premium 64-bit

Just to clarify, I am not overclocking the video card. All that was altered was the fan speed.
My System SpecsSystem Spec
19 Apr 2012   #3

Windows 7 Home Premium 64-bit

Thank you for responding. Yes I have.
My System SpecsSystem Spec

19 Apr 2012   #4


Does this happen only when playing starcraft??

What other games do you play?
My System SpecsSystem Spec
19 Apr 2012   #5

Windows 7 Home Premium 64-bit

Well, it started while playing starcraft. Then I reinstalled Windows and did not reinstall Starcraft because the BSOD persisted even tho SC2 was not installed. I do not have any other games installed.
My System SpecsSystem Spec
19 Apr 2012   #6

Windows 7 Home Premium 64-bit

Anyone else have any insight or point me in the right direction
My System SpecsSystem Spec
20 Apr 2012   #7


My System SpecsSystem Spec
21 Apr 2012   #8

Windows 7 Home Premium 64 Bit

Microsoft (R) Windows Debugger Version 6.12.0002.633 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [D:\Kingston\BSODDmpFiles\deebirch\041912-19890-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*C:\SymCache*
Executable search path is: 
Windows 7 Kernel Version 7601 (Service Pack 1) MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Built by: 7601.17727.amd64fre.win7sp1_gdr.111118-2330
Machine Name:
Kernel base = 0xfffff800`02201000 PsLoadedModuleList = 0xfffff800`02445650
Debug session time: Wed Apr 18 21:49:18.679 2012 (UTC - 6:00)
System Uptime: 0 days 0:01:14.179
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 1E, {0, 0, 0, 0}

Probably caused by : USBPORT.SYS ( USBPORT!USBPORT_Core_iMapTransfer+24a )

Followup: MachineOwner

3: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

This is a very common bugcheck.  Usually the exception address pinpoints
the driver/function that caused the problem.  Always note this address
as well as the link date of the driver/image that contains this address.
Arg1: 0000000000000000, The exception code that was not handled
Arg2: 0000000000000000, The address that the exception occurred at
Arg3: 0000000000000000, Parameter 0 of the exception
Arg4: 0000000000000000, Parameter 1 of the exception

Debugging Details:

EXCEPTION_CODE: (Win32) 0 (0) - The operation completed successfully.

00000000`00000000 ??              ???

EXCEPTION_PARAMETER1:  0000000000000000

EXCEPTION_PARAMETER2:  0000000000000000







EXCEPTION_RECORD:  fffff88001ef67c8 -- (.exr 0xfffff88001ef67c8)
ExceptionAddress: fffff800023ab617 (nt!ExAllocatePoolWithTag+0x0000000000000537)
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 0000000000000000
   Parameter[1]: ffffffffffffffff
Attempt to read from address ffffffffffffffff

TRAP_FRAME:  fffff88001ef6870 -- (.trap 0xfffff88001ef6870)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=effffa8006636990 rbx=0000000000000000 rcx=fffffa800610a650
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff800023ab617 rsp=fffff88001ef6a00 rbp=0000000000001000
 r8=0000000000000000  r9=fffff80002407520 r10=fffff80002407348
r11=0000000000000005 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl zr na po nc
fffff800`023ab617 48895808        mov     qword ptr [rax+8],rbx ds:f980:effffa80`06636998=????????????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff800022756fe to fffff8000227dd10

fffff880`01ef58a8 fffff800`022756fe : fffeffff`dfffffef f5d7aef7`dffdef7d fffff880`01ef6020 fffff800`022a8da0 : nt!KeBugCheck
fffff880`01ef58b0 fffff800`022a8a6d : fffff800`0248671c fffff800`023c3078 fffff800`02201000 fffff880`01ef67c8 : nt!KiKernelCalloutExceptionHandler+0xe
fffff880`01ef58e0 fffff800`022a7845 : fffff800`023c6fac fffff880`01ef5958 fffff880`01ef67c8 fffff800`02201000 : nt!RtlpExecuteHandlerForException+0xd
fffff880`01ef5910 fffff800`022b87c1 : fffff880`01ef67c8 fffff880`01ef6020 fffff880`00000000 00000000`00000000 : nt!RtlDispatchException+0x415
fffff880`01ef5ff0 fffff800`0227d3c2 : fffff880`01ef67c8 fffff800`02407520 fffff880`01ef6870 00000000`0000000b : nt!KiDispatchException+0x135
fffff880`01ef6690 fffff800`0227bcca : fffffa80`058e78b0 fffff880`029ef48f fffffa80`0613000c fffff880`01ef68f8 : nt!KiExceptionDispatch+0xc2
fffff880`01ef6870 fffff800`023ab617 : 00000000`00000000 fffffa80`060e4d00 fffffa80`061348a0 00000000`00000000 : nt!KiGeneralProtectionFault+0x10a
fffff880`01ef6a00 fffff800`027ed6a5 : fffffa80`00000000 00000000`00000000 fffffa80`06eff050 fffffa80`00000000 : nt!ExAllocatePoolWithTag+0x537
fffff880`01ef6af0 fffff800`027ed420 : fffffa80`06eff050 00000000`00000005 fffffa80`000000a0 fffff880`02835e6b : hal!HalBuildScatterGatherList+0x279
fffff880`01ef6b60 fffff880`02834586 : fffffa80`06eff050 00000000`00000000 fffffa80`06effd28 fffffa80`067fdc20 : hal!HalGetScatterGatherList+0x44
fffff880`01ef6bc0 fffff880`02831ea6 : fffffa80`06692110 fffffa80`06eff050 fffff800`027ed3dc fffffa80`06eff1a0 : USBPORT!USBPORT_Core_iMapTransfer+0x24a
fffff880`01ef6c40 fffff880`02822f89 : fffffa80`06eff050 00000000`00000000 fffffa80`06effd02 fffffa80`06effd28 : USBPORT!USBPORT_Core_UsbMapDpc_Worker+0x296
fffff880`01ef6ca0 fffff800`0228851c : fffff880`01ece180 fffffa80`06effd28 fffffa80`06effd40 00000000`00000000 : USBPORT!USBPORT_Xdpc_Worker+0x1d9
fffff880`01ef6cd0 fffff800`02275a6a : fffff880`01ece180 fffff880`01ed8fc0 00000000`00000000 fffff880`02822db0 : nt!KiRetireDpcList+0x1bc
fffff880`01ef6d80 00000000`00000000 : fffff880`01ef7000 fffff880`01ef1000 fffff880`01ef6d40 00000000`00000000 : nt!KiIdleLoop+0x5a


fffff880`02834586 4c63c0          movsxd  r8,eax



FOLLOWUP_NAME:  MachineOwner




FAILURE_BUCKET_ID:  X64_0x1E_0_USBPORT!USBPORT_Core_iMapTransfer+24a

BUCKET_ID:  X64_0x1E_0_USBPORT!USBPORT_Core_iMapTransfer+24a

Followup: MachineOwner
You crash analysis above shows a USB device caused the crash. What USB devices do you have plugged into your system?

Do some USB troubleshooting.
  • Start with USB Driver - General Fix for Problems to resolve the USB issues. Also, USB ports can sometimes enter a safe power state to protect the system from power surges due to USB devices. To reset the USB ports to a nominal power state:
    1. Shut down and turn off the computer.
    2. Unplug the computer from the wall or surge protector (then remove the battery if it is a laptop).
    3. "Remove the computer from any port replicator or docking station, disconnect
      cables to printers or devices such as external monitors, USB memory sticks or SD cards, headset or external speakers, mouse or auxiliary keyboard, turn off WIFI and Bluetooth wireless devices." (Use Hard Reset to Resolve Hardware and Software Issues HP Pavilion dv5000 Notebook PC series - HP Customer Care (United States - English))
    4. Hold down the power button for 30 seconds. This closes the circuit and ensures all
      power from components is drained to clear the software connections between the BIOS
      and hardware and clear any corruption in the temporary memory.
    5. (If it is a laptop, plug the battery back into the laptop and then) Plug the computer back into the wall. Do not reconnect any unnecessary peripherals; monitor, keyboard,
      and mouse should suffice and be the only peripherals reconnected.
    6. Turn it on to reinitialize the software connections between the BIOS and hardware
My System SpecsSystem Spec
25 Apr 2012   #9

Windows 7 Home Premium 64-bit

I have an external HD, keyboard, mouse, external sound card and midi controller plugged into the PC.

Sorry for the delayed response, the PC has not been booting up. Got lucky today and its been running.

I will try everything layed out by you guys and get back to you. Thanks.
My System SpecsSystem Spec
05 May 2012   #10

Windows 7 Home Premium 64-bit

Quote   Quote: Originally Posted by TGSoldier View Post
Sorry for the delay. I havent been able to get the PC booted. I ran both and did not find any errors.

"Windows Resource Protection did not find any integrity violations"

Attached are the newest DMP files. Any help is greatly appreciated.

My System SpecsSystem Spec

 BSOD When Playing StarCraft 2

Thread Tools

Similar help and support threads
Thread Forum
BSOD playing StarCraft II
New build.graphic card drivers up to date as far as I can tell. I've run memory tests & HDD scans. All OK. I attached your diagnostic results. I can't figure out which driver is giving me grief please help thanks in advance.
BSOD Help and Support
BSOD when playing Starcraft 2
Some Specs AMD Athlon(tm) II X4 630 Processor Microsoft Windows 7 Home Premium 4.0 GB RAM NVIDIA GeForce GTX 550 Ti 1GB 589 GB / 916 GB HDD
BSOD Help and Support
BSOD playing starcraft
Hi all, I have had some BSOD. My game comes to a screaching halt, the audio screams, i get the BSOD but not long enough to read. Neither is there a dump file. I ran memtest a few times, all passes, no errors. I ran driver verifier a whole day, without getting a bsod. I cleaned my pc, checked for...
BSOD Help and Support
BSOD playing Starcraft 2
Hi everyone I've been having problems for a while now getting BSOD playing Starcraft 2 (and I think on skyrim as well although I don't play it as much) I'm not entirely clear what I'm supposed to write here to accompany the zipped folders so tell me if you need to know something else please. ...
BSOD Help and Support
BSOD while playing Starcraft 2
Hi all, recently i've been suffering from BOSD while i am playing starcraft2 i've tried to analyse minidump but not sure what exactly to look for please help me out here, i've attached my recent minidump in the post system details OS Windows 7 Ultimate x64 CPU i7 930 @4GHz (21 x 190)...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 16:08.
Twitter Facebook Google+