Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD while running firefox and keepass

27 Apr 2012   #1

Windows 7 Home Premium 64 bit
BSOD while running firefox and keepass

This is about the third or fourth time i've had a BSOD over the last few months and as far as i can see the connecting thread was using firefox with keepass running in the background but i can't read the dmp file since it's all scrambled. I hoped posting it here would let me read it.

I ran the SF Diagnostic Tool to get the dmp file but how do you read the damn thing? Opening it in notepad just shows garbage.

My System SpecsSystem Spec
27 Apr 2012   #2

Windows 7 Home Premium 64 bit

I ran through the suggestion in the BSOD posting instructions which i admit i should have done in the first place. Sorry.

I believe there may be an IRQ conflict somewhere. When it went to the BSOD the first line said 'IRQ_NOT_LESS_OR_EQUAL'.

-Windows 7 Home Premium 64
-Original OS
-OEM but an unbranded PC from a custom builder

-OS and hardware are 2 years old this month and no reinstall.
My System SpecsSystem Spec
28 Apr 2012   #3

Windows 7 Home Premium 64 Bit

You do not have any Windows updates installed. I would recommend installing all Windows updates to start.

Microsoft (R) Windows Debugger Version 6.12.0002.633 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [D:\Kingston\BSODDmpFiles\rawshark\Windows_NT6_BSOD_jcgriff2\042712-15475-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*C:\SymCache*
Executable search path is: 
Windows 7 Kernel Version 7600 MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS Personal
Built by: 7600.16539.amd64fre.win7_gdr.100226-1909
Machine Name:
Kernel base = 0xfffff800`02c0c000 PsLoadedModuleList = 0xfffff800`02e49e50
Debug session time: Fri Apr 27 13:12:14.595 2012 (UTC - 6:00)
System Uptime: 0 days 0:51:55.015
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck A, {0, 2, 0, fffff80002c8069f}

Probably caused by : dxgmms1.sys ( dxgmms1!VidMmiProcessTerminationCommand+5f )

Followup: MachineOwner

2: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If a kernel debugger is available get the stack backtrace.
Arg1: 0000000000000000, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, bitfield :
	bit 0 : value 0 = read operation, 1 = write operation
	bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
Arg4: fffff80002c8069f, address which referenced memory

Debugging Details:

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff80002eb40e0


fffff800`02c8069f 488b09          mov     rcx,qword ptr [rcx]





TRAP_FRAME:  fffff880025b9a50 -- (.trap 0xfffff880025b9a50)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=fffffa80068c54e8 rbx=0000000000000000 rcx=0000000000000000
rdx=0000000000000000 rsi=0000000000000000 rdi=0000000000000000
rip=fffff80002c8069f rsp=fffff880025b9be0 rbp=0000000000000000
 r8=0000000000000000  r9=0000000000000000 r10=0000000000000000
r11=fffff880025b9c20 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl nz ac po cy
fffff800`02c8069f 488b09          mov     rcx,qword ptr [rcx] ds:0001:00000000`00000000=????????????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80002c7bb69 to fffff80002c7c600

fffff880`025b9908 fffff800`02c7bb69 : 00000000`0000000a 00000000`00000000 00000000`00000002 00000000`00000000 : nt!KeBugCheckEx
fffff880`025b9910 fffff800`02c7a7e0 : fffffa80`068c54e0 fffffa80`068c54e0 00000000`00000000 fffff880`02f63180 : nt!KiBugCheckDispatch+0x69
fffff880`025b9a50 fffff800`02c8069f : 00000000`00000001 fffff880`041461cc 00000000`00000000 fffffa80`05b99501 : nt!KiPageFault+0x260
fffff880`025b9be0 fffff880`0415636b : fffffa80`00000000 00000000`00000000 fffffa80`063b2500 fffff880`025b9ca0 : nt!KeSetEvent+0x10f
fffff880`025b9c50 fffff880`0417416d : fffffa80`00000000 fffffa80`0568c410 00000000`0000000f fffff880`04175f09 : dxgmms1!VidMmiProcessTerminationCommand+0x5f
fffff880`025b9ca0 fffff880`041733f8 : fffff800`00b96080 fffffa80`05b99570 00000000`00000000 fffffa80`0568c410 : dxgmms1!VidSchiSubmitDeviceCommand+0x39
fffff880`025b9cd0 fffff880`04172e96 : 00000000`00000000 fffffa80`05b3fac0 00000000`00000080 fffffa80`0568c410 : dxgmms1!VidSchiSubmitQueueCommand+0xb0
fffff880`025b9d00 fffff800`02f21a86 : 00000000`02054a7f fffffa80`056eab60 fffffa80`0366db30 fffffa80`056eab60 : dxgmms1!VidSchiWorkerThread+0xd6
fffff880`025b9d40 fffff800`02c5ab06 : fffff800`02df6e80 fffffa80`056eab60 fffff800`02e04c40 fffff880`01229a90 : nt!PspSystemThreadStartup+0x5a
fffff880`025b9d80 00000000`00000000 : fffff880`025ba000 fffff880`025b4000 fffff880`025b9690 00000000`00000000 : nt!KxStartSystemThread+0x16


fffff880`0415636b 33d2            xor     edx,edx


SYMBOL_NAME:  dxgmms1!VidMmiProcessTerminationCommand+5f

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: dxgmms1

IMAGE_NAME:  dxgmms1.sys


FAILURE_BUCKET_ID:  X64_0xA_dxgmms1!VidMmiProcessTerminationCommand+5f

BUCKET_ID:  X64_0xA_dxgmms1!VidMmiProcessTerminationCommand+5f

Followup: MachineOwner
The above crash was DirectX/graphics card related.
  • Try re-installing DirectX using the Download: DirectX Redist (June 2010) - Microsoft Download Center - Download Details and see how the system responds.

    Follow the steps for Diagnosing basic problems with DirectX. To re-install your display card drivers as outlined in the DirectX link, use the following steps.
    1. Download the drivers you want for your display card(s)
    2. Click Start Menu
    3. Click Control Panel
    4. Click Uninstall a program
    5. For NVIDIA:
      • Uninstall the NVIDIA Graphics Driver (this should uninstall all NVIDIA software and drivers)
      • Restart your computer
      • Make sure NVIDIA 3D Vision Driver, NVIDIA 3D Vision Video Player, NVIDIA HD Audio Driver, and NVIDIA PhysX System Software are not still listed under Uninstall a program through Control Panel
      • If any remain of the above, uninstall one at a time
      • If asked to restart after uninstalling any of the above, do so, and continue uninstalling any remaining NVIDIA items until all are removed
    6. For AMD:
      • Uninstall AMD Catalyst Install Manager if it is listed (this should remove all AMD graphics software and drivers)
      • If AMD Catalyst Install Manager is not listed, use the following method to uninstall the graphics drivers:
        1. Click Start Menu
        2. Right Click My Computer/Computer
        3. Click Manage
        4. Click Device Manager from the list on the left
        5. Expand Display adapters
        6. Do the following for each adapter (in case you have multiple display cards)
          • Right click the adapter
          • Click Uninstall (do not click OK in the dialog box that pops up after hitting Uninstall)
          • Put a tick in Delete driver software for this device (if this option is available, otherwise just hit OK) and hit OK

          1. Login as an adminstrative user
          2. Click Start Menu
          3. Click Control Panel
          4. Click Hardware and Sound
          5. Click Device Manager (the last link under Devices and Printers)
          6. Expand Display adapters
          7. Do the following for each adapter (in case you have multiple display cards)
            • Right click the adapter
            • Click Uninstall (do not click OK in the dialog box that pops up after hitting Uninstall)
            • Put a tick in Delete driver software for this device (if this option is available, otherwise just hit OK) and hit OK
      • Restart your computer after uninstalling drivers for all display cards
      • Install the driver you selected for the display cards once Windows starts
My System SpecsSystem Spec

28 Apr 2012   #4

Windows 7 Home Premium 64 bit

That's interesting because i do have windows updates installed which are shown when i go into 'view update history' but when i go into 'installed updates' nothing is listed and nothing comes up when i check for new updates. Win7 has always seemed flakey to me when it comes to updates, though i don't have service pack 1 so maybe that would resolve it, but i have never been given the option to download it through updates.

I'll try reinstalling direct x and my catalyst drivers though.

Thanks for your help, much appreciated.
My System SpecsSystem Spec
28 Apr 2012   #5

Windows 7 Home Premium 64 Bit

My System SpecsSystem Spec
28 Apr 2012   #6

Windows 7 Home Premium 64 bit

Thanks for those links, i can never find anything. It feels like you need schooling in the dark arts to find stuff buried in microsoft's servers sometimes.
My System SpecsSystem Spec
28 Apr 2012   #7

Windows 7 Home Premium 64 Bit

Sometimes it helps to know tricks with Google, too.

In Google, for instance, you could search for
Code: Windows 7 Service Pack 1 Windows 7 Update Readiness Tool
My System SpecsSystem Spec
28 Apr 2012   #8

Windows 7 Home Premium 64 bit

Yeah it's just the number of variations of patches and updates and tools can be a bit overwhelming.

Anyway, i've reinstalled direct x and updated my graphics drivers so i'll see if that resolves the initial problem. I ran the update readiness tool and according to the logs no problems were found, though in the steps to follow before installing the service pack i couldn't install the three updates it suggests. Each one said that it was not applicable to my computer even though i got the x64 versions. So now i'm just going ahead with downloading SP1 and see if i can install it.
My System SpecsSystem Spec
28 Apr 2012   #9

Windows 7 Home Premium 64 Bit

Sounds like good steps. Let us know how things go after the DirectX/Graphics Card re-installs, and keep us posted on how SP1 installs. If you have any troubles installing SP1, feel free to start a thread in Windows Updates & Activation - Windows 7 Forums where experts reside for fixing Windows update problems.
My System SpecsSystem Spec
29 Apr 2012   #10

Windows 7 Home Premium 64 bit

I'll wait and see how the direct x and graphic driver reinstalls fair but SP1 failed to install unfortunately, even after trying numerous solutions so i'll check out that other forum. Thanks.
My System SpecsSystem Spec

 BSOD while running firefox and keepass

Thread Tools

Similar help and support threads
Thread Forum
BSOD while running Firefox
Hello, I'm using win7 on my desktop with the following config: Intel duel core 3Ghz processor with intel(R) G41 Express chipset motherboard 1 TB Hitachi HD 4 GB RAM. For last few weeks I'm having trouble while using Firefox. Suddenly firefox stops working and within a few seconds...
BSOD Help and Support
BSOD - Randomly often while Firefox is running
Greetings, I have set-up a new computer system and facing BSOD from time to time. I have not noticed a special program running except for Firefox, but that browser is running nearly at all times. I'll add the SF Diagnostic Tool Zip to this post. Please tell me, if I need to add information. ...
BSOD Help and Support
BSOD while in the middle running multiple firefox windows.
Hello all, I'm a help desk analyst and I run one instance of IE with about 6 tabs open and one instance of Firefox with about 6 tabs open supporting end users. Each day or Every other day it seems like I get this same BSOD while in the middle of working in firefox / internet explorer. See below...
BSOD Help and Support
BSOD After Installing and Running Firefox
I need help. I am running Windows Seven 32 bit and have been for a couple of years without issue. I recently installed Firefox and a file downloading addin for Firefox. Everything was fine until I needed to restart my computer. Once I restarted everything seemed to load and I got to my...
BSOD Help and Support
BSOD while running Firefox(?), BCCode:10d
I've been running into a bluescreen roughly 20-30 minutes into every Windows 7 session - as far as I can tell, the error code indicates some kind of driver conflict - if someone could take a look at the memory dump for me and confirm that this is the case, and possibly tell me what to do to fix it...
BSOD Help and Support
BSOD while running firefox. Computer has been running terrible.
I was not able to get perfmon /report to work, so I only have the BSOD report.
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:23.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App