Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD bad pool header

14 May 2012   #1

Windows 7 Ultimate 64 bit
BSOD bad pool header

I just recently updated to windows 7 and I have only gotten this BSOD once but I am unsure why I got it and any help will be appreciated. This error happened while I was opening league of legends. Please let me know if I need to include anything else.

Attached is the minidump and a screen of the error windows gave me.

My System SpecsSystem Spec
14 May 2012   #2
Vir Gnarus

Microsoft Community Contributor Award Recipient

Windows 7 64-bit

This may be a bug from a March version of an Avast driver that you have. It looks to be making an illegal API call. See if there isn't an update you can install for it.

Typically, if a solitary BSOD or unusual symptom occurs, it's best to leave it be unless it repeats. Such hiccups can occur at times, and it's only with repeat offenses should one be concerned. Either way, go ahead and update Avast and be vigilant.


2: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

The pool is already corrupt at the time of the current request.
This may or may not be due to the caller.
The internal pool links must be walked to figure out a possible cause of
the problem, and then special pool applied to the suspect tags or the driver
verifier to a suspect driver.
Arg1: 0000000000000003, the pool freelist is corrupt.
Arg2: fffffa8003961770, the pool entry being checked.
Arg3: 6946657461657243, the read back flink freelist value (should be the same as 2).
Arg4: 775a071b006e6f69, the read back blink freelist value (should be the same as 2).

Debugging Details:

TRIAGER: Could not open triage file : C:\Program Files (x86)\Windows Kits\8.0\Debuggers\x64\triage\modclass.ini, error 2






LAST_CONTROL_TRANSFER:  from fffff80002daa4b3 to fffff80002c801c0

fffff880`084046c8 fffff800`02daa4b3 : 00000000`00000019 00000000`00000003 fffffa80`03961770 69466574`61657243 : nt!KeBugCheckEx
fffff880`084046d0 fffff880`01081819 : 00000000`00000001 fffffa80`0413aa50 fffffa80`066dc850 fffffa80`00000000 : nt!ExDeferredFreePool+0xa53
fffff880`084047c0 fffff880`01611be3 : 00000000`00000000 00000000`00000000 fffffa80`04ad6108 fffffa80`04ad6108 : fltmgr!FltpReallocNameControl+0x39
fffff880`084047f0 fffff880`0107a035 : fffffa80`0466e3b0 fffff8a0`0a08f6f0 fffffa80`00000000 00000000`00000000 : luafv!LuafvGenerateFileName+0x9b
fffff880`08404820 fffff880`01079ead : fffff880`02fd3100 fffffa80`04ad6108 fffffa80`0466e3b0 fffff880`08404a14 : fltmgr!FltpCallOpenedFileNameHandler+0x75
fffff880`08404860 fffff880`01065b9d : c00000bb`00000000 00000000`00000000 fffffa80`06868b00 fffffa80`06868020 : fltmgr!FltpCreateFileNameInformation+0x17d
fffff880`084048c0 fffff880`0105fbf6 : fffffa80`04518100 fffffa80`06868010 fffffa80`04ad6108 fffff800`02c7ba10 : fltmgr!HandleStreamListNotSupported+0x15d
fffff880`08404900 fffff880`01066b44 : fffffa80`066dc800 00000000`00000000 fffffa80`06868010 00000000`00000102 : fltmgr! ?? ::FNODOBFM::`string'+0x30f3
fffff880`08404980 fffff880`03e72717 : fffffa80`0466e3b0 fffffa80`0466f450 00000000`00000000 fffffa80`04ad6108 : fltmgr!FltGetFileNameInformation+0x184
fffff880`08404a10 fffffa80`0466e3b0 : fffffa80`0466f450 00000000`00000000 fffffa80`04ad6108 00610065`00650076 : aswSnx+0x3717
fffff880`08404a18 fffffa80`0466f450 : 00000000`00000000 fffffa80`04ad6108 00610065`00650076 00000000`00000000 : 0xfffffa80`0466e3b0
fffff880`08404a20 00000000`00000000 : fffffa80`04ad6108 00610065`00650076 00000000`00000000 fffffa80`04ad6108 : 0xfffffa80`0466f450


2: kd> lmvm aswSnx
start             end                 module name
fffff880`03e6f000 fffff880`03f3c000   aswSnx   T (no symbols)           
    Loaded symbol image file: aswSnx.SYS
    Image path: \SystemRoot\System32\Drivers\aswSnx.SYS
    Image name: aswSnx.SYS
    Timestamp:        Tue Mar 06 19:04:05 2012 (4F56A5F5)
    CheckSum:         000CF38B
    ImageSize:        000CD000
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
2: kd> !error c00000bb
Error code: (NTSTATUS) 0xc00000bb (3221225659) - The request is not supported.
I may be reading this wrong, so take this analysis with a grain of salt. Best thing to do is to have client use Driver Verifier if the issue repeats.

Btw, when looking at the values given by Arg3 and Arg4 of the bugcheck:

2: kd> .formats 6946657461657243
Evaluate expression:
  Hex:     69466574`61657243
  Decimal: 7585862172876829251
  Octal:   0645063127214131271103
  Binary:  01101001 01000110 01100101 01110100 01100001 01100101 01110010 01000011
  Chars:   iFetaerC
  Time:    Mon Aug 22 21:41:27.682 25639 (UTC - 4:00)
  Float:   low 2.64534e+020 high 1.49904e+025
  Double:  1.33932e+199
2: kd> .formats 775a071b006e6f69
Evaluate expression:
  Hex:     775a071b`006e6f69
  Decimal: 8600194250970132329
  Octal:   0735320161540033467551
  Binary:  01110111 01011010 00000111 00011011 00000000 01101110 01101111 01101001
  Chars:   wZ...noi
  Time:    Sat Dec  6 08:44:57.013 28853 (UTC - 4:00)
  Float:   low 1.01419e-038 high 4.42213e+033
  Double:  8.39253e+266
No words I can think of, maybe foreign language? Anyways, they do appear to be parts of a character string (at least the first one does). I can't figure if it's code.
My System SpecsSystem Spec
14 May 2012   #3

Windows 7 Ultimate 64 bit

Thanks for the quick response, ill try to update and will use driver verifier if it keeps occuring.
My System SpecsSystem Spec

14 May 2012   #4
Vir Gnarus

Microsoft Community Contributor Award Recipient

Windows 7 64-bit

To use DV properly, you'll want to consult the article here. For the checks to run, select all except Low Resource Sim, Force Pending I/O Requests, and IRP Logging. Restart after everything is finished. Keep DV 'running' until you get a crash or two. You can turn it off in Safe Mode if you get a reboot loop after turning it on. Again, provide us the crashdumps.
My System SpecsSystem Spec

 BSOD bad pool header

Thread Tools

Similar help and support threads
Thread Forum
BSOD on Steam Update, Bad Pool Caller or Bad Pool Header, no dmp files
Good day all, I hope someone can help me with a consistent BSOD problem I've had today. Every time my Steam client starts up and attempts to download its latest update, I get a BSOD with a Bad Pool Caller (one time out of about a dozen crashes it was Bad Pool Header instead). I have tried the...
BSOD Help and Support
Bad Pool Header BSOD
This has happened several times. Usually the only thing I have open is web browsers. This has happened with Firefox open, but most recently with Chrome open. I have a Dell Inspiron N7010 with 6 GB RAM Windows 7 Home Premium SP1 64-bit
BSOD Help and Support
BSOD - Bad Pool Header
Hello, Thank you in advance for all help; it is much appreciated. I like to fall asleep to a movie, so I play a video on VLC. When the video has finished, Sleep# puts the computer to sleep. The next morning, I woke the computer from sleep mode to see the BSOD. I have tried updating...
BSOD Help and Support
Bsod bad pool header
Hi I get a BSOD everytime I try to plug in the new monitor I purchased. The monitor is a Yamakasi Catleap 2703. If you need any other information let me know. Thanks for your help. Mitch
BSOD Help and Support
[BSOD] Bad Pool Header
This is a complete new system, that I've put together and recently I've been plagued with a BSOD message, as the title describes it. A Bad Pool Header. I have no idea what is causing it, but I have made sure all my drives are up-to-date, though I might be wrong, and I hope to be wrong. As I fear it...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:55.
Twitter Facebook Google+