Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Order number 379 was not found in the dynamic link library

23 May 2012   #1

Windows 7 Home Premium 64 bit
ordinal 379 was not found in the dynamic link library

So this is "kind of" the message i get up when trying to install champions online, i also get it when starting up diablo 3, now it doesnt affect diablo 3 as i am aware of. The problem is that i cant install this game, the game itself is not a install file but a downloader for the game, the error seems to be part of iertutil.dll, this problem occured after reinstalling and reformating the hard drive because of an error that suddenly occured to me, is there any easy fix for this ? Thank you in advance and i am sorry for my bad spelling :)


Edit1: So i found out that i currently have the Iertutill.dll file, so the problem must have something to do with this ordinal 379, i have no idea of what it is, and i have no idea how to insert it into the dynamic link library, i am aware of that it has something to do with explorer.exe

My System SpecsSystem Spec
23 May 2012   #2

Windows 7 Home Premium 64 Bit

Here are the results of a Google search: ordinal 379 could not be located - Google Search. I found lots of hits for similar problems, but no solution. If you find one, do let us know. :)

And I am fairly certain it is ordinal 379, not order number 379.

This may be a good place to start: cannot connect to internet getting message ordinal 379 - Microsoft Answers
My System SpecsSystem Spec
23 May 2012   #3

Windows 7 Home Premium 64 bit

Ahh okay thank's, ill edit that ^^
Ye, i could not find any solutions eighter, but i suspect it might be the hardrive acting up :/
My System SpecsSystem Spec

23 May 2012   #4

Windows 7 Home Premium 64 Bit

Hard disk problems can encompass a number of things. They could mean hard disk corruption, bad sectors, a failing hard disk, Windows files or registry corruption, viruses, or memory problems.

Here are the steps I recommend to determine which:
  • If you are overclocking any hardware, please stop.

  • Run Disk Check with both boxes checked for all HDDs and with Automatically fix file system errors checked for all SSDs. Post back your logs for the checks after finding them using Check Disk (chkdsk) - Read Event Viewer Log (you may need to search for wininit instead of chkdsk).
    For any drives that do not give the message:
    Windows has checked the file system and found no problems
    run disk check again as above. In other words, if it says:
    Windows has made corrections to the file system
    after running the disk check, run the disk check again.

  • Run the short and long tests with SeaTools for HDDs.
    SeaTools for Windows

    SeaTools for DOS
  • If you have an SSD, make sure the following are up to date:
    • SSD firmware
    • BIOS Version
    • Chipset Drivers
    • Hard disk controller drivers/SATA drivers
    • If you have a Marvell IDE ATA/ATAPI device, uninstall it in device manager and see if the system performs better.

  • Check Windows for corruption. Run SFC /SCANNOW Command - System File Checker up to three times to fix all errors with a restart in between each. Post back if it continues to show errors after a fourth run or if the first run comes back with no integrity violations. Use OPTION THREE of SFC /SCANNOW Command - System File Checker to provide us with the sfcdetails.txt file if errors occur.

  • Download and install Malwarebytes, update it, do not start the free trial, and then run a full scan. Also run a full scan with your antivirus software installed on your system. If you do not have antivirus software installed, see the Good and Free system security combination. for better security steps and scanning tools. Make sure to update the security software before running the full scan.

  • Run the boot version of Memtest86+ paying close attention to Parts 2 and 3 of the tutorial. Also, in case Memtest86+ misses anything and comes up with no errors, run the extended version of the Windows Memory Diagnostics Tool for at least five passes. These you may want to run overnight since they take a long time to complete (run them an hour before bed each of the next two nights and check before going to sleep that they are still running).
    warning   Warning
    Before you proceed with the following, answer these two questions: Are you still under warranty? Does your warranty allow you to open up the machine to check hardware? If you are unsure of the answers to these questions, contact your system manufacturer. WARNING: The steps that follow can void your warranty!!!

    For Part 3: If You Have Errors: If you swap any memory components, follow these steps for ESD safety:
    1. Shut down and turn off your computer.
    2. Unplug all power supplies to the computer (AC Power then battery for laptops, AC power for desktops)
    3. Hold down the power button for 30 seconds to close the circuit and ensure all power drains from components.
    4. Make sure you are grounded by using proper grounding techniques, i.e. work on an anti-static workbench, anti-static desk, or an anti-static pad. Hold something metallic while touching it to the anti-static surface, or use an anti-static wristband to attach to the anti-static material while working. If you do not have an anti-static workbench, desk, or pad, you can use your computer tower/case by finding a metal hold in it, such as a drive bay.
    Once these steps have been followed, it is safe to remove and replace components within your computer.
My System SpecsSystem Spec
24 May 2012   #5

Windows 7 Home Premium 64 bit

Okay, my computer is not at home but ill do this tomorrow, ill post the log's as i go along
thank you in advance for your help

My System SpecsSystem Spec
24 May 2012   #6

Windows 7 Home Premium 64 Bit

You're welcome. Let us know if you need any help as you go through the steps, as well.
My System SpecsSystem Spec
27 May 2012   #7

Windows 7 Home Premium 64 bit

Hello, i have had even more problems occuring during starting the computer now, not huge problems but the screen goes black for 20-30 seconds before mouse pointer comes up, then at startup the processor is running at 0 %, when i finally manage to get to task mannager and stop google installation tool it runs fine.

PS: I cant run Read Event Viewer Log because it says it is not running at the moment when starting the program, i will try the other steps later, i also tried to run disk check but after running it for 8-12 hours it had come around 30% so i gave up on that.

Another thing that i am wondering about, it's really hot here in norway and the moisture came up to 95%, on a desktop computer can this damage any hardware ? Thank you

I will follow up with the next steps as soon as i get the time, got a lot of work this weekend.

My System SpecsSystem Spec
27 May 2012   #8

Windows 7 Home Premium 64 Bit

For the Google Updater issue: Troubleshoot Application Conflicts by Performing a Clean Startup may help. You should uninstall the application through Start Menu -> Control Panel -> Uninstall a program once you are sure it is the problem.

There was a similar problem yesterday with the Event Viewer on another system:

You may want to see what was suggested for that...

Do you have any temperature monitoring of your system to make sure it is not overheating?

Run some hardware checks.
My System SpecsSystem Spec
28 May 2012   #9

Windows 7 Home Premium 64 bit

All is fine now, instead of following the steps i reinstalled, reformated, updated bios, installed new drivers, updated drivers and all is fine ;] Thank you for the help dough :)
My System SpecsSystem Spec
28 May 2012   #10

Windows 7 Home Premium 64 Bit

No problem. Glad your problem was solved. Thank you for posting what the solution was.

You may mark the thread solved when you feel ready to do so.
My System SpecsSystem Spec

 Order number 379 was not found in the dynamic link library

Thread Tools

Similar help and support threads
Thread Forum
The Ordinal 323 could not be located in the dynamic library error Pic if interested Been having this issue for a couple of days. Don't know when it started as it only comes up when installing Adobe Products it seems. Could have been an issue since I installed Win7. I don't know. Also, I was trying to install a game called...
General Discussion
ordinal 459 could not be located in the dynamic link library urlmon.dl
Quick issue. This has been going on for MONTHS and im sick of it. This issue started happening after i removed some crap called SpyHunter. Because of this error "ordinal 459 could not be located in the dynamic link library urlmon.dll" i have not been able to use a lot of programs and i cant remove...
A dynamic link library (DLL) initialization routine failed
hi, i have windows 7 operating system since a few weeks when ever i right click on my computer folder (pictures, documents etc) i get this error msg: there was a problem starting c\users\ermn\appdata\local\temp\stbxcwc\swwqlrx\wow.dll A dynamic link library (DLL) initialization routine...
General Discussion
Ordinal 120 could not be located in Dynamic Link library iertutil.dl
Hi all, I find an isssue when i try to run my application in windows 7 which is working well in windows xp. The issue comes when i try to open a file from my application.The following error i am getting "Ordinal 120 could not be located in Dynamic Link library...
Custom dynamic link libraries????????
can anyone helptel me what this meeans???:confused::confused::confused: Log Name: System Source: Microsoft-Windows-Wininit Date: 23/05/2010 03:18:49 PM Event ID: 11 Task Category: None Level: Warning Keywords:
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:20.
Twitter Facebook Google+