Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD Playing Metro 2033, error 0x00000124

24 Jun 2012   #1

Windows 7 Ultimate x64
BSOD Playing Metro 2033, error 0x00000124

This is my first post to the forums and I need some help from you guys. I have been having BSOD problems ever since I purchased this computer a couple years back. I never used to play games on my computer, so it used to be just when I turned my MOTU 828mkII off that sometimes I would get BSOD, or when I was watching videos on youtube or similar sites.

Recently though, I bought a new video card and power supply for my computer so I could start playing games on it. I reinstalled Windows 7 before installing the hardware as I had heard that was a good idea when installing new hardware and to run your games at the best performance.

I have been playing games like Blacklight: Retribution, Tribes Ascend, and most recently Metro 2033. All of these games have caused me to have BSODs intermittently. I am really tired of dealing with this problem and could really use some help in trying to pinpoint the problem. I have run the Seagate hard drive long scan, the Windows Memory Diagnostic (4 runs on standard), ran virus scans with Super Anti Spyware, Malware Bytes, and Avira anti virus programs. So far nothing has come up. I have read that the ntoskrnl.exe error may point to RAM and I can't remember what the hal.dll error I am getting was supposed to mean. I also performed the nat sys command prompt reset. And I have also run Prime 95 in the past with no problems.

I should also mention that while playing Blacklight and Tribes my CPU temp was only 44C at maximum. My drivers are also up to date as well.

Here are my system specs:
Windows 7 Ultimate x64 Service Pack 1 Full Retail Version (installed last week)
The OEM was Windows 7 x64 Home

OEM Computer is 2-3 years old

Intel i5-650 3.20 Clarkdale Processor
1TB Seagate ST31000528AS Hard Drive
MOTU 828MKII Firewire Sound Interface
Texas Instruments PCI Firewire Card
Power Color AMD HD 7770 Graphics Card (brand new)
Antec Basiq Plus 550W Power Supply (brand new)

I have also included the BSOD Dump & System File Collection and PERFMON reports. I read the BSOD posting instructions so I hope this is enough information.

My System SpecsSystem Spec
25 Jun 2012   #2

Windows 7 Home Premium 64 Bit

Problematic Software:
Start Menu	Default:Start Menu	Default
Start Menu\Programs\ASIO4ALL v2	Public:Start Menu\Programs\ASIO4ALL v2	Public
Start Menu\Programs\ASUS\ASUSUpdate	Public:Start Menu\Programs\ASUS\ASUSUpdate	Public
Start Menu\Programs\Driver Checker	Public:Start Menu\Programs\Driver Checker	Public
Start Menu\Programs\Driver Genius Professional Edition	Public:Start Menu\Programs\Driver Genius Professional Edition	Public
  • Recommend removing your ASUS utilities through Start Menu -> Control Panel -> Uninstall a program. They can provide software interfaces with the hardware for overclocking, and even when the overclock is not enabled, that interface can cause instability.

  • We do not recommend automated driver update software. It often finds drivers for devices similar to but not exactly the same as the hardware actually on the system. This can lead to conflicts and blue screen crashes. If you need help finding driver updates for a certain device, please start a thread in Drivers - Windows 7 Forums instead of using software. Driver updates are not always necessary and some updates can actually decrease system stability rather than increase it, so it is usually better not to update unless a device or its driver is causing problems with the system. If it ain't broke, don't fix it.

All crashes are 0x124 Hardware Stop BugCheck crashes: Stop 0x124 - what it means and what to try

How long did you run Prime95 tests? Did you run Small FFTs, in place Large FFTs, and Blend for at least three hours each?

Here is what I generally recommend for this BugCheck:
Quote   Quote: Originally Posted by writhziden
BugCheck 0x124

You have a 0x124 hardware bugcheck. If the system is still under warranty, I would recommend sending it in to have diagnostic tests done and any bad hardware replaced.

warning   Warning
Before you proceed with the following, answer these two questions: Are you still under warranty? Does your warranty allow you to open up the machine to check hardware? If you are unsure of the answers to these questions, contact your system manufacturer. WARNING: The steps that follow can void your warranty!!!

For your hardware stop 0x124 crash, read through Stop 0x124 - what it means and what to try and use the following hardware checks to supplement that link.
  • If you are overclocking any hardware, please stop.

  • If you have an SSD, make sure the following are up to date:
    • SSD firmware
    • BIOS Version
    • Chipset Drivers
    • Hard disk controller drivers/SATA drivers
    • If you have a Marvell IDE ATA/ATAPI device, make sure the drivers are up to date from the Intel site or Marvell site and not from your motherboard/vendor support site.

  • Run all but the advanced tests with SeaTools for HDDs.
    SeaTools for Windows

    SeaTools for DOS
  • Monitor temperatures during the following tests.
    Use the following programs to monitor the temperatures.
  • Run the boot version of Memtest86+ paying close attention to Parts 2 and 3 of the tutorial. Also, in case Memtest86+ misses anything and comes up with no errors, run the extended version of the Windows Memory Diagnostics Tool for at least five passes. These you may want to run overnight since they take a long time to complete (run them an hour before bed each of the next two nights and check before going to sleep that they are still running).

    For Part 3: If You Have Errors: If you swap any memory components, follow these steps for ESD safety:
    1. Shut down and turn off your computer.
    2. Unplug all power supplies to the computer (AC Power then battery for laptops, AC power for desktops)
    3. Hold down the power button for 30 seconds to close the circuit and ensure all power drains from components.
    4. Make sure you are grounded by using proper grounding techniques, i.e. work on an anti-static workbench, anti-static desk, or an anti-static pad. Hold something metallic while touching it to the anti-static surface, or use an anti-static wristband to attach to the anti-static material while working. If you do not have an anti-static workbench, desk, or pad, you can use your computer tower/case by finding a metal hold in it, such as a drive bay.
    Once these steps have been followed, it is safe to remove and replace components within your computer.

Remember to read closely through Stop 0x124 - what it means and what to try for the crash.
Some of the above you did, but you may not have done all of the steps for those checks you already did. Make sure to do the tests exactly as I have laid out for the best results and diagnostics.

Additionally, we should check your RAM compatibility:
  • Download and install CPU-Z and Upload screenshots of the CPU, Mainboard, Memory, and SPD tabs. In the SPD tab, upload an image of each slot.
My System SpecsSystem Spec
25 Jun 2012   #3

Windows 7 Ultimate x64

Thank you for the quick response. I will go step by step with the tests and instructions you have provided and post any results that I get.

I ran Orthos 64 3 times in blend mode yesterday and received a crash every time with the same error as before. I ran all of the SeaTools tests and my HDD passed all of them. I should also mention I ran Memtest+86 for 9 passes and received no errors.

I have attached the images requested from CPU-Z.

Note: I have since removed ASUSUpdate, Driver Checker, and Driver Genius from my computer. But I did not install any of those programs until AFTER I started to received BSODs (in hopes it was a driver issue that I could fix easily).
My System SpecsSystem Spec

26 Jun 2012   #4

Windows 7 Ultimate x64

Here is another update: I ran the Furmark Test for 20 minutes and the maximum temperature of my GPU was 78C (also where it evened out). I then ran Intel Burn Test. The Standard test completed without incident, so I tried the High test and received another BSOD. So I decided to pull out the RAM that ran the Memtest slower in my initial investigation. I then ran the IBT again on High test and although the test got further, I received another BSOD.

Could this mean that it is my processor that is somehow damaged or defective?
My System SpecsSystem Spec
26 Jun 2012   #5

Windows 7 Home Premium 64 Bit

RAM looks good in terms of compatibility. Could still be a bad module, even though Memtest86+ came up clean: Finicky RAM.

We'll have to see what the other tests reveal. Do you have the same problems with Prime95? I know Orthos was based off Prime95, so if the blend feature in it is the same, I would suspect memory problems or your processor's memory controller are at fault with your crashes.
My System SpecsSystem Spec
26 Jun 2012   #6

Windows 7 Ultimate x64

When I ran Prime95 the other day I also received a crash using the blend test. As stated above in my update, I also crashed on the Intel Burn test on High although not on Normal setting. I should also mention that I ran regular Memtest before I ran Memtest+86 and received an error at 13% that said something along the lines of "error between location x and location y" (can't remember exactly what it said). So I ran the test again and it came up with nothing.

Another update: So I decided to reinstall my OS again, just to confirm that it couldn't by chance be anything related to software. Right after installing Windows 7 Ultimate 64 again I ran the Intel Burn Test and received the same crash that I have been receiving over and over.
My System SpecsSystem Spec
26 Jun 2012   #7

Windows 7 Home Premium 64 Bit

You may have bad install media. Please follow the Windows Genuine and Activation Issue Posting Instructions. Post the results in your next post; do not start a new thread.
My System SpecsSystem Spec
27 Jun 2012   #8

Windows 7 Ultimate x64

I really do not think that a bad install is the problem. I have had BSOD errors from the moment I bought this computer, with the OEM original install. I have a copy of Windows 7 Pro 64 though as well that I can use to confirm that this is a hardware problem and nothing software related.
My System SpecsSystem Spec
27 Jun 2012   #9

Windows 7 Home Premium 64 Bit

Where did you obtain the installation media?

I still suspect bad installation media. Please follow the Windows Genuine and Activation Issue Posting Instructions. Post the results in your next post; do not start a new thread.
Quote   Quote: Originally Posted by Brink
NOTE: The MGADIAG report does not contain any sensitive or personal information, and is best posted un-edited for us to be able to help.
My System SpecsSystem Spec
29 Jun 2012   #10

Windows 7 Ultimate x64

Reinstalled the original OEM Windows 7 Home Premium x64 (w/ Service Pack1) after downloading it from Installed and and ran Intel Burn Test again, which failed again. The problem is most certainly not software related.

After learning how to do some debugging with the Windows Debugging Utility, I discovered the following errors: Error Micro-Architectural Error, and Error Internal unclassified (Proc 0 Bank 5). The Bugcheck code is 0x124_GenuineIntel. This would indicate a definite hardware problem although I am not sure if it truly identifies the processor as the culprit or not. Here is the debugging info:

Microsoft (R) Windows Debugger Version 6.2.8400.0 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Users\D\Desktop\MEMORY.DMP]
Kernel Summary Dump File: Only kernel address space is available

Symbol search path is: srv*J:\Symbols*
Executable search path is: 
Windows 7 Kernel Version 7600 MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7600.16385.amd64fre.win7_rtm.090713-1255
Machine Name:
Kernel base = 0xfffff800`0284b000 PsLoadedModuleList = 0xfffff800`02a88e50
Debug session time: Wed Jun 27 19:42:20.443 2012 (UTC - 4:00)
System Uptime: 0 days 0:01:39.567
Loading Kernel Symbols
Loading User Symbols
PEB is paged out (Peb.Ldr = 000007ff`fffd8018).  Type ".hh dbgerr001" for details
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 124, {0, fffffa80077e3028, ba000000, 400405}

Page 204552 not present in the dump file. Type ".hh dbgerr004" for details
Probably caused by : GenuineIntel

Followup: MachineOwner

0: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

A fatal hardware error has occurred. Parameter 1 identifies the type of error
source that reported the error. Parameter 2 holds the address of the
WHEA_ERROR_RECORD structure that describes the error conditon.
Arg1: 0000000000000000, Machine Check Exception
Arg2: fffffa80077e3028, Address of the WHEA_ERROR_RECORD structure.
Arg3: 00000000ba000000, High order 32-bits of the MCi_STATUS value.
Arg4: 0000000000400405, Low order 32-bits of the MCi_STATUS value.

Debugging Details:

Page 204552 not present in the dump file. Type ".hh dbgerr004" for details

BUGCHECK_STR:  0x124_GenuineIntel


PROCESS_NAME:  linpack64.exe


fffff800`00ba8a98 fffff800`02814903 : 00000000`00000124 00000000`00000000 fffffa80`077e3028 00000000`ba000000 : nt!KeBugCheckEx
fffff800`00ba8aa0 fffff800`029d1513 : 00000000`00000001 fffffa80`076af820 00000000`00000000 fffffa80`076af870 : hal!HalBugCheckSystem+0x1e3
fffff800`00ba8ae0 fffff800`028145c8 : 00000000`00000728 fffffa80`076af820 fffff800`00ba8e70 fffff800`00ba8e00 : nt!WheaReportHwError+0x263
fffff800`00ba8b40 fffff800`02813f1a : fffffa80`076af820 fffff800`00ba8e70 fffffa80`076af820 00000000`00000000 : hal!HalpMcaReportError+0x4c
fffff800`00ba8c90 fffff800`02813dd5 : 00000000`00000004 00000000`00000001 fffff800`00ba8ef0 00000000`00000000 : hal!HalpMceHandler+0x9e
fffff800`00ba8cd0 fffff800`02807e88 : 00000000`01cf4380 00000000`0001ee88 00000000`00000000 00000000`00000000 : hal!HalpMceHandlerWithRendezvous+0x55
fffff800`00ba8d00 fffff800`028bb7ac : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : hal!HalHandleMcheck+0x40
fffff800`00ba8d30 fffff800`028bb613 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KxMcheckAbort+0x6c
fffff800`00ba8e70 00000001`402ddf83 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiMcheckAbort+0x153
00000000`00b3e9c0 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x00000001`402ddf83


FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: GenuineIntel

IMAGE_NAME:  GenuineIntel



BUCKET_ID:  X64_0x124_GenuineIntel_PROCESSOR_MAE

Followup: MachineOwner

0: kd> !errrec fffffa80077e3028
Common Platform Error Record @ fffffa80077e3028
Record Id     : 01cd54be4415b0a4
Severity      : Fatal (1)
Length        : 928
Creator       : Microsoft
Notify Type   : Machine Check Exception
Timestamp     : 6/27/2012 23:42:20 (UTC)
Flags         : 0x00000000

Section 0     : Processor Generic
Descriptor    @ fffffa80077e30a8
Section       @ fffffa80077e3180
Offset        : 344
Length        : 192
Flags         : 0x00000001 Primary
Severity      : Fatal

Proc. Type    : x86/x64
Instr. Set    : x64
Error Type    : Micro-Architectural Error
Flags         : 0x00
CPU Version   : 0x0000000000020652
Processor ID  : 0x0000000000000000

Section 1     : x86/x64 Processor Specific
Descriptor    @ fffffa80077e30f0
Section       @ fffffa80077e3240
Offset        : 536
Length        : 128
Flags         : 0x00000000
Severity      : Fatal

Local APIC Id : 0x0000000000000000
CPU Id        : 52 06 02 00 00 08 10 00 - ff e3 98 02 ff fb eb bf
                00 00 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00
                00 00 00 00 00 00 00 00 - 00 00 00 00 00 00 00 00

Proc. Info 0  @ fffffa80077e3240

Section 2     : x86/x64 MCA
Descriptor    @ fffffa80077e3138
Section       @ fffffa80077e32c0
Offset        : 664
Length        : 264
Flags         : 0x00000000
Severity      : Fatal

Error         : Internal unclassified (Proc 0 Bank 5)
  Status      : 0xba00000000400405

Here is the Windows Genuine Activation information as requested.

Diagnostic Report (1.9.0027.0):
Windows Validation Data-->

Validation Code: 0
Cached Online Validation Code: N/A, hr = 0xc004f012
Windows Product Key: *****-*****-GDRYQ-P9FBQ-RTB9M
Windows Product Key Hash: Xk542MXjK8YXqUEqb5CbKI53zrA=
Windows Product ID: 00359-OEM-9808532-31849
Windows Product ID Type: 8
Windows License Type: COA SLP
Windows OS version: 6.1.7601.2.00010300.1.0.003
ID: {75895D7C-FB7A-474A-8062-C3DBC75F6B19}(1)
Is Admin: Yes
TestCab: 0x0
LegitcheckControl ActiveX: N/A, hr = 0x80070002
Signed By: N/A, hr = 0x80070002
Product Name: Windows 7 Home Premium
Architecture: 0x00000009
Build lab: 7601.win7sp1_rtm.101119-1850
TTS Error: 
Validation Diagnostic: 
Resolution Status: N/A

Vista WgaER Data-->
ThreatID(s): N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002

Windows XP Notifications Data-->
Cached Result: N/A, hr = 0x80070002
File Exists: No
Version: N/A, hr = 0x80070002
WgaTray.exe Signed By: N/A, hr = 0x80070002
WgaLogon.dll Signed By: N/A, hr = 0x80070002

OGA Notifications Data-->
Cached Result: N/A, hr = 0x80070002
Version: N/A, hr = 0x80070002
OGAExec.exe Signed By: N/A, hr = 0x80070002
OGAAddin.dll Signed By: N/A, hr = 0x80070002

OGA Data-->
Office Status: 109 N/A
OGA Version: N/A, 0x80070002
Signed By: N/A, hr = 0x80070002
Office Diagnostics: 025D1FF3-364-80041010_025D1FF3-229-80041010_025D1FF3-230-1_025D1FF3-517-80040154_025D1FF3-237-80040154_025D1FF3-238-2_025D1FF3-244-80070002_025D1FF3-258-3

Browser Data-->
Proxy settings: N/A
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Win32)
Default Browser: C:\Program Files (x86)\Mozilla Firefox\firefox.exe
Download signed ActiveX controls: Prompt
Download unsigned ActiveX controls: Disabled
Run ActiveX controls and plug-ins: Allowed
Initialize and script ActiveX controls not marked as safe: Disabled
Allow scripting of Internet Explorer Webbrowser control: Disabled
Active scripting: Allowed
Script ActiveX controls marked as safe for scripting: Allowed

File Scan Data-->
File Mismatch: C:\Windows\system32\wat\watadminsvc.exe[Hr = 0x80070003]
File Mismatch: C:\Windows\system32\wat\npwatweb.dll[Hr = 0x80070003]
File Mismatch: C:\Windows\system32\wat\watux.exe[Hr = 0x80070003]
File Mismatch: C:\Windows\system32\wat\watweb.dll[Hr = 0x80070003]

Other data-->
Office Details: <GenuineResults><MachineData><UGUID>{75895D7C-FB7A-474A-8062-C3DBC75F6B19}</UGUID><Version>1.9.0027.0</Version><OS>6.1.7601.2.00010300.1.0.003</OS><Architecture>x64</Architecture><PKey>*****-*****-*****-*****-RTB9M</PKey><PID>00359-OEM-9808532-31849</PID><PIDType>8</PIDType><SID>S-1-5-21-3569384856-4282321353-472628713</SID><SYSTEM><Manufacturer>ASUSTeK Computer INC.</Manufacturer><Model>CM5675</Model></SYSTEM><BIOS><Manufacturer>American Megatrends Inc.</Manufacturer><Version>0502   </Version><SMBIOSVersion major="2" minor="6"/><Date>20100716000000.000000+000</Date></BIOS><HWID>89CA3507018400FC</HWID><UserLCID>0409</UserLCID><SystemLCID>0409</SystemLCID><TimeZone>Eastern Standard Time(GMT-05:00)</TimeZone><iJoin>0</iJoin><SBID><stat>3</stat><msppid></msppid><name></name><model></model></SBID><OEM><OEMID>_ASUS_</OEMID><OEMTableID>Notebook</OEMTableID></OEM><GANotification/></MachineData><Software><Office><Result>109</Result><Products/><Applications/></Office></Software></GenuineResults>  

Spsys.log Content: 0x80070002

Licensing Data-->
Software licensing service version: 6.1.7601.17514

Name: Windows(R) 7, HomePremium edition
Description: Windows Operating System - Windows(R) 7, OEM_COA_SLP channel
Activation ID: 5e017a8a-f3f9-4167-b1bd-ba3e236a4d8f
Application ID: 55c92734-d682-4d71-983e-d6ec3f16059f
Extended PID: 00359-00196-085-331849-02-1033-7601.0000-1812012
Installation ID: 013454695756655310511162243295864714156084353750745812
Processor Certificate URL:
Machine Certificate URL:
Use License URL:
Product Key Certificate URL:
Partial Product Key: RTB9M
License Status: Licensed
Remaining Windows rearm count: 3
Trusted time: 6/29/2012 4:23:08 PM

Windows Activation Technologies-->
HrOffline: 0x00000000
HrOnline: N/A
HealthStatus: 0x0000000000000000
Event Time Stamp: N/A
ActiveX: Not Registered - 0x80040154
Admin Service: Not Registered - 0x80040154
HealthStatus Bitmask Output:

HWID Data-->

OEM Activation 1.0 Data-->

OEM Activation 2.0 Data-->
BIOS valid for OA 2.0: yes
Windows marker version: 0x20001
OEMID and OEMTableID Consistent: yes
BIOS Information: 
  ACPI Table Name    OEMID Value    OEMTableID Value
  APIC            071610        APIC1751
  FACP            071610        FACP1751
  HPET            071610        OEMHPET 
  MCFG            071610        OEMMCFG 
  OEMB            071610        OEMB1751
  SSDT            DpgPmm        CpuPm
  SLIC            _ASUS_        Notebook
My System SpecsSystem Spec

 BSOD Playing Metro 2033, error 0x00000124

Thread Tools

Similar help and support threads
Thread Forum
Metro 2033 free!
Hey guys, Didn't know if anyone has heard but you can get Metro 2033 free only until tomorrow 10:00 am PST so if you don't already have it, get it! You will need to have Steam client installed to get it though. :)
ntoskrnl.exe +0x7F1C0 BSOD playing Metro 2033
Hi there had some previous BSODs associated with faulty Etron USB 3 drivers which I think Ive resolved. This new one came up whilst I was playing Metro 2033. Thanks for any help you can give. Seems like a great resource here. win7 64bit SP1 is the original OS installed OEM version...
BSOD Help and Support
Metro 2033 will not go fullscreen
I tinkered with the user.cfg before, and I went back in to change it, but I can still see the taskbar when I open Metro. I when into Steam and verified the files, and it re-downloaded 1 thing at it didn't help. I've tried F11 and Alt+Enter.
BSOD while playing Metro 2033
To make long story short, I have experienced some BSODs while playing Metro 2033, I looked at .DMP files and found the following drivers that caused BSOD - CompositeBus.sys and blbdrive.sys. I googled and could not find anything that would explain which application(s) use these drivers. I was...
BSOD Help and Support
Metro 2033 Demo
Finally we have a demo :D News: Metro 2033 Demo - I was quite shocked we even got a demo to be honest,It seems these days game developers dont bother to make a Demo for us to try the game,They just expect you to buy it :/

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:03.
Twitter Facebook Google+