Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Apphang with literally any program

17 Jul 2012   #1

Windows 7 home premium 64 bit
Apphang with literally any program

Hi everyone,

I recently purchased a SSD and installed it into my PC. Since then I have been running into a number of weird issues and crashes. First it started with skype crashing/hanging and generally acting weird. Whenever I would shutdown my PC I'd need to force restart because skype would never close and then the pc would hang at the Shutting Down screen with the swirling spinner. The only way to shut it down would be to hit the power on it.

Its strange because its still spinning so it isn't crashing, its actively trying to do something. I know because when I hit the reset button it'd freeze and stop spinning, usually then it'd reboot in a second or two.

I'm on my 5th or 6th reinstall since friday trying to figure out this problem. At first it was only skype acting up and I uninstalled it thinking that it was just skype not wanting to work with my PC but now I'm starting to have other programs hang. I read around on these forums and the one thing that I seen suggested was a memory dump. I just graduated from a 2 year tech school, a pretty good one, and I have never played with memory dumps before. I changed my dump files to be small dump files.

This morning I found one of my programs had crashed and I was able to make a dump file, 1.1gigs in size, and when I opened it with the windows debugging tool I got these lines of code:

Microsoft (R) Windows Debugger Version 6.2.8400.0 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Users\Tony\Desktop\Diablo III.DMP]
User Mini Dump File with Full Memory: Only application data is available

Symbol search path is: *** Invalid ***
* Symbol loading may be unreliable without a symbol search path. *
* Use .symfix to have the debugger choose a symbol path. *
* After setting your symbol path, use .reload to refresh symbol locations. *
Executable search path is:
Windows 7 Version 7601 (Service Pack 1) MP (4 procs) Free x64
Product: WinNt, suite: SingleUserTS
Machine Name:
Debug session time: Tue Jul 17 08:40:41.000 2012 (UTC - 4:00)
System Uptime: 0 days 19:45:38.383
Process Uptime: 0 days 8:35:18.000
....................................................WARNING: profapi overlaps mswsock
.WARNING: winspool overlaps version
WARNING: winspool overlaps wow64cpu
WARNING: authz overlaps PeerDist
.WARNING: rasapi32 overlaps authz
...WARNING: SensApi overlaps IPHLPAPI
....WARNING: FWPUCLNT overlaps dnsapi
.WARNING: NapiNSP overlaps comctl32
................WARNING: propsys overlaps dnsapi
..WARNING: MMDevAPI overlaps winmm
....WARNING: AudioSes overlaps MMDevAPI
....WARNING: rsaenh overlaps cryptsp
....WARNING: MSVCR100_CLR0400 overlaps AcLayers
........WARNING: GdiPlus overlaps d3d9
*** ERROR: Symbol file could not be found. Defaulted to export symbols for ntdll.dll -
*** WARNING: symbols timestamp is wrong 0x4ce7ca38 0x4e212273 for wow64cpu.dll
00000000`74cf2e09 c3 ret

I can see that its telling me that I haven't loaded a file for the symbols but it seems to load a default one at the end? Does this information give anyone an insight to some problem that I'm having? Its more than just this game crashing, Firefox will also crash on me. This is just the first dump file I've gotten and I'm not even at home with the crashing PC, I have remote access to it.

My System SpecsSystem Spec
17 Jul 2012   #2

Windows 7 home premium 64 bit

Something I think this problem came from was setting my BIOS for AHCI for the new SSD. That was the only real change I've made, I've installed on 3 separate hard drives and all of them had the same issues, all of them still had AHCI set. At some point I'm going to swap back to SATA and see if the issue still persists and if not... that's not a good thing because then I can't make the most of the SSD.
My System SpecsSystem Spec
20 Jul 2012   #3
Microsoft MVP


Try the SATA drive first with the AHCI turned off.
Then try the SATA drive with AHCI turned on
Any differences?

Then try the SSD on the one that worked best.
Be sure that your SSD firmware is the latest available from the SSD manufacturer's website (not the DVD that came with it). Also ensure that the controller drivers on your mobo is the latest available.

To fix the symbols, open the debugger and select: File...Symbol File Path
Paste the following into the box there and click on OK.
Then, when closing the debugger, answer Yes the first time it asks to save the Workspace (and answer "No" every time after that)
My System SpecsSystem Spec


 Apphang with literally any program

Thread Tools

Similar help and support threads
Thread Forum
Explorer crash ( apphang )
Hi guys, I have a problem with my windows explorer. Keeps on crashing once in a while and I really don't know why. I've attached my event viewer logs about the last crash. It's kinda annoying. Thanks for your help. LE: While I was typing, it crashed again. I see something there...
BSOD Help and Support
Hello all, I have recently purchased a PC that frequently has APPCRASH and APPHANG(B1) issues. Could anyone offer some instight as to what may be causing this? I have run several diagnostic tools on the processor, RAM and Video card and all have reported no errors. Here are a couple of...
BSOD Help and Support
Windows 7 apphang
So it starts out with Firefox causing an apphangB1. This snowballs until I cannot use any form of media. As in, once Firefox has caused an apphang, Windows Mediaplayer, Itunes, Flash, Photoshop, Image Gallery, and any other program including games will not run, at all. This happens to me literally...
BSOD Help and Support
Save yourself - literally!
Yesterday sucked. On Friday, I had two random BSODs. On Saturday, I figured I'd try to fix the problem. Based on my reading here, it seemed that I should check and update my device drivers. I ran into a major issue with ATI Catalyst. Basically, it got wedged - could not uninstall the old or...
BSOD Help and Support
AppHang/GPO related crash?
Hello everyone! I've come across an issue with a game crashing, but I posted here as I believe the issue lies in the GP settings. When I run Just Cause 2, the game randomly freezes, tabs down so I can see my background, and then stops communicating. I can't alt+tab back to the game, although sounds...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:22.
Twitter Facebook Google+