Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD running Java Server, error 0xD0000147

22 Aug 2012   #1

Windows 7 x64 bit
BSOD running Java Server, error 0xD0000147

I have had two BSODs in the past 3 hours.

The first:

Here is the MEMORY.DMP file's last entry
GetContextState failed, 0xD0000147
Unable to get current machine context, NTSTATUS 0xC0000147
MODULE_NAME: Unknown_Module
IMAGE_NAME: Unknown_Image
Followup: MachineOwner
GetContextState failed, 0xD0000147
GetContextState failed, 0xD0000147
I also opened up the mini dump -
You can run '.symfix; .reload' to try to fix the symbol path and load symbols.
FAULTING_MODULE: fffff80002e04000 nt
DEVICE_OBJECT: fffffa80039e7e30
LAST_CONTROL_TRANSFER:  from fffff80002eed6c2 to fffff80002e831c0
fffff800`00b9c388 fffff800`02eed6c2 : 00000000`0000009f 00000000`00000003 fffffa80`039e7e30 fffff800`00b9c3d8 : nt+0x7f1c0
fffff800`00b9c390 00000000`0000009f : 00000000`00000003 fffffa80`039e7e30 fffff800`00b9c3d8 fffffa80`04715430 : nt+0xe96c2
fffff800`00b9c398 00000000`00000003 : fffffa80`039e7e30 fffff800`00b9c3d8 fffffa80`04715430 00000000`c00000bb : 0x9f
fffff800`00b9c3a0 fffffa80`039e7e30 : fffff800`00b9c3d8 fffffa80`04715430 00000000`c00000bb 00000000`00000000 : 0x3
fffff800`00b9c3a8 fffff800`00b9c3d8 : fffffa80`04715430 00000000`c00000bb 00000000`00000000 fffff800`0302ab20 : 0xfffffa80`039e7e30
fffff800`00b9c3b0 fffffa80`04715430 : 00000000`c00000bb 00000000`00000000 fffff800`0302ab20 00000003`00000002 : 0xfffff800`00b9c3d8
fffff800`00b9c3b8 00000000`c00000bb : 00000000`00000000 fffff800`0302ab20 00000003`00000002 00000000`00018000 : 0xfffffa80`04715430
fffff800`00b9c3c0 00000000`00000000 : fffff800`0302ab20 00000003`00000002 00000000`00018000 fffff800`0302ab10 : 0xc00000bb
fffff800`02e831c0 48894c2408      mov     qword ptr [rsp+8],rcx
SYMBOL_NAME:  nt+7f1c0
FOLLOWUP_NAME:  MachineOwner
IMAGE_NAME:  ntoskrnl.exe
Followup: MachineOwner
The second was an 0x0000001E BSOD which completely locked my PC.
Details are available if you need them.

Computer is extremely laggy, freezing occasionally but returning to normal afterwards. If more info is required tell me and I can attach the whole DMP.

My System SpecsSystem Spec
23 Aug 2012   #2
Vir Gnarus

Microsoft Community Contributor Award Recipient

Windows 7 64-bit

Your event logs (app & sys) did not seem to be exported properly (they're both 0 bytes in size). The latest crashdump provided is from the 20th, with the one before that from the 3rd.

The Aug 20th crashdump reports a memory management issue that occurred when the process RzSynapse.exe was running. I am very well aware of Razer and their poor driver code, but you should still check to see if there are any updates for your Razer product(s) as well as firmware, since that has relieved a lot of issues for Razer customers.

The crashdump from the 3rd reports an issue where your Hamachi driver was not properly handling what appears to be the system going into a low power state. As a result, it hung up on a power IRP and therefore the system crashed. The driver itself is from Feb 2009, which is pre-Windows 7 release date driver. You will definitely want to consider updating it.

Other than that, I'm not able to determine the cause of your most recent crashes. Given your latest one was a memory management issue, you may wanna look into running Memtest for a few passes on the machine, but that's probably not a very appropriate option with what is probably a production server (am I correct?).

I may be able to provide some more assistance from your MEMORY.DMP file. Can you verify that it is the latest date (at least not from the 20th)? Also, given you appear to already have Windbg installed, run Dumpchk on the dump file, just to verify its integrity before uploading it to some 3rd-party filesharing site. You should find it in the same directory where the Windbg.exe executable is located.

Btw, before we continue, or before you even upload the crashdump, be advised that a kernel dump has a lot of information on. If this is in a production environment, you will want to forgo uploading it as it'd be quite a security risk and would probably be against company security policy.
My System SpecsSystem Spec
23 Aug 2012   #3

Windows 7 x64 bit

Vir Gnarus, thanks very much for the reply!

A little update on my impatience...

I was beginning to get (8/10 times on booting) a:
"Disk read error, Press Ctrl + Alt + Delete to restart"
It was C:\ that was 'corrupt' despite me running CHKDSK several times (in the event that the PC would actually get to the desktop) which said that the hard drive was secure and healthy (also displayed in the drive properties). From there, bad went to worse as I was unable to access the computer apart from the BIOS and ASROCK interface. I tried booting from my windows CD to no avail, getting the same disc read error.

I followed a tutorial on seven forums in making a USB boot drive which worked in getting me to the hard drive options which I desperately needed. I delete some partitions I made earlier and formatted the system reserved drive so my C:\ was empty and the reserved drive was mainly empty. I tried to install windows but I received an error saying the data on the USB drive was corrupt.

I thought it was all over, as I had bricked my PC by deleting all info on C:\ and having a faulty disk drive and a corrupt USB, I had no way to repair it.

Strangely, after deleting all the C:\ info and reformatting the system portion, ASROCK software detected my windows disk in the boot options (which I had accidentally left in the disk drive). I reinstalled windows and had CHKDSK run on the first boot which:
"fixed incorrect information file segments" in the 131xxx segments
... And a bunch of other stuff including file records in segments 22xxx and verifying indexes. It deleted a huge amount of index entries. It also recovered a set of 'orphaned' files and it inserted data attributes into files.

Windows restarted and is now 'completing its installation'. All looks good at this stage, I will keep you posted if the error persists upon launching the fully installed fresh Windows.

*EDIT* --

P.S The program I was running when most of the BSODs were occuring was a java application which was a server for Minecraft! Its my PC that is having issues so there are no security risks or anything!

Crucial Update

Fresh install didnt work. Sort of postponed the issue of freezing. I asked a mate for his take on the whole thing.
My System SpecsSystem Spec

24 Aug 2012   #4

Windows 7 x64 bit

Update -

Under recommendation from a friend I bought a new HDD (Seagate 2TB) and replaced my WD 1TB which we assumed was 'corrupt'.

Got home, swapped the positioning of both and jumped the BIOS - PC booted fine and quicker than normal. (Note it has fresh windows on it from ^ post). I got to the desktop with no lag whatsoever however as soon as I put my ASRock Intel-Intel Series IIH67-11 driver disc the process became frozen and I was forced to restart.

Now I get one of the following upon boot:

a) A successful boot to the HDD however I am unable to load the Win7 Installation disc to try and do some system repairs. BSODS often occur during my attempts to do a system restore or anything else like drivers. I cant get the 7forums diagnostic tool to find out what these BSODs are because it doesnt recognise my USB disk or my USB network adapter


b) The disk drive miraculously boots the windows 7 retail disk but gets stuck while "Windows is loading files" -- then I am given an error = 0xc00000e9 (Info: An unexpected I/O error has occurred) this error can be caused by faulty hardware such as a hard drive or CD-ROM drive tat is failing. Make sure any removable storage is properly connected and then restart your computer.

When I hit F11 on the BIOS launch and I have two options:
or (occasionally) 3. My HDD (which never works)

Both of the HL-DT-ST options are named after my LG optical drive, however if I choose to boot from either I get given;
a) a flashing cursor on a black screen
b) a Ctrl+Alt+Delete to restart
or c) 'Reboot and Select Proper Boot device or Insert Boot Media in selected Boot device and press a key' which starts the loop again

I was convinced the HDD was corrupt, however getting a new one has only made my occasional boot faster. I doubled my RAM... cant be that. Is it my optical drive or could it be my MOBO?
My System SpecsSystem Spec
24 Aug 2012   #5
Vir Gnarus

Microsoft Community Contributor Award Recipient

Windows 7 64-bit

First of all, unless absolutely necessary for initial functioning of Windows, do not use the drivers for motherboards that come with the disc. Always install the latest drivers available. If you're able too, installing the latest BIOS will also be very beneficial. However, given you're having issues with multiple items, such as USB, drives, etc., I'd venture to point blame at your motherboard for sure.
My System SpecsSystem Spec
24 Aug 2012   #6

Windows 7 x64 bit

Quote   Quote: Originally Posted by Vir Gnarus View Post
First of all, unless absolutely necessary for initial functioning of Windows, do not use the drivers for motherboards that come with the disc. Always install the latest drivers available. If you're able too, installing the latest BIOS will also be very beneficial. However, given you're having issues with multiple items, such as USB, drives, etc., I'd venture to point blame at your motherboard for sure.

Ok, those initial drivers didnt seem to do any good so its nice to have that cleared up. Also, as mentioned, since I cant get a USB working with windows and my access to the internet is through a USB adapter, AND my disk drive is screwed, I have no way of updating the software on the machine!!!!!

So it sounds like my motherboard... I need to be sure though because I dont particularly feel like wasting any more money. It seems that way though... at this stage my PC is virtually bricked. Do you recommend I search for a new mobo? Or is the issue still solvable through software (despite my issues of getting any software ON the PC)?

I have access to the majority of the mobos in this catalogue locally.
My System SpecsSystem Spec
24 Aug 2012   #7
Vir Gnarus

Microsoft Community Contributor Award Recipient

Windows 7 64-bit

Bad USB ports is pretty much always conducive of a bad mobo just in itself. The failing drive I/O on multiple drives only adds credence to our suspicions against the motherboard. The only other exception I can see is the power supply, but unfortunately without a multimeter there's no way to properly test a PSU.
My System SpecsSystem Spec
24 Aug 2012   #8

Windows 7 x64 bit

Ok so since I have already gone and got new RAM and a new HDD, I would see it pointless not to go all the way. Is replacing the motherboard the only way to solve this kind of issue? If so; could you please suggest a suitable motherboard for my current rig:

Intel Core i5-2400 @3.10Ghz
Nvidea GTX460
ASRock H67M-GE (the culprit)
2TB Seagate HDD
8GB GForce Ripjaws (2x4GB)

So long as it is reasonably priced, but overall compatible with what I have, I would greatly appreciate an expert's recommendation.
My System SpecsSystem Spec
24 Aug 2012   #9
Vir Gnarus

Microsoft Community Contributor Award Recipient

Windows 7 64-bit

I personally don't see what's wrong with the mobo you have. There's just times when you get unlucky and purchase a dud.

Though if you are planning on getting an upgrade mobo, since this one is older and I'm sure by now there's better variations out there, then I wouldn't see any problem getting another ASRock. Beyond that, I cannot give you any specific recommendations, though I'm sure the Hardware & Devices area here will assist you in that endeavor.
My System SpecsSystem Spec
24 Aug 2012   #10

Windows 7 x64 bit

Ah I see...

Well thanks a lot for all the help here Vir Gnarus! I'll be sure to check in over at the hardware section and see what the guys there will recommend for me. Just one last question: my motherboard is about 2 years old - is that a long enough time for it to die?

P.S. I know its not much, but I added to your rep
My System SpecsSystem Spec

 BSOD running Java Server, error 0xD0000147

Thread Tools

Similar help and support threads
Thread Forum
Java Error : java.lang.RuntimeException when Updating Vuze
Hello to everyone! I am currently experiencing this Java problem that I only encounter when updating my Vuze Bittorrent Client. I am just updating it to newer version but every time I try, the error pops up. The complete error is: "An error occurred: java.lang.RuntimeException:...
BSOD While Running Plex Media Server
I just built a media server and after I installed Plex Media Server, the system will either freeze or goto BSOD sometimes within minutes and other times after a few hours (idle or in use) if Plex Media Server is running. I exited out of Plex Media Server, ran Prime95 for 12 hours and no problems. ...
BSOD Help and Support
BSOD running Plex Media Server, now NIC not working and locking up
OK, I've been doing a fresh install of Windows 7 x64 and had almost finished installing all the software, when I found it would BSOD whenever I tried to run Plex Media Server, which scans certain folders to build a media database. Running defrag didn't cause any problems, so it didn't seem to be an...
BSOD Help and Support
Possible JAVA Error?, Cannot run any programs requiring JAVA?
Evening all, first post... Hopefully someone could help, Everything was working fine yesterday (05/06/2013) then when i turn on today (06/06/2013) i cannot run any applications that are running java. For example, firefox uses JAVA, but when i start firefox, it crashes..... heres the...
Java Problem running IE9 in Win 7 64 bit
Does anyone know how I can get rid of this error? I have scanned the web for so long for an answer that I finally realized I don't even understand the difference between Sun Java and Oracle Java nor do I know how to get rid of either and start over. Any help offered will be greatly appreciated....
Browsers & Mail
BSOD @ Random Times. Running SQL Server, could be related?
BSOD occurs randomly, sometimes 2-3 times a day, sometimes 2-3 times a week total. But generally always happens at least once per week. Been ongoing for over a year. I upgraded all my RAM. I have run the MemTest86 and it reported good. The BSOD was occurring before and after that RAM upgrade. ...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:16.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App

Windows 7 Forums