Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Explorer.exe taking up 15-30% CPU usage when moving mou

15 Sep 2009   #1
kevindd992002

Windows 7 Ultimate x6
 
 
Explorer.exe taking up 15-30% CPU usage when moving mou

I don't have any programs opened just the task manager. When I'm not moving the mouse my CPU usage stay from 0-2% but as soon as I move the mouse pointer, even though just a bit, it shoots up to 30%!!!!

Why is that happening? I'm really frustrated about it.

Thanks.


My System SpecsSystem Spec
.
15 Sep 2009   #2
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by kevindd992002 View Post
I don't have any programs opened just the task manager. When I'm not moving the mouse my CPU usage stay from 0-2% but as soon as I move the mouse pointer, even though just a bit, it shoots up to 30%!!!!

Why is that happening? I'm really frustrated about it.

Thanks.

In order to help you we need you to fill in your system specs (lower left corner) so we know what hardware you have.

thanks

Ken
My System SpecsSystem Spec
15 Sep 2009   #3
mckillwashere

Windows 7 x86/x64, Server 2008r2, Web Server 2008
 
 

What version of windows 7 are you running?

Did you obtain it legitly?
If not do the MD5 sums match up?

If its hacked im assuming your using an activation hack. Which could be causing it.
My System SpecsSystem Spec
.

16 Sep 2009   #4
kevindd992002

Windows 7 Ultimate x6
 
 

RTM 7500 x64.. I got it from torrent but yes the MD5 sums match up perfectly with the original one.

I'm not using an activation hack. Still on trial mode.
My System SpecsSystem Spec
16 Sep 2009   #5
kevindd992002

Windows 7 Ultimate x6
 
 

Quote   Quote: Originally Posted by zigzag3143 View Post
Quote   Quote: Originally Posted by kevindd992002 View Post
I don't have any programs opened just the task manager. When I'm not moving the mouse my CPU usage stay from 0-2% but as soon as I move the mouse pointer, even though just a bit, it shoots up to 30%!!!!

Why is that happening? I'm really frustrated about it.

Thanks.

In order to help you we need you to fill in your system specs (lower left corner) so we know what hardware you have.

thanks

Ken
Updated my specs list.
My System SpecsSystem Spec
16 Sep 2009   #6
kevindd992002

Windows 7 Ultimate x6
 
 

What program can I use (and how do I use it) to monitor the thread activities of the explorer.exe process?

Is this the only way to determine which thread is causing explorer.exe to be using high cpu usage?

I just noticed that even though I totally don't move the mouse pointer, after 30 seconds or so, the CPU usage just boosts up high and after 1 second it drops to 0-1% again.

BUT, continually moving the mouse pointer will maintain the high CPU usage 20-30%.
My System SpecsSystem Spec
16 Sep 2009   #7
Barman58

Windows 10 Pro x64 x2 Windows 10 Enterprise x64, Ubuntu
 
 

The best tools for this type of investigation are those in the sysinternals suite

Windows Sysinternals: Documentation, downloads and additional resources

In particular for this case I would look at

Autoruns - what automatically starts

Process Explorer - Enhanced task manager with more in depth information

Process Monitor - list process use over time for particular process or processes

Full details and instructions are available on the site
My System SpecsSystem Spec
16 Sep 2009   #8
kevindd992002

Windows 7 Ultimate x6
 
 

Here's the output of Process Explorer while moving my mouse pointer:

My System SpecsSystem Spec
16 Sep 2009   #9
swarfega

Windows 7 Professional 64-bit
 
 

build 7500? Wasnt aware of such a build.
My System SpecsSystem Spec
16 Sep 2009   #10
Barman58

Windows 10 Pro x64 x2 Windows 10 Enterprise x64, Ubuntu
 
 

Looking at your specs - are you using the Logitec drivers for the mouse? - if so you may want to disable these (uninstall) and try running with just the default Microsoft drivers.
It may be an incompatibility between the current drivers and windows 7.

I have seen this with other Logitec product drivers during the Windows 7 Development.
My System SpecsSystem Spec
Reply

 Explorer.exe taking up 15-30% CPU usage when moving mou




Thread Tools




Similar help and support threads
Thread Forum
Two explorer.exe, One taking all of my RAM's Memory
Hello, Ever since last month on October 2014 I'v noticed that I have 2 Explorer.exe's with one being my desktop (The one with the username, Afrim) and another explorer.exe process that has no username but this explorer.exe process starts off using a minimal amount of my Memory but after a few...
Performance & Maintenance
CPU usage jumps to 50% when moving cursor around.
Good day everyone, I would just like to mention that this beautiful machine of mine is 5-6 years old, so I'd understand if it's beyond repair, but I'd like to see if this problem could be fixed anyway. For quite a while now, I've been experiencing some frame rate lag, whoever, it only lags...
Performance & Maintenance
Explorer.exe taking up 20%+ cpu
computer specs AMD A8-4500M APU with Radeon HS graphics windows 7 64x 8gb of ram I ive had this computer for about a week and already im running into this problem with explorer.exe. like the title says explorer is taking up most of my cpu. when i use process monitor i says its reading a file...
Performance & Maintenance
Explorer.Exe taking up ALL my RAM
Why? http://img194.imageshack.us/img194/762/memrl.png
Performance & Maintenance
CPU usage from 1 to 30% when moving the cursor
Hello all today I was bored so I randomly opened taskmanager and went to the performance-tab. My CPU usage was 30% in taskmanager when moving around my mouse cursor randomly (not opening anything, clicking anything etc). Then I had to do something downstairs, so went downstrairs with the...
Performance & Maintenance
Explorer Problem : Renaming only taking after refresh
**Explorer Problem : Renaming only taking effect after refresh (F5) Hi guys. Since I'm in a huge hard drive clean up these days, I am often renaming files, using software to batch rename and batch music tagging. So, the problem is... When I rename a file manually, by right-clicking,...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:50.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App