Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: portcls BSOD with three audio programs open

06 Sep 2012   #1

windows 7 home premium 64bit
portcls BSOD with three audio programs open

was using virtual audio cable to send audio from media player classic to VSTHOST.
it worked but VSTHOST doesnt let me apply a stereo vst plugin to the front speakers, the rear speakers, the center and subwoofer independantly.

i found a program that does, it is called live professor.

well it isnt finalized yet and still in beta stage (although the website said the software was used in places where there would be a public listening, i thought that was worth something)

ever since i first tried using live professor i couldnt get any audio to the plugin.
the first time was my mistake, because i routed all the inputs and outputs for the plugins.. but i forgot to connect each plugin to eachother.
after i did get the plugins connected to eachother, i couldnt get the audio to stop skipping.

i had to use asio4all to get audio into live professor because the only thing it accepts is asio.
(i also learned VSTHOST would not work with the regular creative asio drivers, but would work with the asio4all drivers)
well i cranked up the buffer in asio4all all the way to 2048 samples and it still wouldnt stop the audio from skipping.
keep in mind i run foobar with asio drivers all the way down to 2ms latency with four instances of impulse response convolvers and three time delays totalling seven vst plugins at 2ms.

well i posted on the live professor forum and somebody said maybe it was my computer specs and i was asked what they were.
i went back into VSTHOST to gather up some comparison information, and i stopped the VSTHOST running but didnt close the window.. i also stopped the media player classic home cinema and i dont remember if i closed it and reopened it or left it open.
but.. i opened up the live professor program to try and get it to run (i think i was just finishing up trying asio4all in VSTHOST and going back to live professor to see what was wrong)
i also believe it was then that i realized i forgot to connect each plugin to eachother.

well what happened is.. audio was playing choppy, and i had VSTHOST open too.

i think maybe i stopped the media player and started it again to see if the driver would refresh, well the audio stopped playing and wouldnt start again.
then a few moments later the computer crashed with portcls.sys on the screen.

now, ever since then, whenever i go back into VSTHOST the audio refuses to go into the vst plugins.
i can connect the input box to the output box directly and get the female voice from virtual audio cable, but if i put a plugin inbetween those two boxes there isnt any audio anymore.

to make matters worse, asio4all wont let me select the virtual audio cable anymore.

i've reinstalled VSTHOST, asio4all, virtual audio cable, as well as live professor.. none of that has brought functionality back.

i've been talking to the person on the live professor forum, but i was told there wouldnt be any help for portcls.sys crashing.

the conversation is somewhat long, but it can be read here:
ifoundasound user forum - asio4all + virtual audio cable = no audio

i've done everything i could to get functionality back except for erasing the hard drive and reinstalling the operating system.
but i have a problem with reinstalling the operating system because it hasnt been on the hard drive for a whole year yet.
(i've got a bunch of photos and text files that i need to organize and my life is in disarray already as it is, and i'm only looking forward to organizing all of that.. much less than getting in there to clean .. plus i've got some various programs that linger and need organized .. it something i want to take in small steps)

well.. what brings me here?
i am hoping somebody can tell me something about the BSOD that changed all the functionality.
it looks like VSTHOST and live professor use the same DLL file, and that file has been changed causing both programs to not work now that asio4all is refusing to cooperate.
i mean, sometimes i cant choose my webcam microphone or internet telephone in the list of routing options because the little triangle wont show up.. all i get is the power button on the left.

foobar uses a vst wrapper, and i figure that makes it possible for that vst to use a different DLL file, because audio gets sent to those vst plugins.
(i went back to VSTHOST and choosed a different driver connection method and audio went to the vst plugins.. leading me to point at asio4all)

i cant continue testing the live professor program when asio4all is being stubborn.
therefore i am hoping somebody can reply with something i can use to get back to what i was doing with my audio hobby.

My System SpecsSystem Spec
08 Sep 2012   #2


There is no dump file in the attachment so unfortunately we cant tell you anything without that
My System SpecsSystem Spec
18 Jan 2013   #3

windows 7 home premium 64bit

i haven't gotten many portcls.sys bsods lately, but i did get one or two.. and i've also been getting some pfn list corrupt bsods.

i read some ways to look into the problem about pfn list corrupt, and it said to run driver verifier to look for any problem drivers.
well when i did that, it came back with portcls.sys was trying to address memory beyond the allocation.

that brought me back here wanting to find the minidump file and upload it.
i went into the system options and decided to change the kernel dump to small memory dump, and double-checked the location.
now that i can find the minidump file, i went and got the windows seven diagnostic tool again to try uploading the minidump.

this time i can see a .dmp file in the folder created.
hopefully somebody can say something about it.

i tried to do a repair with the install disc, and the operating system wasn't showing up in the list.
i tried to load the drivers for the harddrive, but after waiting for about half an hour .. it still said 'adding drivers'
is it normal for the computer to be extra extra extra slow when going through the system repair functions?
it seems like the only thing that goes fast is when it checks for system startup problems.
everything else i've tried in the repair menu takes a long time, about 10 minutes or more per mouse click.

the computer is running with a core2duo overclocked to 3.24ghz
My System SpecsSystem Spec


 portcls BSOD with three audio programs open

Thread Tools

Similar help and support threads
Thread Forum
BSOD D1 possibly portcls.sys related
Seriously need help with BSOD. Started 13 Oct 2013 and happens at least once each day. Same errors every time. portcls.sys is mentioned every time. A new version of this was installed about that time when a Windows monthly update happened. I found an older version and installed it but BSOD...
BSOD Help and Support
BSOD when opening Volume Manager - portcls.sys error
So here is the issue, ever since I built my computer I have had nothing but trouble with the Chinese crap sound card, also known as VIA. I have re-installed drivers countless times and ran countless diagnostic tools and other thing to no avail. Every time I open Volume Manager I get a portcls.sys...
BSOD Help and Support
Intermitant BSOD on shutdown w autorestart. ntoskrnl.exe? portcls.sys?
Intermittant BSOD on shutdown with auto-restart. BlueScreenView seems to flag ntoskrnl.exe & portcls.sys. I am uncertain how to deal with this.
BSOD Help and Support
BSOD portcls.sys
I noticed when everytime I opened skype, it BSODs and says portcls.sys. These minidumps are from the driver verifier so hopefully the BSOD was triggered by the driver verifer. From what I read, it may be the sound driver or something but I'm not sure where to go about with it. Thanks
BSOD Help and Support
BSOD - while playing ut2004 (portcls.sys)
BSOD appears only while playing ut2004. BF3 etc works fine. Appeared after graphic card change Ati 4870 --> GTX 560 Ti Everything at stock clocks. The most of components are half year old. OS installed 08.19.2011 System specs: AMD Phenom II X4 955 Asus M4A87TD/USB3
BSOD Help and Support
cannot play audio with 2 programs open
For instance if I open itunes then I open youtube, or any other program with audio, the program opened second will not make sound. I'm using a asus p6t mobo with on board sound running windows 7 64 and running realtek sound driver. Any way to fix this?
Sound & Audio

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:52.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App