Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD usually involving Memory_Management or Memory_Corruption

12 Sep 2012   #1

Windows 7 Home Premium 64bit
BSOD usually involving Memory_Management or Memory_Corruption

Been getting BSOD's when playing Guild Wars 2 after 10-15 minutes in. Not overclocking, updated known drivers (video card, bios, chipset) and to Windows SP1. Computer seems to run fine when not doing anything graphics intensive (ie. web browsing, checking email, etc.)

Passed Memtest86+ with 11 passes, also passed Windows Memory Diagnostic with 10 passes. Also ran Western Digital HDD Diagnostic and passed the test. SFC /SCANNOW found no integrity violation. The graphics card passed the MG Video Memory Stress test. However, upon using the FurMark test, I got a BSOD about 8 minutes in (granted, the temperature was already stable about 4 minutes in). I also got a BSOD on the Prime95 test after the 5th-ish test.

I had previous problems, about 2 weeks ago, but with a clean install of Windows 7 Ultimate, my computer was running fine with no BSODs for about 2 weeks.

To recap:
-Passed Memtest86+, Windows Memory Diagnostic, HDD Diagnostic, MG Video Memory
-BSOD on FurMark & Prime95

My System SpecsSystem Spec
12 Sep 2012   #2

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1

Hi i got one of these : nvlddmkm.sys The rest are memory_corruption and ntkrnlmp.exe . The last two are not very helpful.
nvlddmkm.sys : nvidia graphics
Where did you get the graphics drivers from? Whats your computers make and model?
My System SpecsSystem Spec
12 Sep 2012   #3

Windows 7 Home Premium 64bit

The graphics drivers are from Nvidia GeForce found here : Drivers | GeForce as per recommended by ArenaNet (Guild Wars 2). Computer is about 3 years old, never had any serious issues until last month. Was remedied with a fresh install of Windows 7. Worked for about 2 weeks. I also just failed the CPU IntelBurnTest, getting a BSOD on the ~4th trial. The last 2 dumps are probably from when I BSOD from the Prime95 and FurMark stress tests.

My system specs:
AMD Phenom II x4 965 - 3.4gHz
Kingston HyperX Blu RAM - 2 x 2GB - DDR3 1600 (currently running on 1333)
Asrock Extreme 3 870 motherboard
OCZ Fatality 550W PSU
Western Digital Caviar Black 1TB

My USB devices:
Logitech G700 mouse
Razer BlackWidow keyboard
TP-Link WN722N wireless adapter
My System SpecsSystem Spec

13 Sep 2012   #4

Windows 7 Home Premium 64bit

Latest BSOD blames usbstor.sys. I've noticed high CPU usage when I'm on Guild Wars 2 (75%+ CPU usage). I know GW2 is a system intense game, but I don't think I ever hit CPU usage that high. I've been monitoring my temps, and I hit around 45C on my CPU and 55C on my GPU so I don't think it's an overheating problem. This may be another driver issue that I had a few weeks back.

EDIT: Looks like there's a new 306 drivers for Nvidia graphics cards. Will try it out and post results.
My System SpecsSystem Spec
13 Sep 2012   #5

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1

Sounds good and wait a second look what i found,
Microsoft (R) Windows Debugger Version 6.2.8400.0 AMD64
Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Users\Skyler\AppData\Local\Temp\Rar$DIa0.185\091312-23618-01.dmp]
Mini Kernel Dump File: Only registers and stack trace are available

Symbol search path is: SRV*c:\symbols*
Executable search path is: 
Windows 7 Kernel Version 7601 (Service Pack 1) MP (4 procs) Free x64
Product: WinNt, suite: TerminalServer SingleUserTS
Built by: 7601.17835.amd64fre.win7sp1_gdr.120503-2030
Machine Name:
Kernel base = 0xfffff800`03067000 PsLoadedModuleList = 0xfffff800`032ab670
Debug session time: Wed Sep 12 22:30:02.080 2012 (UTC - 5:00)
System Uptime: 0 days 0:43:01.704
Loading Kernel Symbols
Loading User Symbols
Loading unloaded module list
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck A, {fffff8000337ce6a, 2, 0, fffff8000310f912}

*** WARNING: Unable to verify timestamp for athurx.sys
*** ERROR: Module load completed but symbols could not be loaded for athurx.sys
Probably caused by : memory_corruption

Followup: memory_corruption

1: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If a kernel debugger is available get the stack backtrace.
Arg1: fffff8000337ce6a, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, bitfield :
	bit 0 : value 0 = read operation, 1 = write operation
	bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
Arg4: fffff8000310f912, address which referenced memory

Debugging Details:

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff80003315100
GetUlongFromAddress: unable to read from fffff800033151c0
 fffff8000337ce6a Nonpaged pool


fffff800`0310f912 410fb60c24      movzx   ecx,byte ptr [r12]





TRAP_FRAME:  fffff88004f9d9e0 -- (.trap 0xfffff88004f9d9e0)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=fffff88002fd84a8 rbx=0000000000000000 rcx=0000000002181443
rdx=fffff88002fd84c8 rsi=0000000000000000 rdi=0000000000000000
rip=fffff800031861f2 rsp=fffff88004f9db70 rbp=0000000000000000
 r8=4e6f130ff0df94ee  r9=fffff88004f9dc00 r10=0000000000000074
r11=3fc29ffb02181443 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl nz na po cy
fffff800`031861f2 4d8b4018        mov     r8,qword ptr [r8+18h] ds:4e6f130f`f0df9506=????????????????
Resetting default scope

EXCEPTION_RECORD:  fffff88004f9d938 -- (.exr 0xfffff88004f9d938)
ExceptionAddress: fffff800031861f2 (nt!KeCheckForTimer+0x0000000000000102)
   ExceptionCode: c0000005 (Access violation)
  ExceptionFlags: 00000000
NumberParameters: 2
   Parameter[0]: 0000000000000000
   Parameter[1]: ffffffffffffffff
Attempt to read from address ffffffffffffffff

LAST_CONTROL_TRANSFER:  from fffff800030e5769 to fffff800030e61c0

fffff880`04f9c7a8 fffff800`030e5769 : 00000000`0000000a fffff800`0337ce6a 00000000`00000002 00000000`00000000 : nt!KeBugCheckEx
fffff880`04f9c7b0 fffff800`030e43e0 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`0000005a : nt!KiBugCheckDispatch+0x69
fffff880`04f9c8f0 fffff800`0310f912 : fffff800`0337ce6a fffff880`04f9cac8 fffff880`04f9d938 fffff880`06016000 : nt!KiPageFault+0x260
fffff880`04f9ca80 fffff800`03120b81 : fffff880`04f9d938 fffff880`04f9d190 fffff880`00000000 fffff880`04f9dc40 : nt!RtlDispatchException+0x122
fffff880`04f9d160 fffff800`030e5842 : fffff880`04f9d938 fffff880`02fd8400 fffff880`04f9d9e0 fffff880`04f9dc80 : nt!KiDispatchException+0x135
fffff880`04f9d800 fffff800`030e414a : fffff880`04f9daa8 fffff800`0357f5d7 00000000`00000000 00000000`00000000 : nt!KiExceptionDispatch+0xc2
fffff880`04f9d9e0 fffff800`031861f2 : bfc4aa75`2e0e5bf9 bf62d6fc`ce64716c c0078011`2609fc74 c0078011`2609fc74 : nt!KiGeneralProtectionFault+0x10a
fffff880`04f9db70 fffff800`035743b6 : 00000000`00000001 fffff880`0150684e 00000000`00000074 00000000`00000000 : nt!KeCheckForTimer+0x102
fffff880`04f9dbe0 fffff880`01506808 : 00000000`00002710 00000000`0000000d 00000000`00002710 fffffa80`06ef3030 : nt!VerifierKeInitializeTimerEx+0x26
fffff880`04f9dc10 fffff880`0601cf8e : fffffa80`067f2030 fffffa80`00000010 fffff880`04f9dcd0 fffff880`009f4fc0 : ndis!NdisMSleep+0x18
fffff880`04f9dc90 fffffa80`067f2030 : fffffa80`00000010 fffff880`04f9dcd0 fffff880`009f4fc0 fffffa80`069d2b50 : athurx+0x6f8e
fffff880`04f9dc98 fffffa80`00000010 : fffff880`04f9dcd0 fffff880`009f4fc0 fffffa80`069d2b50 00000000`00000002 : 0xfffffa80`067f2030
fffff880`04f9dca0 fffff880`04f9dcd0 : fffff880`009f4fc0 fffffa80`069d2b50 00000000`00000002 0000002f`00000002 : 0xfffffa80`00000010
fffff880`04f9dca8 fffff880`009f4fc0 : fffffa80`069d2b50 00000000`00000002 0000002f`00000002 fffffa80`067f2030 : 0xfffff880`04f9dcd0
fffff880`04f9dcb0 fffffa80`069d2b50 : 00000000`00000002 0000002f`00000002 fffffa80`067f2030 00000000`039d7b00 : 0xfffff880`009f4fc0
fffff880`04f9dcb8 00000000`00000002 : 0000002f`00000002 fffffa80`067f2030 00000000`039d7b00 fffff800`031e7e00 : 0xfffffa80`069d2b50
fffff880`04f9dcc0 0000002f`00000002 : fffffa80`067f2030 00000000`039d7b00 fffff800`031e7e00 fffff980`0afa8d80 : 0x2
fffff880`04f9dcc8 fffffa80`067f2030 : 00000000`039d7b00 fffff800`031e7e00 fffff980`0afa8d80 fffffa80`06ef3030 : 0x0000002f`00000002
fffff880`04f9dcd0 00000000`039d7b00 : fffff800`031e7e00 fffff980`0afa8d80 fffffa80`06ef3030 00000000`00000001 : 0xfffffa80`067f2030
fffff880`04f9dcd8 fffff800`031e7e00 : fffff980`0afa8d80 fffffa80`06ef3030 00000000`00000001 fffff880`04f9dd40 : 0x39d7b00
fffff880`04f9dce0 00000000`00000000 : 00000000`00000000 00000000`00000000 fffff880`04f9e000 fffff880`04f98000 : nt!EtwpCCSwapTrace+0x4d0


CHKIMG_EXTENSION: !chkimg -lo 50 -d !nt
    fffff8000310fd30 - nt!RtlDispatchException+540
	[ b6:5c ]
1 error : !nt (fffff8000310fd30)

MODULE_NAME: memory_corruption

IMAGE_NAME:  memory_corruption

FOLLOWUP_NAME:  memory_corruption





Followup: memory_corruption
athurx.sys: Atheros AR9271 Wireless Network Adapter
Try downloading this driver here : Drivers for Atheros AR9271 and Windows 7
OR temporary disabling the Atheros wireless driver
My System SpecsSystem Spec
13 Sep 2012   #6

Windows 7 Home Premium 64bit

Updated Nvidia graphic drivers to 306 but it didn't help. Still BSOD from ntkrnlmp.

I tried the Atheros update but it ended up slowing my internet a lot and I had to revert the changes.

Attached is the latest dump. I will try to BSOD my computer a few times more so that you'll be able to see a pattern easier.
My System SpecsSystem Spec
18 Sep 2012   #7

Windows 7 Home Premium 64bit

Still bugged with BSOD problems. Various BSOD's from memory managements to win32k.
My System SpecsSystem Spec
19 Sep 2012   #8

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1

Ok this time no nvidia stuff or atheros, but we do have one that states clearly " hardware " so unplug any uneeded devices, and check the seating of the cards, sticks, etcc.. While so run this and upload the latest dumps from it : Driver verifier: Driver Verifier - Enable and Disable
My System SpecsSystem Spec
20 Sep 2012   #9

Windows 7 Home Premium 64bit

I think I got it fixed. Seems to be a bad harddrive even though it ran past CHKDSK and the Western Digital HardDrive diagnostic fine.

I swapped out the harddrive for an older 500GB Caviar Blue and am running fine without any BSODs for the past 6 hours. Thank you Skylais for all the help you provided! This was quite an ordeal and I wouldn't have made it without your assistance!
My System SpecsSystem Spec
20 Sep 2012   #10

Microsoft Windows 7 Ultimate 64-bit 7601 Multiprocessor Free Service Pack 1

Quote   Quote: Originally Posted by aznelf23 View Post
I think I got it fixed. Seems to be a bad harddrive even though it ran past CHKDSK and the Western Digital HardDrive diagnostic fine.

I swapped out the harddrive for an older 500GB Caviar Blue and am running fine without any BSODs for the past 6 hours. Thank you Skylais for all the help you provided! This was quite an ordeal and I wouldn't have made it without your assistance!
NICE JOB! glad you got it, if you are for sure its fixed please mark this thread as solved
My System SpecsSystem Spec

 BSOD usually involving Memory_Management or Memory_Corruption

Thread Tools

Similar help and support threads
Thread Forum
BSOD memory_corruption with faulting_IP nt !MiAgeWorkingSet+348
the machine is a Dell E6440 with a Intel SSD, Win7sp1 with periodic BSOD and never came across this type of BSOD before. Any help interpreting the attached info would be great.
BSOD Help and Support
Random BSOD memory_corruption .zip attached
Hi! BSOD mostly appears while playing minecraft counter strike and watching videos,stream,movies etc. I tryed fresh instaling windows twice and windows repair tool and it did not found any disc errors or anything. Windows debugger says memory_corruption, few times it was irql_not_less_or_equal and...
BSOD Help and Support
BSoD - memory_corruption on memory cleanup of a terminating process
I experienced a weird and sudden BSoD. Display froze, quick BSoD (in which I saw 'memory dump FAILED' or something like that) and reboot. What I did: I ran a sfc /scannow which was OK No dump, the one I posted earlier is irrelevant since it is 1 month old I also recorded an...
BSOD Help and Support
BSOD after heavy computer load involving RAM, MEMORY_MANAGEMENT
Hi, After getting a new graphics card and SSD for christmas and reformatting after getting the ramnit.gen!A virus, lately I have been getting BSODs and so I started googling for my problem. I found a reccomendation to run driver verifier and send you guys the dump in another post, so I followed...
BSOD Help and Support
BSOD involving USB drivers
I started having problems with my Logitech G400 while playing video games, it was randomly disconnecting and reconnecting and having tons of input lag problems among other headaches. These problems eventually lead to the BSODs I've been receiving BUGCODE_USB_DRIVER.
BSOD Help and Support
BSOD Involving ntoskrnl.exe
Well, after scouring the internet in an attempt to figure a solution for myself I have finally admitted defeat and here I am. The issue is hard to pinpoint as it happens at random. Be it gaming, browsing the net, or even opening a window to navigate around my computer. It is always the same. The...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:07.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App