Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD'ing after X amount of up time

06 Oct 2012   #1

Windows 7 Ultimate x64 SP1
BSOD'ing after X amount of up time

I just purchased a new motherboard/processor. I brought over my old RAM, GPU, SSD/HDD/Case. I did a fresh install, formatted/installed Windows 7. I had a few programs causing BSOD's after about 30-45 minutes of a reboot/power on, that I was able to troubleshoot(Speccy + antivirus)

I cleared it up, no BSOD's after initial 5-10 hours of up time. I went to bed, I woke up, I saw that I was crashed. My computer would reset and then just hard lock up at loading screen. If I power cycle and turned back on, it boots up with no issues. I check the event log in Computer/Manage - it pointed to a ram issue. I took each stick and ran memplus86 on it for about 5-6 passes each, no errors. I purchased a single 4gb stick to test as well.

I tried leaving my CPU with just the new single stick, same thing, BSOD after about 24 hours.

I decided to come here, I have a new symptom now, though. I have a little bit of distorted sound for the split second of the sound starting. Example, the windows "ding" sound it makes or the bootup windows sound, it's distorted and static-y for the first half a second or so.

Also, when I was creating folders/renaming them on desktop for your SF_diag tool, I had to right click- refresh to see the changes.

My System SpecsSystem Spec
06 Oct 2012   #2

Windows 7 Ultimate x64 SP1

I am currently trying dual channel with the triple channel in slots 2 and 4. Will see if I crash overnight.
My System SpecsSystem Spec
06 Oct 2012   #3

Microsoft Community Contributor Award Recipient

Windows 7 x64

From where I'm sitting it seems like your soundblaster device is having problems.
First thing I would suggest is a reinstall of the drivers.
Probably caused by : XENfiltv.sys ( XENfiltv+1817 )

Followup: MachineOwner

4: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If a kernel debugger is available get the stack backtrace.
Arg1: 0000000000003378, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000001, bitfield :
    bit 0 : value 0 = read operation, 1 = write operation
    bit 3 : value 0 = not an execute operation, 1 = execute operation (only on chips which support this level of status)
Arg4: fffff8000309044e, address which referenced memory

Debugging Details:

WRITE_ADDRESS: GetPointerFromAddress: unable to read from fffff800032b9100


fffff800`0309044e 488908          mov     qword ptr [rax],rcx





TRAP_FRAME:  fffff88003963900 -- (.trap 0xfffff88003963900)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000003378 rbx=0000000000000000 rcx=0000000000003390
rdx=fffff8800454b1d8 rsi=0000000000000000 rdi=0000000000000000
rip=fffff8000309044e rsp=fffff88003963a90 rbp=0000000000000000
 r8=0000000000000000  r9=fffff880009b3180 r10=0000000000000100
r11=fffff80003239260 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei pl nz na po nc
fffff800`0309044e 488908          mov     qword ptr [rax],rcx ds:b000:00000000`00003378=????????????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80003089769 to fffff8000308a1c0

fffff880`039637b8 fffff800`03089769 : 00000000`0000000a 00000000`00003378 00000000`00000002 00000000`00000001 : nt!KeBugCheckEx
fffff880`039637c0 fffff800`030883e0 : fffff880`016b1000 fffff800`03382000 fffff800`0337c000 fffff880`0454b1e0 : nt!KiBugCheckDispatch+0x69
fffff880`03963900 fffff800`0309044e : fffff800`0352b340 fffff800`0322fe50 fffffa80`0ade7620 00000000`00000000 : nt!KiPageFault+0x260
fffff880`03963a90 fffff800`0308e846 : 00000000`00000000 fffffa80`0ade7620 00000000`00000000 fffff800`0322fe50 : nt!KiSignalSynchronizationObject+0x4e
fffff880`03963ae0 fffff880`063ed817 : fffff880`00000000 fffff980`00000008 fffff800`0322fe00 fffffa80`0b402f50 : nt!KeSetEvent+0x106
fffff880`03963b50 fffff880`00000000 : fffff980`00000008 fffff800`0322fe00 fffffa80`0b402f50 fffffa80`0ade7620 : XENfiltv+0x1817
fffff880`03963b58 fffff980`00000008 : fffff800`0322fe00 fffffa80`0b402f50 fffffa80`0ade7620 fffff800`0352b2eb : 0xfffff880`00000000
fffff880`03963b60 fffff800`0322fe00 : fffffa80`0b402f50 fffffa80`0ade7620 fffff800`0352b2eb fffffa80`0ade7620 : 0xfffff980`00000008
fffff880`03963b68 fffffa80`0b402f50 : fffffa80`0ade7620 fffff800`0352b2eb fffffa80`0ade7620 fffffa80`0ade7620 : nt!ViPendingWorkers+0x100
fffff880`03963b70 fffffa80`0ade7620 : fffff800`0352b2eb fffffa80`0ade7620 fffffa80`0ade7620 fffff980`0b74eff8 : 0xfffffa80`0b402f50
fffff880`03963b78 fffff800`0352b2eb : fffffa80`0ade7620 fffffa80`0ade7620 fffff980`0b74eff8 fffff980`0b74eca0 : 0xfffffa80`0ade7620
fffff880`03963b80 fffff800`0352b36c : fffff800`0322fe50 00000000`00000080 fffffa80`066d95f0 3cd7002c`00000100 : nt!ViPendingCompleteAfterWait+0x7b
fffff880`03963bc0 fffff800`03320e6a : 7d3c3ed8`0fb2b5a9 c7174a8e`e71e64f1 74242ce8`2bd3fd6b 25828fa5`6d48705c : nt!ViPendingWorkerThread+0x2c
fffff880`03963c00 fffff800`0307aec6 : fffff880`009b3180 fffffa80`06732040 fffff880`009be0c0 7baf37ff`1dfc9134 : nt!PspSystemThreadStartup+0x5a
fffff880`03963c40 00000000`00000000 : fffff880`03964000 fffff880`0395e000 fffff880`039638d0 00000000`00000000 : nt!KxStartSystemThread+0x16


fffff880`063ed817 ??              ???


SYMBOL_NAME:  XENfiltv+1817

FOLLOWUP_NAME:  MachineOwner


IMAGE_NAME:  XENfiltv.sys



BUCKET_ID:  X64_0xA_VRF_XENfiltv+1817

Followup: MachineOwner
My System SpecsSystem Spec

06 Oct 2012   #4

Windows 7 Ultimate x64 SP1

Alright. As I type this, I am uninstalling everything having to deal with my headset. I'll re-download the newest drivers and firmware. We'll see how it goes then.
My System SpecsSystem Spec
07 Oct 2012   #5

Windows 7 Ultimate x64 SP1

I woke up to a BSOD with the error being: 0x00000f4.
It didn't appear to make a minidump file, so I took a screenshot of the event viewer and I am attaching a new SF_Diag file as well, in case I missed it.

Normally, my system reboots and is locked up when I come to it. It was just frozen at blue screen and I had to manually turn it off.
My System SpecsSystem Spec
07 Oct 2012   #6

Windows 7 Ultimate x64 SP1

Ok, my mic was all garbled, so I rebooted, I was greeted with a blue screen, IRQ not equal, etc, and it made a dump file, here is the updated SF_Diag file.
My System SpecsSystem Spec
07 Oct 2012   #7

Microsoft Community Contributor Award Recipient

Windows 7 x64

have you at any point turned on driver verifier?
Driver Verifier - Enable and Disable

Most of these crashes all have power state nonsense related to them. Is your headset a usb type headset?
Try this if so.
To Disable Selective Suspend:

open the control panel
go to power options (you may have to set view to small icons)
click change plan settings
in the window that opens:
click change plan settings
click change advanced power settings, expand usb and ensure usb selective suspend is disabled.

It might not hurt to set power to always on for a day or two as well.
Just fyi the new dump is pretty much identical to the one I read yesterday blames the same creative labs driver for the problem
My System SpecsSystem Spec
07 Oct 2012   #8

Windows 7 Ultimate x64 SP1

I did turn on the driver verifier, but I don't know what it does. I selected everything except microsoft drivers.

My headset is a USB headset, yes. I did uninstall and reinstall the drivers.

My selective suspend was set to enabled. My HDD was set to turn off after 20 minutes as well. I set it to never.

I had my headset plugged into the onboard jacks. I decided to plug in the USB thing for it, to test the USB selective and immediately blue screen when plugging it in. IRQ less not equal error, same error as before. What does this tell me? I'm going to uninstall the headset drivers and use the jacks for now, see if I crash. If I don't crash, should I just get a new headset that isn't Creative?
My System SpecsSystem Spec
07 Oct 2012   #9

Microsoft Community Contributor Award Recipient

Windows 7 x64

Something you should know about driver verifier, it causes crashes.
That's its job.
My System SpecsSystem Spec
07 Oct 2012   #10

Windows 7 Ultimate x64 SP1

How do I show you what the report it made? Just new SF_Diag?
My System SpecsSystem Spec

 BSOD'ing after X amount of up time

Thread Tools

Similar help and support threads
Thread Forum
BSOD After random amount of time, suspected hardware error
Since I moved to college, I decided to ship the desktop I built to my apartment. I had invested a decent amount into it so I didn't want to go many many months without using it. I decided to ship it via USPS after taking it apart. I thought that would have made it safe enough to ship, but I was...
BSOD Help and Support
My Ram keeps filling up over a short amount of time, help please.
So i turn my computer on and leave it for a few hours and the Ram fills up slowly over time (a few hours) it will get to around 4000MB and i cannot find the culprit, i have read many forums, tried a lot of different possible solutions but nothing seems to work. Please help as it is killing my...
Performance & Maintenance
2 BSOD within a short amount of time
Hi, Last night I received two BSOD within 30 minutes of each other. The first time it occurred I had a few programs open (some pdfs, photoshop etc.) but I wasn't actively using the computer. I noticed the mouse pointer started to lack and a minute or two later it BSOD'd. I was busy at the time...
BSOD Help and Support
Sound Card Seems to Shut Off After a Certain Amount of Time
I'm running my sound through a Line 6 KB37 interface and out through some studio monitors. However yesterday after having Spotify on from 30 - 60mins the sound stopped, Spotify crashed, i tried to restart and explorer.exe couldn't shutdown because it was stuck trying to play the logoff sound. I...
Sound & Audio
auto shut down after x amount of time with windows 7
hi, is there such a function with windows 7? where i can type in a certain amount of time and the pc/lap top will switch itself off so i can leave it downloading and go to bed but not have to leave the lap top running over night?
General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 14:08.
Twitter Facebook