Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Multiple BSOD's first from a game, maybe bad RAMs

24 Oct 2012   #1

Multiple BSOD's first from a game, maybe bad RAMs

Hi, I'm having this laptop that I bought not more than like 8 months ago, running Windows 7 64-bit.
Recently I was playing Icewind Dale 2, I had played for some hours, and my computer seemed pretty hot the whole time with the cooling fan system running with high noises.
Suddenly while in-game, I get a BSOD.
Restarts computer, and it starts like it should, but after short time, before I open any programs my self, it comes up with some programs stopped to work messages. Anyway I'm able to use the computer just fine, but suddenly while I'm just having a few tabs open in google chrome, I get a second BSOD.
I then donwload BlueScreenViewer, and searched up the "cause by driver", and read something about restoring windows. So I restore windows back a date before I had Icewind Dale 2 installed. But I get a third BSOD, so it didn't work.

I tried running the newest version of MemTest(free version) and after some hours it said:" Memory error detected! Copying between 1351d8 and 134f72 did not result in accurate copy.

MemTest has detected that your computer cannot accurately store data in RAM.
You need to fix this."

Also I tried command "chkdsk /f", but didn't fix anything either

I attached a SF Diagnostics rar. file, not sure what it is or what it shows you though.
So here is also information from my latest BSOD in form of the information from BlueScreenView:

Dump File - 102212-29671-01.dmp
Crash Time 22-10-2012 17:34
Bug Check String - BAD_POOL_CALLER
Bug Check Code - 0x000000c2
Parameter 1 - 00000000`00000007
Parameter 2 - 00000000`0000109b
Parameter 3 - 00000000`00000000
Parameter 4 - 00000000`0008e9ba
Caused By Driver - ntoskrnl.exe
Caused By Address - ntoskrnl.exe+7f1c0
File Description - NT Kernel & System
Product Name - Microsoft Windows Operating System
Company - Microsoft Corporation
File Version - 6.1.7601.17835 (win7sp1_gdr.120503-2030)
Processor - x64
Crash Address - ntoskrnl.exe+7fc0

I haven't had BSOD the whole day yesterday and today, but it still seems like the same, with Shockwave crashing constantly, and some strange pixel bugs on my screen(very tiny either purple or green(matrix looking) stripes and squares at random times and random places on screen). Also it was first yesterday that I ran the MemTest program which found an error.

If this isn't the hardware not working correctly, could I just reset computer to factory settings, and then it should work as if I just got it again?

My System SpecsSystem Spec
24 Oct 2012   #2

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit


OMG, start with reducing the items at start-up first:
After freeing up your start-up, uninstall Daemon Tools. It's notorious for BSODs.

Can you tell me the name of the antivirus you're using?

Usual causes:  Memory corruption, Hardware (memory in particular), Overclocking failure, Installing a faulty or mismatched hardware (especially memory) or a failure after installing it, 3rd party firewall, Device drivers, SCSI/network/BIOS updates needed, Improperly seated cards, Incompatible storage devices, Overclocking, Virus scanner, Backup tool, Bad motherboard, Missing Service Pack
BugCheck 7F, {8, 80050031, 406f8, fffff8000311d9f1}
Probably caused by : ntkrnlmp.exe ( nt!KiDoubleFaultAbort+b2 )
Usual causes:  Device driver, ?Memory
BugCheck C2, {7, 109b, 0, 8e9ba}
*** WARNING: Unable to verify timestamp for win32k.sys
*** ERROR: Module load completed but symbols could not be loaded for win32k.sys
Probably caused by : ntkrnlmp.exe ( nt!PfpFlushBuffers+23e )
My System SpecsSystem Spec
24 Oct 2012   #3


Hi thanks for the answer!
I deleted Steam, ManyCams, Skype and MSNMSNG from my startup list.
Uninstalled Daemon Tools(which could be the root problem, since I was using it for my disc in Icewind Dale cd)
I'm using Avast Antivirus, it seems. At least it sometimes block websites for me, no idea what else it's doing, or if I even got it turned on right. My Firewall is turned off, can't remember why, but I guess it's because Avast don't want other protection programs while using it.
My "solve pc issues: " in right corner next to internet connection and such tells me 4 messages :
2 important security: Virus protection (Important) Windows did not find antivirus software on this computer.
Network firewall (Important) Windows Firewall is turned off or set up incorrectly

Maintance: Check for solutions to unreported problems.
Set up backup.
My System SpecsSystem Spec

24 Oct 2012   #4

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Uninstall Avast! AV and install MSE (at least to test). Look for the Avast! removal tool in google or use free Revo Uninstallers Advance Mode to remove Avast!. (It contributes in BSODs)

Recommended antivirus program for Windows 7 based on stability compared to others:-
Run a full scan with both (separately) once downloaded, installed and updated.

Run the System File Checker that scans the of all protected Windows 7 system files and replaces incorrect corrupted, changed/modified, or damaged versions with the correct versions if possible:
Run Disk Check on your hard disk for file system errors and bad sectors on it:
My System SpecsSystem Spec
24 Oct 2012   #5


Hi thanks again!
I've deleted Avast, and turned on Windows Firewall.
Also I downloaded MSE and Malwarebytes.
When I run MSEInstall it starts a loading bar but comes up with an error message saying "File is corrupt".
I ran a full scan with Malwarebytes 3 times now, two of the times I just go BSOD almost instantly, the third time it was running for almost 40 minutes, with 1 corrupt file found(that I didn't look at, because I wanted to let it finish scan. Does it delete such files instantly, or do I have to do that my self? or do I get the option when scan is done?) But eventually I also god a BSOD there.

Restarted my pc, and now Windows Security Alert is saying that Windows Firewall has blocked som features from File Transfer Program, publisher: Microsoft, path: C:\windows\syswow64\ftp.exe , also got a message that Windows Blocker stopped working.

I got the option to "Allow access" or "Cancel"
What should I do?
My System SpecsSystem Spec
24 Oct 2012   #6

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

What's windows blocker? You'll have the option to select and delete the corruptions/virus. Did you restart after uninstalling the previous antivirus?
My System SpecsSystem Spec
24 Oct 2012   #7


I'm sorry I mean Windows Defender, anyway got another BSOD, and this time it works(Windows Defender).
Yes I did restart.
But still the mseinstall comes up with "File is corrupt", when I try to run it.
My System SpecsSystem Spec
24 Oct 2012   #8

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Try downloading it again. Did you restart you computer after doing the other steps? Restarting the computer is very important.
My System SpecsSystem Spec
24 Oct 2012   #9


This time I did a quick-scan with Malwarebytes, and I deleted the corrupt file, which appeared to be a trojan. I restarted, and then I was noticed that there was 5 updates for windows ready, and I installed them, restarted again. And it looks like it's working again now :) Still not able to install the mseinstall, but I'll try downloading it again.

But thanks a lot for helping me with finding and solving my problem, I really appreciate it!
My System SpecsSystem Spec
24 Oct 2012   #10

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

No problem.

Run this tool as well:, delete anything it finds.
My System SpecsSystem Spec

 Multiple BSOD's first from a game, maybe bad RAMs

Thread Tools

Similar help and support threads
Thread Forum
BSOD when starting Multiple Wakfu Game Client
For some reason today my PC immediately shutdown and restarted when I was playing the Wakfu game. I had 4 clients of the game running along side my browser, and some other applications. I am not sure what caused it but I find it odd that it shut down since this is relatively a new machine. I am...
BSOD Help and Support
BSOD Multiple After GPU/PSU upgrade, In Game at First, Now At Desktop
hey everyone, usually i can figure this stuff out on my own, im a technical computer science major, but right now im just stuck for once, i have a hp p6520y quad core desktop which i purchased unmodified and working great, windows 7 home prem 64 bit after 2 months of using the computer i...
BSOD Help and Support
BSOD while playing any game, multiple error codes
I'm currently running Windows 7 Home Premium x64 and have been getting multiple blue screens. I thought that I had fixed it, however it seems to come and go, which is a little frustrating. The most recent blue screen displayed a NETIO.SYS crash, I did a basic Google search for it, and these forums...
BSOD Help and Support
BSOD while playing online game and doing multiple actions
Alright a client based mmorpg game knightonline were open and i was doing my regular things. The BSOD happened. Gathered with BlueScreenView Here the result ================================================== Filename : hal.dll Address In Stack : hal.dll+12a3b From Address ...
BSOD Help and Support
BSOD whenever playing a game, multiple different errors
Is Windows 7 . . . - x86 (32-bit) or x64 ? 64 bit - the original installed OS on the system? yep - an OEM or full retail version? full retail - OEM = came pre-installed on system - Full Retail = you purchased it from retailer - What is the age of system (hardware)? 1.5 years - What is the...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:23.
Twitter Facebook Google+