Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD error when connecting to wifi

29 Oct 2012   #1

windows 7 32bit
BSOD error when connecting to wifi

I am new to these forums and may i first say hi!

Every time i turn on my wireless and connect to the network i get the BSOD. I can connect to the network vis an Ethernet cable and it worked perfectly.

i have attached my dump files.


My System SpecsSystem Spec
29 Oct 2012   #2

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Welcome to SevenForums

Looks like the BSOD was caused by F-Secure Distributed Firewall Driver.

Please uninstall it and see if the issue persists. (Look for its removal tool in Google, or uninstall using Revo Uninstaller [Free] Advanced Mode)

What antivirus are you using BTW?

Recommended antivirus program for Windows 7 based on stability compared to others:- Run a full scan with both (separately) once downloaded, installed and updated.

You might also want to look for updates on your graphic card drivers.
Driver	c:\windows\system32\drivers\atikmpag.sys (, 310.50 KB (317,952 bytes), 29/09/2011 02:34)
The following is for information purpose only;
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck D1, {28, 2, 0, fffff88003ad1459}

*** WARNING: Unable to verify timestamp for fsdfw.sys
*** ERROR: Module load completed but symbols could not be loaded for fsdfw.sys
Probably caused by : fsdfw.sys ( fsdfw+d459 )

Followup: MachineOwner

1: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

An attempt was made to access a pageable (or completely invalid) address at an
interrupt request level (IRQL) that is too high.  This is usually
caused by drivers using improper addresses.
If kernel debugger is available get stack backtrace.
Arg1: 0000000000000028, memory referenced
Arg2: 0000000000000002, IRQL
Arg3: 0000000000000000, value 0 = read operation, 1 = write operation
Arg4: fffff88003ad1459, address which referenced memory

Debugging Details:

READ_ADDRESS: GetPointerFromAddress: unable to read from fffff80002efa100
GetUlongFromAddress: unable to read from fffff80002efa1c0
 0000000000000028 Nonpaged pool


fffff880`03ad1459 8b4628          mov     eax,dword ptr [rsi+28h]





TAG_NOT_DEFINED_c000000f:  FFFFF88002F22FB0

TRAP_FRAME:  fffff88002f20e00 -- (.trap 0xfffff88002f20e00)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=0000000000000036 rbx=0000000000000000 rcx=0000000000000042
rdx=0000000000000004 rsi=0000000000000000 rdi=0000000000000000
rip=fffff88003ad1459 rsp=fffff88002f20f90 rbp=00000000ffffffea
 r8=0000000000000014  r9=fffff88002f21038 r10=fffff88003ad1950
r11=fffff88002f21008 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz na po nc
fffff880`03ad1459 8b4628          mov     eax,dword ptr [rsi+28h] ds:00000000`00000028=????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80002cca569 to fffff80002ccafc0

fffff880`02f20cb8 fffff800`02cca569 : 00000000`0000000a 00000000`00000028 00000000`00000002 00000000`00000000 : nt!KeBugCheckEx
fffff880`02f20cc0 fffff800`02cc91e0 : 00000000`00000000 00000000`00000000 00000000`00000000 fffff880`02f215e0 : nt!KiBugCheckDispatch+0x69
fffff880`02f20e00 fffff880`03ad1459 : 00000000`00000000 fffff880`0162ed11 00000000`00000000 00000000`00000000 : nt!KiPageFault+0x260
fffff880`02f20f90 00000000`00000000 : fffff880`0162ed11 00000000`00000000 00000000`00000000 fffff880`02f216a0 : fsdfw+0xd459


fffff880`03ad1459 8b4628          mov     eax,dword ptr [rsi+28h]


SYMBOL_NAME:  fsdfw+d459

FOLLOWUP_NAME:  MachineOwner


IMAGE_NAME:  fsdfw.sys


FAILURE_BUCKET_ID:  X64_0xD1_fsdfw+d459

BUCKET_ID:  X64_0xD1_fsdfw+d459

Followup: MachineOwner

1: kd> lmvm fsdfw
start             end                 module name
fffff880`03ac4000 fffff880`03ad9380   fsdfw    T (no symbols)           
    Loaded symbol image file: fsdfw.sys
    Image path: \SystemRoot\System32\drivers\fsdfw.sys
    Image name: fsdfw.sys
    Timestamp:        Mon Jun 14 17:04:05 2010 (4C160CA5)
    CheckSum:         0002374F
    ImageSize:        00015380
    Translations:     0000.04b0 0000.04e4 0409.04b0 0409.04e4
Run the System File Checker that scans the of all protected Windows 7 system files and replaces incorrect corrupted, changed/modified, or damaged versions with the correct versions if possible:Run Disk Check on your hard disk for file system errors and bad sectors on it:Let us know the results and further .dmps
My System SpecsSystem Spec
29 Oct 2012   #3

windows 7 32bit

Thanks for the quick reply!

the anti-virus that i am using is f-secure internet security 2011, i have done a check disk and everything has come up fine.

so would my best option be to uninstall the entire programme using revo?

My System SpecsSystem Spec

29 Oct 2012   #4

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Quote   Quote: Originally Posted by sgc3000000 View Post
so would my best option be to uninstall the entire programme using revo?
Yes, or at least to test and if the bugs go away. You can see that fsdfw.sys is on the "probably caused by:" line = Driver Reference Table
My System SpecsSystem Spec
26 Nov 2012   #5

Microsoft Community Contributor Award Recipient

Windows 10 Home 64Bit

Any updates?
  • If your problem is solved please use the Mark this thread as solved link at the top of your thread or down on the left corner.
My System SpecsSystem Spec

 BSOD error when connecting to wifi

Thread Tools

Similar help and support threads
Thread Forum
BSOD when connecting to the internet via wifi
Recently, I was just using my PC and surfing the net like a normal human being. Then after one night, as i tried to connect to my internet via wifi, windows suddenly changed my wifi network name from "c8daed" to "c8daed 2" and loses internet connection. I tried the reconnecting thing and deleting...
BSOD Help and Support
WiFi Not Connecting
Not only am I a WiFi newbie, I'm also a Windows 7 newbie as well. I learned to use computers on Mac/Apple computers. This just adds to my dilemma and confusion. OK, here's where I'm at right now. I have an HP laptop (windows 7 x 64 bit) that I've been trying to get to connect to several local...
Network & Sharing
BSOD connecting to wifi network
Im guessing this was after I tried installing an Atheros driver. After restarting and attempting to connect to a nearby WiFi network the computer goes straight to a BSOD. Help is needed fast and appreciated.
BSOD Help and Support
BSOD connecting DroidX to Intel My Wifi signal, netwns64.sys 4d36bce4
At one time I used Connectify which enables a Windows 7 notebook to share it's internet connection by turning the notebook into a wifi hot spot. I received BSOD each time I would connect to the signal with my DroidX, this was not a problem with any other system I connect. I received a...
BSOD Help and Support
BSOD when connecting to a wifi network
- OS: Win7 Home Premium x64 - the original installed OS on the system? Yes - an OEM or full retail version? It was OEM, then I reinstalled with a version downloaded from the internet and input my serial key - What is the age of system (hardware)? 2 months - What is the age of OS installation...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:19.
Twitter Facebook Google+ Seven Forums iOS App Seven Forums Android App