Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD every 7 to 7 1/2 hrs

06 Nov 2012   #1

win7 Pro SP1 64bit
BSOD every 7 to 7 1/2 hrs

Originally posted this back in June. No answers then. Hoping someone has new ideas. This thing is still BSODing every 7-7 1/2 hrs (+/-) if I don't re-boot it prior to that time. Have attached last 32 days of minidumps and your SF_ file. I let it BSOD on numerous occasions so you could study the time lines. There are some minidumps that are probably not applicable because I "reset" the computer before the dump file completed. You can also disregard any about memory. Had one 8gb stick fail and GSkill replaced all 8. Ran 2 x 8gb GSkill DDR3-2100 for 10 days while waiting for 8x8gb Gskill DDR3-1600 replacement w/ same BSOD occurances. BSOD's occur regardless of what programs are running, or not running. Even left it on safe boot for 7+ hours and it BSOD'd. It's almost like it some kind of "time sync" error. When it BSOD's, it just goes thru the minidump/startup screen sequences automatically and reboots itself w/ no lost info (unless I'm into some heavy video editing. Then I lose the edit). Also makes no difference if it's running w/ the bios setup as "default", or running at 4800 or anywhere in between. System is great for the 7 +/- hours it's up, but the BSOD is a real "inconvienience"
FYI: A clean install was done AFTER this started w/ the same BSOD results occuring.
System Specs can be found in my profile.

Thank you-

My System SpecsSystem Spec
07 Nov 2012   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 10 Pro Insider Preview 64-bit

Hello AngryChief.

It is caused by Intel RST (Rapid Storage Technology) driver
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck D1, {70, 2, 0, fffff88001921205}

*** WARNING: Unable to verify timestamp for iaStorA.sys
*** ERROR: Module load completed but symbols could not be loaded for iaStorA.sys
Probably caused by : iaStorA.sys ( iaStorA+62205 )

Followup: MachineOwner
Get rid of intel rapid storage.
  1. Right click on "my computer" icon and click "manage" on the context menu.
  2. It will open the "computer management" window.
  3. Select "Device Manager" in the left pane, It will list all the existing devices up.
  4. Expand "IDE ATA/ATAPI controllers" by clicking on the triangle in front of it.
  5. Select one Intel device item under it, right click, uninstall.
  6. Continue the process for all Intel items under "IDE ATA/ATAPI controllers"
  7. Now restart the computer. At restart, windows will auto configure the appropriate native system driver.
Kaspersky Lab Intermediate Network Driveris causing some problems with your network connectivity.
fffff800`00b9c728  fffff880`07d35307Unable to load image klim6.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for klim6.sys
*** ERROR: Module load completed but symbols could not be loaded for klim6.sys
And, Kaspersky Unified Driver too.
fffff800`00b9c598  fffff880`01230017Unable to load image kl1.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for kl1.sys
*** ERROR: Module load completed but symbols could not be loaded for kl1.sys
As you have Microsoft Security Essentials already installed, dont use two AV programs at the same time. Uninstall Kaspersky using Kaspersky Removal Tool. Use Microsoft Security Essentials as your antivirus with windows inbuilt firewall, and free MBAM as the on demand scanner.
Download and install those, and then run full system scans with both of them, one by one.

Some Continuous issues with USB ports
fffff800`00b9c7b8  fffff880`08386f4e USBPORT!MPf_SubmitTransfer+0x96
fffff800`00b9c808  fffff880`0839656a USBPORT!GetHcFdoExt+0x1a
fffff800`00b9c838  fffff880`083949b9 USBPORT!USBPORT_TxSetState+0x1d
fffff800`00b9c868  fffff880`0839656a USBPORT!GetHcFdoExt+0x1a
fffff800`00b9c888  fffff800`03601e04 hal!HalpSendNodeIpi64+0x105
fffff800`00b9c890  fffffa80`36a64d28
fffff800`00b9c898  fffff880`083875c2 USBPORT!USBPORT_Xdpc_iSetState+0x2a
fffff800`00b9c8b8  fffff880`0839b0a4 USBPORT!USBPORT_Core_DecIoRequestCount+0xe8
Reinstall USB Ports drivers
  1. Right click on the My Computer icon> Select manage. It will open the computer management window.
  2. Click on the "Device manager" in the left pane.
  3. Expand USB Serial Bus Controller.
  4. Right click > Uninstall them all, one by one.
  5. When Done, restart the computer.
  6. On restart, the necessary drivers will be auto-installed.
Also, disable USB Selective Suspense.

Let us know the results.
My System SpecsSystem Spec
07 Nov 2012   #3

win7 Pro SP1 64bit
no joy-

iastorA.sys has nothing to do w/ disk drives. It only appears in the Device Manager under "Storage Controllers "Intel C600 Series Chipset SATA RAID Controller" ". I did uninstall the console and it still BSOD'd @ 7hrs 3 min. With the Intel C600 chipset, iastorA & F drivers are installed only with the F6 method. I learned the hard way a year ago. In bios you must set the chipset SATA mode to raid to get your Raid 5 capability on ports 2 thru 5. AHCI is set automatically when Raid is chosen. Simple msahci does not give you raid. Screenshots are attached for bios page and Device Manager page. I went thru all the devices in Device Manager to check for newer updates for ANY device and did not find any. So I went to Intels update page and ran their auto checker and it also said all drivers were up to date. I did however note that a newer version of iastorA.sys was available in the RSTE pkg so I did download and install it. I'll just wait another 7 hours and see if that does any good.
Thanks for your ideas though-
My System SpecsSystem Spec

20 Dec 2012   #4

win7 Pro SP1 64bit
storport.sys BSOD intervals now up to 22-24hr

Clean install on clean formatted disk using all latest drivers from Intel's site. 3 bsod's since except now 22-26hrs apart. All storport.sys. Ran driver verifier. Didn't blue screen, just finally locked up about 26 hr mark forcing a manual re-boot and leaving no minidump file. One thing I found interesting, but have no idea what it means, is that the kernal times on cpu1 were running at 99%-100% while driver verifier was running. Lost the 1st 2 BS minidumps when I ran a diskcleanup. But here are the latest mini and memory dumps. From memory, these appear to be identical to the 1st 2 that i had deleted. (I use bluescreenviewer for the minidumps)
My System SpecsSystem Spec
26 Aug 2013   #5

win7 Pro SP1 64bit
BSOD's now every 20:48 to 20:56 hours

Still having the BSOD's on this machine. More of a nuisance now than problem. It just BS's and reboots itself automatically, and everything is fine. I've attached a *.txt file that shows the BS time intervals for the last 2 months.
All from 20h 48m to 20h 56m for the last 12 months. Makes no difference what the memory configuration is, or what the cpu/gpu clock settings are. Kaspersky is NOT the problem. Removed it and had the same problem. ALL bios & drivers are constantly updated when available. System specs can be found in my profile.
My System SpecsSystem Spec
24 May 2014   #6

win7 Pro SP1 64bit
new multiple cause BSOD's back to 4hrs 50min +/- after 2 years HELP!

multiple cause BSOD's back to 4hrs 50min +/- after 2 years HELP!
Been living successfully w/ BSOD's @ 20hr +/- intervals for the last 2 years. You can find some 2yr old posts in this forum & Intels forum when it was 7- 71/2 hr intervals. Then suddenly, with NO changes to the computer or software, it BSOD'ing every 4:50 +/-. Ran thru the normal routines, memtest86 5.1.0, 4 passes, w/ both sets of my G-skill memory (2 x 8gb DDR3-2133 & 8 x 8gb DDR3-1600) Ran scannow & verifier routines. Found nothing. Had a new, unused, Win7Pro x64 so I elected to do a clean install thinking that something may be defunct in the program itself or that the "RAID" setting in bios was causing the problem. F6'd the AHCI driver and set bios to AHCI. . Same BSOD's @ 4:50 +/-.(note: this was w/ only Win defender installed). Reran verifier at the suggested settings and got almost immediate BSOD. See result @ 5/22/2014, 4:11PM. Re-ran at normal settings and finally got a total lockup about 5:10hrs into it. CPU had all cores at 100% and task manager showed that Outlook was using 97% of that. Go figure. Had to do a hard reboot to safe mode and disabled verifier. Re-booted into windows. Checked all drivers against Intel & AMD and they are the latest where applicable. Checked for hardware problems by running stress tests using HD-Tune, Furmark (including CPU test), 3D_Mark, y-cruncher to 10,000,000,000 places & the complete AIDA test routine for 2 hours. All tests were run @ 42x100 and were completed successfully. Highest temp seen was 51C. HD's never went over 32c. I'm just old & retired but I've got better things to do than work on this thing. I need it up and dependable 24x7, or at least back to the 20+/- hr BSOD's. Need to reload all my engineering and lighting design programs back up. They make my "funny money" so I can play my Hot Rods. I have attached the DM & SF logs which probably contain some random BOSD's going back 2 years. At least they do in the Bluescreenviewer program I use. This was used to create the BOSD time interval PDF attach. Also attached is a fully exploded Windows 7 driver status screen shot, and just for the hell of it, a screenshot of the current desktop.
My System SpecsSystem Spec
27 May 2014   #7

win7 Pro SP1 64bit
Kudu's to TheDoctor44

Removing the Intel iaStorA & F drivers solved the issue. 1st time in the last 2 years this thing has seen "1d*" on the "uptime" clock. (see attachment). Posted this problem many times in many forums and no one ever suggested to "just delete it". I really didn't think the disk controller would work without it. I read 2 interesting posts last night on this issue and it seems it is very common on Intel x79 platforms and Intel has never managed to fix the drivers. One deals w/ complete removal of the 2 drivers in question, and the other w/ a rollback scenario to an older modded driver called "iaStor" to restore raid capability which I may try. Links here: Rapid Storage 11.5a - Bugs and removal notes & Intel AHCI/RAID Drivers Modded Intel AHCI and RAID Drivers

Again, a very grateful "Thank You" to THEDOCTOR44
My System SpecsSystem Spec

 BSOD every 7 to 7 1/2 hrs

Thread Tools

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 23:19.
Twitter Facebook Google+