Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: BSOD while playing games (SC2, Planetside 2, The War Z), 0x00000050

13 Dec 2012   #1

Windows 7 x64
BSOD while playing games (SC2, Planetside 2, The War Z), 0x00000050

I've been experiencing BSOD's while playing games for a few weeks now. The Bug Check String is: PAGE_FAULT_IN_NONPAGED_AREA so my immediate guess was faulty memory. I ran windows Memory checking utility, and ran Memtest86+ for several hours, all without errors. I adjusted the memory timings to 9-9-9-24 as suggested on corsair's site (my memory timings were previously 8-8-8-20 as set with the auto setting on my BIOS). I still have not adjusted the voltage of the memory, I will try that next. All my drivers are up to date as I just re-installed windows yesterday, and downloaded the latest graphics driver from NVidia's site.

Any ideas?

System specs:
Windows 7x64
ASUS Rampage II GENE LGA 1366 Intel X58 Micro ATX Intel Motherboard
Intel Core i7-920 Bloomfield 2.66GHz LGA 1366 130W Quad-Core Processor BX80601920 (Overclocked to 2.97 GHz)
CORSAIR XMS3 6GB (3 x 2GB) 240-Pin DDR3 SDRAM DDR3 1600 (PC3 12800) Triple Channel Kit Desktop Memory Model
CORSAIR Enthusiast Series CMPSU-550VX 550W ATX12V V2.2 SLI Ready CrossFire Ready 80 PLUS Certified Active PFC Compatible
EVGA 01G-P3-1155-TR GeForce GTS 250 1GB 256-bit GDDR3 PCI Express 2.0 x16 HDCP Ready SLI Support Video Card

I've uploaded the logs/driver lists, but here's a view of the event viewer:

Log Name: System
Source: Microsoft-Windows-Kernel-Power
Date: 12/13/2012 1:14:03 PM
Event ID: 41
Task Category: (63)
Level: Critical
Keywords: (2)
Computer: xxx-PC
The system has rebooted without cleanly shutting down first. This error could be caused if the system stopped responding, crashed, or lost power unexpectedly.
Event Xml:
<Event xmlns="">
<Provider Name="Microsoft-Windows-Kernel-Power" Guid="{331C3B3A-2005-44C2-AC5E-77220C37D6B4}" />
<TimeCreated SystemTime="2012-12-13T18:14:03.134806400Z" />
<Correlation />
<Execution ProcessID="4" ThreadID="8" />
<Security UserID="S-1-5-18" />
<Data Name="BugcheckCode">80</Data>
<Data Name="BugcheckParameter1">0xfffff8b009110858</Data>
<Data Name="BugcheckParameter2">0x0</Data>
<Data Name="BugcheckParameter3">0xfffff8800481d135</Data>
<Data Name="BugcheckParameter4">0x5</Data>
<Data Name="SleepInProgress">false</Data>
<Data Name="PowerButtonTimestamp">0</Data>

My System SpecsSystem Spec
13 Dec 2012   #2

Windows 8 Professional x64

update your direct x drivers

*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Use !analyze -v to get detailed debugging information.

BugCheck 50, {fffff8b00f87f530, 1, fffff88004b81983, 5}

Could not read faulting driver name
Probably caused by : dxgmms1.sys ( dxgmms1!VidMmDestroyAllocation+43 )

Followup: MachineOwner

4: kd> !analyze -v
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *

Invalid system memory was referenced.  This cannot be protected by try-except,
it must be protected by a Probe.  Typically the address is just plain bad or it
is pointing at freed memory.
Arg1: fffff8b00f87f530, memory referenced.
Arg2: 0000000000000001, value 0 = read operation, 1 = write operation.
Arg3: fffff88004b81983, If non-zero, the instruction address which referenced the bad memory
Arg4: 0000000000000005, (reserved)

Debugging Details:

Could not read faulting driver name

WRITE_ADDRESS: GetPointerFromAddress: unable to read from fffff80002cbd100
GetUlongFromAddress: unable to read from fffff80002cbd1c0
 fffff8b00f87f530 Paged pool

fffff880`04b81983 4c8908          mov     qword ptr [rax],r9







TRAP_FRAME:  fffff8801141e830 -- (.trap 0xfffff8801141e830)
NOTE: The trap frame does not contain all registers.
Some register values may be zeroed or incorrect.
rax=fffff8b00f87f530 rbx=0000000000000000 rcx=fffffa8007ec1000
rdx=fffff8a000f1f980 rsi=0000000000000000 rdi=0000000000000000
rip=fffff88004b81983 rsp=fffff8801141e9c0 rbp=fffffa8007ec1000
 r8=fffff8a007503980  r9=fffff8a00f87f530 r10=0000000000000000
r11=fffff88002dd1120 r12=0000000000000000 r13=0000000000000000
r14=0000000000000000 r15=0000000000000000
iopl=0         nv up ei ng nz na pe cy
fffff880`04b81983 4c8908          mov     qword ptr [rax],r9 ds:fffff8b0`0f87f530=????????????????
Resetting default scope

LAST_CONTROL_TRANSFER:  from fffff80002a348af to fffff80002a8dfc0

fffff880`1141e6c8 fffff800`02a348af : 00000000`00000050 fffff8b0`0f87f530 00000000`00000001 fffff880`1141e830 : nt!KeBugCheckEx
fffff880`1141e6d0 fffff800`02a8c0ee : 00000000`00000001 fffff8b0`0f87f530 00000000`00000000 fffff8a0`0f87f530 : nt! ?? ::FNODOBFM::`string'+0x437c1
fffff880`1141e830 fffff880`04b81983 : fffffa80`0a479010 fffff880`1141ea10 00000000`00000000 00000000`00000000 : nt!KiPageFault+0x16e
fffff880`1141e9c0 fffff880`04ac406f : 00000000`00000000 00000000`00000000 fffff8a0`09180000 00000000`00000174 : dxgmms1!VidMmDestroyAllocation+0x43
fffff880`1141e9f0 fffff880`04ad6784 : fffff8a0`0a95af70 00000000`00000000 00000000`00000000 fffff8a0`09180068 : dxgkrnl!DXGDEVICE::DestroyAllocations+0x5eb
fffff880`1141eae0 fffff880`04abb815 : 00000000`fffffeda fffff8a0`0bb02980 fffff880`1141eca0 fffffa80`07ea8000 : dxgkrnl!DXGDEVICE::~DXGDEVICE+0x19c
fffff880`1141eb50 fffff880`04ad78f2 : fffffa80`08a4d060 fffffa80`08a4d060 00000000`fffdb000 fffff8a0`09180000 : dxgkrnl!DXGADAPTER::DestroyDevice+0x1c9
fffff880`1141eb80 fffff960`001a04ea : 00000000`00000020 00000000`00000000 00000000`000007da 00000000`75296244 : dxgkrnl!DxgkDestroyDevice+0x1f6
fffff880`1141ebf0 fffff800`02a8d253 : fffffa80`08a4d060 fffff880`1141eca0 00000000`fffdb000 fffffa80`09df1b50 : win32k!NtGdiDdDDIDestroyDevice+0x12
fffff880`1141ec20 00000000`752b144a : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KiSystemServiceCopyEnd+0x13
00000000`0009dfc8 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : 0x752b144a


fffff880`04b81983 4c8908          mov     qword ptr [rax],r9


SYMBOL_NAME:  dxgmms1!VidMmDestroyAllocation+43

FOLLOWUP_NAME:  MachineOwner

MODULE_NAME: dxgmms1

IMAGE_NAME:  dxgmms1.sys


FAILURE_BUCKET_ID:  X64_0x50_dxgmms1!VidMmDestroyAllocation+43

BUCKET_ID:  X64_0x50_dxgmms1!VidMmDestroyAllocation+43

Followup: MachineOwner
My System SpecsSystem Spec
13 Dec 2012   #3

Windows 7 x64

Done. Will give it a few sessions tomorrow and see if that helped =)
My System SpecsSystem Spec

14 Dec 2012   #4

Windows 8 Professional x64

If it bsod upload the new dumps
My System SpecsSystem Spec
14 Dec 2012   #5

Windows 7 x64

Thank you for your help, it is much appreciated. I will post again with the new dumps if another crash occurs. Thank you again, bagavan.

For what it's worth, before my fresh windows install yesterday, I am 99% sure I had the latest directX drivers installed, and still had similar BSOD's.
My System SpecsSystem Spec
14 Dec 2012   #6

Windows 8 Professional x64

My System SpecsSystem Spec
14 Dec 2012   #7

Windows 7 x64

Yes, I did.
My System SpecsSystem Spec
14 Dec 2012   #8

Windows 8 Professional x64

Post back new dumps if it BSOD`s
My System SpecsSystem Spec
15 Dec 2012   #9

Windows 7 x64

Seems to have happened again. This time it's a "MEMORY_MANAGEMENT" Error. I was AFK when it happened, wasn't playing any games or anything.
My System SpecsSystem Spec
16 Dec 2012   #10

Windows 8 Professional x64

Perform this and post back

RAM - Test with Memtest86+

Errors might be found after 7 passes.

Do it overnight

Also run this

SFC /SCANNOW Command - System File Checker
My System SpecsSystem Spec

 BSOD while playing games (SC2, Planetside 2, The War Z), 0x00000050

Thread Tools

Similar help and support threads
Thread Forum
BSOD playing various games on Steam, 0x00000050
Hello Sevenforums! I have a problem with my custom built computer. It's been bluescreening lately and sometimes even restarting without showing a bluescreen. I've had this computer for 5 months now and it only started to do this about 20 days after I switched from Windows 10 back to Windows 7....
BSOD Help and Support
BSOD playing games for 15-20 minutes, error 0x00000050
I recently upgraded to a gtx 760. Earlier I didn't used to play games that much so don't know if the BSOD problem while playing games would've been there since before. I ran furmark at highest resolution a 8xmsaa for a long time, it didn't crash or anything. GPU temp reached a max of 81C. The...
BSOD Help and Support
BSOD While Playing Games - Planetside 2 and Dark Orbit
I'm Not sure what im doing much to be fair i got a debugger and copy'd the latest dump info as much as i understand whats right, hope this helps :o took out useless info and pasted new info in my 2nd post...
BSOD Help and Support
BSOD while playing most games. 0x00000050
Hi, I've posted here before about almost the same problem with a different twist this time. I've been getting these BSODs for page fault and IRQL errors. I've tried a lot of things. I first replaced my RAM back in 2011, then fresh installed my windows and did all sorts of driver cleans. Now I've...
BSOD Help and Support
BSOD 0x00000050 and 0x0000000a when playing games
Hello. I've been getting blue screens recently when playing games. Ntoskrnl.exe has been in all of the crash dumps and the bug check codes have been either 0x0000000a and 0x000000050. Win32k.sys has also appeared in the crash dumps. This hasn't happened during every game but it happens...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:14.
Twitter Facebook Google+