Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Bsod. Irql_not_less_or_equal

26 Dec 2012   #1

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
Bsod. Irql_not_less_or_equal

Okay. I recently carried out a new install of Win 7 64bit. I did so in order to fix a problem I was having in terms of my pc not powering down properly. I was also experiencing some BSOD's in the last two days, but I felt I knew how/why I had caused those(in trying to fix the power down issue), and wasn't so concerned. (I previously had BSOD's Jan-July, and has been BSOD free Aug-dec).

I noticed the powering down issue round about the time I installed a second hard drive for storage. WD caviar green 2TB. Just a bit of background.

Well, I reinstalled windows (in EFI mode if that is important) on Saturday, and it cured the powering down issue, only yesterday I noticed I had three BSOD's. I was a little surprised; I mentioned I had trouble before, so I learnt quite a lot. I was sure I had gotten all the drivers and such correct this time around.

After the first BSOD. I noticed an unknown device in device manager. So, after a quick search I found it was related to bluetooth. Luckily there was a driver on my mobo disk, the rest of the drivers (Chipset, intel MEI, Lan, Audio, USB) I got from Asus' website. And the GPU driver I already had. Other than that, I noticed an update had failed in the win update history. But I'm not sure if that's of any consequence I have had bluescreens after updating the bluetooth driver. I also made sure to complete all pending windows updates.

So yeah, a little stumped in a way. Not sure if it is something little I have forgotten to do. Or something larger at fault.

Anyway, I appreciate what time of year it is...but thought I may as well put the thread up now rather than leave it. If anyone can help, I would appreciate that very much.

My System SpecsSystem Spec
26 Dec 2012   #2
x BlueRobot


BugCheck A, {ffffffffffffffff, 2, 1, fffff8000e4c59b2}

Probably caused by : ntkrnlmp.exe ( nt!KxWaitForLockOwnerShip+12 )
Usual causes:  Kernel mode driver, System Service, BIOS, Windows, Virus scanner, Backup tool, compatibility
3: kd> k
Child-SP          RetAddr           Call Site
fffff880`096a7d88 fffff800`0e494569 nt!KeBugCheckEx
fffff880`096a7d90 fffff800`0e4931e0 nt!KiBugCheckDispatch+0x69
fffff880`096a7ed0 fffff800`0e4c59b2 nt!KiPageFault+0x260
fffff880`096a8060 fffff800`0e4a488d nt!KxWaitForLockOwnerShip+0x12
fffff880`096a8090 fffff800`0e4622eb nt!MiInsertPageInFreeOrZeroedList+0x55d
fffff880`096a81a0 fffff800`0e462c52 nt!MmPurgeSection+0x4db
fffff880`096a8290 fffff880`012a49f3 nt!CcPurgeCacheSection+0x172
fffff880`096a8300 fffff880`012d28de Ntfs!NtfsFlushAndPurgeScb+0x1bd
fffff880`096a8390 fffff880`012c1065 Ntfs!NtfsOpenAttribute+0x80e
fffff880`096a84a0 fffff880`012bcebb Ntfs!NtfsOpenExistingAttr+0x145
fffff880`096a8560 fffff880`012c011f Ntfs!NtfsOpenAttributeInExistingFile+0x5ab
fffff880`096a86f0 fffff880`012d01f6 Ntfs!NtfsOpenExistingPrefixFcb+0x1ef
fffff880`096a87e0 fffff880`012cd9a1 Ntfs!NtfsFindStartingNode+0x5e6
fffff880`096a88b0 fffff880`0122b95d Ntfs!NtfsCommonCreate+0x3e1
fffff880`096a8a90 fffff800`0e49e641 Ntfs!NtfsFspDispatch+0x26d
fffff880`096a8b70 fffff800`0e72be5a nt!ExpWorkerThread+0x111
fffff880`096a8c00 fffff800`0e485d26 nt!PspSystemThreadStartup+0x5a
fffff880`096a8c40 00000000`00000000 nt!KiStartSystemThread+0x16
Run some hard-drive diagnostics and follow these steps:Find your hard-drive manufacturer and run their tests.

Additional Tests:Post a screenshot of Crystal Disk Info summary: Make sure you have the latest firmware for SSD, and ensure all the SATA and Power cables are connected to the drive.

Check for any file system errors and bad sectors using Option #2 of:Use this command with Disk Check:

chkdsk C: /f /r
Run Driver Verifier to scan for any corrupted drivers which may be causing problems, this program works by running various stress tests on drivers, in order to produce a BSOD which will locate the driver; run for least 24 hours: Additional Help - Using Driver Verifier to identify issues with Drivers
My System SpecsSystem Spec
26 Dec 2012   #3

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

Thank you for the prompt reply. (saw this earlier, but only replying now). I think I can handle everything on the list.
I'll try and get them done as quick as I can and feedback soon.

All the best,
My System SpecsSystem Spec

28 Dec 2012   #4

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

Okay. just checking in. I'm not sure if the order was particularly important. But, I've done some of the things on the list.

I've ran chkdsk on all my drives, and it came back clean, didn't say there was any errors to fix [Realised typing this I used option 1, not option ill have to redo those.

[EDIT] I just ran chkdsk on all drives using option 2. Basically doing chkdsk C: /F Came back clean, and was much faster than what I did the first time!

I've ran Western Digital's 'Digital Data Lifeguard diagnostic' on my 2TB WD caviar green. Still got to run it on my other drive. It gave my drive a pass, so I assume that means it found no errors to fix.

I've included screenshots of crystal disk info, it rates both my drives as 'good' but whether that means much or not is beyond me.

Still to do:

Run WD life guard diagnostic on 1TB WD Caviar Blue.
Burn seatools to disk and test both hard drives.
Run Driver verifyer for 24 hours.
My System SpecsSystem Spec
29 Dec 2012   #5
x BlueRobot


Thanks for the update :) post back the results of the other tests.
My System SpecsSystem Spec
30 Dec 2012   #6

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

I tried to run Seatools today, and it loaded up fine, except that, it said it couldn't detect any hard drives.
And it said something along the lines of, 'If you believe this to be incorrect, check power connectors and jumpers'

Well, I know that's incorrect because I've been using the hard drives.

One thing I did think, is that ever since I've had my pc set up, I get some message on start up. When I turn my pc on, I get an asus splash screen, followed by a black screen with a bit of white text, then a second splash screen (I can only get into the UEFI BIOS at the second splash screen if that is important, if I press delete at the first splash screen, it would just wait until the second one pops up, if that makes sense.

Anyway, I'm not sure if the black screen with white text is normal, but its never appeared to cause any mischief. The text that I noticed before reads

"Adapter 1 - disks information: AHCI mode

So, that is the message I get each start up, I don't know exactly what it means, how can it not detect the hard disks, if they show up in the BIOS, and I am obviously able to use them? But, I just thought that perhaps that might possibly related to why Seatools couldn't detect my hard drives?

I'll try and get a photograph of the 'black' screen if that helps.
My System SpecsSystem Spec
30 Dec 2012   #7
x BlueRobot


Have you made sure that SATA cables and Power connectors are fully connected to the drives?

Scan for any malware or rootkits using:
My System SpecsSystem Spec
30 Dec 2012   #8

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

I checked all the connectors. As far as I can tell they're in perfect.

Also, I uploaded a pic of that black screen I mentioned. It's probably unimportant, but I figured it couldn't hurt. I'm d/ling 64 bit win defender atm. :)
My System SpecsSystem Spec
31 Dec 2012   #9
x BlueRobot


Does the computer boot at all?

Have you tried booting into the BIOS, and then changing the SATA setting to IDE?
My System SpecsSystem Spec
31 Dec 2012   #10

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1

My PC boots fine, just like always. I've always had the black-screen at start up, but since it never interfered with anything, I never bothered with it.

I ran the Win defender offline from my memory stick. The update feature didn't seem to work, but I think it was up to date anyway (I'm assuming when you download it and set up the memory stick it has the latest version on it). Anyway, it didn't find any problems from what I could tell.

And I tried running my Seatools disk afterwards, but it still wouldn't detect any drives.

I tried changing the sata mode to IDE, which made windows not start up, which makes sense I suppose. That 'black screen' still popped up though, and it was saying the exact thing it always does. Anyway, I changed it back to the AHCI setting, which is its default setting.
My System SpecsSystem Spec

 Bsod. Irql_not_less_or_equal

Thread Tools

Similar help and support threads
Thread Forum
BSOD irql_not_less_or_equal
Hello, the computer is rebooting after ~10 minutes, there was no "lucky" attempt it's always rebooting with irql_not_less_or_equal error message. Already tried running sfc.exe, found nothing. Attached DM Log Collector file. Thanks for your time.
BSOD Help and Support
Bsod irql_not_less_or_equal
BSOD every 15 minutes. Windows 7 Prem x86. I have several machines exhibiting the same symptoms. Attached is a current dump file.
BSOD Help and Support
Bsod - irql_not_less_or_equal
I'm so confused! I've been getting BSOD's for about a month now so I finally restored my PC to factory settings. After a couple hours, sure enough, another BSOD. This is the error: On Wed 8/22/2012 1:24:03 PM GMT your computer crashed crash dump file: C:\Windows\memory.dmp This was...
BSOD Help and Support
Bsod irql_not_less_or_equal
Hi, I receive BSOD IRQL_NOT_LESS_OR_EQUAL around once a week. I always have more applications running, so it is hard to tell which is causing it. And it also happens, when I dont touch computer in that moement at all... Please find attached zip with more information and also perfmon html file....
BSOD Help and Support
Hello, I really need some help on this. I can't figure out what is causing the problem of a BSOD. I have attached my latest dump files. I have run a memtest and had my ram replaced recently by the manufacturer and I still get the BSOD's. My OS is Windows 7 Ultimate 64bit. My copy is a full...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:48.
Twitter Facebook Google+